Jump to content

Hard drive not being recognized


Recommended Posts

Hi there, I'm having an issue with my box not recognizing a new drive and I'm not sure how to troubleshoot the issue. When I plug the drive in (hot swap cage), I get the following in the dmesg:


[ 3946.015580] ata10.00: exception Emask 0x10 SAct 0x4000 SErr 0x780000 action 0x6 frozen
[ 3946.015582] ata10.00: irq_stat 0x08000000, interface fatal error
[ 3946.015584] ata10: SError: { 10B8B Dispar BadCRC Handshk }
[ 3946.015586] ata10.00: failed command: READ FPDMA QUEUED
[ 3946.015590] ata10.00: cmd 60/08:70:00:00:00/00:00:00:00:00/40 tag 14 ncq dma 4096 in
                        res 40/00:70:00:00:00/00:00:00:00:00/40 Emask 0x10 (ATA bus error)
[ 3946.015591] ata10.00: status: { DRDY }
[ 3946.015595] ata10: hard resetting link
[ 3946.478566] ata10: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[ 3946.481529] ata10.00: configured for UDMA/133
[ 3946.481540] ata10: EH complete


But, the drive never gets a /dev/sd-letter assigned. Any ideas where to look next?

Link to comment

Ok, reseated the card and tried a second replacement SATA cable. Same issue. The problems seem to be isolated to when I connect 2 disks to my HighPoint Rocket 62x controller. 


This card was working perfectly by running the enable_ahc script. I realize now that this might have stopped working when I upgraded to UnRAID 6. I spent ages working the array when I added the second parity drive, and "a disk failed". It was a redundant disk anyway, so I just shrunk the array and ignored it but now I realize that it was the second disk on this controller so it's likely a driver issue.


Does anyone know what's involved in getting this controller working on V6?



Link to comment

OK! So i think I have found the problem. I replaced the CPU in my system (with a Xeon for Plex transcoding) a few weeks ago - and that required a BIOS upgrade. I have a feeling that the new bios defaulted to AHCI disabled. That means that my HPT card may not be working correctly. 


In the middle of a big copy now, but as soon as it's over, I'll be reboot and check it.


Diagnostics from the other day (nothing has really changed since then) attached. Can you see if the Marvell chip on that card is being recognized? I have a Marvell chipset on the MB as well that is working fine.


Thanks for your input!



PS: I have tried 3 cables and 3 disks with no major difference. Today I did manage to get a disk to mount, but as soon as I put it under any heavy load, I started getting write errors (cp: cannot create regular file '...': Input/output error) even though it's still mounted rw.

Link to comment

Ok, we'll this is clearly the problem... my HPT 62x is not being recognized. The only  ACHI setting in the BIOS was for the on board controller and it was enabled.


As far as I can tell this happened when I upgraded the CPU/BIOS, so I'm unsure what to do next.


Any idea why this would be recognized?

Link to comment
34 minutes ago, johnnie.black said:


No, but it's not software/driver related, try a different slot if available.


This also means the the earlier ATA errors you posted are from a different disk, one with a bad SATA cable.


No, they are for sure from this disk - all my disks are 3tb reds, except an SSD, and the drives plugged into this card.


When I have one disk plugged into the HPT card, it works perfectly. When I put a second disk in to it, there are intermittent errors like the ones I originally posted. This was the same problem I had when I first got the card until in found the enable_achi script linked above.


Now it's not being recognized again so we're back to a basic default operation (that I don't really understand how it works).


Ill try a different slot and report back!



Link to comment

OK! I have a bit more info here.  Updated the IPMI firmware - read somewhere if you upgrade the BIOS without the IPMI you can get troubles. Moved the HighPoint RocketRaid 62X card to a different slot and I get exactly the same thing. No reference to the card in the dmesg, but a single drive on port 1, will work. 


The only Hitachi drive in the system is attached to my HPT card, but the card is not recognized in the dmesg. Here is the drive getting recognized and I can use it properly in the OS.


[   11.309998] ata9: SATA link up 6.0 Gbps (SStatus 133 SControl 330)
[   11.311615] ata9.00: ATA-8: Hitachi HDS5C3020ALA632,       ML0220F313PSBD, ML6OA580, max UDMA/133
[   11.311921] ata9.00: 3907029168 sectors, multi 0: LBA48 NCQ (depth 31/32), AA
[   11.313574] ata9.00: configured for UDMA/133
[   11.313941] scsi 10:0:0:0: Direct-Access     ATA      Hitachi HDS5C302 A580 PQ: 0 ANSI: 5
[   11.325619] random: crng init done
[   11.329146] sd 10:0:0:0: Attached scsi generic sg7 type 0
[   11.329160] sd 10:0:0:0: [sdh] 3907029168 512-byte logical blocks: (2.00 TB/1.82 TiB)
[   11.329238]  sdg: sdg1
[   11.329315] sd 10:0:0:0: [sdh] Write Protect is off
[   11.329317] sd 10:0:0:0: [sdh] Mode Sense: 00 3a 00 00
[   11.329360] sd 10:0:0:0: [sdh] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA

New diagnostics attached. In the lspci I do see the device now as a SATA controller, but it seems to also list a IDE interface - so is there an AHCI issue still?


Any more input would be VERY much appreciated!



Link to comment

It's being detected and loading both AHCI and IDE drivers, this is kind of strange but some HPT controller are, I suspect some incompatibility and probably there's not much you can do about it.

02:00.0 SATA controller [0106]: Marvell Technology Group Ltd. 88SE9120 SATA 6Gb/s Controller [1b4b:9120] (rev 12)
    Subsystem: Marvell Technology Group Ltd. 88SE9120 SATA 6Gb/s Controller [1b4b:9120]
    Kernel driver in use: ahci
    Kernel modules: ahci
02:00.1 IDE interface [0101]: Marvell Technology Group Ltd. 88SE912x IDE Controller [1b4b:91a4] (rev 12)
    Subsystem: Marvell Technology Group Ltd. 88SE912x IDE Controller [1b4b:91a4]
    Kernel driver in use: pata_marvell
    Kernel modules: pata_marvell


Marvell controllers are not recommended with v6 anyway so recommend you get a new controller, if 2 ports are enough look for an Asmedia 1601, they can be found for about 15$, and they work great with unRAID.

Link to comment
34 minutes ago, whiteatom said:

Marvell not recommended?


Don't know if it's the chips or the drivers, but they're a source of problems for many users and not recommended for v6, though some people continue to use them without issues


37 minutes ago, whiteatom said:

I'll try commenting out the ahci script when I get home.


I assumed you removed it after the upgrade, it's not needed for v6.


Link to comment

Ok.. that was not clear from the instructions.. Tried with out the script and I basically get the same thing where the card is found as both SATA and IDE. Between this card and the Marvell controller on the board, I have just ordered a second SASLP, so we'll see if that fixes me up!


Thanks again all for the help.


Link to comment

I haven't either, but this comment made me realize there could be issues that I haven't had yet (I have a SASLP, and I just ordered an SAS2LP for continued expansion). 

On 2017-06-25 at 5:07 AM, johnnie.black said:

Marvell controllers are not recommended with v6 anyway so recommend you get a new controller, if 2 ports are enough look for an Asmedia 1601, they can be found for about 15$, and they work great with unRAID.


What's the "recommended" 8 port SATA card now? (or 2x SAS for breakout cables)

Link to comment
1 hour ago, johnnie.black said:

Any LSI with the SAS2008 chip, eg, 9211-8i and clones


Johnnie -


Notice you routinely recommend the 9211-8i and not the 9201-8i. The latter being a pure HBA with no need for firmware updates.


Curious if there is a reason. Is the 9211 superior in some way?


I have the 9201 and it works great, and have recommended to several people that have also had a good experience. Just curious.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...