Jump to content

USB problems - bad motherboard? (SOLVED)


Recommended Posts



Running v6.1.7.  Server's been running pretty well.  Uptime was almost 300 days.  I think the hardware is a good 5 years with hdd upgraded throughout.  Noticed an error 2 to 3 weeks ago about losing UPS communications (via USB).  Didn't think anything of it at the time and honestly forgot about it.  Then the other day all shares were missing.  Tried to do some things via web access but that didn't work out so well.  I did notice though that I was having flash drive problems.  So after doing a hard shutdown, I pulled the flash drive and it seemed to be ok via a windows box.  I didn't run any test on it, but seemed to be ok at first glance.  Afterwards, I couldn't get the server back up without reconfiguring the bios to boot from it, weird.


It came up ok and parity check was fine.  But less than 1 day later, pretty much right after the parity check, I lost UPS comm again and when I look at the log I have a ton of these errors:

Jul  5 00:33:01 hitch kernel: FAT-fs (sda1): Directory bread(block 8192) failed

I attached a snipet from the log from the completion of the parity check, then the UPS comm lost and finally the flash drive errors (sda1).  I guess I'm wonder has anyone seen this before?  Is it a bad flash drive, motherboard going bad, UPS somehow taking out USB ports.  At this point, I probably will need a new USB flash drive as this one after 30 hours has over 30 zillion writes to it.  Outside of this, everything else seems to be working ok, but I'm sure it's going to lock up at some point.  Thanks for any help.



Link to comment

Changed from using motherboard usb port to one of the motherboard headers, same results.  This is with the UPS USB disconnected.  Tried a different flash driver, same problem.  So at this point, I'm leaning towards motherboard.  The only other thing I can think of is power supply.  I did do a memory check and it came back fine.

Link to comment

USB2 ports have a Black plastic insert while the USB3 ports have a Blue plastic insert.


You should also check and see if that USB drive in question will boot on another computer.  Don't worry, booting to unRAID will not write to any of the hard disk(s) on that test computer unless you tell it to...

Link to comment
2 hours ago, Frank1940 said:

Don't worry, booting to unRAID will not write to any of the hard disk(s) on that test computer unless you tell it to...

by assigning a drive to one of the array slots.


As long as you don't assign a drive to one of the drop down slots you will be fine.

Link to comment
  • 2 weeks later...

I'll go ahead and mark this one complete.  Although I don't know for sure, I do feel it most likely is the motherboard.  The only other component I didn't swap was the memory.  I replaced the motherboard, memory and processor with a new one and problem solved.  I took the old processor and put it in my backup server and the problem didn't come back.  So that just leaves the motherboard and memory.  Thanks for the help and suggestions.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...