Jump to content

Samba issues with Windows 7


Recommended Posts

purko, I agree with what you're saying. It's good to see some concerns showing up early.


I'm having a hell of a time (bad) reconfiguring my extra samba shares for the user access I want. It's mostly on the side of Windows 7 not wanting to cooperate. I'm able to get it working using from Linux using 'smbclient' or from dos prompt 'net use' but Windows Explorer just doesn't want to function. But I'm not too frustrated yet, because I'm learning more about SAMBA configuration and administration.


Link to comment

On my main Windows 7 machine I adjusted a few settings and got it working. I tried setting only the 1 item which I figure was the key item on another machine and it worked. It deals with NTLM encryption levels either 128bit required or allow for 40/56bit.


Control Panel

- Administrative Tools

-- Local Security Policy {secpol.msc}


Security Settings

- Local Policies

-- Security Options

--- Network security: Minimum session security for NTLM SSP based (including secure RPC) clients

---- Uncheck "Require 128-bit encryption"

--- Network security: Minimum session security for NTLM SSP based (including secure RPC) servers

---- Uncheck "Require 128-bit encryption"


Link to comment

Oh my god. Saw this thread accidently ...


Since months I try to get my Music Streamer to work (http://www.music-streamer.com and http://www.helium-music-manager.com). Connection from that Web-Server-Service to my unRAID machines is always refused. They call me stupid because it would work everywhere. Is it because unRAID does something weird with the SMB protocol???


The required Policy Editors are not installed on Windows 7 Home installations, these come only with the highend Windows 7 packages, but I do have three Windows 7 Home installations. These steps simply don't work here. I would like to check out if these two settings would help to get that Streamer running.


For the first step I found a workaround in a MS Tech Blog:


"Add a DWORD value called LmCompatibilityLevel to HKLM|System|CurrentControlSet|Control|Lsa and set the value to 2"


EDIT: For the second step I didn't find a matching workaround. Here's the second workaround:


"Change HKLM|System|CurrentControlSet|Control|Lsa|MSV1_0|NtlmMinClientSec to 0x80000000"


"Change HKLM|System|CurrentControlSet|Control|Lsa|MSV1_0|NtlmMinServerSec to 0x80000000"


Didn't help here. Any ideas why some Windows 7 applications do have Problems to touch files stored on my unRAID boxes and some don't??


Thanks in advance



Link to comment

purko, I agree with what you're saying. It's good to see some concerns showing up early.

Is your post a continuation of a previous private discussion?



This thread was copied off by a moderator from the 5.0 Announcement Thread general discussions.

Link to comment

I have been using windows 7 for about two months now and haven't run into any issues except one.  If my wireless signal gets interrupted my music or video streams won't resume.  I have to close the programs and restart them.


Really? You've been using unRAID 5.0 Beta 1 for 2 months?



Link to comment
  • 2 months later...

Guess it's time I set up a Win7 machine  :P


Tom, please consider applying this Samba patch. Ever since I upgraded to Windows 7, the foobar2000 media library indexing has been severely broken. It re-indexes the entire library every time instead of just applying the changes within the library. With my somewhat large music collection this can take ages.


More info on this bug here and here.


Link to comment
  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...