Jump to content
MyKroFt

Internet Outage: No UI

7 posts in this topic Last Reply

Recommended Posts

Why when there is a internet outage you can not access the UI via local lan IP?

Share this post


Link to post
12 minutes ago, MyKroFt said:

Why when there is a internet outage you can not access the UI via local lan IP?

Works fine here. Can you ping the IP?

Share this post


Link to post
Posted (edited)

Ya pings just fine.  It trys to resolve to my unraid.ner domin name. 

 

When I enter 192.168.0.104, it trys to resolve a.domin name and fails

 

It's trying to resolve to an HTTPS maybe that's what's causing it

Edited by MyKroFt

Share this post


Link to post

Works just fine for me also  Accessing via https to either the IP address or by it's name.  

 

You running something like maybe piHole that's playing with the network?

Share this post


Link to post
9 hours ago, MyKroFt said:

Ya pings just fine.  It trys to resolve to my unraid.ner domin name. 

 

When I enter 192.168.0.104, it trys to resolve a.domin name and fails

 

It's trying to resolve to an HTTPS maybe that's what's causing it

Try https://192.168.0.104

Share this post


Link to post
Posted (edited)

ya running pihole

 

and https://192.168.0.104 does not work for me either when no internet

 

hm... stumped

Edited by MyKroFt

Share this post


Link to post

I have had mixed results with https://ipaddress . At a minimum you will need to bypass the browser warnings telling you that the certificate doesn't match the url.

 

http://ipaddress will automatically redirect to https://hash.unraid.net . If your computer hasn't cached that address already and your Internet is down, it won't be able to do a DNS lookup, which causes the issue you are seeing.

 

One solution is to add an entry to your local hosts file that points  hash.unraid.net to the correct IP address.  The downside is that this overrides DNS, so you need to remember to update the hosts file if the IP address ever changes.

 

Another solution is to disable SSL by editing the /boot/config/ident.cfg file and changing USE_SSL to "no", then typing "powerdown -r" from the console to reboot. When it comes back up you will be able to use http://ipaddress to access the gui.
 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.