Jump to content
Hoopster

X470D4U/3900X "Ryzen" to the top of the list

14 posts in this topic Last Reply

Recommended Posts

I have been contemplating my next server upgrade for about a year.  I have built six or seven unRAID servers and have always used Intel CPUs and compatible motherboards. 

 

One of the reasons for Intel was that my first few builds were with Mini-ITX boards and the Intel CPUs I have used have all had integrated graphics - no GPU required.  Another reason is that those iGPUs support Quick Sync Video for hardware transcoding in Plex/Emby/HandBrake, etc.

 

My current server build is now in a case that accommodates mATX and ATX boards so form factor is no longer an issue.

 

Up until a few weeks ago, I was looking at moving to the Intel Xeon E-2278G CPU which is an 8-core/16-thread Xeon with an iGPU.  That is double the cores/threads of my current Xeon E3-1245 v5.  However, the 3rd generation Ryzen chips, especially the 3900X (12c/24t), have really piqued my interest lately.  AMD has been coming on strong and by most accounts has completely overtaken Intel in many key areas.  Recent Intel offerings have been rather uninspiring and lackluster compared to their AMD counterparts.  It appears that most, if not all, of the early Ryzen issues have been resolved.

 

I like workstation/server boards for my main server rather than desktop/gaming boards with lots of bells and whistles that are unnecessary on a server.  In my research, I came across a very interesting motherboard offering, the ASRock Rack X470D4U. It's a server board with IMPI and support for ECC RAM with an AM4 CPU socket that can support 2nd and 3rd generation Ryzen CPUs.  The negatives from my perspective are the paucity of USB ports and the limited M.2 options (1 PCIe 3.0 x2 and 1 PCIe 2.0 x4).  It only has two USB ports on the rear panel and a single header for two more; all of which are USB 3.1.  No USB 2.0 support.  I care about that only because I know there are occasionally problems with the unRAID flash drive in USB 3.x ports whereas USB 2.0 seems to be more reliable.

 

I am now thinking my next server build will look something like this:

 

ASRock Rack mATX X470D4U Motherboard

Ryzen 3900X CPU

64GB ECC DDR4 RAM

Quadro P2000 to use with the LSIO Unraid Nvidia plugin for hardware transcoding needs

Need to work out if the BMC/Aspeed onboard video and VGA port will suffice for unRAID boot/command line video

 

Is anyone currently using the ASRock X470D4U with unRAID and care to comment on what you like and don't like with this board?

 

Edited by Hoopster

Share this post


Link to post

I have just had one delivered today to use with a 3700x. It was fine to build with, I would rather have a full ATX board though. I will update you once I have successfully booted the system.

Share this post


Link to post
11 minutes ago, EarthYak said:

I would rather have a full ATX board

Agreed. 

 

X570 offers more PCIe lanes as well, but, X570 boards seem to draw a lot more power than their X470 counterparts.  What would really be nice is an X570D4U in an ATX form factor with at least one more PCIe slot, and a few more USB ports.  This of course, assumes your own power plant in the back yard is not necessary to run it :)

Share this post


Link to post
2 hours ago, Hoopster said:

What would really be nice is an X570D4U in an ATX form factor with at least one more PCIe slot, and a few more USB ports.  

That would be an improvement. I would have liked another couple of USBs, after the flash drive and a keyboard you have to rely on the case having ports. I would have liked another PCIe slot too, I only plan on using 1 or 2 HBAs and maybe upgrading to 10Gbe later but that would fill the board. I am only using one HBA at the moment though so it is a future issue and I could solve it with a bigger HBA, although a new motherboard would probably be cheaper.

 

The IPMI is what ended up selling me on it over a full ATX x470 or x570. My new server location is a chore to get to and occasionally I am away when I need to work on it.

 

The X399D8A is a good alternative though if you want to use a 2nd Gen Threadripper instead. It didn't make sense for me though.

 

Share this post


Link to post

Quick update on progress.

 

I am replacing the CPU and Motherboard after my Motherboard failed on my previous server. 

 

I quickly attempted to boot the server tonight my old installation would not boot, it generated kernel errors on starting Unraid. I booted it up successfully with another flash drive on 6.8.0 rc4 though. I know the kernel has been updated in the 6.8.0 update.

 

I will attempt to transition my flash drive to the new installation tomorrow or Sunday, then I can start  testing it properly.

Share this post


Link to post

My build with the x470du is complete now, it has been running perfectly for 2 days. Aside from the points noted above, I have no complaints. The 3700x has been more than sufficient for my needs and booting from a USB 3.0 port has caused no problems so far. I am back running unraid 3.7.2 without issue.

 

The only thing that is not working at the moment is that Dynamix System Temperature is not detecting any sensors. That said it didn't work on my old Tyan dual socket board and it is not a major issue.

 

The IPMI is great so far, I would like the ability to adjust more settings through it but all the functions you need are there and the ability to flash the BIOS will be very useful I suspect.

 

I have not attempted to run any VMs yet, it will probably be a week or two before I have the time to. My dockers were the priority.

Share this post


Link to post
3 hours ago, EarthYak said:

Dynamix System Temperature is not detecting any sensors

I you are running a 6.8.0 rc version, check the latest update to the plugin.

 

 

Share this post


Link to post
On 11/3/2019 at 6:59 PM, EarthYak said:

My build with the x470du is complete now, it has been running perfectly for 2 days. Aside from the points noted above, I have no complaints. The 3700x has been more than sufficient for my needs and booting from a USB 3.0 port has caused no problems so far. I am back running unraid 3.7.2 without issue.

 

The only thing that is not working at the moment is that Dynamix System Temperature is not detecting any sensors. That said it didn't work on my old Tyan dual socket board and it is not a major issue.

 

The IPMI is great so far, I would like the ability to adjust more settings through it but all the functions you need are there and the ability to flash the BIOS will be very useful I suspect.

 

I have not attempted to run any VMs yet, it will probably be a week or two before I have the time to. My dockers were the priority.

Hello, can you post your IOMMU group?

Thank you very much.

Share this post


Link to post

Good day, I've been running a ROG STRIX X470-F GAMING atx with a ryzen 2700x for a couple of months now. VM pass-through gave me a hard-time until I discovered (thanks to advice on this forum) that the motherboard bios upgrades from March 2019 onwards had broken AGESA. I had to "manually" downgrade the bios to Version 4207 (Dic 2018) and since then it all works great!

 

Now I want to upgrade my Ryzen to 3900x and I suspect I have to upgrade my bios. Anyone has had any experience with x470 atx and Ryzen 3900x? Specifically pass-through.

 

 

Share this post


Link to post

Did anyone manage to get GPU pass through working with x470d4u?

I tried for a few hours today, it just doesn't work.

 

Otherwise, everything else works just fine. This board is great for a home server, unraid build.

Edited by nextgenpotato

Share this post


Link to post

I'm using (recently built it) the X470D4U with a Ryzen 5 3600 (gen 3) and 16GB ECC Ram.

You don't need a keyboard and mouse for the Mobo. You can use the IPMI to manage the server from another computer.

I.e. IPMI allow you to manage the server such as power off/on, patch firmware, remote console etc. Apart from the two USB3 in the back, there is one socket for another two USB3 ports. I installed a two port USB3 adapter directly on the mobo so my USB Unraid device id "directly" on the mobo.

Apart from the IPMI port, there are two more ethernet ports that I have in active/active mode to improve the network throughput. Yet to play with the different options for optimum performance. Connected to a Unifi switch so it can in theory do all the different modes.

 

The M.2 seem a bit sad. Was looking at using them for NVMe cache. But I can not find any NVMe SSD to match the "specs".

Have any of you found workable SSD for the M.2? If so, what are you using and what read/write speed to you get?

Cheers

Martin

 

Share this post


Link to post
On 11/4/2019 at 3:59 AM, EarthYak said:

My build with the x470du is complete now, it has been running perfectly for 2 days. Aside from the points noted above, I have no complaints. The 3700x has been more than sufficient for my needs and booting from a USB 3.0 port has caused no problems so far. I am back running unraid 3.7.2 without issue.

 

The only thing that is not working at the moment is that Dynamix System Temperature is not detecting any sensors. That said it didn't work on my old Tyan dual socket board and it is not a major issue.

 

The IPMI is great so far, I would like the ability to adjust more settings through it but all the functions you need are there and the ability to flash the BIOS will be very useful I suspect.

 

I have not attempted to run any VMs yet, it will probably be a week or two before I have the time to. My dockers were the priority.

@EarthYak any update on your build? I've finally found a reasonable board in Australia for my first build and was going to go the same as you in a node 804.

 

Will mainly be Plex/radarr/file server. I have a seperate gaming PC so no need to passthrough

Share this post


Link to post

Any update for gpu passthrough for x470d4u? Same board and i am using 3700x. 
Win 7 vm fail to run after restart, showing ‘unable to execute qemu command resetting....’

 

thanks. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.