[SOLVED] Windows XP Help

19 posts in this topic Last Reply

Recommended Posts

I have some old windows XP based music software and files that I created a long time ago. They won't run on windows 7.  So, I am trying to get an XP VM based on a Windows XP SP3 to run but am struggling.  I have tried a number of virtIO drivers and but every time it halts at "Booting from hard drive" and pegs a single cpu at 100% until force shut down.


Suggestions and help is appreciated.


Logs and Images below:








Screen Shot 2020-04-24 at 7.38.01 PM.png

Edited by dubbly
image size
Link to post
7 hours ago, rachid596 said:


Try to change vdiisk bus to ide or sata and assign 2 core to the VM

Made some progress based on assistance from rachid596 and also gareth_iowc


The XP VM now appears to boot the ISO and begin installing.  However, I now get a blue screen right when it says "starting windows," see the image below.  After the blue screen I need to force quit the VM. Then it WILL NOT boot/install again.  In that see is "booting from HDD" with no action.   I can destroy the VM and setup new and end up in the same loop.


 Screen shots and config file below.  I wonder if my XP SP3 ISO is somehow corrupted or the HDD doesn't function. 


<?xml version='1.0' encoding='UTF-8'?>
<domain type='kvm'>
  <name>Windows XP</name>
    <vmtemplate xmlns="unraid" name="Windows XP" icon="windowsxp.png" os="windowsxp"/>
  <memory unit='KiB'>1048576</memory>
  <currentMemory unit='KiB'>1048576</currentMemory>
  <vcpu placement='static'>4</vcpu>
    <vcpupin vcpu='0' cpuset='1'/>
    <vcpupin vcpu='1' cpuset='5'/>
    <vcpupin vcpu='2' cpuset='2'/>
    <vcpupin vcpu='3' cpuset='6'/>
    <type arch='x86_64' machine='pc-i440fx-4.2'>hvm</type>
      <relaxed state='on'/>
      <vapic state='on'/>
      <spinlocks state='on' retries='8191'/>
      <vendor_id state='on' value='none'/>
  <cpu mode='host-passthrough' check='none'>
    <topology sockets='1' cores='2' threads='2'/>
    <cache mode='passthrough'/>
  <clock offset='localtime'>
    <timer name='hypervclock' present='yes'/>
    <timer name='hpet' present='no'/>
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source file='/mnt/user/isos/Windows XP/en_windows_xp_professional_with_service_pack_3_x86_cd_vl_x14-73974.iso'/>
      <target dev='hda' bus='sata'/>
      <boot order='2'/>
      <address type='drive' controller='0' bus='0' target='0' unit='0'/>
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source file='/mnt/user/isos/virtio-win-0.1.160-1.iso'/>
      <target dev='hdb' bus='sata'/>
      <address type='drive' controller='0' bus='0' target='0' unit='1'/>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw' cache='writeback'/>
      <source file='/mnt/user/domains/Windows XP/vdisk1.img'/>
      <target dev='hdc' bus='sata'/>
      <boot order='1'/>
      <address type='drive' controller='0' bus='0' target='0' unit='2'/>
    <controller type='usb' index='0' model='ich9-ehci1'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x7'/>
    <controller type='usb' index='0' model='ich9-uhci1'>
      <master startport='0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x0' multifunction='on'/>
    <controller type='usb' index='0' model='ich9-uhci2'>
      <master startport='2'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x1'/>
    <controller type='usb' index='0' model='ich9-uhci3'>
      <master startport='4'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x2'/>
    <controller type='pci' index='0' model='pci-root'/>
    <controller type='sata' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    <controller type='virtio-serial' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
    <interface type='bridge'>
      <mac address='52:54:00:45:e7:cd'/>
      <source bridge='br0'/>
      <model type='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    <serial type='pty'>
      <target type='isa-serial' port='0'>
        <model name='isa-serial'/>
    <console type='pty'>
      <target type='serial' port='0'/>
    <channel type='unix'>
      <target type='virtio' name='org.qemu.guest_agent.0'/>
      <address type='virtio-serial' controller='0' bus='0' port='1'/>
    <input type='tablet' bus='usb'>
      <address type='usb' bus='0' port='1'/>
    <input type='mouse' bus='ps2'/>
    <input type='keyboard' bus='ps2'/>
    <graphics type='vnc' port='-1' autoport='yes' websocket='-1' listen='' keymap='en-us'>
      <listen type='address' address=''/>
      <model type='qxl' ram='65536' vram='65536' vgamem='16384' heads='1' primary='yes'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    <memballoon model='virtio'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0'/>


 This is just before the blue screen:



Blue Screen:



This is what I see if I restart after the blue screen. 


Edited by dubbly
corrected XML
Link to post
6 minutes ago, meep said:

try reducing the number of CPU cores to just 1 for the setup process.

Thank you for the suggestion.  Just tried reducing to a single core and experienced the same issue.  Any other ideas?

Link to post

You could try rebuilding the VM using Q35 rather than i440 machine type.  That's got me out of a few pickles in the past. 


Have you selected your target install disk by this point? It's been a while since I did an XP install? Was there an opportunity to load custom drivers before this point? You might need to load vistor and other drivers from the viirtio iso?


Beyond that, I'd be stumped.


Link to post

When you have the opportunity to load drivers, take it!


You need to follow the driver installation sequence described here;




That's actually for post-OS-install updates, but you my be getting that BSD because Windows Setup doesn't have drivers for some of your VM devices. You need to load the relevant drivers from the ISO as part of the setup process. (you need to do this for Win10, why not XP?)


That page specifically indicates that the viostor drivers should be installed last. You'll need to load  Balloon, NetKVM and vioserial drivers first, then viostor. You do them one at a time, so its a bit repeditive.


Edited by meep
Link to post

Q35 didn't solve the problem  However, pressing F6 while loading brought up the following screen (see image).  It seems that it can't find a mass storage device to save to.


At least that is how I read it.  Pressing S resulted in no additional drivers found. I wasn't able to see a way to load the drivers. 


This seems like progress.  Suggestions?719543323_setup6.thumb.JPG.f1e520caf9ddbeaa1ba6bdbe511acb4d.JPG



Link to post

More good news. I found this for you;




It looks lies WinXP doesn't support SATA for install, and VIRTIO is causing a problem for you. Also, it seems that the drivers need to be on floppy (!) or USB, so likely why pressing 'S' results in no dice.


Try setting your primary vDisk bus to IDE specifically. Or see if you can follow the instructions oin the above article. 


Good luck!



Link to post

For some reason I am not able to find a way to open an load the drivers in XP setup.  Pressing F6 should work as shown in the image above.  However, no options exist to load drivers when I press S. 


I wonder if I need to add a virtual floppy drive.

Edited by dubbly
clarity update
Link to post
8 minutes ago, dubbly said:

For some reason I am not able to find a way to open an load the drivers in XP setup.

Was the article above no help?

set primary vDisk bus to IDE then, and see how that goes....

Link to post
30 minutes ago, dubbly said:

clarified above.  The issue is that the VirtIO drivers on the ISO aren't available to install.  I wonder if I need to add a virtual floppy or something. It keeps asking for one. 

Yes, it seems XP needs a floppy at that point, or a USB spoofed as a floppy.

Did you try to et primary vDisk bus to 'IDE' in VM config?


Link to post
  • JorgeB changed the title to [SOLVED] Windows XP Help
  • 2 months later...
  • 7 months later...
On 7/14/2020 at 11:17 PM, DeathByDentures said:

Does anyone have a link to a valid copy of viostor-31-03-2010-floppy.img? The site hosting changed to a .org and none of the old stuff is available.

Maybe someone can post and share their copy?


Found it on the Wayback Machine if anyone needs it.


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.