**GUIDE** How to Install Authelia on unRAID

Recommended Posts

Had a lot of trouble fining help getting Authelia working on unRAID. Mostly due to my own lack of knowledge. But thanks to some help and time put in, I present you my guide written based on what I did to get it working, alongside NGINX Proxy Manager.


Never used git before but here you go: https://github.com/ibracorp/authelia


If anyone knows how to put an XML on Community Apps for easier finding please let me know I'd be happy to do it.



Link to comment

I have domain for radarr - radarr.myunraid.ru/

and domain for authelia - authelia.myunraid.ru/

and after go to radarr.myunraid.ru/ page redirect to https://authelia.myunraid.ru/?rd=http://radarr.myunraid.ru/

and i see 403 error.

but if i write https://authelia.myunraid.ru/?rd=httpS://radarr.myunraid.ru/ then that work.

How change config for all urls to redirect https ?





authelia nginx advanced container nginx advanced

authelia nginx 1.png

authelia nginx 2.png

sonar 1.png

sonar 2.png


Edited by Un1Q
add log and config
Link to comment

@Un1Q thanks for posting the logs and files. 


I see in your Authelia configuration the information is not right. Such as the rules section. Is this on purpose? Currently it shows example.com. which needs to be updated. 


Also, for HTTPS, NGINX Proxy Manager should already be handling this for you. I use Cloudflare too which guarantees the SSL and is free. Perhaps this is something you could set up too.

Link to comment
  • 3 months later...


I have swag and Authelia containers, I want to jail login attemps from Authelia, but jail.local need to reads Authelia log. I tried to point to Authelia log from swag/jail.local, but it could not find it. How can jail.local read Authelia log?


I want to backup Authelia. I have backup the appdata/authelia and MariaDB. Do I need to backup redis DB? If yes how?

Edited by Moka
Link to comment
  • 6 months later...

One issue I am getting is bypassing local network these are my setting if someone can help. Even with this rule it stills ask for authentication internally


default_policy: deny


    - domain: "*.XXXXXXXX.com"

      policy: bypass



    - domain: "*.XXXXXXXcom"

      policy: two_factor

Link to comment
  • 1 month later...

I am using Authelia together with Nginx Proxy Manager. Both are installed with Docker containers on the same host. I have got the setup working with most of my services, but for some reason when trying to get it to work with VSCode (using linuxserver/code-server) I only get a white/blank screen after login. Anyone have any tip as to what might be wrong? I am using the same endpoint configuration for all the services just changing out the address and port number. I have no trouble with VSCode when not behind Authelia.

Link to comment
  • 2 months later...
  • 2 weeks later...
3 hours ago, xxbigfootxx said:

Follow this video:



Very good guide on how to set it up.


This what i followed ... also guide from ibracorp website (they made cool job) but having server error on start up authelia docker!

but no auto config file when created authelia docker.

Also deleted and recreated container some times but having same error .

1. maked database in mariadb

2. installed redis + bitnami folder

3. when making authelia container no auto making config ?!?


then i dowloaded original config and from ibracorp github also edited config with my data and copied to Authelia empty folder

made other stuff like auth.myserver.com but same error ...



Link to comment
1 hour ago, xxbigfootxx said:

You won't typically get that error even if another application is using the same port. It will still add, it just won't start the container as something else is running.


That error usually means there's an issue with docker image.


But if it's working now, that's good.


Finaly all working after changed port back to 9091 and prometheus msi exporter 9092 ...


The question - we can add users only by adding them to users_database.yml file manualy like in video we added first user ?


Link to comment
  • 2 weeks later...

Hope this is the right spot for Authelia support questions...it's been awhile since I've posted, everything has been working very well.     


I applied some docker updates this morning, but now I cannot get Authelia to start.   Redis, MariaDB and swag all start ok, but Authelia gives the following error:



time="2021-09-13T17:16:02-05:00" level=info msg="Authelia v4.30.4 is starting"
time="2021-09-13T17:16:02-05:00" level=info msg="Log severity set to debug"
time="2021-09-13T17:16:02-05:00" level=debug msg="Storage schema is being checked to verify it is up to date"
[mysql] 2021/09/13 17:16:02 packets.go:37: unexpected EOF
[mysql] 2021/09/13 17:16:02 packets.go:37: unexpected EOF
[mysql] 2021/09/13 17:16:02 packets.go:37: unexpected EOF
time="2021-09-13T17:16:02-05:00" level=fatal msg="Unable to initialize SQL database: driver: bad connection" stack="github.com/authelia/authelia/v4/internal/storage/mysql_provider.go:81 NewMySQLProvider\ngithub.com/authelia/authelia/v4/internal/commands/root.go:95 getProviders\ngithub.com/authelia/authelia/v4/internal/commands/root.go:65 cmdRootRun\ngithub.com/spf13/[email protected]/command.go:860 (*Command).execute\ngithub.com/spf13/[email protected]/command.go:974 (*Command).ExecuteC\ngithub.com/spf13/[email protected]/command.go:902 main\ngithub.com/authelia/authelia/v4/cmd/authelia/main.go:11 main\nruntime/proc.go:225 main\nruntime/asm_amd64.s:1371 goexit"


Has anyone else seen this?


Link to comment
6 minutes ago, gravymaker said:
[mysql] 2021/09/13 17:16:02 packets.go:37: unexpected EOF
time="2021-09-13T17:16:02-05:00" level=fatal msg="Unable to initialize SQL database: driver: bad connection"

Seems like an issue with your SQL database.


Stop Authelia, force a manual update check on Mariadb and restart it, and then try to start Authelia.

Link to comment

OK - yeah, tried the force update on MariaDB, but it does look like something is wrong with MariaDB.    Although it shows as "started" in the Unraid GUI, the MariaDB log shows that it is constantly restarting.   Lots of this repeating in the log:


2021-09-13 17:31:14 0 [Note] /usr/bin/mariadbd (mysqld 10.5.12-MariaDB-log) starting as process 705 ...
2021-09-13 17:31:14 0 [Note] InnoDB: Uses event mutexes
2021-09-13 17:31:14 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2021-09-13 17:31:14 0 [Note] InnoDB: Number of pools: 1
2021-09-13 17:31:14 0 [Note] InnoDB: Using crc32 + pclmulqdq instructions
2021-09-13 17:31:14 0 [Note] mariadbd: O_TMPFILE is not supported on /var/tmp (disabling future attempts)
2021-09-13 17:31:14 0 [Note] InnoDB: Using Linux native AIO
2021-09-13 17:31:14 0 [Note] InnoDB: Initializing buffer pool, total size = 268435456, chunk size = 134217728
2021-09-13 17:31:14 0 [Note] InnoDB: Completed initialization of buffer pool
2021-09-13 17:31:14 0 [ERROR] InnoDB: Upgrade after a crash is not supported. The redo log was created with MariaDB 10.4.18.
2021-09-13 17:31:14 0 [ERROR] InnoDB: Plugin initialization aborted with error Generic error
2021-09-13 17:31:14 0 [Note] InnoDB: Starting shutdown...
2021-09-13 17:31:14 0 [ERROR] Plugin 'InnoDB' init function returned error.
2021-09-13 17:31:14 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2021-09-13 17:31:14 0 [Note] Plugin 'FEEDBACK' is disabled.
2021-09-13 17:31:14 0 [ERROR] Unknown/unsupported storage engine: InnoDB
2021-09-13 17:31:14 0 [ERROR] Aborting


Link to comment
8 minutes ago, gravymaker said:

Although it shows as "started" in the Unraid GUI, the MariaDB log shows that it is constantly restarting.

Might be easier to just blow away Mariadb and reinstall container. Depending on how many databases you've got setup, but if you don't clear appdata and reinstall from CA Previous Apps if should be fine.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.