tazire

Members
  • Posts

    307
  • Joined

  • Last visited

Everything posted by tazire

  1. My issue seems to have progressed to the following error now... [Warning] Aborted connection 69 to db: 'nextcloud' user: '*****' host: '172.19.0.1' (Got an error reading communication packets)
  2. Yes I have tried different pc's different browsers and still nothing. Also noticed my auto uploads from my phone have stopped working. I did post in mariadb about a warning I was getting in relation to a mysql upgrade but having done that the problem still persists with nextcloud! no warnings in logs either which is making it a real pain to try diagnose.
  3. Thank you... this has solved the warnings I was getting however my underlying nextcloud issue persists.... I assumed it was a DB issue as my files tab just wont load in at all since a recent update and the only errors/warnings I could see were those mentioned... Looks like im off to the nextcloud support to try solve it...
  4. Got an error with Mariadb since a recent update to Nextcloud 23.0.2. I get the following error in logs.... 220221 03:39:47 mysqld_safe Logging to '/config/databases/75c70985ee01.err'. 220221 03:39:47 mysqld_safe Starting mariadbd daemon with databases from /config/databases In the corresponding .err file i get the following reoccurring... 2022-02-21 21:53:59 0 [Warning] InnoDB: Table mysql/innodb_index_stats has length mismatch in the column name table_name. Please run mysql_upgrade running mysql_upgrade in the container console just spits out the following... Version check failed. Got the following error when calling the 'mysql' command line client ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO) FATAL ERROR: Upgrade failed EDIT Ok since this I have managed to login as root on mariadb but mysql_upgrade still has no effect. Any help at all would be much appreciated.
  5. Started getting a strange issue with the files tab on the webgui... It wont populate for me at all.... Just updated recently to 23.0.2 which seemed to be fine but now this. Functionally its fine in every other aspect. Photos tab shows all the most recent uploaded photos etc. Anyone else experienced this? Have updates the container just there this evening too and the problem persists. Is this possibly a mariadb issue?
  6. As I'm not sure if that is the source of the issue or a symptom of a different issue I thought it best to put it in the general support section. I can put it in the UD section if that is the best place for it. Is there another way to mount the share without using UD? Just to see if that solves my issue.
  7. Basically what seems to happen is UD has issues with the NFS share to my truenas server... this in turn seems to cause my docker service to drop completely. All containers no longer available. 1 cpu core gets pegged to 100%. I can stop my docker service and it seems to stop just fine. but i can not restart it. This will cause the server to hang completely. I can not unmount/remove the NFS share at all. And when I try to reboot the server it hangs and requires a hard shut down... This is the 2nd time this has happened. Server has been up 18 days without issue since this last happened. I've included my diagnostics. any help is much appreciated. Oh and my truenas is still working just fine btw. Can access it and see all the files using my personal rig. Thanks in advance. server-diagnostics-20220110-1244.zip
  8. have started getting the same error. [error] 1028#1028: *24559 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 172.19.0.1, server: localhost, request: "POST /RPC2 HTTP/1.1", upstream: "scgi://127.0.0.1:5000", host: "192.168.1.18:9080" the container failed to stop after this... I managed to stop docker but it failed to start then. I rebooted the server and it hung on shut down. After a hard restart this container will not start. I have tried changing the vpn server and re installing the container no joy atm. EDIT Randomly started working again this morning. Must have just been a PIA issue. supervisord.log
  9. Dont go into the docker console to enter those commands. Use Unraid terminal. Also for manual update start at step 3 on the first post.
  10. This solved my issue. Thanks a million for the post.
  11. Have you tried doing the manual update in the first post on this thread?? I have stopped doing the updates in nextcloud because I get errors every now and then and the manual update just works every time for me. Currently on 22.2.3
  12. Having the same issue. I'm trying to install using the Swag certs.... I've copied the .key and .crt files and renamed them to onlyoffice as i have done in the past... unfortunately after that I am kinda stuck... 400 bad request error. Anyone who got this working through swag could you possibly post a guide? cheers.
  13. thanks for the info. I think thats a very new image. I checked and installed all the different images available at the time. good to know its back. EDIT As it turns out I just cant get that container to play nice with SWAG. can access it directly but not using reverse proxy
  14. Thanks for that. I imagine it is likely to get fixed quickly so. Its not super pressing for me so I can hang on for an update. Thanks again for the info. EDIT I imagine you can probably delete app and then install the older version to get it fixed too.
  15. Anyone using the document server with the nextcloud app?? With the most recent update I keep getting The "documentType" parameter for the config object is invalid when trying to open any documents. Googling the issue doesnt really give any info from what I can see. Just curious if anyone has experienced this and perhaps fixed it??
  16. I could but tbh I kinda like that I've been able to to everything I've needed through docker alone. I have 0 VM's setup and havent needed them. And this docker just hasnt worked consistently for me.
  17. Latest update seems to have broken this for me again. Safe to say I wont be returning to Rocket Chat after this. Just has not been stable enough for me.
  18. I did get this sorted. It was a security file which isnt mentioned in the spaceinvaderone video. I'll edit this post when I find it but I cant for the life of me remember where I found it at the moment. It was just a copy paste thing so I dont remember the details atm I'm afraid. I will say I havent actually put RC back into use like I had it but the container is there, running just fine ready for whenever/ if I ever decide to use it. EDIT That solved my issues.
  19. I havent tried to a mounted NFS share to host my appdata but I dont see why you couldnt just use the SSD array as your appdata drive?? unless its too small ofc. MAybe just get a decent sized SSD to handle this side of things for you? I use an NVME for this as I find the quicker access times and speed really make all my containers super snappy.
  20. Yes I did and have it running atm. Its not without its issues though. In my experience I could only access the CLI on first install so I needed to get everything setup the first time. I had to get it setup in multi inbox mode and save all the login details at this point. I have no way to access the CLI after this. I cant change any details or settings but its still running and working just fine other than that.
  21. did you ever get this sorted? I currently have a truenas server I want to mount in unraid. I have it mounted using UD as an SMB share but it is extremely unstable and connection drops regularly. I have tried using NFS too but for the life of me I just cant get the permissions working properly. So at this point I'm just looking for any option to mount a network drive in unraid thats stable.
  22. After recent update the following will appear in rocketchat logs and just not proceed any further. Change Stream is available for your installation, give admin permissions to your database user to use this improved version. This isnt the first time ive had an issue like this. Had the same issue a while back and re installed everything. I havent put it back into use as I wanted to monitor a few updates before I did. And now this again. Any idea what to do?
  23. Looks like im going to have the same trouble with TOTP if I upgrade to 20.0.7. Anyone else have this warning?
  24. I have an idea as to what happened... When I was downloading the .tar file I noticed there is a version of TOTP released already for NC 21-22 which according to the documentation doesnt support NC 20... Id say my instance of NC noticed this as the latest release and that its not compatible and therefore wont show it or allow me to download it. Either way its good to know what to do should it happen again.
  25. Yea im about to go through the manual process of installing the app now... just looking at the appdata for nextcloud it appears to have fully removed the app files from the app folder. I get that during install it may for whatever reason show the app as incompatible with that version but im surprised it has disappeared from the app list as a download option! EDIT No joy on first attempt.... docker exec -it nextcloud occ app:install twofactor_totp Error: Could not download app twofactor_totp EDIT 2 Solved it... I downloaded the .tar file fully extracted it and put it in the apps folder in the appdata and restarted nextcloud. The app re appeared in the disabled list for me. Enabled it and seems to be working as before. Still held the same link to my Google Auth app too. Was expecting to have to set this up again and delete the old one but seems to be fine.