Nextcloud > Benutzer anlegen klappt nicht


Go to solution Solved by mgutt,

Recommended Posts

10 minutes ago, mgutt said:

Also da ist in jedem Fall was in Nextcloud 25 verbuggt.

 

10 minutes ago, mgutt said:

Hatte ich eigentlich schon angemerkt, dass meine private NC auf 24 festgesetzt ist?

Das werde ich jetzt auch erstmal so halten.

 

Danke an Alle für Eure Unterstützung. 🤗

Link to comment
19 minutes ago, mgutt said:

Ok, ich denke das liegt am Browser. Welchen verwendest du? Adblocker oder Popupblocker aktiv? Inkognito-Tab ausprobiert? Mir ist nämlich aufgefallen, dass das Popup ca 1 Sekunde braucht zum Laden. Also schon ungewöhnlich lange. EDIT: Gerade noch mal gedrückt und es dauerte diesmal 10 Sekunden bis das Popup erschien... erneut gedrückt 15 Sekunden, dies mal konnte man kurz die Warnung vom Browser sehen, dass die Seite nicht antwortet. Also da ist in jedem Fall was in Nextcloud 25 verbuggt. EDIT: Diesmal noch länger und ich konnte einen Screen von der Meldung machen:

Ich schätze, das mir das, wenn ich Nextcloud schon länger nutzen würde, auch aufgefallen wäre.

Da ich aber nun mit Version 25 einsteigen wollte, ist es schon etwas unglücklich.

Sollten man die Jungs und Mädels vom NC-Team darauf aufmerksam machen?

Edited by saber1
Link to comment
1 hour ago, saber1 said:

Dann wird zwar der Header gesetzt, aber die Warnung bleibt.

 

Dann wird ja offensichtlich die Advanced Regel bei dir nicht angewendet.

 

Gerade gecheckt, bei mir schon:

image.png.c2a454db4e0fde9052fcb1f8c5d23312.png

 

Sieht bei mir aber soweit genauso aus wie bei dir würde ich sagen:

 

image.png.cb8e149c8ffb16544111f10767e2cc28.png

 

Schau mal bitte in das appdata Verzeichnis von NPM. Im Verzeichnis proxy_host sind die Config-Dateien (leider nur nummeriert):

image.png.3f9a63e8d12a74d6900b8d954371ccc6.png

 

Hat der das dann da entsprechend übernommen?

image.png.a685d3083e187fce9754a6afa1717629.png

Link to comment

 

7 hours ago, saber1 said:

Dann wird zwar der Header gesetzt, aber die Warnung bleibt.

 

Ist denn der Header jetzt da, wenn Du die Advanced Regel gesetzt hast? Falls ja, dann testet Nextcloud sich selbst vermutlich einfach über die lokale IP und da fehlt der Header dann ja. Das heißt du hast in der config.php vermutlich was nicht gesetzt. Hast du overwrite.cli.url gesetzt?

 

 

Link to comment

So sieht die config.php aus:

 

<?php
$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'datadirectory' => '/data',
  'instanceid' => 'xxxxxxxxxx’,
  'passwordsalt' => 'XXXXXXXXXXXXX',
  'secret' => 'XXXXXXXXXXX',
  'trusted_domains' => 
  array (
    0 => '10.0.1.7:444',
    1 => 'nextcloud.domain.com',
  ),
  'trusted_proxies' => 
  array (
    0 => 'nginx',
  ),
  'dbtype' => 'mysql',
  'version' => '25.0.1.1',
  'overwrite.cli.url' => 'https://nextcloud.domain.com/',
  'overwritehost' => 'nextcloud.domain.com',
  'overwriteprotocol' => 'https',
  'dbname' => 'nextcloud_db',
  'dbhost' => '10.0.1.7:3307',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'xxxxxx',
  'dbpassword' => 'XXXXXXXX',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'xxxxxxxx',
  'mail_domain' => 'nextcloud.domain.com',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'smtp.domain.com',
  'mail_smtpport' => '465',
  'mail_smtpname' => 'nextcloud@nextcloud.domain.com',
  'mail_smtppassword' => 'XXXXXXXXXXX',
  'default_phone_region' => 'DE',
);

 

Wie genau prüfe ich, ob der Header "da" ist?

 

Hatte einfach mit einem Header Checker online geprüft.

 

Welche Domain gibt man eigentlich im SSL-Certificate Feld an?

Die Domain? domain.com

Oder die Subdomain? nextcloud.domain.com

 

Weil es ja auch eine Option HSTS Subdomains gibt...

 

Edited by saber1
Link to comment
2 hours ago, saber1 said:
  array (
    0 => '10.0.1.7:444',
    1 => 'nextcloud.domain.com',
  ),
  'trusted_proxies' => 
  array (
    0 => 'nginx',
  ),

 

Trusted Proxies kann nicht funktionieren oder kann nextcloud den Hostnamen "nginx" zum NPM auflösen?

 

Die IP in trusted_domains ist auch überflüssig, weil du overwriteprotocol und overwrite.cli.url auf https gesetzt hast. Nextcloud ist also gar nicht mehr direkt über die IP zu erreichen.

 

2 hours ago, saber1 said:

Hatte einfach mit einem Header Checker online geprüft.

Geht auch. Ich mach das über die Entwicklertools des Browsers. Du hast wieder die Antwort unterschlagen. Fügt nun die Advanced Regel den Header hinzu oder nicht?

 

2 hours ago, saber1 said:

Welche Domain gibt man eigentlich im SSL-Certificate Feld an?

Welches Feld soll das sein?

 

 

Link to comment
9 hours ago, mgutt said:

Trusted Proxies kann nicht funktionieren oder kann nextcloud den Hostnamen "nginx" zum NPM auflösen?

Okay. Also die IP vom NPM eintragen. So sagt es ja auch die Nextcloud Doku... 🙈

 

9 hours ago, mgutt said:

Fügt nun die Advanced Regel den Header hinzu oder nicht?

Heute Nachmittag kann ich mich dem wieder widmen...

 

9 hours ago, mgutt said:

Welches Feld soll das sein?

Oben mein Screenshot vom NPM "Edit Proxy Host". In dem von mir geschwärzten Feld ist meine subdomain.domain.com eingetragen.

Es gib für HSTS dann aber ja zwei Optionen. Eben auch extra eine für Subdomains.

Oder wird es so sein, wenn im Feld bereits eine Subdomain eingetragen wurde, muss halt die Option HSTS Subdomains nicht noch extra aktiviert sein?

 

Link to comment
On 11/20/2022 at 9:00 PM, mgutt said:

Trusted Proxies kann nicht funktionieren oder kann nextcloud den Hostnamen "nginx" zum NPM auflösen?

Welche IP trägt man denn hier ein?

NPM läuft im Bridge-Mode. Also nur die unraid-IP wird wohl nicht reichen.

Welcher Port soll es noch sein? 80? 443?

Link to comment

Eine weitere Frage habe ich zu den Access Lists im Nginx Proxy Manager.

Neben Nextcloud habe ich noch eine weitere Subdomain für BookStack (Wiki) angelegt.

Mittels einer Access List ist es ja möglich eine User/Passwort Abfrage vor dem eigentlichen Erreichen der Oberfläche zu schalten.

Dies funktioniert wohl mittels htaccess, nehme ich an?

 

Jedenfalls klappt das für BookStack auch einwandfrei.

Leider aber nicht für Nextcloud. Es scheint, als ob die Access List einfach ignoriert wird.

 

Muss dafür eventuell auch noch etwas in der config.php von NC konfiguriert werden?

Link to comment
7 hours ago, saber1 said:

Dies funktioniert wohl mittels htaccess, nehme ich an?

 

Jein, also nginx kennt keine htaccess, aber ja es wird dann innerhalb von nginx/NPM eine entsprechende Config hinterlegt.

 

7 hours ago, saber1 said:

Muss dafür eventuell auch noch etwas in der config.php von NC konfiguriert werden?

Nein, der NPM weiß nichts von NC und dessen Config. Entweder lässt er den Traffic durch oder nicht. Und bei Access List sollte er eben erst mal nach dem Login fragen.

 

EDIT: Da hat NPM einen Bug. Keine Ahnung ob das schon bekannt ist, aber sobald man die Advanced Regeln mit einem "location /" Block erstellt, werden die Access Regeln ignoriert. Hier ohne Advanced und mit Access Regel:

image.png.854cc815d8c398c0d97e40060321f093.png

 

Und hier mit Advanced und mit Access Regel:

image.png.535600b4c8c39e7c571d2ac5f47410ac.png

 

 

Wenn du also selbst einen Location Block gesetzt hast, musst du quasi selbst die Regeln ergänzen. Doof ist natürlich, dass NPM mit diesen Zahlen arbeitet. Also nur "1". Die Nummer siehst du wenn du das 3-Punkte-Menü öffnest

image.png.0c29e8e85e2bdb774818b0c2b3f99ec2.png

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.