Jump to content
prostuff1

SickBeard unMenu package

111 posts in this topic Last Reply

Recommended Posts

Hi, I have Sickbeard installed, but not through your package... But I didn't want to start a new thread because this is very close to other reported problems in this thread. Please let me know if you want me to delete this post and start a fresh thread!

 

Problem: After Sickbeard does its 'sorting' of the episode into my TV directory, I can see it in the directory structure of the share over SMB, but I can't open/play it. If I run newperms on it, or if I chmod it after it has been sorted, it will open fine. Currently, I just newperms the whole TV share each time I want to watch TV... which is obviously not ideal.

 

Attempted Solutions: 1) I've tried 'chmod 770' on the autoprocessTV directory and 'chown -R nobody:users' on the autoprocessTV directory as well, but that doesn't seem to help at all.

2) I've tried to make a script that just newperms the TV episode after it has been moved, but SABnzbd gives an 'Exit(-1) Cannot Run Script' error when I select it as the post-processing script. The script is as follows: (note: I've probably made some simple mistake that keeps it from running)

python /mnt/user/temp/sickbeard/autoProcessTV/sabToSickBeard.py "$1" "$2" "$3" "$4" "$5" "$6"
sleep 10
/usr/local/sbin/newperms /mnt/user/TV

 

Also, I have SABnzbd and Sickbeard actually running from my array, not on the flash drive (/mnt/user/temp/). It used to work just fine on unraid 4.7, so it's obviously something with the new security model that I'm not understanding.

 

SABnzbd 0.6.9

Sickbeard current Alpha Master

UnRaid 5b12

 

Thanks for any help you can give!

 

 

You are probably running SABnzb and SickBeard as the root user.  Therefore every file downloaded is own and only owned by that user and group.  That is the reason all my packages check for the version of unRAID being run and then starts the app as either root (on 4.7)  or nobody (on 5.0).

Share this post


Link to post

Thanks for the response! Is there a quick way to edit the go script to start SABnzbd and SickBeard as nobody? Or would the best way be to reinstall using your packages?

Share this post


Link to post

Thanks for the response! Is there a quick way to edit the go script to start SABnzbd and SickBeard as nobody? Or would the best way be to reinstall using your packages?

If you want support from me... use my packages

 

Starting the apps as nobody involves quite a few steps, all of which are in the .conf file.

Share this post


Link to post

Going to try and install this tomorrow, I already have SAB installed on my cache drive.  Anything special I need to know, settings, things to change, ports, etc?

 

Thanks

Share this post


Link to post

Going to try and install this tomorrow, I already have SAB installed on my cache drive.  Anything special I need to know, settings, things to change, ports, etc?

 

Thanks

 

Well I found it very easy to setup using the config files supplied here. It should install it on port 8081 and Sab will be 8082. You will need to put your nzb provider details in so SB can search for you and also the SAB api key and port. I just googled sabtosickbeard to get a step by step guide which will allow SB to post process.

 

I am having a minor problem. SickBeard is on my cache drive and working very well so far. However I want to rename some of the existing tv shows on a raid drive but I cannot access it using the sickbeard ui. When i go to mnt/cache/and so on its fine but it will not go past /mnt/disk2 to access my tv shows. This happens regardless if the disk is spinning or not, its just the barber shop loading bar down the bottom..

Thanks

Share this post


Link to post

Well Im sure it will probably work if you installed Sb onto 8082, but its so simple to reinstall and you wont lose any downloads I guess its not much trouble to reinstall it - you will be covered by the default configs for anything you overlook at least  :P

Share this post


Link to post

Ok I have a question that is semi off topic. I had sickbeard running on a PC, I am now installing on unraid. Is there anyway I can copy over a file containing the database for lack of a better term of the shows i have set up and what is already downloaded?

 

Thanks

 

John

Share this post


Link to post

Ok I have a question that is semi off topic. I had sickbeard running on a PC, I am now installing on unraid. Is there anyway I can copy over a file containing the database for lack of a better term of the shows i have set up and what is already downloaded?

 

Thanks

 

John

Probably... but I am not going to even hazard a guess on how to do it.

Share this post


Link to post

Ok I have a question that is semi off topic. I had sickbeard running on a PC, I am now installing on unraid. Is there anyway I can copy over a file containing the database for lack of a better term of the shows i have set up and what is already downloaded?

 

Thanks

 

John

Probably... but I am not going to even hazard a guess on how to do it.

 

Hey nothing ventured nothing gained right ??

 

So I figured its a fresh install how bad can I eff it up.......

 

Copied over the 3 db files renaming the existing ones .old and everthing populated I figure I might still have to tweak some settings and rescan directories but at least  Iam not starting from scratch.

 

Share this post


Link to post

Anyone else having problems installing this lately? The Md5 sum is not matching and while it's mentioned in the first post I'm wondering if that is the issue. Followed the same instructions and process for Transmission and Sabnzbd and they work fine.

Share this post


Link to post

yeah, there's been an update. the new file is midgetspy-Sick-Beard-9427d92.tar.gz and the md5 is e73561b08bdb167f60178ca0d43b4c06

Thanks and uploaded the new one.

Share this post


Link to post

hi,

 

Don't know if my problem is related with a reboot of my unRaid tower, but I can't restart sickbeard since.

 

I have downloaded the latest .conf for sickbeard and sabnzbd to reinstall them, without any problem. But when I try to reach my NAS:8082 to get sickbeard, nothing appears. So I have checked the "start sickbeard" button in the user script of unmenu, and it says :

 

mkdir: cannot create directory `': No such file or directory
SickBeard started as root.

 

And if I check the logs of sickbeard, it says :

 

Jan-16 19:51:23 INFO     MAIN :: Starting Sick Beard on http://localhost:8081
Jan-16 19:51:29 ERROR    MAIN :: Unable to start web server, is something else running on port 8081?
Jan-16 19:51:29 ERROR    MAIN :: Launching browser and exiting

 

I know that it's sabnzbd running on 8081, but in the Configuration Variables of the sickbeard package, the install-port is 8082. I try to change it to 8083 and re-install sickbeard, but it's the same problem, and the same ERROR in the log file of sickbeard  :(

 

Any ideas ?

 

edit :

 

I have deleted all the related file in the package directory, restart my unRaid and restart an installation of sickbeard via the last .conf in the 1st page. Still the same error :

 

Installed Sick Beard to /mnt/cache/.sickbeard
SickBeard config.ini file already exists
Created unraid.d directory
Created init script, /etc/rc.d/unraid.d/rc.unraid_sickbeard
Created unmenu start script, /boot/unmenu/42-unmenu_user_script_start_sickbeard
Created unmenu start script, /boot/unmenu/42-unmenu_user_script_stop_sickbeard
mkdir: cannot create directory `': No such file or directory
SickBeard started as root.
Please go Here to setup SickBeard the rest of the way

 

I have checked my config.ini file of my sickbeard directory, and it's empty. Perhaps it's a hint ?

 

edit 2 :

 

I have deleted that existing config.ini, and now, every thing is fine, sickbeard works. But it still say that "There is a newer version available (or else you're ahead of master)— Update Now" but it works, that all I wanted :)

 

Share this post


Link to post

I was going through this .conf file trying to figure out how to write my own and I noticed that there are some references to sabnzbd at the bottom in the start script. Is it supposed to be like that?

Share this post


Link to post

I was going through this .conf file trying to figure out how to write my own and I noticed that there are some references to sabnzbd at the bottom in the start script. Is it supposed to be like that?

No, that was just a mistype, it is fixed now and a new file has been uploaded.

Share this post


Link to post

a couple more things. there's a new version.

 

file: midgetspy-Sick-Beard-b746984.tar.gz

md5: 745530684e0b217fcbb288a4457057e3

 

 

Also, the first post has references to CouchPotato.

Share this post


Link to post

a couple more things. there's a new version.

 

file: midgetspy-Sick-Beard-b746984.tar.gz

md5: 745530684e0b217fcbb288a4457057e3

 

 

Also, the first post has references to CouchPotato.

Thanks, and new file with update SickBeard uploaded.  Keeping up to date with the latest versions of these apps can be a pain in the arse sometimes.

Share this post


Link to post

i saw you updated the .conf so i thought i would update mine as the nag at the top of SB screen was bugging me...i telnetted into server and typed..

 

rm /etc/rc.d/unraid.d/rc.unraid_sickbeard

 

then i dropped the .conf file into packages folder on flash but it wont let me overwrite, i need permissions, having been a windows stalwort for many years i am finding it difficult to do somthing which im sure most of you here find easy

Share this post


Link to post

removing the rc.unraid_sickbeard wouldn't have been the way to go. You could have updated through Sick Beard itself.

I tried to code the package in a way that an update through SickBeard would stick but to be totally honest I am not sure if it truly works.

 

I update the packages but I rarely update the app that is running on my server unless I really need to.

 

 

As far as not being able to copy to the flash, sounds like the flash is read-only or something like that.  You should be able to over write the .conf file without issue.

Share this post


Link to post

I've used your script to install, and update through the app with no problem. has stayed updated after a reboot too. I have it installed on the cache drive, not sure if that makes a difference.

Share this post


Link to post

I've used your script to install, and update through the app with no problem. has stayed updated after a reboot too. I have it installed on the cache drive, not sure if that makes a difference.

That is actually very good to know!!

 

I install everything to a cache drive also, but like I mentioned, I never bothered trying to update as it was not that important to me as long as the application was working.

Share this post


Link to post

It is indeed set to read only on that file, how do i change the permission ?

 

 

I have updated via the SB and it seems to work but ill keep an eye on it as i am sure i already done this, however, it could be a newer update

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.