Jump to content
mayhem2408

Serviio Media Server V1.4 Plugin for unRAID V5.0

269 posts in this topic Last Reply

Recommended Posts

This is a plugin for the Serviio media server V1.4. Serviio is a cross platform, java based DLNA/uPnP media server capable of serving audio, video and images. This plugin will install a Java Runtime Environment (JRE), the Serviio media server, ffmpeg and librarys compatible with Serviio, and a webgui to allow easy configuration of the Serviio media server from within the unRAID webgui. Serviio can also be configured via a Mac OSX and Windows Console which can be downloaded from http://www.serviio.org/ and via an Android app called ServiiDroid available for free on the android market.

 

Installation:

create a directory called "plugins" at the root of your unraid USB key and copy the .plg file into it. There are two plugins to choose from. One called cache and one called flash. The Cache version of the plugin will install serviio onto your cache drive. If you do not have a cache drive, use the flash version of the plugin to install serviio onto your USB boot flash drive.

 

Run:

The plugin script will automatically run when the unRAID server starts up.

However, it you want to start the plugin without rebooting, either go to the console or telnet into the server

as the prompt, type

installplg /boot/plugins/serviio-1.4-1jr-flash.plg

or

installplg /boot/plugins/serviio-1.4-1jr-cache.plg

After running the install, you will need to reboot your unraid server for the database creation to start.

 

As of plugin version 1.0.1-2, it is no longer nessessary to remove the old Version 1.0 folders as the new script will be able to update the program files and leave your original database intact. If you have a version prior to V1.0, (Beta versions included), the new version will install and new folder leaving your old version intact, but dues to database changes, your old data will not be compatible with the new version and will have to be set up as new.

 

This installation also includes all the online source plugins as at 26/02/2013.

 

History:

2013-08-21 1.4-1jr - Updated to Serviio V1.4, Latests Plugins.

2013-08-21 1.3.1-1jr - Updated to Serviio V1.3.1, Latests Plugins.

2013-03-29 1.2.1-1jr - Updated to Serviio V1.2.1, Latests Plugins.

2013-03-02 1.2-1jr - Updated to Serviio V1.2, Plugins for V1.2.

2013-02-12 1.1-10jr - Complete rewrite of the ffmpeg package. ffmpeg and librarys are now in a slackware package for easy installation or portability.

2013-02-06 1.1-9jr - Big rewrite of the rc.serviio start and stop routines and complete rewrite on disks_mounted and unmounting_disks. Should fix issues causing the script to fail and for some people preventing the unRAID server from stopping the array cleanly.

2013-02-05 1.1-8jr - Modified ffmpeg installer so it will run smoother with the modified subsonic plugin

2013-02-04 1.1-8.0jr - Modified some of the code that handled version numbering. Does not affect the functionality of the plugin. Just makes it easier to maintain.

2013-02-04 1.1-7jr - Relocated the unpack script to rc.serviio which is only executed once the array comes on line. Should solve the ffmpeg issue once and for all.

2013-02-04 1.1-6jr - temporary work around for ffsetup.sh script issue on cache drives.

2013-01-29 1.1-5jr - Added a Done button to the Serviio settings page.

2013-01-27 1.1-4jr - Added file permissions correction and fix a bug in the unpack script.

2013-01-26 1.1-3jr - Added libdc1394 and libraw1394 packages at the request of piotrasd.

2013-01-23 1.1-2jr - Updated jre to 7u2. Serviio V1.1 seems stable on 7u2 now.

2013-01-15 1.1-1jr - Updated to Serviio V1.1, Webui V1.0.1 and Plugins. as of 2013-01-14

2012-09-11 1.0.1-5jr - Corrected a minor bug in the unpack script.

2012-08-23 1.0.1-4jr - Updated version detection in script. Reduced code size and faster.

2012-08-21 1.0.1-3jr - Updated online sources plugins now with over 70 supported

2012-08-19 1.0.1-2jr - Updated unpack script so it can upgrade V1.0 servio to V1.0.1 without a clean install

2012-08-19 1.0.1-1jr - Updated to Serviio V1.0.1

2012-05-02 1.0-1jr - Reverted to jre 6u27. Included support for over 50 online sources. Updated to Serviio V1.0

2012-04-27 0.9-1jr - Updated jre to 7u2 (from 6u27)

2012-04-20 0.8-1jr - Moved plugins to /boot/plugins and packages to /boot/packages

2012-04-20 0.7-1jr - Included the download and installation of java jre-6u27-i586-1aj

2012-04-18 0.6-1jr - Added page, php and png files for unraid/serviio webui intergration

2012-04-17 0.5-1jr - Added WebUI accessable at http://tower:8123/serviio/console

2012-04-17 0.4-1jr - Created a dropbox account to access the ffmpeg files required by serviios transcoder

2012-04-17 0.3-1jr - Modified the disks_mounted event to only start attempt to start serviio if it is not running

2012-04-16 0.2-1jr - Modified to use unRAID V5.0 events instead of the unraid_addon_control.sh script

2012-04-15 0.1-1jr - first release

 

Please report any problems with the plugin here. If you have specific issues or feature requests with Serviio, please direct them here http://forum.serviio.org/

 

Files:

plugin file: http://dl.dropbox.com/u/73389880/serviio-files/serviio-1.4-1jr-cache.plg

plugin file: http://dl.dropbox.com/u/73389880/serviio-files/serviio-1.4-1jr-flash.plg

 

2013-04-24: For the users out the that also want to use the Subsonic Streamer, I have modified the original subsonic plugin so that is does not clobber the newer ffmpeg installed by my plugin and fixed an issue that was preventing subsonic from using the newer ffmpeg I installed when working from the USB boot drive.

plugin file: http://dl.dropbox.com/u/73389880/subsonic-files/subsonic-4.8-1.0.0jr.plg

 

 

Screenshots:

Serviio_1_settings_menu1.png

 

Serviio_2_unraidpage1_v1.1.png

 

Serviio_3_consolewebgui1_v1.1.png

 

Serviio_4_serviiomediabrowser.png

 

Serviio_5_serviidroid.png

https://play.google.com/store/apps/details?id=com.serviidroid&hl=en

 

Serviio_6_serviigo.png

https://play.google.com/store/apps/details?id=com.serviigo

Share this post


Link to post

Your JRE install is clobbering the previous JRE install - same version is installed, but something is different and kills it.

 

The JRE I previously have installed is what subsonic installs.....

 

Have to removed yours

 

Myk

 

Share this post


Link to post

Your JRE install is clobbering the previous JRE install - same version is installed, but something is different and kills it.

 

The JRE install is the same as the one used by the ps3 media server plugin. I'll have a look and the JRE install from subsonic and find out where the conflict is. Thanks for the feedback.

Share this post


Link to post

The JRE I previously have installed is what subsonic installs.....

 

There appears to be a few conflicts with subsonic and serviio. My install uses JRE 6u27, while subsonic used JRE 7u2. I will experiment with updating my plugin to use the newer version.

 

Subsonic plugin is installing an old version of ffmpeg V0.6.1. Serviio requires V0.9 or higher. I install V0.9 of ffmpeg and a number of updated librarys that are linked to it. I do not know if Subsonic can use ffmpeg v0.9, but I know for sure that serviio can not use ffmpeg V0.6.1. The version I install is of my own compile to make sure it is 100% compatible with serviio. I'll do some experimenting with subsonic and see what happens.

Share this post


Link to post

I don't post very often (or at all) but I wanted to thank you for creating this plugin. I've been trying to find an alternative to minidlna that plays nice with Samsung TVs.

 

...Unfortunately I can't get this to work. At first I assumed that it was other plugins, such as the aforementioned Subsonic that were causing the conflict. However, even after uninstalling all my plugins it still doesn't work.

 

I've attached my log file in the hopes it might provide some answers. I don't know much about linux but I'll be glad to provide any other information you might need.

 

installing plugin: serviio-0.8-1jr
file /boot/plugins/jre-6u27-i586-0.2-1jr.plg: downloading from http://dl.dropbox.com/u/73389880/serviio-files/jre-6u27-i586-0.2-1jr.plg ... 2012-04-30 13:30:14 URL:http://dl.dropbox.com/u/73389880/serviio-files/jre-6u27-i586-0.2-1jr.plg [2329/2329] -> "/boot/plugins/jre-6u27-i586-0.2-1jr.plg" [1]
success
file /boot/config/plugins/serviio/serviio-0.6.2-linux.tar.gz: downloading from http://download.serviio.org/releases/serviio-0.6.2-linux.tar.gz ... 2012-04-30 13:30:33 URL:http://download.serviio.org/releases/serviio-0.6.2-linux.tar.gz [14038981/14038981] -> "/boot/config/plugins/serviio/serviio-0.6.2-linux.tar.gz" [1]
success
file /boot/config/plugins/serviio/serviio-ffmpeg-1.1-1jr.tgz: downloading from http://dl.dropbox.com/u/73389880/serviio-files/serviio-ffmpeg-1.1-1jr.tgz ... 2012-04-30 13:30:41 URL:http://dl.dropbox.com/u/73389880/serviio-files/serviio-ffmpeg-1.1-1jr.tgz [9544473/9544473] -> "/boot/config/plugins/serviio/serviio-ffmpeg-1.1-1jr.tgz" [1]
success
file /boot/config/plugins/serviio/serviio-webui-0.6.2-d.tgz: downloading from http://dl.dropbox.com/u/73389880/serviio-files/serviio-webui-0.6.2-d.tgz ... 2012-04-30 13:30:42 URL:http://dl.dropbox.com/u/73389880/serviio-files/serviio-webui-0.6.2-d.tgz [198950/198950] -> "/boot/config/plugins/serviio/serviio-webui-0.6.2-d.tgz" [1]
success
file /boot/config/plugins/serviio/serviio.png: downloading from http://dl.dropbox.com/u/73389880/serviio-files/serviio.png ... 2012-04-30 13:30:42 URL:http://dl.dropbox.com/u/73389880/serviio-files/serviio.png [4329/4329] -> "/boot/config/plugins/serviio/serviio.png" [1]
success
file /tmp/unpackserviio.sh: successfully wrote INLINE file contents
  successfully changed file mode
  /bin/bash /tmp/unpackserviio.sh ... installing plugin: jre-6u27-i586-0.2-1jr
2012-04-30 13:30:57 URL:http://carroll.cac.psu.edu/pub/linux/distributions/slackware/slackware-current/slackware/l/jre-6u27-i586-1.txz [24575196/24575196] -> "/boot/packages/jre-6u27-i586-1.txz" [1]
file /boot/packages/jre-6u27-i586-1.txz: downloading from http://carroll.cac.psu.edu/pub/linux/distributions/slackware/slackware-current/slackware/l/jre-6u27-i586-1.txz ... success
  upgradepkg --install-new /boot/packages/jre-6u27-i586-1.txz ...
+==============================================================================
| Installing new package /boot/packages/jre-6u27-i586-1.txz
+==============================================================================

Verifying package jre-6u27-i586-1.txz.
Installing package jre-6u27-i586-1.txz:
PACKAGE DESCRIPTION:
# Java(TM) 2 Platform Standard Edition Runtime Environment.
#
# The J2SE(TM) Runtime Environment (JRE) is intended for software
# developers and vendors to redistribute with their applications.
# It contains the Java virtual machine, runtime class libraries, and
# Java application launcher that are necessary to run programs written
# in the Java programming language.
#
# If you need development tools, obtain the jdk from /extra, or see the
# web page:   http://java.com/
#
Executing install script for jre-6u27-i586-1.txz.
Package jre-6u27-i586-1.txz installed.


success
2012-04-30 13:31:06 URL:http://dl.dropbox.com/u/2902950/unRAID/jre/jre.png [2020/2020] -> "/boot/config/plugins/jre/jre.png" [1]
file /boot/config/plugins/jre/jre.png: downloading from http://dl.dropbox.com/u/2902950/unRAID/jre/jre.png ... success
file /tmp/jre-cleanup: successfully wrote INLINE file contents
  /bin/bash /tmp/jre-cleanup ... success
file /boot/config/plugins/jre/jre.cfg: successfully wrote INLINE file contents
file /usr/local/emhttp/plugins/jre/jre.page: successfully wrote INLINE file contents
file /usr/local/emhttp/plugins/jre/jre.png: successfully copied LOCAL file
file /usr/local/emhttp/plugins/jre/jre.php: successfully wrote INLINE file contents
file /var/log/plugins/jre: successfully wrote INLINE file contents
plugin successfully installed
tar: serviio-0.6.2/lib/serviio.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/serviio-client.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/log4j.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/freemarker.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/derby.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/jaudiotagger.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/sanselan.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/slf4j-api.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/jul-to-slf4j.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/slf4j-log4j12.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/jcl-over-slf4j.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/jcs.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/concurrent.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/xstream.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/org.restlet.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/org.restlet.ext.xstream.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/org.restlet.ext.net.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/rome.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/jdom.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/rome-modules.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/gson.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/groovy-all.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/winp.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/httpcore.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: serviio-0.6.2/lib/org.restlet.ext.gson.jar: Cannot change mode to rwsrwsrwt: Operation not permitted
tar: Exiting with failure status due to previous errors
/tmp
success
file /tmp/serviio-cleanup.sh: successfully wrote INLINE file contents
  successfully changed file mode
  /bin/bash /tmp/serviio-cleanup.sh ... rm: cannot remove `/usr/local/emhttp/plugins/serviio': No such file or directory
success
file /boot/config/plugins/serviio/serviio-webui.sh: successfully wrote INLINE file contents
  successfully changed file mode
  /bin/bash /boot/config/plugins/serviio/serviio-webui.sh ... success
file /usr/local/emhttp/plugins/serviio/Serviio.php: successfully wrote INLINE file contents
file /usr/local/emhttp/plugins/serviio/Serviio.page: successfully wrote INLINE file contents
file /usr/local/emhttp/plugins/serviio/serviio.png: successfully copied LOCAL file
file /etc/rc.d/rc.serviio: successfully wrote INLINE file contents
  successfully changed file mode
file /usr/local/emhttp/plugins/serviio/event/disks_mounted: successfully wrote INLINE file contents
  successfully changed file mode
file /usr/local/emhttp/plugins/serviio/event/unmounting_disks: successfully wrote INLINE file contents
  successfully changed file mode
plugin successfully installed

 

The window/frame that should provide information to Serviio either remains empty, or displays a "This web page is not available" depending on the browser which makes me assume the process hasn't started. Additionally running a "ps -ef" shows no indication of Serviio running. The Java plugins appears to be working fine but I'm not sure how to test it.

 

My suspicion is that it has something to do with the long string of "Cannot change mode to rwsrwsrwt: Operation not permitted", but heck if I know! I should mention I was logged in as root via telnet, if that helps.

 

Thanks again for making the plugin, I really hope to be able to get it running at some point.

 

 

*EDIT* Just tried a 100% fresh install, same issue.

Share this post


Link to post

The JRE I previously have installed is what subsonic installs.....

 

There appears to be a few conflicts with subsonic and serviio. My install uses JRE 6u27, while subsonic used JRE 7u2. I will experiment with updating my plugin to use the newer version.

 

Subsonic plugin is installing an old version of ffmpeg V0.6.1. Serviio requires V0.9 or higher. I install V0.9 of ffmpeg and a number of updated librarys that are linked to it. I do not know if Subsonic can use ffmpeg v0.9, but I know for sure that serviio can not use ffmpeg V0.6.1. The version I install is of my own compile to make sure it is 100% compatible with serviio. I'll do some experimenting with subsonic and see what happens.

 

If it helps, I'm using ffmpeg V0.9 for Subsonic without issue (ffmpeg-0.9-i486-1alien.tgz).  In fact, video in Subsonic was flakey until I updated.  I think others running Subsonic on UnRaid have upgraded also.  Check the Subsonic thread on these forums.

 

I also have JRE 6u27 as I wanted to run the same as SAB and Sickbeard. Not sure if that's changed in recent times as tend to modify plugins to fit my needs so unfortunately my system is no template for others, but the info might help you guys reach a common package level.

 

Share this post


Link to post

My suspicion is that it has something to do with the long string of "Cannot change mode to rwsrwsrwt: Operation not permitted", but heck if I know! I should mention I was logged in as root via telnet, if that helps.

 

The Cannot change mode error is not a problem. This is because some of the required files are written to the flash drive and because the flash drive is formatted in FAT, the modes can not be assigned. It does not cause a problem though.

 

Have you tried a reboot since the install. I have had an issue with serviio not starting up after an install. It creates the required databased first on first run, but the process did not start. On the second start, (with the database already created), serviio started OK and the webgui wrapper also started OK.

 

You can try to manually stop and start the serviio process from the prompt. I usually use telnet.

At the prompt type

/etc/rc.d/rc.serviio stop

this will stop the serviio service

then type

/etc/rc.d/rc.serviio start

to start it up again.

 

Let me know if this works.

Share this post


Link to post

Alternatively you and stop and start serviio by stopping and starting the array from unRAIDs main menu.

 

Share this post


Link to post

Well then, that was simple enough...

 

While starting and stopping the process didn't work (it claimed there was nothing to stop), rebooting the server post install seemed to fix it. I'll test it out tonight, thanks!

Share this post


Link to post

I use Unraid version 5B14

The Installation want OK, but when I try to see the server under setting (tower web interface) i get start of the windows (the fist horizontal line)

Only If i run installplg servioo again (it actually do nothing, since every thing is already installed) , the I get the web interface.

After boot the server , same issue , I lost the serviio server web page.

 

any idea ?

 

Share this post


Link to post

I have Serviio installed but I can't access any of my files on my Unraid server? Is this a unraid server setup issue or Serviio setup issue. I can see the folders on my server but can't see the files. What do I need to see the files so I can stream them to my Xbox and Asus TF300t tablet?

Share this post


Link to post

the ajax interface doesn't appear to function properly in firefox 12.0 on Mac. Works fine in Safari though.

 

here it is in firefox - http://cl.ly/0e050B251X0S2d1Z1n3D

and in safari - http://cl.ly/140m3H1X0H3T3X3h1m3b

 

You can try my modification of this plugin - you will find in the attachment or on my GitHub. If you install it just click on 'Serviio' below 'Additional informations'. This plugin is redesigned for cahce drive systems.

serviio_mod.zip

Share this post


Link to post

Having trouble getting this installed - rebooting the server does not seem to work, as I cannot seem to get the Serviio icon to appear in the settings menu. When I try and install manually from the console I get the following message:

 

Warning: simplexml_load_file(): I/O warning : failed to load external entity "/boot/plugins/serviio-0.8-1jr.plg" in usr/local/sbin/installplg on line 13 xml parse error

 

Can anyone suggest where I am going wrong?

 

Many thanks

Share this post


Link to post

I had the same problem as you BlackBriar, I opened the plg file and copied it into notepad++ and resaved.  Works fine after that

Share this post


Link to post

Any help. I still can't see my files on my Unraid server but Serviio seems to be working because I can change setting through the Android app and I can see the server through MyNet on my Asus TF300t but go to video and don't see anything. I get on my Windows 7 PC and can see Serviio server and can play the files. What gives?

Share this post


Link to post

I cannot load the necessary Java files ( jre-6u27-i586-1.txz )- they do not appear to be available from the site described in the serviio plg file- to enable me to install the Serviio Media Plugin

"

<FILE Name="/boot/packages/jre-6u27-i586-1.txz" Run="upgradepkg --install-new">

<URL>http://carroll.cac.psu.edu/pub/linux/distributions/slackware/slackware-current/slackware/l/jre-6u27-i586-1.txz</URL>

<MD5>a21d5346d9250290cd3b4f8305d5a7eb</MD5>

</FILE>

"

Can anyone advise an alternate site for this file?

 

Share this post


Link to post

I managed to boot with Unraid Serviio. It shares the folders that contain music, but containing videos not detect the files.

 

At last someone with something similar?

Share this post


Link to post

I successfully installed serviio using the posted instructions, but when clicking the icon at first I was presented with a "could not connect page" that indicated the correct IP address.  Next I rebooted my unRAID server and at the server login prompt apparently the serviio script ran because it inserted "/boot/config/plugins/serviio/serviio-0.6.2/bin/serviio-wrapper.sh: line 59: /usr/lib/java/bin/java: No such file or directory"

 

Any ideas what is causing this?  Is there somewhere in one of the serviio files I need to insert my username/password so that it is logged in prior to trying to execute the script?

 

After manually logging in I ran the serviio script using the above command and received "line 59: java : command not found"

 

When installing serviio it appeared to have downloaded and installed the necessary components.  Did I miss something?

 

Thanks.

Share this post


Link to post

Hi i am able to install serviio, but i can not add any files to the library. i've tried to alter permission but i must be doing something wrong. Can any one help please

 

Share this post


Link to post

All good library scanning is very slow.

 

But i do have another problem if i change the selected render from generic to suit my media players, serviio disappears and even after clean restart does not come back online. Maybe internal serviio prob??

Share this post


Link to post

All good library scanning is very slow.

 

But i do have another problem if i change the selected render from generic to suit my media players, serviio disappears and even after clean restart does not come back online. Maybe internal serviio prob??

 

I had similar issues with speed until I put a 128GB SSD as my cache drive. It went for 2 minutes to build a new database on my flash drive, to 2 seconds to build on the SSD.

 

If you have gone from a Beta version to V1.0 or V1.0 to V1.0.1, you may have to delete the serviio-1.0 folder and start fresh. It could be a database issue. Best idea is to go to the serviio forums, turn on detailed loging in serviio and post the log. The serviio developer should be able to pinpoint the problem.

Share this post


Link to post

Hi,

 

I am running unRAID 5.0-rc5 with  serviio-1.0.1-3jr-flash.plg

 

Noticed that there isn't a Remote tab in the Serviio console - unRAID/LIME TECH Web page--Settings panel - Network services- Serviio Media server ( used for setting user password for remote access ). I  used the Serviio Console installed on my pc instead.

 

Rgds.

 

Stan Chelchowski

 

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.