Jump to content
theone

VirtualBox Plugin for unRAID v5 and v6

778 posts in this topic Last Reply

Recommended Posts

well, this is a nice plugin and so forth - but is not going to work for me - trying to load my asterisk pbx vm causes a out of memory error by filling up the ram drive that /opt sits on.  I got 6G in this machine, and it runs just find on windows with 2G - so I am going to have to figure something else - was trying to eliminate one more machine running - but it aint gonna happen....

 

Myk

 

Share this post


Link to post

Hi, I have following issues

 

1: no internet on Slackware 32 & 64 bit, but W8 I have internet

2: no Install Guest Additions both for slack & w8

 

I cant find where to  Install Guest Additions, my bee that is why I have low resolution and mouse lagging ?

 

Any one have a solution to make progress ?

 

Maybe Install Guest Additions should be a part of the plugin?

 

EDIT

 

I found this on google

 

After installing Windows (XP, 7, etc.) on your virtual machine, simply select Devices ? Install Guest Additions...

But that is not existing in phpvirtualbox ??? see a image attached

 

//Peter

install.JPG.aad1b9f9f91f618df4feed0752444ef9.JPG

Share this post


Link to post

have you been able to get remote desktop connection to work - it defaults to 127.0.0.1 for the ip - which would be fine if I were not viewing the phpvb interface from a windows machine so remote desktop connection trys to connect to itself - cant not find anywhere to change the ip

 

Myk

 

Share this post


Link to post

when the indv vm is running, its at the bottom of the settings gear icon.....

For me my menu looks like this when I started a VM

 

vm8.JPG.6771462f732537a453bf99739bbef7e3.JPG

Share this post


Link to post

I manage to fix this, needed to DL the VBoxGuestAdditions_4.2.6.iso from here -> http://download.virtualbox.org/virtualbox/4.2.6/

 

Then I add this to storage for the VM, then in slackware I mounted this and run the installer, now it works

 

EDIT

 

Works on slackware 32 but not on slackware 14 64bit, is VBoxGuestAdditions_4.2.6.iso not compatible with 64 bit OS ?

EFIT 2

 

Solved; increased the display memory, now everything works

 

Learning by doing  ;)

 

 

//Peter

Share this post


Link to post

New version:

0.4.2 - Fixed: Icon file couldn't be saved because plugin folder doesn't exist on first run.

Share this post


Link to post

New version:

0.5  - Added option to download GuestAdditions Package

      - Added option to change /boot/custom/vbox to different location including moving of files

      - Changed configuration update code

 

I added the option of downloading Guest Additions package so you don't have to look for it online.

Changing the /boot/custom/vbox to a different location was requested so that there will not be any writing to the flash drive by VirtualBox.

 

Share this post


Link to post

I've updated to v0.5 of the plugin and then reloading everything from scratch because of some other issues with Vbox. When i click the install option it kinda hangs and doesn't proceed to install. using the top command from terminal I see this running

 

"11547 root      20   0 20616 7704 4104 S  100  0.1   8:53.54 /opt/VirtualBox/VBoxSVC --auto-shutdown" 

 

I've run the autoshut down from terminal and get this output.

 

 

"root@Storageking:~# /opt/VirtualBox/VBoxSVC --auto-shutdown 
VBoxSVC: error: Failed to register the server name "VBoxSVC-4.2.6" (rc=NS_ERROR_FAILURE)!
VBoxSVC: error: Is another server already running?
XPCOM server has shutdown."

 

 

Is there a way to downgrade the plg file to an older version?

 

Thanks

WIll

 

Share this post


Link to post

 

Changing the /boot/custom/vbox to a different location was requested so that there will not be any writing to the flash drive by VirtualBox.

Any one knows if the files in /boot/custom/vbox is just temporary files? It looks like if they are removed, no machine show up in the web GUI (phpvirtualbox)

//Peter

Share this post


Link to post

peter_sm,

They are not just temporary files.

When moving this symlink in my plugin I also move the files to the new location.

 

BillyJ,

please post your syslog and virtualbox.cfg

Share this post


Link to post

Thanks, How about to move all machines from cache to the array, I need to have some protection, what is the best way to do this? can this be a part of the plugin? ;-)

//Peter

 

Share this post


Link to post

Thanks, How about to move all machines from cache to the array, I need to have some protection, what is the best way to do this? can this be a part of the plugin? ;-)

//Peter

I think you can copy them over and reopen them from new location using phpVirtualbox.

I don't want to add too much to the plugin that can be achieved using phpVirtualbox.

Share this post


Link to post

New version: 0.5.1 - Fixed bottom of page is sometimes not visible due to unRAID progressframe

Share this post


Link to post

 

 

I added the option of downloading Guest Additions package so you don't have to look for it online.

Changing the /boot/custom/vbox to a different location was requested so that there will not be any writing to the flash drive by VirtualBox.

Didn't work 100%, now machine shows up in phpvirtualbox, however copy all files from /boot/custom/vbox to new location, all is working ;-)

 

//Peter

Share this post


Link to post

Didn't work 100%, now machine shows up in phpvirtualbox, however copy all files from /boot/custom/vbox to new location, all is working ;-)

 

//Peter

 

Didn't it move over the files automatically once you changed the symlink location in the WEBUI?

Can you please post a syslog so I can see if I have an error in the plugin?

 

Share this post


Link to post

Here are some log

 

Upgrading local plugin (v0.4.2) to hosting server plugin (v0.5.1)
Feb 25 16:39:56 tower rc.virtualbox[25009]: Icon downloaded from icon hosting server
Feb 25 16:39:56 tower rc.virtualbox[25012]: Icon copied to emhttp plugin folder
Feb 25 16:39:56 tower rc.virtualbox[25014]: New/Updated plugin installation complete
Feb 25 16:41:00 tower rc.virtualbox[26970]: Latest VirtualBox Guest Additions (v4.2.6) does not exist in local plugin folder, removing all existing local versions and downloading...
Feb 25 16:45:33 tower rc.virtualbox[31643]: Symbolically linked /mnt/cache/VirtualBox/vbox to /root/.VirtualBox
Feb 25 16:45:33 tower rc.virtualbox[31644]: VBOX_SYMLINK_LOCATION not valid - Cannot move file to new symlink location
Feb 25 16:45:33 tower rc.virtualbox[31645]: Plugin configuration written
Feb 25 16:45:56 tower rc.virtualbox[32255]: VBoxManage setproperty websrvauthlibrary null
Feb 25 16:45:56 tower rc.virtualbox[32270]: vboxwebsrv service started
Feb 25 16:55:36 tower rc.virtualbox[12221]: No Virtual Machines running - nothing to save
Feb 25 16:55:36 tower rc.virtualbox[12223]: vboxwebsrv service stopped
Feb 25 16:55:42 tower rc.virtualbox[12350]: VBoxManage setproperty websrvauthlibrary null
Feb 25 16:55:42 tower rc.virtualbox[12365]: vboxwebsrv service started
Feb 25 16:55:42 tower rc.virtualbox[12451]: Starting Virtual Machine: Slack 64 ...
Feb 25 16:55:59 tower rc.virtualbox[12542]: All available Virtual Machines from previous session were started
Feb 25 16:58:02 tower rc.virtualbox[13979]: Saving state of Virtual Machine: Slack 64 ...
Feb 25 16:58:07 tower rc.virtualbox[14033]: All running Virtual Machines were saved
Feb 25 16:58:07 tower rc.virtualbox[14035]: vboxwebsrv service stopped
Feb 25 16:58:13 tower rc.virtualbox[14162]: VBoxManage setproperty websrvauthlibrary null
Feb 25 16:58:13 tower rc.virtualbox[14177]: vboxwebsrv service started
Feb 25 16:58:14 tower rc.virtualbox[14264]: Starting Virtual Machine: Slack 64 ...
Feb 25 16:58:18 tower rc.virtualbox[14316]: All available Virtual Machines from previous session were started

 

 

Share this post


Link to post

Here are some log

 

Upgrading local plugin (v0.4.2) to hosting server plugin (v0.5.1)
Feb 25 16:39:56 tower rc.virtualbox[25009]: Icon downloaded from icon hosting server
Feb 25 16:39:56 tower rc.virtualbox[25012]: Icon copied to emhttp plugin folder
Feb 25 16:39:56 tower rc.virtualbox[25014]: New/Updated plugin installation complete
Feb 25 16:41:00 tower rc.virtualbox[26970]: Latest VirtualBox Guest Additions (v4.2.6) does not exist in local plugin folder, removing all existing local versions and downloading...
Feb 25 16:45:33 tower rc.virtualbox[31643]: Symbolically linked /mnt/cache/VirtualBox/vbox to /root/.VirtualBox
Feb 25 16:45:33 tower rc.virtualbox[31644]: VBOX_SYMLINK_LOCATION not valid - Cannot move file to new symlink location
Feb 25 16:45:33 tower rc.virtualbox[31645]: Plugin configuration written
Feb 25 16:45:56 tower rc.virtualbox[32255]: VBoxManage setproperty websrvauthlibrary null
Feb 25 16:45:56 tower rc.virtualbox[32270]: vboxwebsrv service started
Feb 25 16:55:36 tower rc.virtualbox[12221]: No Virtual Machines running - nothing to save
Feb 25 16:55:36 tower rc.virtualbox[12223]: vboxwebsrv service stopped
Feb 25 16:55:42 tower rc.virtualbox[12350]: VBoxManage setproperty websrvauthlibrary null
Feb 25 16:55:42 tower rc.virtualbox[12365]: vboxwebsrv service started
Feb 25 16:55:42 tower rc.virtualbox[12451]: Starting Virtual Machine: Slack 64 ...
Feb 25 16:55:59 tower rc.virtualbox[12542]: All available Virtual Machines from previous session were started
Feb 25 16:58:02 tower rc.virtualbox[13979]: Saving state of Virtual Machine: Slack 64 ...
Feb 25 16:58:07 tower rc.virtualbox[14033]: All running Virtual Machines were saved
Feb 25 16:58:07 tower rc.virtualbox[14035]: vboxwebsrv service stopped
Feb 25 16:58:13 tower rc.virtualbox[14162]: VBoxManage setproperty websrvauthlibrary null
Feb 25 16:58:13 tower rc.virtualbox[14177]: vboxwebsrv service started
Feb 25 16:58:14 tower rc.virtualbox[14264]: Starting Virtual Machine: Slack 64 ...
Feb 25 16:58:18 tower rc.virtualbox[14316]: All available Virtual Machines from previous session were started

 

OK, because this was an upgrade from 0.4x version to 0.5.1 version and there was no previous Symbolic link defined in the cfg file then it didn't know where to move the existing files from.

When upgrading from older version plugins the following line should be added to cfg file before upgading the plugin:

VBOX_SYMLINK_LOCATION="/boot/custom/vbox"

That way the plugin can move existing files once you decide to move the VirtualBox symbolic link from original location "/boot/custom/vbox" to your new desired location.

 

Share this post


Link to post

Hi all,

 

I'm having toubles getting this working, the virtualbox packages won't install..

 

vboxsrv.log:

 

VirtualBox XPCOM Server 4.2.6 r82870 linux.x86 (Dec 19 2012 15:42:02) release log

00:00:00.001047 main    Log opened 2013-02-27T21:38:24.697408000Z

00:00:00.001057 main    OS Product: Linux

00:00:00.001061 main    OS Release: 3.4.26-unRAID

00:00:00.001066 main    OS Version: #1 SMP Tue Jan 29 16:11:11 GMT 2013

00:00:00.001117 main    Host RAM: 4021MB total, 913MB available

00:00:00.001127 main    Executable: /opt/VirtualBox/VBoxSVC

00:00:00.001130 main    Process ID: 7219

00:00:00.001134 main    Package type: LINUX_32BITS_GENERIC

00:00:00.336045 nspr-2  Successfully initialised host USB using sysfs

00:00:00.339706 nspr-2  VDInit finished

00:00:07.580696 Watcher  ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={3b2f08eb-b810-4715-bee0-bb06b9880ad2} aComponent={VirtualBox} aText={The object is not ready}, preserve=false

 

What's not ready?!

 

 

Also, trying to install the packages usign rc.vboxserv install:

 

grep: The: No such file or directory

grep: xboxd: No such file or directory

expr: syntax error

 

Share this post


Link to post

 

Also, trying to install the packages usign rc.vboxserv install:

 

grep: The: No such file or directory

grep: xboxd: No such file or directory

expr: syntax error

 

I've just tried the rc.virtualbox getlocalversion and that is what's giving the errors above...

Share this post


Link to post

What is rc.vboxserv?

 

If the package does not install then the plugin will show it as not installed.

Can you post a screenshot of the WEBUI?

 

Can you post your syslog?

Do you have the following folder /opt/VirtualBox? what is the contents?

Do you have the following folder /opt/VirtualBox/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack? what is the contents?

 

I am not responsible for the package itself - just the plugin. Does it install when you manually try to install it using "installpkg ...."?

 

Share this post


Link to post

 

If the package does not install then the plugin will show it as not installed.

 

Morning!

 

Thanks for the reply.

 

You were quite right, I'd forgotten that I was using a recompiled kernal based on rc4. Chaning back to stock rc11 got vbox plugin showing all running ok now.

 

Just got to get the phpvirtualbox web bit working now as it reports "PHP does not have the SOAP extension enabled." when logging in ..

 

Thanks again :)

 

Share this post


Link to post

 

If the package does not install then the plugin will show it as not installed.

 

Morning!

 

Thanks for the reply.

 

You were quite right, I'd forgotten that I was using a recompiled kernal based on rc4. Chaning back to stock rc11 got vbox plugin showing all running ok now.

 

Just got to get the phpvirtualbox web bit working now as it reports "PHP does not have the SOAP extension enabled." when logging in ..

 

Thanks again :)

 

Hi, Interested in your resolution going forward. Mine was working until I upgraded the latest SimpleFeatures version and the Vbox 0.5.2 and with all updates.

Share this post


Link to post

Hi, Interested in your resolution going forward. Mine was working until I upgraded the latest SimpleFeatures version and the Vbox 0.5.2 and with all updates.

I haven't tested it on the new simplefeatures yet, maybe over the weekend.

Can you describe the problems you see? post syslog? screenshot WEBUI?

 

Edit:

Tested it on my virtual test server and it is working OK under SimpleFeatures v1.0.11

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.