[PhAzE] Plugins for Unraid 5/6


Recommended Posts

Hey PhAzE, sorry I keep coming back. The installation to the cache drive has not been very stable at all. Plex will frequently just strop streaming and disconnect. I tried erasing everything and starting over, but I'm still getting the same error when trying to install to usr/local .  Any other ideas?

Link to comment

What's up Phaze... I am on 6RC1 fresh install and 2 plugins are acting squirly. Sonarr gives me

 

 Cannot write: No space left on device tar: UI/vendor.js: Cannot write: No space left on device tar: UI/vendor.map: Cannot write: No space left on device tar: Exiting with failure status due to previous errors Updating export file Updating application config ... Install OK

 

A whole string of that and SAB wont install either. It was working fine for 8 hours. Came back home and neither were working.

Link to comment

What's up Phaze... I am on 6RC1 fresh install and 2 plugins are acting squirly. Sonarr gives me

 

 Cannot write: No space left on device tar: UI/vendor.js: Cannot write: No space left on device tar: UI/vendor.map: Cannot write: No space left on device tar: Exiting with failure status due to previous errors Updating export file Updating application config ... Install OK

 

A whole string of that and SAB wont install either. It was working fine for 8 hours. Came back home and neither were working.

How much ram is in your nas? Also how many plugins are you running?

Link to comment

I'm running Unraid 6.

Plex plugin 2015.05.03.1

Plex version 0.9.12.1.1079-b655370

 

I installed Guacamole 3 months ago with a docker, but couldn't figure out how to get it to work so it's sitting there.  All the other plugins I installed were yours. I was able to get plex to install to the cache again, but it only works on my local network. If I try to stream anywhere from the internet, it says the video cannot be played.

 

Edit: Just restarted the plex plugin and now it won't restart. It's giving the PID error again.

Link to comment

8GB ECC ram

 

2 total and both your plugins running SAB and Sonarr. To further assist. here is syslog and img of screen output. I posted on a thread in general support and they suggested it was sonarr and to let you know.

 

Status: RUNNING with version: 2.0.0.3004 <- sonarr

Interesting, I haven't tested RC1 yet but the error it shows is "not a valid assembly" which means it's trying to run the wrong arch type version. I'll see if I can look at that tomorrow as it may affect other plugins if it involves a core change at the os level.

Link to comment

I'm running Unraid 6.

Plex plugin 2015.05.03.1

Plex version 0.9.12.1.1079-b655370

 

I installed Guacamole 3 months ago with a docker, but couldn't figure out how to get it to work so it's sitting there.  All the other plugins I installed were yours. I was able to get plex to install to the cache again, but it only works on my local network. If I try to stream anywhere from the internet, it says the video cannot be played.

 

Edit: Just restarted the plex plugin and now it won't restart. It's giving the PID error again.

Are you running rc1 also?

Link to comment

I'm running Unraid 6.

Plex plugin 2015.05.03.1

Plex version 0.9.12.1.1079-b655370

 

I installed Guacamole 3 months ago with a docker, but couldn't figure out how to get it to work so it's sitting there.  All the other plugins I installed were yours. I was able to get plex to install to the cache again, but it only works on my local network. If I try to stream anywhere from the internet, it says the video cannot be played.

 

Edit: Just restarted the plex plugin and now it won't restart. It's giving the PID error again.

Are you running rc1 also?

 

6.0 beta14b

Link to comment

I have a couple of questions for any Plex guru's out there.

 

I currently have PlexMediaServer setup to use /mnt/user0 (user shares without contents of cache drive) - which appears to be a rookie error from when I initially installed unRAID and configured Plex. Plex works great, however, it is annoying to have to run the mover to update the Plex library each time SB picks up and scans new episodes.

 

My questions are:

  • Is there any forseeable issue with using the regular /mnt/user share for Plex library updates (i.e. will Plex and mover still function as normal)
  • Is there any way to change this reference in the Plex settings without having to re-scan the entire library of thousands of movies/shows etc. I have already got all metadata (most of which is setup how I like it), and would prefer to avoid this if at all possible.

 

Thanks in advance

Link to comment

I know it will function the same, but I'm not sure about the rescan. As far as I know, Plex used a tag to identify the movies, so I would assume when it goes to rescan it will locate all of the meta data locally. But I've never done what you're asking so I'm not 100% sure.

Link to comment

I'm running Unraid 6.

Plex plugin 2015.05.03.1

Plex version 0.9.12.1.1079-b655370

 

I installed Guacamole 3 months ago with a docker, but couldn't figure out how to get it to work so it's sitting there.  All the other plugins I installed were yours. I was able to get plex to install to the cache again, but it only works on my local network. If I try to stream anywhere from the internet, it says the video cannot be played.

 

Edit: Just restarted the plex plugin and now it won't restart. It's giving the PID error again.

Are you running rc1 also?

 

6.0 beta14b

Do you happen to have an "extras" folder on the root of your USB? If so is there anything in it?

 

The Plex app has no dependencies, so my plugin literally downloads and extracts the install folder and then runs it. In wondering if maybe it is a port problem. If you can get it stated, try changing the port it uses to connect externally.

 

As for getting it going, when using the cache drive, the array must be stated in order for the app to work. Check in the Plex log and syslog to see of any new errors are showing some you did get out working once.

Link to comment

If you mean the big blue update button in the plugin settings page, I would use that as it downloads a copy and stores it in the USB for quicker installation on next boot.

 

There should be an update button showing for sab too

Link to comment

I just attempted to upgrade the BtSync plugin and it failed to install due to failing to write to a directory. I then tried to downgrade the plugin and my server froze. It seems to be stuck on "chown: changing group of 'boot/unmenu': Operation not permitted" and "chown: changing group of  '/sys/kernel/slab/unraid/md' : No such file or directory." The screen has many other 'Operation not permitted' entries and all of them are pertaining to the boot directory. I will now have to now a reset to restore the server, but How can I restore the BtSync plugin to being functional. This happened on one other server and after a reboot the plugin is no longer available.

 

Correction:

I did not have to reset the server. I do now see this on my BitTorrent Sync Setting tab:

Plugin Version: 0.0.1

Update Plugin to Version: 2015.05.03.1?

 

I am running unRAID Server Pro

version: 5.0.6

Link to comment

I tried to uninstall the plugin completely and received this error:

 

Warning: array_key_exists(): The second argument should be either an array or an object in /usr/local/emhttp/plugins/webGui/template.php on line 38

Warning: passthru(): Cannot execute a blank command in /usr/local/emhttp/plugins/webGui/template.php on line 277

Link to comment

Sorry if this has been posted already, I did try to search it but couldn't find an answer.  I have several phaze plugins installed and they are working, but I'm not able to run python from ssh.

[email protected]:~# python
bash: python: command not found

There is a python executable in /usr/local/PhAzE-Common/usr/bin.  I did update to rc2, and was running beta 15 previously which was working with no problem running python.

Link to comment

I'm running Mylar, Transmission, PMS and Sickbeard with no problems so far.  I was just used to being able to run python from command line after installing in unraid5.  Is there an alternative method I could use that would add your common binaries and libs to the default, or do I just need to run startcfg.sh in the same line as running python?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.