[Support] Linuxserver.io - Tiny Tiny RSS


32 posts in this topic Last Reply

Recommended Posts

linuxserver_medium.png

 

Application Name: Tiny Tiny RSS

Application Site: https://tt-rss.org/gitlab/fox/tt-rss/wikis/home

Docker Hub: https://hub.docker.com/r/linuxserver/tt-rss/

Github: https://github.com/linuxserver/docker-tt-rss

 

Please post any questions/issues relating to this docker you have in this thread.

 

If you are not using Unraid (and you should be!) then please do not post here, instead head to linuxserver.io to see how to get support.

Edited by linuxserver.io
Link to post
  • 2 months later...

I tried out the tt-rss docker and was not able to get the web interface to come up. When I look on the filesystem the "www" directory only has .git in it and not the actual webui files. Can someone else try it?

 

thanks!

Link to post

the initial git pull can take a few minutes to get from tt-rss.

 

if however you've stopped the container before it completed then the remnants of the failed pull will stop a new pull completing.

 

 

the remedy is to stop the container, go to the appdata folder and delete www/tt-rss , the whole folder tt-rrs , not just its contents.

 

restart the container and give a good few minutes, depending on your net speed for the pull to complete.

Link to post

I guess I was being impatient. On the docker creation screen when it said it was done I assumed it was. I left it well alone and the files are there now. Thanks for your help.

 

Yeah.. because our dockers update on startup, the startup process can take a bit ;)

Link to post
  • 9 months later...

Hi, I'm starting to feel a little stupid, but I can't for the life of me figure out why my reverse proxy isn't working.  I'm using nginx and I've set the path to "/news/"

 

Coming in from my domain.com/news works as it presents me with my basic auth, but I believe that the url prefix isn't working where I've changed it in the container. 

 

conifg/appdata/tt-rss/www/tt-rss/config.php

define('SELF_URL_PATH', 'https://172.16.100.5:8787/news/');

 

I'm still presented with a 404 not found.  Not sure which config to post for you though.  Any help?

 

Thank you

Link to post
  • 3 weeks later...

 

Thank you squid. Attached is the command after install.  I've also already tried the force update and to view the logs.  Since it cannot start, there are no logs.

 

..... Just installed your Fix Common Problems plugin (http://lime-technology.com/forum/index.php?topic=48972.0), it said I was using a user share which are not good for Dockers.

 

I didn't know this, I deleted the docker and reinstalled using disk3 instead of user and it worked. Is this standard practice? All of my other dockers work using user shared (i.e. nextcloud, plex, sync, syncthing)

 

 

Capture.PNG.fde3a737f39c085b3c32cc89bb10c9ad.PNG

Capture2.PNG.4f2ca022ae7f51b0f04547550799f6c0.PNG

Link to post
  • 3 weeks later...

Any chance of rebasing this to Alpine? It would be nice to get the last vestiges of Phusion off of my server...

 

(also, any chance of a dokuwiki docker? sparkly's is a bit out of date and also uses phusion)

 

This is called tinytiny and you're called neersighted... Surprised you noticed....

 

We're still in the process of migrating everything to either Alpine or Xenial, I believe Sparkly hasn't got around to the Apache based containers yet (Or Apache itself for that matter)

Link to post
  • 3 months later...

Yes ... with the letsencrypt docker

 

server {

    server_name domain;

    # sub1 config

 

        listen 80;

 

        listen 443 ssl;

 

        root /config/www/nextcloud;

        index index.html index.htm index.php;

 

        ###Set certificates ####

        ssl_certificate /etc/letsencrypt/live/domain/fullchain.pem;

        ssl_certificate_key /etc/letsencrypt/live/domain/privkey.pem;

 

        ### Add Diffie–Hellman key exchange ###

#      ssl_dhparam /config/keys/server.com/dhparam.pem;

 

        ### Disable SSL by enforcing TLS ###

        ssl_protocols TLSv1 TLSv1.1 TLSv1.2;

 

        ### Add some ciphers and reject weaker ones ###

        ssl_ciphers "EECDH+AESGCM:EDH+AESGCM:ECDHE-RSA-AES128-GCM-SHA256:AES256+EECDH:DHE-RSA-AES128-GCM-SHA256:AES256+EDH:ECDHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA256:ECDHE-RSA-AES256-SHA:ECDHE-RSA-AES128-SHA:DHE-RSA-AES256-SHA256:DHE-RSA-AES128-SHA256:DHE-RSA-AES256-SHA:DHE-RSA-AES128-SHA:ECDHE-RSA-DES-CBC3-SHA:EDH-RSA-DES-CBC3-SHA:AES256-GCM-SHA384:AES128-GCM-SHA256:AES256-SHA256:AES128-SHA256:AES256-SHA:AES128-SHA:DES-CBC3-SHA:HIGH:!aNULL:!eNULL:!EXPORT:!DES:!MD5:!PSK:!RC4";

 

        ###Extra Settings###

        ssl_prefer_server_ciphers on;

        ssl_session_cache shared:SSL:10m;

 

        ### Add HTTP Strict Transport Security ###

        add_header Strict-Transport-Security "max-age=63072000; includeSubdomains";

        add_header Front-End-Https on;

 

        client_max_body_size 0;

 

        location / {

        proxy_pass http://192.168.1.10:82/;

  }

}

 

Link to post
  • 1 month later...

Anyone running this via reverse proxy and using the Reeder app on iOS? The times on the articles are not showing the correct time. It shows the time it was sync and not the time the article was published.

 

Thanks for updating the docker to alpine and nginx.

Edited by jrdnlc
Link to post
  • 10 months later...
  • 2 weeks later...
On 11/01/2018 at 8:59 PM, deadnote said:

Hi

I try to run tt-rss via reverse proxy width the letsencrypt docker but i only get 404 or 502 error

Someone can help me ?

Thanks !

 

Not unless you post a lot more detail to be honest.

Link to post
  • 1 month later...

I'm not super experienced with this stuff so would be grateful of some guidance.

 

I've installed the Docker and am now at the Installer in the WebUI however I'm a little stuck.

 

Have selected PostgreSQL as tt-rss appear to recommend it over MySQL

Have create a user and password

Added a database name 'ttrss' - wasn't sure if this was my choice or whether there is something specific I should be putting here

Used the ip of my system as the Host - is it better to leave this blank?

Set the port to 5432 for PostgreSQL

Added the tt-rss url as http://***.***.*.***:****/ (ip addr & port)

Configuration test returns "Configuration check succeeded".

 

BUT Checking database has the following errors...

SQLSTATE[08006] [7] could not connect to server: No such file or directory Is the server running locally and accepting connections on Unix domain socket "/tmp/.s.PGSQL.5432"?

 

Unable to connect to database using specified parameters.

 

I have a feeling this will be something really simple but I'm struggling to even start to work it out. Any pointers would be gratefully received.

Link to post
7 hours ago, stove81 said:

I'm not super experienced with this stuff so would be grateful of some guidance.

 

I've installed the Docker and am now at the Installer in the WebUI however I'm a little stuck.

 

Have selected PostgreSQL as tt-rss appear to recommend it over MySQL

Have create a user and password

Added a database name 'ttrss' - wasn't sure if this was my choice or whether there is something specific I should be putting here

Used the ip of my system as the Host - is it better to leave this blank?

Set the port to 5432 for PostgreSQL

Added the tt-rss url as http://***.***.*.***:****/ (ip addr & port)

Configuration test returns "Configuration check succeeded".

 

BUT Checking database has the following errors...

SQLSTATE[08006] [7] could not connect to server: No such file or directory Is the server running locally and accepting connections on Unix domain socket "/tmp/.s.PGSQL.5432"?

 

Unable to connect to database using specified parameters.

 

I have a feeling this will be something really simple but I'm struggling to even start to work it out. Any pointers would be gratefully received.

 

you need a postgres server before using this

 

https://github.com/linuxserver/docker-tt-rss#setting-up-the-application

Link to post
  • 3 weeks later...

Hi,

 

I'm getting a 404 error when trying to reverse proxy this with nginx.

 

Here's my location block :

 

	location  /ttrss/ {
	proxy_pass http://192.168.1.69:7845;
	proxy_set_header Host $host;
     proxy_set_header X-Real-IP $remote_addr;
     proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; 
	}

Any ideas?  My other location blocks for other dockers work fine.

 

Edit : This is in my letsencrypt nginx config.

Should I move that to the ttrss nginx config?

Edited by stefer
Link to post
  • 2 months later...
  • 1 month later...

Hi

Need help to use tt-rss with let's encrypt

I spend 2 hours I spent 2 hours testing configuration in let's encrypt and/or ttrss nginx folder without results.

I only get 404, 502 or "Welcome to our serveur"

 

Can someone help me please ? Thanks for your help :)

Link to post
  • trurl locked this topic
Guest
This topic is now closed to further replies.