Jump to content
linuxserver.io

[Plugin] Linuxserver.io - Unraid DVB

1681 posts in this topic Last Reply

Recommended Posts

So does v6.1.9 work on the test system and does v6.2 beta23 work on the production system?

Share this post


Link to post

This is my setup...

 

Testsystem: 6.2 beta23  (USB 3.0 is used to boot, Haswell CPU, Asrock Rack Mainboard)

Prodsystem: 6.1.9 (USB 3.0 is used to boot, Skylake CPU, Fujitsu Mainboard)

 

Diffrent versions same behavior (strange thing is, it worked on the testsystem for 3 days...).

Will try to boot on a USB 2.0 port (test & prod).

 

No rush, i can test on weekend (at the earliest).

 

And how can i spend you a beer or a coffee  ;)?

 

So does v6.1.9 work on the test system and does v6.2 beta23 work on the production system?

 

Aside from the above point which I'd be curious to know...

 

Here's the build you requested.

Share this post


Link to post

It seems like the file servers for linuxsserver.io are down atm. Fair assumption? I'm getting  cloudflare error page I think.

Share this post


Link to post

It seems like the file servers for linuxsserver.io are down atm. Fair assumption? I'm getting  cloudflare error page I think.

 

This has now been fixed, there was an issue at our hosts who have now sorted the issue.

Share this post


Link to post

Update:

 

OpenELEC developer CvH has moved to the LibreELEC project.  He's kindly agreed to let me use the LibreELEC firmware, so new builds have been pushed to our server.  Going forward I don't plan on continuing the OpenELEC builds but rather switching to LibreELEC.

 

If someone can test the new LibreELEC builds I'd be grateful.

 

Come on chaps.  I'll build 'em, but I can't test 'em.  As always I need your help with testing both this and the Digital Devices Github build.

Share this post


Link to post

LE 6.2.0-Beta 23 working fine with my Hauppauge 2250

 

Thanks man, much appreciated...  ;)

Share this post


Link to post

Another update, trying to get the DVB adapters present on the system displayed on the plugin page.  Working on mine, hopefully should work across the board.  Big thanks to Squid for his help with php/bash on this one.  (I entered a rabbit hole of sed hell......)  Thanks to saarg for the suggestion (and damn you for suggesting it!)

 

8IJDcAs.png

Share this post


Link to post

Another update, trying to get the DVB adapters present on the system displayed on the plugin page.  Working on mine, hopefully should work across the board.  Big thanks to Squid for his help with php/bash on this one.  (I entered a rabbit hole of sed hell......)  Thanks to saarg for the suggestion (and damn you for suggesting it!)

 

8IJDcAs.png

Lol. I was wondering what took you so long  ;D Good work mate, or should I say Squid?  ;D

Share this post


Link to post

I did most of it, then asked Squid a couple of things when I got stuck! Cheeky bugger...

 

Sent from my LG-H815 using Tapatalk

 

 

Share this post


Link to post

Lol. I was wondering what took you so long  ;D Good work mate, or should I say Squid?  ;D

I have, as of yet, not rubbed his face in it...  :-X

 

Seriously though, this plugin is all CHBMB, and the coding is all his....

Share this post


Link to post

Liar.... you wrote it, I just changed the text around a bit...

 

Sent from my LG-H815 using Tapatalk

 

 

Share this post


Link to post

Liar.... you wrote it, I just changed the text around a bit...

 

Sent from my LG-H815 using Tapatalk

Isn't that what coding is? That's what I do  :o

Share this post


Link to post

Liar.... you wrote it, I just changed the text around a bit...

 

Sent from my LG-H815 using Tapatalk

Give yourself credit...  Where it is now vs the basic framework I gave you is night and day.  (That and I'm covering my butt for any bugs  ;D  )

Share this post


Link to post

Lol. I was wondering what took you so long  ;D Good work mate, or should I say Squid?  ;D

 

This was what took me so long..

 

dmesg | grep -i dvb | grep -i 'adapter 0' | sed 's|^.*\((.*)\).*$|\1|' | tr -d '()'

 

but when in php the backslashes need a backslash before (or after, can't remember) because they're special...  I hate sed with a passion....

 

$adapter0 = shell_exec ( "dmesg | grep -i dvb | grep -i 'adapter 0' | sed 's:^.*\\((.*)\\).*$:\\1:' | tr -d '()'" );

 

I've got no doubt there is a neater more economical way of writing that, but it works...

 

;)

Share this post


Link to post

Lol. I was wondering what took you so long  ;D Good work mate, or should I say Squid?  ;D

 

This was what took me so long..

 

dmesg | grep -i dvb | grep -i 'adapter 0' | sed 's|^.*\((.*)\).*$|\1|' | tr -d '()'

 

but when in php the backslashes need a backslash before (or after, can't remember) because they're special...  I hate sed with a passion....

 

$adapter0 = shell_exec ( "dmesg | grep -i dvb | grep -i 'adapter 0' | sed 's:^.*\\((.*)\\).*$:\\1:' | tr -d '()'" );

 

I've got no doubt there is a neater more economical way of writing that, but it works...

 

;)

I'll be signing up for your sed course  :P

Share this post


Link to post

TBS Drivers updated for 6.1.9 and 6.2 beta 23 to version 160630...

 

 

 

Sent from my LG-H815 using Tapatalk

 

 

Share this post


Link to post

Unraid V6.2 Release Candidate 1 Builds done and uploaded to our server.

 

LibreELEC, TBS DVB-S/T, TBS DVB-C, Digital Devices Github,

 

1 hour 18 minutes following release..  ;D

 

Let me know if they're working please.

Share this post


Link to post

Your release schedule is now as often as mine

 

Sent from my LG-D852 using Tapatalk

 

 

Share this post


Link to post

I wouldn't go quite that far....

 

8DDDPFb.png

Share this post


Link to post

I wouldn't go quite that far....

 

8DDDPFb.png

But where was a-j?

Share this post


Link to post

 

 

Unraid V6.2 Release Candidate 1 Builds done and uploaded to our server.

 

Let me know if they're working please.

LE release is working. Am I the only one that tests them?

 

Share this post


Link to post

 

 

Unraid V6.2 Release Candidate 1 Builds done and uploaded to our server.

 

Let me know if they're working please.

LE release is working. Am I the only one that tests them?

 

Looks that way. but as we're in a beta cycle it may well be that people aren't using these builds.  At least I now know TBS & LE are working, so should in theory work for V6.2 Final.  At which point I may get some messages about Digital Devices Github and TBS DVB-C builds not working.  (Although TBS DVB-C is pretty much the same as the DVB-S/T build so don't anticipate any problems there.)  Digital Devices Github is the one I have concerns about as it's moving to an entirely new repo from the Experimental one.  Although tunip has tested it for his card and it was working, the symlink to the config file is the bit I could really do with a couple of people to test, tunip's earlier issues in this thread, it turned out were due to a faulty card.

 

But I am very grateful for your input and it's nice to know at least 1 person is using each build lol...

Share this post


Link to post

@CHBMB latest build for DD with latest DD driver spam dmesg ... after few min you have empty space in /var/log

 

[  317.887242] mxl5xx: ber 00000000 00000000 00000000 00000000 00000000 00000000 00000000

[  317.887246] mxl5xx: ber2 00000000 00000000 00000000 00000000

[  317.892320] mxl5xx: ber 00000000 00000000 00000000 0000006c 0000000c 00000000 000001b3

[  317.892323] mxl5xx: ber2 00000000 00000000 00000000 0000006c

[  317.896104] mxl5xx: freq=1892000000 delsys=1 srate=27500000

[  317.901134] mxl5xx: ber 00000001 00000001 00100f63 00000000 00000000 00000000 00000000

[  317.901138] mxl5xx: ber2 00000001 00000001 00100f63 00000000

[  317.904907] mxl5xx: freq=1931000000 delsys=2 srate=27500000

[  317.932073] mxl5xx: ber 00000000 00000000 00000000 00000000 00000000 00000000 00000000

[  317.932076] mxl5xx: ber2 00000000 00000000 00000000 00000000

[  317.937094] mxl5xx: ber 00000000 00000000 00000000 00000000 00000000 00000000 00000000

[  317.937097] mxl5xx: ber2 00000000 00000000 00000000 00000000

[  317.982242] mxl5xx: ber 00000000 00000000 00000000 00000000 00000000 00000000 00000000

[  317.982257] mxl5xx: ber2 00000000 00000000 00000000 00000000

[  317.987376] mxl5xx: ber 00000000 00000000 00000000 0000006c 0000000c 00000000 00060c36

[  317.987379] mxl5xx: ber2 00000000 00000000 00000000 0000006

 

i dont know if in ddbridge.conf is some switch to disable this :/

 

UPDATE:

OK im suppose this commit are not includec into official DD github source of driver

 

https://linuxtv.org/hg/%7Eendriss/media_build_experimental/rev/66c6e6cc0e1b

please download and try apply on driver - if pass without error - that mean this missing. THX

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.