Jump to content
linuxserver.io

[Plugin] Linuxserver.io - Unraid DVB

1673 posts in this topic Last Reply

Recommended Posts

an idea: Its not easyer to build only one UNRAID Version with nvidia AND dvb include ? And everyone is happy.

Share this post


Link to post

No. It's more complicated than that, read both threads for actual info that discusses that exact point.

Share this post


Link to post
On 3/8/2020 at 2:16 PM, bgood said:

Hi,  Unraid newbie here, just trying it out to see if it will work with my setup and have a query. 

 

I'm using a HP Microserver with an AMD Turion II Neo N54L processor and a TBS 6981 dual tuner sat card, I tried running the 6.8.2 DVB Unraid build but although the drivers loaded fine the card was not detected so tried 6.8.1 & 6.8.0 but still no joy so dropped back to 6.7.2 and it is working, so the question is there anything I can do to get it working in 6.8.2?

 

I realise it's a pretty old tuner card but I was under the impression the drivers were backward compatible, it was working fine in Ubuntu 18.04.4 LTS without any additional configuration.

So just on the off chance that anyone else has the same or a similar problem, despite the fact I'm using a TBS 6981 card the TBS (open source) 6.8.2 DVB build failed to detect the card but the 6.7.2 version worked fine, however I wanted to be using 6.8.2 ideally so I decided to give the LibreELEC 6.8.2 DVB build a try and that actually works just fine, well in fact better than the TBS 6.7.2 as I now have equally good signal strength on both tuners 🙂

Share this post


Link to post
Posted (edited)

Hello, I have been at this for many hours today and hoping I have simply overlooked something very simple.

I have installed a DBSky S952 (2.2a) PCIe card, followed by installing this Plugin.

On the notion that it is not TBS I started with the LibreELEC latest release, nothing detected.

I have rolled back through the versions to 6.7.2, nothing detected (rebooting as instructed after each installation).

Tried the latest releases of TBS on the off-chance, nothing detected.

 

95kjI9n.png

 

In my Hardware Profile I can see the PCI card is recognised here:

yrUAZ5b.png

 

Using 'lspci' command I can see: 

Quote

09:00.0 Multimedia video controller: Conexant Systems, Inc. CX23885 PCI Video and Audio Decoder (rev 04)

 

Using 'lspci -v' to get more information the following is present:

Quote

09:00.0 Multimedia video controller: Conexant Systems, Inc. CX23885 PCI Video and Audio Decoder (rev 04)
        Subsystem: DVBSky S952
        Flags: bus master, fast devsel, latency 0, IRQ 35
        Memory at fcc00000 (64-bit, non-prefetchable)
        Capabilities: [40] Express Endpoint, MSI 00
        Capabilities: [80] Power Management version 2
        Capabilities: [90] Vital Product Data
        Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [200] Virtual Channel
        Kernel driver in use: cx23885
        Kernel modules: cx23885

 

So, it seems like the OS can detect the hardware is present.

 

One of the issues I seem to have found is that '/dev/dvb/ is not a valid file/directory. My knowledge is not good enough to know if this is what is causing my issues, or if this is missing because 'Unraid DVB' isn't detecting my PCIe and then not creating it.

 

Any guidance, help, requests for logs etc. would be greatly appreciated as at this point I have run out of things to read or try.

 

Note: All of these commands I have found by googling various keywords, and searching within this thread. I have also read the last few pages of the post (so maybe 6 months of real time) and did not see anything I thought was relevant. What I have learnt to do in Unraid is from reading helpful threads like this and trying thing out, so to the more knowledgeable people who take the time to reply and keep threads like this active, Thank You.

Edited by Hikaari

Share this post


Link to post

I upgraded from TBS (CrazyCat) 6.7.2 build to the TBS (Open Source) 6.8.2 build and I'm having issues.

It seems that dvb-demod-m88rs6000.fw is missing.

 

Quote

[   21.036412] SMI PCIe driver 0000:03:00.0: card detected: DVBSky S952 V3
[   21.045936] TBSECP3 driver 0000:02:00.0: TurboSight TBS 6281SE DVB-T/T2/C
[   21.046329] dvbdev: DVB: registering new adapter (TBSECP3 DVB Adapter)
[   21.145793] dvbdev: DVB: registering new adapter (SMI_DVB)
[   21.204156] TBSECP3 driver 0000:02:00.0: DVB: registering adapter 0 frontend 0 (TurboSight TBS 6281SE DVB-T/T2/C )...
[   21.204385] dvbdev: DVB: registering new adapter (TBSECP3 DVB Adapter)
[   21.335983] TBSECP3 driver 0000:02:00.0: DVB: registering adapter 2 frontend 0 (TurboSight TBS 6281SE DVB-T/T2/C )...
[   21.337447] TBSECP3 driver 0000:02:00.0: TurboSight TBS 6281SE DVB-T/T2/C : PCI 0000:02:00.0, IRQ 25, MMIO 0xf8200000
[   21.388645] SMI PCIe driver 0000:03:00.0: DVB: registering adapter 1 frontend 0 (Montage Technology M88RS6000)...
[   21.395158] SMI PCIe driver 0000:03:00.0: DVBSky S952 V3 port 0 MAC: 00:18:42:54:55:52
[   21.395309] dvbdev: DVB: registering new adapter (SMI_DVB)
[   21.629974] SMI PCIe driver 0000:03:00.0: DVB: registering adapter 3 frontend 0 (Montage Technology M88RS6000)...
[   21.636512] SMI PCIe driver 0000:03:00.0: DVBSky S952 V3 port 1 MAC: 00:18:32:54:55:53
[   21.636610] Registered IR keymap rc-dvbsky
[   21.636721] rc rc0: IR (DVBSky S952 V3) as /devices/pci0000:00/0000:00:1c.1/0000:03:00.0/rc/rc0
[   21.636920] input: IR (DVBSky S952 V3) as /devices/pci0000:00/0000:00:1c.1/0000:03:00.0/rc/rc0/input8
[  111.463494] m88ds3103 6-0069: Direct firmware load for dvb-demod-m88rs6000.fw failed with error -2
[  111.463497] m88ds3103 6-0069: firmware file 'dvb-demod-m88rs6000.fw' not found
[  111.572384] SMI PCIe driver 0000:03:00.0: DVB: adapter 3 frontend 0 frequency 0 out of range (950000..2150000)
[  111.611343] m88ds3103 6-0069: Direct firmware load for dvb-demod-m88rs6000.fw failed with error -2
[  111.611357] m88ds3103 6-0069: firmware file 'dvb-demod-m88rs6000.fw' not found
[  111.622881] si2168 3-0064: downloading firmware from file 'dvb-demod-si2168-b40-01.fw'
[  113.485476] TBSECP3 driver 0000:02:00.0: DVB: adapter 2 frontend 0 frequency 0 out of range (48000000..870000000)
[  113.504372] m88ds3103 5-0069: Direct firmware load for dvb-demod-m88rs6000.fw failed with error -2
[  113.504376] m88ds3103 5-0069: firmware file 'dvb-demod-m88rs6000.fw' not found
[  113.610339] SMI PCIe driver 0000:03:00.0: DVB: adapter 1 frontend 0 frequency 0 out of range (950000..2150000)
[  113.627214] si2168 2-0064: downloading firmware from file 'dvb-demod-si2168-b40-01.fw'
[  115.500587] TBSECP3 driver 0000:02:00.0: DVB: adapter 0 frontend 0 frequency 0 out of range (48000000..870000000)
[  115.513707] si2168 2-0064: downloading firmware from file 'dvb-demod-si2168-b40-01.fw'
[  366.415977] m88ds3103 5-0069: Direct firmware load for dvb-demod-m88rs6000.fw failed with error -2
[  366.415980] m88ds3103 5-0069: firmware file 'dvb-demod-m88rs6000.fw' not found
[  399.719840] m88ds3103 6-0069: Direct firmware load for dvb-demod-m88rs6000.fw failed with error -2
[  399.719842] m88ds3103 6-0069: firmware file 'dvb-demod-m88rs6000.fw' not found

 

 

It does seem to exist in their github repo: https://github.com/LibreELEC/dvb-firmware/blob/master/firmware/dvb-demod-m88rs6000.fw

Can I install it manually? why is it missing?

Share this post


Link to post

@natiz may try the libreelec build currently, or try with mini satip docker to use it like this, i d recommend to test libreelec build currently.

Share this post


Link to post

@alturismo I tried LibreELEC, but then my TBS card doesn't even show up 😕

 

I have 2 cards, TBS6281SE for DVB-C and DVBSKy S952 V3 for DVB-S.

I rolled back to TBS Crazycat for now, this is how it looks:
 

Quote

 

DVB Adapter 0:Silicon Labs Si2168

DVB Adapter 1:Montage Technology M88RS6000

DVB Adapter 2:Silicon Labs Si2168

DVB Adapter 3:Montage Technology M88RS6000

 

 

 

I think its because only dvb-fe-cx24117.fw is included in the TBS (OpenSource) build, see here:

https://github.com/linuxserver/Unraid-DVB/blob/master/build_scripts/tbs-os-module.sh#L46-L55

Share this post


Link to post

Hi guys.  After updating from TBS build 6.6.7 (which was fully working with my TBS 6981) to TBS 6.8.2, my TVHeadend docker will no longer start.  Fails with error "Server Execution Error"

 

If I remove '--device=/dev/dvb/' from Extra Parameters it'll launch, but obviously without the card being passed through.  Then when I try to reapply '--device=/dev/dvb/", the action fails with:

"/usr/bin/docker: Error response from daemon: error gathering device information while adding custom device "/dev/dvb": no such file or directory."

 

My TBS card shows up under System Devices as Conexant Systems CX23885, which iirc is how it presented before the update (from 6.6.7 to 6.8.2), so I think the card is being detected as before, but I'm really not sure.  I'm already out of my depth at this point, so any help is appreciated.  Maybe I should try the CrazyCat build instead?

Share this post


Link to post

Hey, my card is also based on a CX23885, which I am also having trouble with. Same error of no such file or directory.

 

Not sure if this is related but I noticed that when comparing the LibreELEC 1.4.0 Firmware list to the DVBSky FW package there is the following:

dvb-fe-ds3000.fw (LE)

dvb-fe-ds300x.fw (DVBSky)

Unsure if this is a naming mistake, or different FWs.

 

dvb-fe-rs6000.fw (DVBSky) is missing entirely from LE 1.4.0

 

The other 7 FW are all present. What are the chances my DVB Card isn't picked up from Unraid DVB (but recognised as HW in Unraid) that it is from one of these two drives that appear to be missing?

 

Is there a way I can recompile to include these two FWs to test? Thanks

Share this post


Link to post
Posted (edited)

Since 6.8.2 the LibreELEC kernel does not detect my DVB card (based on CX23885) any more (see attached screenshot)

The DVB card worked well in the LibreELEC kernel in 6.8.2. when I had an i3 CPU installed. After I installed a Xeon it stopped being detected (lspci does  not see it).

Any ideas right away, or what additional info would you need to diagnose.

 

screenshot.cleaned.thumb.png.24463ea23a4e0d02f00dc65395841d8d.png

Edited by b0m541

Share this post


Link to post
Posted (edited)

SO I know if I ask about 6.8.3, I'm just going to get a response "when it's ready".

 

I'm running 6.8.0 and my god are they getting pushy about the "your system is at risk" call for update. I tried to  manuallyupdate Unraid to 6.8.2  (to use the latest DVB) but I got an error. Is there a utility to automate the update of unraid to a less than current rev like 6.8.2?

 

(or release DVB 6.8.3)

Edited by Mike Rando
update

Share this post


Link to post
On 3/21/2020 at 11:37 AM, natiz said:

I upgraded from TBS (CrazyCat) 6.7.2 build to the TBS (Open Source) 6.8.2 build and I'm having issues.

It seems that dvb-demod-m88rs6000.fw is missing.

 

 

 

It does seem to exist in their github repo: https://github.com/LibreELEC/dvb-firmware/blob/master/firmware/dvb-demod-m88rs6000.fw

Can I install it manually? why is it missing?

@CHBMB do you think dvb-demod-m88rs6000.fw can be added to the TBS OS build? if not can you please provide instructions how/where to run the build scripts to compile my own version of the kernel?

Share this post


Link to post
On 3/15/2020 at 6:14 PM, bgood said:

So just on the off chance that anyone else has the same or a similar problem, despite the fact I'm using a TBS 6981 card the TBS (open source) 6.8.2 DVB build failed to detect the card but the 6.7.2 version worked fine, however I wanted to be using 6.8.2 ideally so I decided to give the LibreELEC 6.8.2 DVB build a try and that actually works just fine, well in fact better than the TBS 6.7.2 as I now have equally good signal strength on both tuners 🙂

Yep, this worked for me as well with the same TBS 6981 tuner card.  Good call. 👍

Share this post


Link to post

Hi All,

I'm new to unraid and have most things setup and working. However one thing I'm struggling with is getting my TV tuners to work with a plex docker.

It detects them (unsupported) and allows me to run a scan. I have them passed through with --device=/dev/dvb/ but it never finds any channels. I have also tried with a TVheadend docker with the same result. However with a TVheadend plugin I'm able to get results with a scan.

So I'm guessing it has something to do with the docker accessing the data from the tuners.

Any help would be appreciated.

Thanks

Share this post


Link to post

Just upgraded my mobo and cpu/cpu cooler allowing me to install my Hauppauge quad hd tuner. Was on unraid 6.8.3 and went to LibreElec 6.8.2 and passed through to plex. Worked straight away. Awesome! great work guys.

 

I have an i9-9900k. To roll back to 6.8.0-rc7 (I believe this is the linux 5 kernel) will this cause me any dramas? I want to ensure the igpu is being utilised

Share this post


Link to post
2 hours ago, kavo said:

Just upgraded my mobo and cpu/cpu cooler allowing me to install my Hauppauge quad hd tuner. Was on unraid 6.8.3 and went to LibreElec 6.8.2 and passed through to plex. Worked straight away. Awesome! great work guys.

 

I have an i9-9900k. To roll back to 6.8.0-rc7 (I believe this is the linux 5 kernel) will this cause me any dramas? I want to ensure the igpu is being utilised

u have to look at the builds provided by this plugin, like u did now ... u where on unraid 683, u went now to 682 (dvb build), when there is a libreelec 680rc7 u can give it a try,  but remember, then your server is on 680rc7 ... this plugin replaces the complete unraid build.

Share this post


Link to post
2 hours ago, alturismo said:

u have to look at the builds provided by this plugin, like u did now ... u where on unraid 683, u went now to 682 (dvb build), when there is a libreelec 680rc7 u can give it a try,  but remember, then your server is on 680rc7 ... this plugin replaces the complete unraid build.

I know how to do it physically, I was wondering if there is anything I need to be aware of or take consideration for rolling back

Share this post


Link to post

The reason they rolled back the kernel was due to an unresolved bug.  I cannot remember exactly the bug, but my brain says something to do with LDAP or AD authentication.  Or I could have had too much to drink tonight.  YMMV

Share this post


Link to post

My rig seems to be HW transcoding with 6.8.2. So I guess I don't have to roll back?

Share this post


Link to post

The DVB plugin is marked as incompatible now by the Common Problems plugin... why is that?

Share this post


Link to post

To be pedantic, it depends on how CA intends to function and what "compatible" means, considering the DVB and the Nvidia plugins entirely replace unRaid. 

 

🍻

Share this post


Link to post
3 hours ago, b0m541 said:

The DVB plugin is marked as incompatible now by the Common Problems plugin... why is that?

Show me a screenshot.  And what version of unraid?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.