Jump to content
thomast_88

[Support] Rclone-mount - with FUSE support for Plex/Emby/Sonarr etc. (beta)

48 posts in this topic Last Reply

Recommended Posts

@sniper

 

Are you on IRC or slack? Think it will be easier to debug if we can have a chat conversation

 

18 minutes ago, sniper said:

 

@thomast_88 I did read it 

right now i have it like this 


--cap-add SYS_ADMIN --device /dev/fuse --security-opt apparmor:unconfine -v /mnt/disks/rclone_volume/Gdrive:/data:shared

I did stop other Containers and run it but still not showing up!

 

I suppose you added the volume /mnt/disks/rclone_volume/Gdrive to the container you want it available in, right?

Edited by thomast_88

Share this post


Link to post
2 hours ago, thomast_88 said:

@sniper

 

Are you on IRC or slack? Think it will be easier to debug if we can have a chat conversation

 

 

I suppose you added the volume /mnt/disks/rclone_volume/Gdrive to the container you want it available in, right?

No I just setup rclone fuse docker and thats it 

 

Edit:

I did try to add /mnt/disks/rclone_volume/Gdrive/Movies

to plex but nothing happen !

Edited by sniper

Share this post


Link to post
I just add the folder  /mnt/disks/rclone_volume/Gdrive/ After i edited the container i want it to use rclone mount with 
 
But i get Error in  Sonarr
Folder is not writable by user abc
 
I dont have any user called "abc" even
 
Its working with plex but i want to work with sonarr and others docker 
Edited by sniper

Share this post


Link to post

@sniper Please post both docker run commands. Both for Rclone-mont and Sonarr. I have it running with Sonarr, so it shouldn't be a problem.

Edited by thomast_88

Share this post


Link to post

Hey there @thomast_88, great work on the containers!

 

I have a quick question - when I go to write to my newly mounted rclone folder, I am getting the "read-only file system" error as well when attempting to write to the folder. I used your template to deploy:

 

Docker run command:

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d 
--name="rclone-mount" 
--net="bridge" 
-e TZ="America/Chicago" 
-e HOST_OS="unRAID" 
-e "RCLONE_REMOTE_MOUNT"="backblaze" 
-e "RCLONE_MOUNT_OPTIONS"="--read-only" 
-e "RCLONE_CONFIG_PASS"="" 
-v "/mnt/user/docker/appdata/rclone":"/config":rw 
--cap-add SYS_ADMIN --device /dev/fuse --security-opt apparmor:unconfine -v /mnt/disks/backblaze/:/data:shared 
tynor88/rclone-mount:dev

 

Docker logs output:

GID/UID
-------------------------------------
User uid:    911
User gid:    911
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 40-config: executing...
[cont-init.d] 40-config: exited 0.
[cont-init.d] done.
[services.d] starting services
Executing => rclone mount --config=/config/.rclone.conf --allow-other --read-only backblaze /data
[services.d] done.

 

ls -l of the /mnt/disks folder:

root@NAS01:/# ls -l /mnt/disks
total 0
drwxrwxrwx 3 nobody users 23 Jun 12 11:25 SATA_SSD_67F407560D2400150419
drwxr-xr-x 1    911   911  0 Jun 12 16:11 backblaze
drwxrwxrwx 3 nobody users 17 Jun  9 15:20 seagate

 

Thoughts? Thanks!

Share this post


Link to post
9 hours ago, ryanborstelmann said:

Hey there @thomast_88, great work on the containers!

 

I have a quick question - when I go to write to my newly mounted rclone folder, I am getting the "read-only file system" error as well when attempting to write to the folder. I used your template to deploy:

 

Docker run command:


-e "RCLONE_MOUNT_OPTIONS"="--read-only" 

 

Docker logs output:


Executing => rclone mount --config=/config/.rclone.conf --allow-other --read-only backblaze /data

 

 

Do you see a possible issue? ;-)

 

I can't test it right now but it should fix your problem

Share this post


Link to post
6 hours ago, MTA99 said:

 

Do you see a possible issue? ;-)

 

I can't test it right now but it should fix your problem

Ahhhh yes, helps if I read my own outputs :D Thanks!

 

For anyone else who hits this, these options were hidden under "advanced" variables when using the UnRAID xml template. That's why I missed them.

Share this post


Link to post
2 hours ago, ryanborstelmann said:

Ahhhh yes, helps if I read my own outputs :D Thanks!

 

For anyone else who hits this, these options were hidden under "advanced" variables when using the UnRAID xml template. That's why I missed them.

 

Yes, the default command mounts it with read-only. I have been following the development of the mount feature on the rclone forums, and unfortunately it doesn't indicate that using the mount for writing is stable (yet). So I would not recommend using it. Instead you can use my other container for writing (utilizing the copy/move feature instead).

Share this post


Link to post
Just now, thomast_88 said:

 

Yes, the default command mounts it with read-only. I have been following the development of the mount feature on the rclone forums, and unfortunately it doesn't indicate that using the mount for writing is stable (yet). So I would not recommend using it. Instead you can use my other container for writing (utilizing the copy/move feature instead).

Is that this container? https://github.com/tynor88/docker-rclone


That could certainly work for me, as I'm really only looking to back up a single folder via rclone to Backblaze. Will throw that container up and see what I can do :) thanks!

Share this post


Link to post
19 minutes ago, ryanborstelmann said:

Is that this container? https://github.com/tynor88/docker-rclone


That could certainly work for me, as I'm really only looking to back up a single folder via rclone to Backblaze. Will throw that container up and see what I can do :) thanks!

 

Ohh, so if you're only going to make backups then yes, definitely use that one: 

 

This container is only if you wish to mount the cloud files as a volume on your server. E.g. for consumption of the data by other containers.

Edited by thomast_88

Share this post


Link to post

Sorry to drag up an old thread - does this still work?

 

I've installed the docker, ran the conf and I've got the /data drive showing within Sonarr which is great - I just don't seem to be getting the actual mount to happen at any point? Have I missed something obvious do you think? 

Share this post


Link to post
On 11/2/2017 at 8:02 PM, dannycorker said:

Sorry to drag up an old thread - does this still work?

 

I've installed the docker, ran the conf and I've got the /data drive showing within Sonarr which is great - I just don't seem to be getting the actual mount to happen at any point? Have I missed something obvious do you think? 

 

Have you read the op and FAQ? Specifically this point "I cannot see my mounted volume/files outside of the container" ? :)

Share this post


Link to post
On 04/11/2017 at 8:29 AM, thomast_88 said:

 

Have you read the op and FAQ? Specifically this point "I cannot see my mounted volume/files outside of the container" ? :)

 

Maybe I'm misunderstanding something - in Sonarr I have a mapping of /data  <-> /mnt/disks/rclone_volume/, but if I browse to data within Sonarr, I just see the contents of my local /mnt/disks/rclone_volume/ folder? It doesn't seem that drive is actually getting mounted there.

Edited by dannycorker
Correction

Share this post


Link to post
14 hours ago, dannycorker said:

 

Maybe I'm misunderstanding something - in Sonarr I have a mapping of /data  <-> /mnt/disks/rclone_volume/, but if I browse to data within Sonarr, I just see the contents of my local /mnt/disks/rclone_volume/ folder? It doesn't seem that drive is actually getting mounted there.

 

Can you please post both your docker run command for Sonarr and Rclone-mount ? (Remember Rclone-mount must be started before Sonarr)

Share this post


Link to post
On 06/11/2017 at 12:47 PM, thomast_88 said:

 

Can you please post both your docker run command for Sonarr and Rclone-mount ? (Remember Rclone-mount must be started before Sonarr)

 

Ah my bad, it was a permissions error on the 'disks/rclone_volume' path! Will have a play with it later this evening, but looking great at the moment, thanks!

Share this post


Link to post
On 2/1/2018 at 11:48 AM, Dimtar said:

Has this docker been updated to include the new cache option?

 

Yes. As of now.

Share this post


Link to post
1 hour ago, thomast_88 said:

 

Yes. As of now.

 

Excellent, will test soon. TY

Share this post


Link to post
34 minutes ago, Dimtar said:

 

Excellent, will test soon. TY

 

Pull the dev tag though. I didn't update the master branch yet.

Share this post


Link to post

So I finally have my Cloud Drive (google) mounted to /mnt/disks. At first I had access errors, but that was solved by a chown 911:911 command on the cloud folder. I also created a SMB share to this directory for my Win10 VM. My big problem seems to be permissions. I can only read the directory through the Win10 VM.

 

Every time I try to do anything else, I get this error message. rclone-mount spits out access errors in the log if I do not have the cloud folder set to chown 911:911. I also made sure my rclone mount options in the docker template have "--max-read-ahead 1024k --allow-other". As a test, I verified I had full access to the cloud folder through root terminal. Why does it have to be 911:911.....why does it not like nobody:users?

You require permission from the unix user/911 to make changes to the file

And here is my SMB Share Setting:

 

[google]
path = /mnt/disks/rclone_volume/google
comment =
browseable = yes
# Public
public = yes
writable = yes
force user = root
force group = root
vfs objects =

Interestingly, when I set force user = root & force group = root in the SMB settings, I can actually delete things from the cloud folder in Win10.......But I cannot write to it.

Edited by Stupifier

Share this post


Link to post

Excellent work on the Container 

sorry may be a dumb question total newb 

i have created a rclone.conf on my base machine but i am new to docker and trying to use your container to mount my drive

the drive is a google Team drive but i do not know how to create your container or i can not get it working

this is what i normally put in to my Ubuntu Server to mount the drive 

sudo rclone --allow-non-empty --allow-other mount tdrive: /home/{user}/tdrive --size-only --dir-cache-time=2m --vfs-read-chunk-size=64M --vfs-cache-max-age 675h --vfs-read-chunk-size-limit=1G --buffer-size=32M

 

this is what i am trying with your container file

docker run -d --name rclone-mount \
    --restart=unless-stopped \
    --cap-add SYS_ADMIN \
    --device /dev/fuse \
    --security-opt apparmor:unconfined \
    -e RemotePath="tdrive:" \
    -e MountCommands="--allow-other --allow-non-empty --size-only --dir-cache-time=2m --vfs-read-chunk-size=64M --vfs-cache-max-age 675h --vfs-read-chunk-size-limit=1G --buffer-size=32M" \
    -v /home/media/.config/rclone:/config \
    -v /home/media/dtdrive:/shared \
    tynor88/rclone-mount

 

sorry again if this wastes your time just looking for some help thank you in advance.

also i am not able to pull your image Error response from daemon: manifest for tynor88/rclone-mount:latest not found: manifest unknown: manifest unknown

Edited by rackeysingh

Share this post


Link to post

Hi there

 

Im having issues getting this to work with google drive (gsuit). I have sorted out the permission issues on the mount.

 

If i ls via docker from the terminal

docker exec -it Rclone-mount rclone --config="/config/.rclone.conf" config

 

i can see my files on google drive but when I access the mount it is empty. I also cannot add files to the mount.

 

root@InternetBackup:~# docker exec -it Rclone-mount rclone --config="/config/.rclone.conf" ls gdrive:
  6035089 Photos/20170614_095401.jpg
        0 Media/Series/series.txt
        0 Media/Movies/movies.txt

 

In the docker log i get the following:

[services.d] starting services
Executing => rclone mount --config=/config/.rclone.conf --allow-other --allow-non-empty gdrive: /data
[services.d] done.
2018/10/26 22:41:59 ERROR : Error traversing cache "/root/.cache/rclone/vfs/gdrive": lstat /root/.cache/rclone/vfs/gdrive: permission denied

2018/10/26 22:42:59 ERROR : Error traversing cache "/root/.cache/rclone/vfs/gdrive": lstat /root/.cache/rclone/vfs/gdrive: permission denied

2018/10/26 22:43:59 ERROR : Error traversing cache "/root/.cache/rclone/vfs/gdrive": lstat /root/.cache/rclone/vfs/gdrive: permission denied

2018/10/26 22:44:59 ERROR : Error traversing cache "/root/.cache/rclone/vfs/gdrive": lstat /root/.cache/rclone/vfs/gdrive: permission denied

Any help would be greatly appreciated. 

Share this post


Link to post
On 10/27/2018 at 12:55 AM, markrudling said:

Hi there

 

Im having issues getting this to work with google drive (gsuit). I have sorted out the permission issues on the mount.

 

If i ls via docker from the terminal


docker exec -it Rclone-mount rclone --config="/config/.rclone.conf" config

 

i can see my files on google drive but when I access the mount it is empty. I also cannot add files to the mount.

 


root@InternetBackup:~# docker exec -it Rclone-mount rclone --config="/config/.rclone.conf" ls gdrive:
  6035089 Photos/20170614_095401.jpg
        0 Media/Series/series.txt
        0 Media/Movies/movies.txt

 

In the docker log i get the following:


[services.d] starting services
Executing => rclone mount --config=/config/.rclone.conf --allow-other --allow-non-empty gdrive: /data
[services.d] done.
2018/10/26 22:41:59 ERROR : Error traversing cache "/root/.cache/rclone/vfs/gdrive": lstat /root/.cache/rclone/vfs/gdrive: permission denied

2018/10/26 22:42:59 ERROR : Error traversing cache "/root/.cache/rclone/vfs/gdrive": lstat /root/.cache/rclone/vfs/gdrive: permission denied

2018/10/26 22:43:59 ERROR : Error traversing cache "/root/.cache/rclone/vfs/gdrive": lstat /root/.cache/rclone/vfs/gdrive: permission denied

2018/10/26 22:44:59 ERROR : Error traversing cache "/root/.cache/rclone/vfs/gdrive": lstat /root/.cache/rclone/vfs/gdrive: permission denied

Any help would be greatly appreciated. 

Pull the latest version (dev tag). There was a bug in Rclone.

 

It should work fine now.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now