Jump to content
benflux

Getting Phlex to work

15 posts in this topic Last Reply

Recommended Posts

I used the docker a few months ago and it was working no problem. Then I redid it this week and issues. Out of about 100 restarts of it only one time did it actually get to the web interface. I get failed to bind to port 80 in the logs.   I am pretty sure you have to run it as host. Also, privledged is required.

Share this post


Link to post

when I put it in as a docker repository and then create a container, it doesn't even appear in the list. That's how far I got!

Share this post


Link to post

I also tried to get this to work as well but keep getting error in my logs. Not sure why it's using port 80 even though I specified to use a different port.

nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address in use)

nginx: [emerg] socket() [::]:80 failed (97: Address family not supported by protocol)

nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address in use)

nginx: [emerg] socket() [::]:80 failed (97: Address family not supported by protocol)

nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address in use)

nginx: [emerg] socket() [::]:80 failed (97: Address family not supported by protocol)

 

Share this post


Link to post

Has anyone gotten this to work? I have been trying for almost a month and have never even seen the webUI. I have it set to host and privileged and no dice.

Share this post


Link to post

I've been trying this morning for the first time to install this with no joy - any advice?

 

Thanks

Share this post


Link to post
8 minutes ago, rbmatt1s said:

chalk me up as having tried and failed to get Phlex running. Hoping there is an update.

I managed to get https://app.phlexchat.com/ working, but there's no way currently to say 'play on living room tv' or 'play on kitchen tv', so it's not much use to me yet.  Worked fine otherwise though

Share this post


Link to post

I am also experiencing this issue. Cannot get Phlex to start due to nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address in use) issue. 

 

ErrorWarningSystemArrayLogin


nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address in use)
nginx: [emerg] still could not bind()
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address in use)
nginx: [emerg] still could not bind()
 

This error just repeats over and over indefinitely. 

 

I was able to get Phlex working for a while and it worked like a dream, but suddenly it stopped. No system or App changes made. Unraid itself is using port 80. This is the only thing I can I think of that would be causing this bind error. 

 

Tried changing docker to privileged, no fix

Tried uninstalling / reinstalling app, no fix

Tried installing a different version of Phlex, no fix

Tried restarting Unraid Server, no fix

Removed all non-essential Apps, no fix

Made sure digitalhigh Phlex is running latest version, no fix

Tried changing Port, no fix

 

I've run out of troubleshooting steps. Any ideas?

Share this post


Link to post

Hi - I got it working by changing the ngix file called "default" located in config/nginx/site-confs

 

I changed the ports from 80 and 443 to 5666 and 5667 at the top of the file :-

 

server {
    listen 5666 default_server;

    listen 5667 ssl;

Share this post


Link to post

I just set the networking to bridge and remapped 443 to 4443 on the host.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.