[Support] Djoss - Avidemux


Djoss

Recommended Posts

Support for Avidemux docker container

 

Application Name: Avidemux
Application Sitehttp://avidemux.org/
Docker Hubhttps://hub.docker.com/r/jlesage/avidemux/
Githubhttps://github.com/jlesage/docker-avidemux

 

This container is based on Alpine Linux, meaning that its size is very small.  It also has a very nice, mobile-friendly web UI to access Avidemux graphical interface and is actively supported!

 

Make sure to look at the complete documentation, available on Github !

 

Post any questions or issues relating to this docker in this thread.

Edited by Djoss
Link to comment
  • 3 months later...
14 minutes ago, drdebian said:

I can't seem to get this container to work. Going with the defaults, there are a number of erros in the log:

 

image.png.7756db8ae1bf24fb227d6d9fa5cd9ead.png

image.png.81207375202d0109ea94507ce60c5c0d.png

 

Connecting to the WebGUI gives me an empty page:

image.thumb.png.9f584448927c40d3fb582d5881570e0a.png

 

any ideas?

Can you try to clear your browser's cache?

  • Like 1
Link to comment
  • 11 months later...
On 1/20/2020 at 2:47 AM, UNcitizenRAID said:

i have had this issue before but newer versions have seemed to fix it on windows but i can not get sound to work it has a audio file selected but i get no sound?

What are you trying to do? Copy the track or encode it?

Link to comment
  • 1 month later...
  • 5 weeks later...
On 3/1/2020 at 3:58 AM, UNcitizenRAID said:

edit commercials from channelsDVR recording so in this case just copy, any help would be appreciated, all the different options in preferences gives me a trouble initializing  audio device error

Hey, did you ever find a fix to the audio issue? I am getting the same failed to initialize audio device error.

Link to comment
  • 4 weeks later...
On 3/1/2020 at 9:58 AM, UNcitizenRAID said:

edit commercials from channelsDVR recording so in this case just copy, any help would be appreciated, all the different options in preferences gives me a trouble initializing  audio device error

 

On 3/31/2020 at 8:20 PM, Baythar said:

Hey, did you ever find a fix to the audio issue? I am getting the same failed to initialize audio device error.

may a question, as im also using avidemux to cut my coms .... and its working perfectly.

 

do i see it correct that u want to have also audio while playing back in avidemux ? cause i cut only by view ;)

 

when u try to get audio working, i guess this is not supported in the docker due there is no sound device ... afaik, and not supported by unraid due there are no drivers installed.

Link to comment

is there a way like  handbrake you copy the files you wanna fix into a folder and it automaticlly runs

as i wanna rencode my cam corder videos etc.. from avi mp4 moi  to mkv...  since i noticd some of my mp4 i made are corrupt the tags i cant re write

so i wanna just batch the entire thing  fixing them  instead of loosing quality   of my jvc and sony cam corder recordings too...  

is there a batch option on here..  like the handbrake  even does the sub folders too

 

Link to comment

whats the difference between convert and prepare..  what is the idx2?  

i was using mp3tag trying to erase tags etc.. and noticed too many issues

so wanted a batch that repairs all my videos and convert from avi moi  to mkv then i can add tags 

but ill check out the tutorial as i dont wanna sit on the comp all day lol

 

Link to comment
2 minutes ago, comet424 said:

whats the difference between convert and prepare..  what is the idx2?  

i was using mp3tag trying to erase tags etc.. and noticed too many issues

so wanted a batch that repairs all my videos and convert from avi moi  to mkv then i can add tags 

but ill check out the tutorial as i dont wanna sit on the comp all day lol

 

when i open a .ts stream, avidemux reads the file and creates a idx2 file to work with ...

now, when i open avidemux to make my comcuts, its immediately here, so i dont have to wait ... takes only a few seconds, but what is done is done ... ;)

 

sample from my script which u could adjust ... runs as schedules task here every few minutes, u would have to add some lines for your usage of course, depends now what u exactly want todo ... and if it works like u want.

 

this will only open the file and read it, not remux it as i need to edit them first ;)

#!/bin/bash

startpath="/mnt/cache/Media/"	### main place where to look for
searchpattern="*.ts"			### what type of files to look for
extradelpattern=".idx2"			### extra delete type - sample, avidemux file

cd $startpath

find . -mindepth 2 -iname $searchpattern|sed "s|^\./||"|while read fname; do
	echo "$fname"
	sourcefile=$(basename "$fname")
	extrafile="$sourcefile$extradelpattern"
	filepath=$(dirname "$fname")

	cd "$startpath/$filepath"

	if ! [ -n "$(lsof "$sourcefile")" ]; then
		if ! [ -f "$extrafile" ]; then
			docker exec avidemux /usr/bin/avidemux3_cli --load /storage/"$fname" --quit > /dev/null
			echo "$sourcefile loading in avidemux ..."
		else
			echo "$extrafile already there..."
		fi
	else
		echo "$sourcefile in use ..."
	fi
done

 

Link to comment

wish i knew programming better..

so remuix  does that mean  just basiclly repair orginal file into a new file  like a new copy?

 

and basiclly all i want is to fix any mkv  or mp4 files that have tag issues  and convert any video  i put in say

/process folder /     to convert all the files

/output/   is the finished folder

 

so  /process folder/2019/home videosa.avi  

     /process folder/2019/home videosb.mp4

 

/output folder

/output/2019/home vidoesa.mkv

/output 2019/home videosb.mkv

 

basiclly like that..i not even suer what a idx2 is or ts file 

 

what does the "fi"  command or did you spell if backwards?

 

 

 

Link to comment

@alturismo

i havent gotten a chance to try your code  

but 1.. is remux mean  copy the old file into a new one?

also  if i want it to search for avi mp4 mkv   do you do "*.avi,*mp4,*.mkv,*moi"

and  i want it to look in 

/process     <input folder>  also be able to process subdirectories

/done         <output folder>   so this is after it fixes the files and puts them in the same directories as the process folder

 

does your coding  do that.. and what i need exactly to just change it..    is is this a python program  or how you excute it..

 

but ya maybe you can help me show what i need to change to your program... been busy and havent gotten a chance to play with things

 

and i skimmed the tutorial  but didnt know which one work for me  exactly  but ill have to re read it

Edited by comet424
Link to comment
11 hours ago, comet424 said:

i tried your code and i tried the code in tutorial at bottom of the page

 

neither one worked  just errors like it cant be found

so been manually loading then re saving  oh  drives me nuts lol

when i followed u correctly, you are using handbrake usually which offers a GUI batch handling, why dont u stay at handbrake and remux there ?

 

and my "code" was just a sample from a script how u could handle schedules processing and trigger batch processing automatically when files are lying in a "watch" folder unused ... also inotify is a option therefore, but u should 1st try the cmd from cli to see what u get, then u can reverse write the lines u need for processing automatically.

 

the sample u see, is just looking in a folder, when it founds a .ts file and the file is unused (record finished) ir will get processed by avidemux to read. as soon the proper idx2 file is there it wont read it again, and leaves other files untouched ...

that is triggered by scripts and scheduled tasks.

 

u have a different workflow, u just want all files in a folder processed (remux from avi to mkv), that was the basic command sample i posted to batch ... 1st u have to look how the remux command would be etc ... i d simple test it by following the avidemux readme, im pretty sure its not that huge effort, u just should put in a routine like me if the files are processed (your ....mkv is there) that it doesnt proceed again.

Edited by alturismo
Link to comment

well 1..  I already asked in handbrake..  there is no such program for handbrake to repair (remux) files  

so I was sent to  mkvtoolnix  and then since they said it doesn't offer batch.,. they told me to use avidemux

 

so far I been manuallying doing loading 600 files so far  I soo tired

I tried  the  "docker exec  avid...."  no such program as avidemux it said . I tried the avideremux2   like tutorial.. also no such file  to run..

 

ya  I want a process folder throw all the files and folders in there .. and it repairs them all  converting them all no matter what file format to avi…. handbrake rencodes them so 1gb avi file be down to 300meg   as they said u loose quality as its rencoding..

 

I just wish they had it in the docker  lol  prebuilt in there what be nice is   

process all the files  then delete the orginals   

and no idea what a idx2 file is...

 

but I did try reading the tutorial  it didn't help though   not sure what readme file you are referring to..   I installed the docker  and I was hoping it would batch repair  out of the box  like handbrake does it lol  well wishful thinking..

but so far still manually repairing videos 

as bunch can no be ready by mymp3tag to erase broken meta tags I had in no avi.. and then in mkv  I can add meta tags to my home videos etc  

 

Link to comment

ok, took a look at handbrake and also couldnt find a remux option .. weird but ok ;)

 

here a sample from cli to simple remux a file

 

/storage/GAMES/Test # avidemux3_cli --load drop.avi --nogui --audio-codec copy --video-codec copy --output-format MKV --save drop.m
kv --quit

 

image.thumb.png.e6349b369ec42eeab0d51ae425a47c75.png

 

--load loads the file

--nogui ...

--audio/video-codec copy ... we dont want to transcode, just remux

--output-format mkv ... if thats what u want

--save --- new filename here

Edited by alturismo
Link to comment

hmm  ok  so which part of the code is the executable  I tried 

avidemux3_cli     and command is not found

same with the avidemux2  and  avidemux  from the sample code  what else do you need?  and I know I don't have a drop.avi    I just tried the code

root@Tower:~# avidemux3_cli
-bash: avidemux3_cli: command not found
root@Tower:~# avidemux3_cli --load drop.avi --nogui --audio-codec copy --video-codec copy --output-format MKV --save drop.m
k-bash: avidemux3_cli: command not found
vroot@Tower:~# kv --quit
-bash: kv: command not found

and dunno why when I copied and pasted your code    it did the kv --quit  should been part of the first part

 

Edited by comet424
Link to comment

ok, as you are running this command from the unraid shell and not inside the docker ...

 

may start like this

Linux 4.19.107-Unraid.
Last login: Fri May  1 05:58:58 +0200 2020 on /dev/pts/3.
root@AlsServer:~# docker exec avidemux avidemux3_cli --help
...
..
.
 Command line possible arguments :
    --append, append video  (one arg )
    --audio-codec, set audio codec (copy|Lame|FDK_AAC|LavAC3|Opus|TwoLame|...)  (one arg )
    --avisynth-port, set avsproxy port accordingly  (one arg )
    --help, print this  ( no arg )
    --info, show information about loaded video and audio streams  ( no arg )
    --list-audio-languages, list all available audio langues  ( no arg )
    --load, load video or workbench  (one arg )
    --nogui, Run in silent mode  ( no arg )
    --output-format, set output format (MKV|MP4|ffTS|ffPS|AVI|RAW|...)  (one arg )
    --quit, exit avidemux  ( no arg )
    --slave, run as slave, master is on port arg  (one arg )
    --run, load and run a script  (one arg )
    --save, save video  (one arg )
    --save-jpg, save a jpeg  (one arg )
    --save-raw-audio, save audio as-is   (one arg )
    --save-uncompressed-audio, save uncompressed audio  (one arg )
    --set-audio-language, Set language of an active audio track {track_index} {language_short_name}  (two args )
    --var, set var (--var myvar=3)  (one arg )
    --video-codec, set video codec (Copy|x264|x265|xvid4|ffMpeg2|ffNvEnc|...)  (one arg )

 ********** Automation ended***********
*********************************
*********************************
End of program..
*********************************
*********************************
 [save] 04:19:13-984  Saving prefs to /root/.avidemux6/config3.tmp
 [destroy] 04:19:13-984  Destroying preview
 [deleteAll] 04:19:13-984  [Editor] Deleting all videos
 [deleteAll] 04:19:13-984  [Editor] Deleting all videos
Normal exit
 [uninstallSigHandler] 04:19:13-984  Removing signal handler
 [abortExitHandler] 04:19:13-984  already done, nothing to do
06:19:13 Call terminate!!!
root@AlsServer:~# 

while avidemux is the dockername in docker exec <dockername> ... exact dockername case sensitive ....

 

but to make it short, this is no avidemux help forum, this is the docker help forum from @Djoss, and may start with some basics to read how to either use docker exec (exec a app inside docker) or for testing manually use the console inside docker.

 

Also, this was just a test sample for 1 file from cli, not to run through your folders and remux all ...

Link to comment

ok you lost me docker/help forum  etc..  the script would be command line not docker.. as there is no section in the avidemux docker settings to say add script..  

I used the command line  to post your script as its a command line script      and then you do  chmod +x   to make it runnable...    if your supposed to be able to add script to the docker. then you need to go back 100 steps and say how do you add a script   other then running it from the command prompt.

as I don't know what your talking about now lol

 

and I tried your command above but doesn't work 

root@Tower:~# docker exec avidemux avidemux3_cli --help
Error: No such container: avidemux
root@Tower:~#

so your going to have to go back several steps  on  how you run scripts in avidmix docker.. as now you confused me lol  doesn't take much haha

 

as the only place I know where you can run scripts   is "user scripts"    and that's all command line  code too  

so I lost lol

Edited by comet424
Link to comment

may before this is getting offending due missunderstandings .... and im not interested in stuff like this.

 

image.thumb.png.f8ba03d5246a55732a02382860622d23.png

 

last try, what is your "exact" dockername ?

image.png.ccace83c270d6401691370c1658cc701.png

 

as described before ... even CaSe SeNsItIvE ... your respond is "docker not found", so my guess is yours is may called Avidemux or whatever ...

so may give it a try with your personal dockername of avidemux ...

 

about a script, i never said u have to add a script inside a docker, but BEFORE you start with a script u should test, and the easiest way would be directly in the shell from the docker, simple as this, click on the docker and then hit console

image.png.0b6a19df52613cd0db8a97f8bb2f3dc6.png

then u are "inside" the docker and can simple use avidemux3_cli directly ... without docker exec ....

 

if you dont know these things and differences u may rather start with basic tutorials here how to use docker commands, then you will see what i meant, as i dont know what your knowledge is etc ... its not a nice move to "lol" and point to things i didnt even mention.

 

and basically u are asking for avidemux functions, not about if this docker itself works or not (what this forum is about), that was my point why i mentioned this is not a avidemux forum, also not a avidemux subforum and may the author will say at some point this is not his app, he made the docker around it, just to clarify ... and i tried to point you directions how u can achieve what u want, but also here, i always said its a sample how a script could use avidemux todo what u want, but its not YOUR script for YOUR usecase, was just trying to help.

just copy/paste my command without understanding will sure lead in "no success" as we have different enviroments (pathes, etc ...) and diff usecases.

 

long story short, check what i mentioned, read the manuals ... and its pretty easy to get what you want by simply drop your files into your folder and run all auto or do it as 1 time job manually by exec some script ... if you need help with a script, there are subforums here and im sure u get help therefore there.

 

but also again, 1st i would try testing some avis from you manually if the result is what u want (remux and working).

 

either in the end by

docker exec <YOURDOCKERNAMEHERE> avidemux3_cli --load /YOUR/MOUNTED/PATH/yourfile.avi ............. --quit

(and that would also be your user scripts script in the end ...)

 

or inside the shell as described above

cd /YOUR/MOUNTED/PATH/

avidemux3_cli --load ............. --quit

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.