Jump to content

[Support] Djoss - MKVCleaver


Recommended Posts

Support for MKVCleaver docker container

Application Name: MKVCleaver
Application Site: https://blogs.sapib.ca/apps/mkvcleaver/
Docker Hub: https://hub.docker.com/r/jlesage/mkvcleaver
Github: https://github.com/jlesage/docker-mkvcleaver


Make sure to look at the complete documentation, available on Github !


Post any questions or issues relating to this docker in this thread.

  • Like 1
Link to comment
1 hour ago, digitalfixer said:

Would this be easier to implement rather than using wine.


It has multiple linux versions.




I saw this software, but I found that it has less features than MKVCleaver...  But I can also create a container for it.


Let me know if you are interested to continue helping with debugging of MKVCleaver :). Since it's working perfectly for me on 2 different systems, it should not be too difficult to find what's different on yours... 


Link to comment
9 hours ago, Djoss said:

The problem may be related to the docker version used in 6.4 rc.

6.4 If you set /storage to be /mnt instead of /mnt/user you will get the UI


But, attempting to open MKV files to process gives a messed up window that looks like it crashes to container

Link to comment
  • 2 weeks later...
10 hours ago, Squid said:

Any progress on this problem?


With @digitalfixer, we looked at a couple of things.  Everything on his system was the same as mine.  One major difference was the docker version.  I used the same version on a PC without reproducing the issue.  Then, at some point, the container started to work.  We tried to remove the container with its appdata.  Even after a clean install, it worked.  So looks like to problem disappeared :S.


From what I was able to see, the problem was the access to the /storage volume that was blocking.  More specifically, the container was blocking on a script executing the command "cd /storage".


Tell me if you would like and have time to help with this!

Link to comment
43 minutes ago, Djoss said:

Tell me if you would like and have time to help with this!

I'll do what I can.  Just let me know


Other investigations:

  • Running RC15e it doesn't matter what you enter in for the host path on /storage.  It never works 
  • cd /storage from docker exec works fine
  • MKVCleaver and wine is running according to top
  • VNC to port 7912 also results in a black screen

Other thoughts


6.4 is compiled to allow execution of 32bit binaries within docker containers (I see that you're running wine64, but the lack of 32bit binaries was what previously stopped wine from executing on unRaid

Link to comment

Delete Appdata, Fresh Install, All defaults




    1 root       0:00 s6-svscan -s -t0 /var/run/s6/services
   32 root       0:00 s6-supervise s6-fdholderd
  496 root       0:00 s6-supervise app
  501 root       0:00 s6-supervise nginx
  502 root       0:00 s6-supervise openbox
  503 root       0:00 s6-supervise xvfb
  504 root       0:00 s6-supervise x11vnc
  505 root       0:00 s6-supervise wineserver
  671 daemon     0:00 s6-fdholderd -1 -i rules
  713 root       0:00 nginx: master process /usr/sbin/nginx -c /etc/nginx/nginx
  728 root       0:00 /usr/bin/Xvfb :0 -screen 0 1280x768x24
  747 root       0:00 [s6-notifyonchec]
  751 nginx      0:00 nginx: worker process
  752 nginx      0:00 nginx: worker process
  753 nginx      0:00 nginx: worker process
  754 nginx      0:00 nginx: worker process
  758 root       0:00 s6-supervise logmonitor
  759 root       0:00 s6-supervise statusmonitor
  760 root       0:00 s6-supervise certsmonitor
  768 root       0:00 /usr/bin/x11vnc -display :0 -rfbport 5900 -rfbportv6 -1 -
  782 app        0:00 /usr/bin/wineserver --foreground --persistent
  792 app        0:00 /usr/bin/openbox
  808 app        0:59 /opt/mkvcleaver/MKVCleaver.exe
  836 app        0:00 {services.exe} C:\windows\system32\services.exe
  840 app        0:00 {winedevice.exe} C:\windows\system32\winedevice.exe
  852 app        0:00 {plugplay.exe} C:\windows\system32\plugplay.exe
  867 root       0:00 ps -A


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...