Jump to content
nlash

Adding more than 2 cores (and the HT pairs) to my Windows 10 VM causes major stuttering.

11 posts in this topic Last Reply

Recommended Posts

Using a Ryzen 2700x.

 

I've tried various groupings of cores (always along with the grouped HT pair) and anything over two cores causes the entire vm (mouse included) to massively stutter every couple of seconds.

 

I've tried everything under the sun and this is the only way I can get a stutter-free Windows 10 VM.

Share this post


Link to post

No where near an expert, or even knowledgeable but, from reading the threads here is there a major latency problem because of NUMA pairing? (or something like that).

 

Maybe google "unraid numa"

Share this post


Link to post

Check out the spaceinvaderone videos on installing lstopo which will give you a visual representation of your numa nodes, the CPU's & PCIe slots tied to them. This will help you pick your CPU assignments.

Share this post


Link to post

Here's my lstopo output. Not exactly sure how to interpret it since it's a different type of CPU than spaceinvaderone's example. 

 

 

1.png

Share this post


Link to post

No, wasn't resolved. What cores I use doesn't seem to matter—adding more than 3 cores causes unfixable stutters. 

 

If I add a 4th, then reduce it back to 3, the stutters stay and can't be fixed. 

Share this post


Link to post

I saw something like this today.  I tried it many times with little tweaks to the configs because I didn't believe what I was seeing, but you are right this is a thing!

 

I have a Ryzen 7 3800X on a ASUS ROG Strix x570-E board with bios 1405 AGESA 1.0.0.4 Patch B, and I saw significant input lag/stutter (i.e. mouse cursor skipping) when isolating CPUs from different CCXs.  I didn't even have to use them in the VM ... just isolating CPU cores in Unraid from different CCXs and starting the VM using cores for 1 CCX (or both) was enough to cause the lag.

 

Here is my CPU architecture which is similar to yours.  I passed the 2nd CCX (cores 4-7 & 12-15) and a HT core from the 1st CCX (cores 3 & 11) leaving the rest of the 1st CCX for Unraid during my testing.

 

topo_cogsworth_v3.thumb.png.7268d4e89a44487331364ee77b626432.png

 

This may be more complicated of an issue for me as I am having other VM stuttering issues which I posted about here. 


But I wanted to validate your finding!  You're not crazy!  

 

-JesterEE

Share this post


Link to post

It's good to know I'm not crazy. 

 

Just to add another data point...I currently have cores 3, 5, and 7 isolated for my Windows VM. If I'm reading my architecture correctly, that's across two CCXs.

 

It runs perfect.

 

If I add another core—any core—guaranteed stuttering. My emulator is on core 0.

 

Luckily this is only a gaming VM, so three cores is enough, but I've never been able to solve it.

 

My MacOS VM that uses those cores plus core 1 runs like butter.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.