[Support] ich777 - Application Dockers


ich777

971 posts in this topic Last Reply

Recommended Posts

This is a nitpicky thing for me, but is there a way to change the date format in dirsyncpro? It's in DD-MM-YYYY on the schedules tab and it's driving me nuts. I would like MM-DD-YYYY

 

Other than that that docker works great for me to backup essential unraid files offsite.

Link to post
  • Replies 970
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

It's not a VPN app, it shows only up as a VPN, only your DNS queries are redirected with Intra. I think @testdasi has such a container.     I use it now for a long time like you

I see you mentioning "unraid optimized"...in what way would these be optimized compared to the images of other docker maintainers?    Another thing I noticed in the used template (and it's a

I had a *lot* of issues with the SQLite database in photoprism actually, lots of "database is locked" errors. After switching it out to MariaDB it just works and everything is much much faster now as

Posted Images

On 12/11/2019 at 3:27 PM, ndaringer said:

This is a nitpicky thing for me, but is there a way to change the date format in dirsyncpro? It's in DD-MM-YYYY on the schedules tab and it's driving me nuts. I would like MM-DD-YYYY

I think that's not possible but i think you can request this here: *Click*

 

On 12/11/2019 at 3:27 PM, ndaringer said:

Other than that that docker works great for me to backup essential unraid files offsite.

Can i ask wich method did you use and if you are using encryption or not (only for my personal information)?

Link to post
  • 2 weeks later...

Having some trouble with your jDownloader container, but I think it's the way I use jDownloader. I've tried all 4 of the jDownloader containers and three of the four have this issue. When trying to decode MultiUp.org links, I get an error in the linkgrabber window "Wrong Captcha!(filename)". aptalca's implementation works as intended just like my Windows install. I'm not sure exactly why this is happening, and I don't really know what to do to combat it.

 

I would prefer to use any other container than aptalca's, and I really would rather not sign up for a my.jdownloader account.

 

Any thoughts?

(Note, screenshot isn't from your container, but the experience is the same--I captured this while testing)

chrome_2019-12-21_00-21-32.thumb.png.041c95488f01126a62181552a2e7bb8c.png

Link to post
1 hour ago, MDKAOD said:

Having some trouble with your jDownloader container, but I think it's the way I use jDownloader. I've tried all 4 of the jDownloader containers and three of the four have this issue. When trying to decode MultiUp.org links, I get an error in the linkgrabber window "Wrong Captcha!(filename)". aptalca's implementation works as intended just like my Windows install. I'm not sure exactly why this is happening, and I don't really know what to do to combat it.

 

I would prefer to use any other container than aptalca's, and I really would rather not sign up for a my.jdownloader account.

 

Any thoughts?

(Note, screenshot isn't from your container, but the experience is the same--I captured this while testing)

chrome_2019-12-21_00-21-32.thumb.png.041c95488f01126a62181552a2e7bb8c.png

Can you give me a little bit more background how MultiUp.org works?

Is this some kind of CutCaptcha? CutCaptcha also doesn't work in my container because it needs an instance of some browser running with the jDownloader plugin.

Also you can write mi a PM for this and i will look into it.

You can also grab the links from your Windows/Mac/Linux machine, solve the captcha, right click on the links in jDownloader, make a DLC file, put this file into your jDownloader directory and then load it in the container.

Link to post
7 hours ago, ich777 said:

Can you give me a little bit more background how MultiUp.org works?

Is this some kind of CutCaptcha? CutCaptcha also doesn't work in my container because it needs an instance of some browser running with the jDownloader plugin.

Also you can write mi a PM for this and i will look into it.

You can also grab the links from your Windows/Mac/Linux machine, solve the captcha, right click on the links in jDownloader, make a DLC file, put this file into your jDownloader directory and then load it in the container.

I'll be honest, I'm not sure exactly how MultiUp works in detail, but maybe you're right. When i went through the motions a few times, I didn't solve any captchas, but eventually I had to "Verify" reCaptcha, so maybe you're dead on with the browser.

 

The DLC file seems(?) to work okay though, so maybe that's my ticket. Thanks for your help.

Link to post

hi,

 i'm trying out the jdownloader2 docker, it seems to work fine, but is there any particular reason why the docker is not reporting its bond ip to unraid?:

 

image.thumb.png.e13751d988269530af1832d5562f1efc.png

 

I also wonder if there's a variable to specify password on the vnc connection? I tried added

 

Variable: VNC_PASSWORD

 

But no go, still fully open to all vnc connections.

 

EDIT: NVM, not sure why password variable didnt take first time, now it works. IP are still null in unraid though but i can connect to the docker.

Edited by je82
Link to post
16 hours ago, je82 said:

hi,

 i'm trying out the jdownloader2 docker, it seems to work fine, but is there any particular reason why the docker is not reporting its bond ip to unraid?:

 

image.thumb.png.e13751d988269530af1832d5562f1efc.png

 

I also wonder if there's a variable to specify password on the vnc connection? I tried added

 

Variable: VNC_PASSWORD

 

But no go, still fully open to all vnc connections.

 

EDIT: NVM, not sure why password variable didnt take first time, now it works. IP are still null in unraid though but i can connect to the docker.

Because i didn't expose the ports in the Dockerfile, is it essential for you or doese something not work properly?

 

For the VNC_PASSWORD, i didn't even thought of this but if it works it's good :D

Edited by ich777
Link to post
3 hours ago, ich777 said:

Because i didn't expose the ports in the Dockerfile, is it essential for you or doese something not work properly?

 

For the VNC_PASSWORD, i didn't even thought of this but if it works it's good :D

Not essential just doesn't look good in the gui, all works fine.

Is there any security advanced in not exposing the ports in the docker file?

 

Thanks and merry christmas!

Link to post
1 hour ago, je82 said:

Not essential just doesn't look good in the gui, all works fine.

Is there any security advanced in not exposing the ports in the docker file?

 

Thanks and merry christmas!

Eventually, if i got two containers with the same port and someone is installing them it simply doesn't work (also other containers like Homeassistant also doesn't have ports exposed).

 

Mary Christmas!

Link to post

Found an issue (maybe with VNC rather then this docker) but if you connect from one computer and forget that you've connected to it you cannot connect with a second, vnc only renders a black screen. If you exit the first connection the second connection works and renders the graphics.

 

Perhaps this is more an issue in VNC, i was wondering if there's any possible way to mitigate this by having some kind of idle timer and if idle for x minutes disconnect the session?

 

EDIT:

Reading up on it i guess x11vnc is installed inside the container, running command x11vnc -R xkb may resolve temporary copy paste issues, question is how you could make the container continously run this everytime a user disconnects from the vnc session clearing out any copy paste that is being held in memory that may result in issues when a new client connects?

Edited by je82
Link to post

Today i also got problems with VNC copy paste, this is rather common with VNC that copy paste operations stop working randomly, i have no idea why. This however did not resolve when i restarted the container. I tried restarting everything and copy paste would still not operate between any computer and the docker container making me believe the problem was on the docker/unraid side of things because copy paste would work fine between my computer and other vnc hosts.

 

I read here: https://stackoverflow.com/questions/35595598/clipboard-operations-fail-using-tight-vnc

 

That vnc trouble with copy paste can be resolved by installing autocutsel whatever that is, maybe worth a shot? I'm not sure how docker operates but i do believe it uses vnc that is installed in unraid? So it would have to be patched in unraid or in the docker?


 

autocutsel -fork

like this

#!/bin/bash
xrdb $HOME/.Xresources
autocutsel -fork
startxfce4 &

restart vncserver

 

Link to post
3 hours ago, je82 said:

Found an issue (maybe with VNC rather then this docker) but if you connect from one computer and forget that you've connected to it you cannot connect with a second, vnc only renders a black screen. If you exit the first connection the second connection works and renders the graphics.

 

Perhaps this is more an issue in VNC, i was wondering if there's any possible way to mitigate this by having some kind of idle timer and if idle for x minutes disconnect the session?

 

EDIT:

Reading up on it i guess x11vnc is installed inside the container, running command x11vnc -R xkb may resolve temporary copy paste issues, question is how you could make the container continously run this everytime a user disconnects from the vnc session clearing out any copy paste that is being held in memory that may result in issues when a new client connects?

Copy and past works for me after 1 or 2 minutes after i fire up the noVNC gui.

But i will look into this.

Also i'm not using the unraidVNC its separated.

The timout should also be no problem.

 

I take a look into this all, but it will take some time since all my containers are getting new baseimages and i clean them a little bit up.

Link to post
4 hours ago, ich777 said:

Copy and past works for me after 1 or 2 minutes after i fire up the noVNC gui.

But i will look into this.

Also i'm not using the unraidVNC its separated.

The timout should also be no problem.

 

I take a look into this all, but it will take some time since all my containers are getting new baseimages and i clean them a little bit up.

Yeah, i have not been able to re-create the issue with ease. it does happen after awhile when you randomly use various vnc sessions against various targets from many machines. I use VNC a lot to give support and i guess i am stressing the protocol a little extra. I probably have had copy paste issues in other docker containers but this one is the only container that copy paste from outside the container matters.

 

Copy paste from inside the container to inside same container always works, its just the transfer of copy paste from client connected to the server that does not always work. No stress, next time it happens i will run some commands on the shell of the jdownloader sessions to see if these things fix it.

 

EDIT: Oh, i must ask, other docker containers i've used i can install multiple ones, but this jdownloader docker seems to be limited to just one? I would want to install a second one, why is it not possible? What i can do to fix that?

Edited by je82
Link to post
52 minutes ago, je82 said:

Yeah, i have not been able to re-create the issue with ease. it does happen after awhile when you randomly use various vnc sessions against various targets from many machines. I use VNC a lot to give support and i guess i am stressing the protocol a little extra. I probably have had copy paste issues in other docker containers but this one is the only container that copy paste from outside the container matters.

 

Copy paste from inside the container to inside same container always works, its just the transfer of copy paste from client connected to the server that does not always work. No stress, next time it happens i will run some commands on the shell of the jdownloader sessions to see if these things fix it.

A quick fix is to start up the container go to file -> analize text (or something like this) put in something in the textbox, highlight it and select copy now your copy past should work (in my case this works just fine).

 

54 minutes ago, je82 said:

EDIT: Oh, i must ask, other docker containers i've used i can install multiple ones, but this jdownloader docker seems to be limited to just one? I would want to install a second one, why is it not possible? What i can do to fix that?

Don't understand the question, what's the error or what does not work, you can always install multiple instances (Please note that the ports must be different, the name of the container itself and also i recommend you to create another directory in the appdata folder).

If you can't download it again from the CA App then the answer is simple, you have to change the name of the installed container or a workaround is to go onto your Docker page in unRAID, click on Add Container select your jDownloader2 (change the name to 2ndjDownloader2 or whatever, change the portnumber, and make another directory in the appdata) done. ;)

Link to post
12 minutes ago, ich777 said:

Don't understand the question, what's the error or what does not work, you can always install multiple instances (Please note that the ports must be different, the name of the container itself and also i recommend you to create another directory in the appdata folder).

Ah, so the name of the docker has to be different? I renamed the container from the original name of "jDownloader2" to jDownloaderX" just to test and i still cannot install another instance of this docker.

 

As you can see the docker tab tells me "edit" is the only available option to me, no install.

What could be blocking me more than the name?

 

Does the data dirr

 image.png.9d04f98f68cf3c66f062be9492538460.png

 

Edit: Also renamed the Appdata path to "jDownloaderX" from jDownloader2 and the issue presists. Since i am using network type: bond0 and a unique ip for each docker, does the port really matter? I have the same port for multiple other "same dockers" with different ip no problem.

Edited by je82
Link to post
2 minutes ago, je82 said:

Ah, so the name of the docker has to be different? I renamed the container from the original name of "jDownloader2" to jDownloaderX" just to test and i still cannot install another instance of this docker.

 

As you can see the docker tab tells me "edit" is the only available option to me, no install.

What could be blocking me more than the name?

No you've got me wrong go to your docker page and click on:

grafik.png.9d06a0f2b39e2dacae10dd416833120d.png

 

Then select your existing jDownloader install (green arrow) and change the other settings (red arrows) and click on apply:

grafik.thumb.png.45fde912c12a268a2041d0d5b3021f73.png

 

Now you've got two different running instances of jDownloader2:

grafik.png.9106030fc7e0c34d2ac180d0cfaa0ed1.png

Link to post
2 minutes ago, ich777 said:

No you've got me wrong go to your docker page and click on:

grafik.png.9d06a0f2b39e2dacae10dd416833120d.png

 

Then select your existing jDownloader install (green arrow) and change the other settings (red arrows) and click on apply:

grafik.thumb.png.45fde912c12a268a2041d0d5b3021f73.png

 

Now you've got two different running instances of jDownloader2:

grafik.png.9106030fc7e0c34d2ac180d0cfaa0ed1.png

ah i get it, ok, weird... other containers have been able to be installed multiple via the CA no problem, thanks for the heads up.

Edited by je82
Link to post
Just now, je82 said:

ah i get it, ok, weird... other containers have been able to be installed via the CA no problem, thanks for the heads up.

Yes but you've installed it initially with the name that it has in the CA App and that's why, if you rename it in the first place you can always redownloaded it from the CA Apps.

You have to delete the my-jDownloader2.xml from your templates-user directory than it works again ;)

Link to post
11 minutes ago, ich777 said:

Yes but you've installed it initially with the name that it has in the CA App and that's why, if you rename it in the first place you can always redownloaded it from the CA Apps.

You have to delete the my-jDownloader2.xml from your templates-user directory than it works again ;)

ah yes, you are right, the other containers i have renamed from the beginning. thanks for the heads up! :) it works fine now.

Link to post
1 hour ago, je82 said:

ah yes, you are right, the other containers i have renamed from the beginning. thanks for the heads up! :) it works fine now.

Container switched now to debian, also you can now connect with multiple computers to the container. ;)

The copy and paste issue is on my todo list... ;)

Click the "Search for Updates" button on the Docker page in unRAID and update the container.

Link to post
22 hours ago, ich777 said:

Container switched now to debian, also you can now connect with multiple computers to the container. ;)

The copy and paste issue is on my todo list... ;)

Click the "Search for Updates" button on the Docker page in unRAID and update the container.

Nice!! Trying out the new containers tonight, thank you for the update!

Link to post

Found another "issue" with the jdownloader container, when downloading videos from sources such as youtube, ffmpeg is required to merge the sound and video together, is it possible to make ffmpeg library a part of the jdownloader container to give it this capability?

Link to post
2 hours ago, je82 said:

Found another "issue" with the jdownloader container, when downloading videos from sources such as youtube, ffmpeg is required to merge the sound and video together, is it possible to make ffmpeg library a part of the jdownloader container to give it this capability?

Oh really? Never heard of that, can you provide me a link where this happens (write me a pm please) and i will look into it.

Link to post
1 hour ago, je82 said:

Any youtube video with sound, example: https://www.youtube.com/watch?v=1H-HOPiai5Y

Trying to download with  jdownloader in container:

image.png.373c7cc11f4c5f3e80c01ec1cc4aeb7a.png

No problem here (just click on download and then a window comes up press the 'Enter' key and it will download the missing files, after a restart of jDownloader2 you are good to go ;) ).

 

grafik.thumb.png.083f4d2a51f8dde4f98c8fe636e73baf.png

Edited by ich777
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.