[Support] SpaceinvaderOne Deconz


51 posts in this topic Last Reply

Recommended Posts

This container needs a ConbeeII usb zigbee stick to work

 

This container is for the deCONZ software from Dresden Elektronik. It is used to control a conbee zigbee usb stick and can be used with home assistant.

Setup.

1.  Without conbee usb stick plugged into the server run the following command in a terminal window

ls /dev/

 

2.  Plug your conbee usb stick into the unraid server. Then run the above again. You will now see an extra device here. This is your  conbee zigbee stick.

Most likely ttyACM0    (unless you have maybe a zwave stick plugged in aswell then it might not be)

 

528113760_ScreenShot2020-05-27at17_37_22.png.f827baf0b01c93c8700f75dc172b7e3e.png

 

 

3. Now add the name of the stick to the template. (default is already ttyACM0)

    Add it to both usb conbee:  and usb device name:  

1964835855_ScreenShot2020-05-27at17_42_04.thumb.png.6a82687fd359f242d29fc058da56f6ad.png

 

4. I think it best to set a static ip for the container. You can then access the container from  http://xxx.xxx.xxx.xxx   (the ip you set)

 

5. Now you can add your zigbee devices in the webui and connect deconz to home assistant for it to be able to access you zigbee devices.

 

 

  • Like 2
  • Thanks 3
Link to post
  • Replies 50
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

This container needs a ConbeeII usb zigbee stick to work   This container is for the deCONZ software from Dresden Elektronik. It is used to control a conbee zigbee usb stick and can be used

There will be a video series (soon) for setting up Home assistant in docker (rather than hassio vm)  along with deconz, mosquitto etc

I updated mine to the latest stable version by using this template for the official docker repo: 'marthoc/deconz': I would suggest taking a backup first, but mine updated without any issues

Posted Images

17 hours ago, SpaceInvaderOne said:

There will be a video series (soon) for setting up Home assistant in docker (rather than hassio vm)  along with deconz, mosquitto etc

Awsome, love your videos! 

 

Why not use ZHA and passthrough the conbee to Home Assistant Core docker though?

Link to post
On 5/27/2020 at 7:07 PM, SpaceInvaderOne said:

This container needs a ConbeeII usb zigbee stick to work

 

This container is for the deCONZ software from Dresden Elektronik. It is used to control a conbee zigbee usb stick and can be used with home assistant.

Setup.

1.  Without conbee usb stick plugged into the server run the following command in a terminal window


ls /dev/

 

2.  Plug your conbee usb stick into the unraid server. Then run the above again. You will now see an extra device here. This is your  conbee zigbee stick.

Most likely ttyACM0    (unless you have maybe a zwave stick plugged in aswell then it might not be)

 

528113760_ScreenShot2020-05-27at17_37_22.png.f827baf0b01c93c8700f75dc172b7e3e.png

 

 

3. Now add the name of the stick to the template. (default is already ttyACM0)

    Add it to both usb conbee:  and usb device name:  

1964835855_ScreenShot2020-05-27at17_42_04.thumb.png.6a82687fd359f242d29fc058da56f6ad.png

 

4. I think it best to set a static ip for the container. You can then access the container from  http://xxx.xxx.xxx.xxx   (the ip you set)

 

5. Now you can add your zigbee devices in the webui and connect deconz to home assistant for it to be able to access you zigbee devices.

 

 

Hi I want to test this container but in my template there are not "usb conbee" and "usb device name".

 

Are those variables?

Link to post

Well - my entire Unraid journey thus far has been to wait for a SpaceInvaderOne video, copy what he did, be happy with the results because it always worked first time.   I wish I knew this video series was on the way otherwise I wouldn't have spent 3 hours last night trying to get deconz working!! 

 

I'm so excited to see this series! During the lockdown home automation has been my number 1 thing to keep me sane, I've tried a CC2531 Zigbee stick, bought loads of Xiaomi sensors and just put a new Sonoff BasicR3 one in to the network. 

 

@SpaceInvaderOne, I saw your docker and tried it - it worked well until I tried to get it linked with HA, but then it wasn't able to get an API key.  I ended up using the one out of the docker hub with this post to fix my integration issues with the home assistant core docker.  I needed to set loads of environment variables and also the "dialout" usermod setting to get it working properly.  I don't know if it's worth you adding those into your docker image too?

 

I used the command ls -l /dev/serial/by-id to find out what my conbee2 was using. 
lrwxrwxrwx 1 root root 13 May 30 02:40 usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2195326-if00 -> ../../ttyACM0

 

This is what I ended up with in my docker settings (obviously I had to remap the port from the usual port 80 to some other random port). 

 

image.thumb.png.2dbca80b9361f37c91e7edaf427ff322.png

Link to post

Just like @tomwhi The use of variables are needed like VNC stuff 

 

Link to https://github.com/marthoc/docker-deconz for variables

DECONZ_VNC_MODE=1	Set this option to enable VNC access to the container to view the deCONZ ZigBee mesh
DECONZ_VNC_PORT=5900	Default port for VNC mode is 5900; this option can be used to change this port
DECONZ_VNC_PASSWORD=changeme	Default password for VNC mode is 'changeme'; this option can (should) be used to change the default password
DECONZ_UPNP=1	Set this option to 0 to disable uPNP, see: https://github.com/dresden-elektronik/deconz-rest-plugin/issues/274

The UPNP maybe necessary for gwid to work also But so far so good!

hope it helps

 

Link to post

@tomwhi   @jazzyjeff yeah I should have added more variables for sure. Extra variables have been added to the template now.

All can be left as default settings and should work. Personally I think using a custom ip is better than running as host (just so you dont have to change the web port and can access the container just by ip in a browser.) but if you run as host network then you will need to change the listing port.

VNC now enabled by default to view Zigbee mesh. Add vnc password if you wish.

To see debug and upnp options these are hidden by default so click show more settings at the bottom of the template.

Link to post

Hi, just that this infomation is also in this Thread.

There is currently an issue with the latest version (.77). The deconz Team is debugging with the comunity right now.

Everyone affected should run version .75 since this version was running just fine.

 

Issue: Mesh doesn't build and some devices get dropped. (out of 50 nodes only 10 were connecting in my place)

 

To have a constructive thing for this thread. maybe provide an additional parameter which determines the version. is that a thing?

 

edit: the docker for HomeAssistant has recently rolled back to version .75

edit2: provided github links as source

Edited by Aluavin
Link to post

Hi there! And thank you for creating this Docker container or making it compatible with Unraid! :)

 

I am having a problem getting the API key from Home Assistant. I followed your advice @SpaceInvaderOne on assigning the DeConz container a static IP address, and now DeConz is automagically detected by Home Assistant when adding the corresponding integration, but then at the next step when I go to the advanced settings of DeConz to unlock the Gateway for 60 seconds, and go back to Home Assistant to press "Submit", Home Assistant can't get the API key.

Is there a tweak to make to some settings to get this to work?

 

Edit : got it to work. The problem I was having was the two Docker containers were set to use two different networks. By settign both to br0 and assigning each one a static local IP of my choice, everything worked just fine. I think it's weird that Home Assistant was detecting the Conbee2 gateway but couldn't "speak" with it because of the different network settings. I am quite a beginner regarding networking in Unraid so it may very well seem obvious for some other folks.

Anyway, I hope this helps someone eventually.

Edited by CiaoCiao
Link to post

Working great for me. Thanks!!!

Connected to Home Assistant Core. The VNC interface is not user friendly enough for me.

I see, above, that some people are running the hassio Core Docker like I am. Would we get any benefit from running an hassio VM, instead? Easier editing of YAML files is not motivation enough for me. What would make it worth switching?

Anybody connecting to anything else?

Link to post

What's the best way of connecting Deconz to Home Assistant? I've got Home Assistant setup on a custom network and accessible via a sub domain. How would I set it up so I can view the WebUI of Deconz but also have it on the same custom network as Home Assistant so it can get the API key?

 

Edit:

 

The easiest way I found to do this..

 

Install a VNC Web Browser on the same network. Then you can open the web browser and easily browse to the Deconz Web UI via VNC which Home Assistant can also see it on the same network.

Edited by Nelinski
Link to post
  • 1 month later...

Ive tried this several times and it seems to work but wehn i got to the Phoscon page via the ip and look at the gateway it shows not connected. Ive updated the firmward via windows, running ls -l /dev/serial/by-id returns:

 

lrwxrwxrwx 1 root root 13 Jul 27 11:06 usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2198782-if00 -> ../../ttyACM1

 

So ive set usb conbee and usb device name as /dev/ttyACM1, the docker loads but doesnt appear to see the device.

 

Does anyone know how i would resolve this?

Link to post
  • 1 month later...
On 5/27/2020 at 7:11 PM, SpaceInvaderOne said:

There will be a video series (soon) for setting up Home assistant in docker (rather than hassio vm)  along with deconz, mosquitto etc

Hey @SpaceInvaderOne

 

first of all thanks for your amazing tutorials and all the work you put in there!

Is the video series for home assistant still on your roadmap? I've been using a hassio vm for quite some time, but as I'm setting things up from the ground in our new home i would prefer to switch to using docker containers and haven't really found a way to do so. I've tried with two seperate containers HA and the supervisor, but that wasn't really a stable solution. 

 

 

Link to post
  • 2 weeks later...

Hi @SpaceInvaderOne,

 

I'd also like to say thanks for all of your video tutorials on YouTube. In the first few months of lockdown I jumped straight into Unraid and my configuration is 99% based on your teachings - so thank you.

 

As for your deCONZ container, I'm struggling to integrate it with my HA instance and wondered if you or any other forum members can shed some light please?

 

I'm running Home Assistant Container, and have 

discovery:

in my Configuration.yaml, yet restarting HA doesn't automatically find deCONZ.

 

If I navigate in HA to Configuration > Integrations > Add deCONZ > Set the discovered gateway (which is already seen as the IP I set in your container) > then complete the final steps including clicking the 'Authenticate app' button in Phoscon, I get the "Couldn't get an API key". I'm stumped and don't know what to do next.

 

Phoscon works fine as I am able to add a variety of Aqara sensors.

 

Do you, or anyone else reading this, have any suggestions on what I'm missing? I've tried resetting the gateway, changing USB port on my Intel NUC that is running everything, yet nothing.

 

Thanks

Link to post
On 10/6/2020 at 9:15 AM, PindyBlitz said:

Hi @SpaceInvaderOne,

 

I'd also like to say thanks for all of your video tutorials on YouTube. In the first few months of lockdown I jumped straight into Unraid and my configuration is 99% based on your teachings - so thank you.

 

As for your deCONZ container, I'm struggling to integrate it with my HA instance and wondered if you or any other forum members can shed some light please?

 

I'm running Home Assistant Container, and have 


discovery:

in my Configuration.yaml, yet restarting HA doesn't automatically find deCONZ.

 

If I navigate in HA to Configuration > Integrations > Add deCONZ > Set the discovered gateway (which is already seen as the IP I set in your container) > then complete the final steps including clicking the 'Authenticate app' button in Phoscon, I get the "Couldn't get an API key". I'm stumped and don't know what to do next.

 

Phoscon works fine as I am able to add a variety of Aqara sensors.

 

Do you, or anyone else reading this, have any suggestions on what I'm missing? I've tried resetting the gateway, changing USB port on my Intel NUC that is running everything, yet nothing.

 

Thanks

There is a bug in the configuration flow initiated from the frontend, work around is to create an entry in configuration.yaml

deconz:
  host: x
  port: y

and then finish the flow from the frontend

Link to post

@SpaceInvaderOne ,I can see that there is a newer release of deconz available on their download page.

Is your plan to update the container when there are new releases or do you have any alternative jedi mindtricks how an eager unraid padawan can get the latest updates when they are available?

marthoc seems to have both a latest and stable branch, so be able to tag stable or latest in unraid would be another nice additional feature.

Thanks for your incredible work

 

 

Edited by joggs
Link to post
On 10/10/2020 at 4:08 PM, joggs said:

There is a bug in the configuration flow initiated from the frontend, work around is to create an entry in configuration.yaml


deconz:
  host: x
  port: y

and then finish the flow from the frontend

Thanks Joggs, however after trying this I still get the same API key error.

 

Any other ideas?

Link to post
On 10/11/2020 at 2:19 AM, joggs said:

@SpaceInvaderOne ,I can see that there is a newer release of deconz available on their download page.

Is your plan to update the container when there are new releases or do you have any alternative jedi mindtricks how an eager unraid padawan can get the latest updates when they are available?

marthoc seems to have both a latest and stable branch, so be able to tag stable or latest in unraid would be another nice additional feature.

Thanks for your incredible work

 

 

Also very interesting in ongoing update methods for this :) otherwise love the container

Link to post

So, I just started rebuilding my home automations after moving and have decided to try the docker route instead of the VM I used to run hass.io in.

The Installation went fine and I can access the web UI. I was even able to pair phoscon and home assistant. But I get a strange behavior in the phoscon web UI. Under settings > gateway I get no product id and under firmware I get not connected. Any ideas what went wrong?

Gesendet von meinem ONEPLUS A6013 mit Tapatalk

Link to post
  • 3 weeks later...
On 5/27/2020 at 7:07 PM, SpaceInvaderOne said:

This container needs a ConbeeII usb zigbee stick to work

 

This container is for the deCONZ software from Dresden Elektronik. It is used to control a conbee zigbee usb stick and can be used with home assistant.

Setup.

1.  Without conbee usb stick plugged into the server run the following command in a terminal window


ls /dev/

 

2.  Plug your conbee usb stick into the unraid server. Then run the above again. You will now see an extra device here. This is your  conbee zigbee stick.

Most likely ttyACM0    (unless you have maybe a zwave stick plugged in aswell then it might not be)

 

528113760_ScreenShot2020-05-27at17_37_22.png.f827baf0b01c93c8700f75dc172b7e3e.png

 

 

3. Now add the name of the stick to the template. (default is already ttyACM0)

    Add it to both usb conbee:  and usb device name:  

1964835855_ScreenShot2020-05-27at17_42_04.thumb.png.6a82687fd359f242d29fc058da56f6ad.png

 

4. I think it best to set a static ip for the container. You can then access the container from  http://xxx.xxx.xxx.xxx   (the ip you set)

 

5. Now you can add your zigbee devices in the webui and connect deconz to home assistant for it to be able to access you zigbee devices.

 

 

@SpaceInvaderOne will you keep maintaining this?

Please do.

Thank you

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.