[Support] SpaceinvaderOne Deconz


Recommended Posts

On 5/27/2020 at 6:11 PM, SpaceInvaderOne said:

There will be a video series (soon) for setting up Home assistant in docker (rather than hassio vm)  along with deconz, mosquitto etc

 

I am pretty desperate for this video SIO! :-)  Please can you let us know when you think it will be due out?

Link to comment
  • 2 months later...
  • 4 weeks later...

OH MY GOSH - I've just worked out why my Home Assistant couldn't talk to my Phoscon/Deconz app....   They weren't on the same docker network... DOH!! 

 

My HA was on "host" because there was too many ports to map across, and my Phoscon was on br0 (also as shown in SIO's instructions but made the most sense because it needs it's own IP for things to find it on tcp/80 and tcp/443. 

 

I found out by going into the console of the HA container and trying to ping my Phoscon IP - it failed!  So the "Api key couldn't not be whatever" is utter bullsh!t from an error message. 

 

I also realised it couldn't talk to Pi-hole (which I was less worried about, but equally as annoyed with not working) - and for anyone else who lives and breaths the SIO videos - it's also on br0!! 

 

So once my HA was moved onto the br0 network everything worked - well - not everything, now it can't talk to the host, so I can't get Sonnar or Raddar data into my HA setup but that really is the lowest of the low priorities and now I've worked this out I'll try and work out how to get it talking to both br0 and host networks.  

Link to comment
  • 3 weeks later...

If someone still has issues getting this to work I was able to solve it by using bits and pieces of this thread.

 

1. Make sure both dockers are in the same mode. Either as Host (remember to change port from port 80) or as custom br0.
This is the most common reason they can't communicate

 

2.There's a newer version of the docker in a different repo. See this post

On 12/11/2020 at 10:37 AM, Propaganda said:

I updated mine to the latest stable version by using this template for the official docker repo: 'marthoc/deconz':

image.thumb.png.36b9da86d552933169684f6dcc55e4c8.png

I would suggest taking a backup first, but mine updated without any issues.

 

3. This is how you flash the firmware. During the flashing process. Double check the latest version that's displayed. Also look for ConBeeII in the file name. My first time I took the wrong file and it failed

On 2/17/2021 at 11:59 AM, h0schi said:

 

Thank you - thats what i searched :)

 

If you need to also update the firmware of the conbee2-stick.

Execute following commands in Unraid-terminal:

 

1) docker stop deconz

2) docker run -it --rm --entrypoint "/firmware-update.sh" --privileged --cap-add=ALL -v /dev:/dev -v /lib/modules:/lib/modules -v /sys:/sys marthoc/deconz

3) Device Path: /dev/ttyACM0 

4) File Name: deCONZ_ConBeeII_0x26660700.bin.GCF

5) Press "Y"

6) Wait about 30 seconds

7) docker start deconz

 

 

Happy Zigbeeing

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.