showstopper

Members
  • Posts

    120
  • Joined

  • Last visited

Everything posted by showstopper

  1. I've had letsencrypt/swag working for a number of years but it is now failing to renew the certificates. I have uninstalled and tried again but i get the same error. I am using proxynet and my domains are all duckdns, no cloudflare. Can anyone point me in the right direction please? Generating new certificate Requesting a certificate for ***.duckdns.org and 3 more domains Certbot failed to authenticate some domains (authenticator: standalone). The Certificate Authority reported these problems: Domain: ***.duckdns.org Type: connection Detail: Fetching http://***.duckdns.org/.well-known/acme-challenge/GX1N0HDQV9cetf0bUvB7E_68fh5OCaDdf168NYwJzpI: Timeout during connect (likely firewall problem) Hint: The Certificate Authority couldn't exterally verify that the standalone plugin completed the required http-01 challenges. Ensure the plugin is configured correctly and that the changes it makes are accessible from the internet. Saving debug log to /var/log/letsencrypt/letsencrypt.log Some challenges have failed. Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details. ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fix your settings and recreate the container EDIT - So i bounced my server and it now all works?! Anyway glad it's now working.
  2. Sure - here: # only office doc server server { listen 443 ssl; listen [::]:443 ssl; server_name external_dns_subdomain.*; include /config/nginx/ssl.conf; client_max_body_size 0; location / { include /config/nginx/proxy.conf; resolver 127.0.0.11 valid=30s; set $upstream_app OnlyOfficeDocumentServer; set $upstream_port 443; set $upstream_proto https; proxy_pass $upstream_proto://$upstream_app:$upstream_port; proxy_max_temp_file_size 2048m; } }
  3. In all honesty I don't know what eventually made it work. I deleted the folder from appdata, and then reinstalled it. It then suddenly started working again.
  4. I initially thought it was $upstream_docs and $upstream_app that was the issue. After lots of tinkering yesterday it now all works.
  5. I have just started to look into onlyoffice integration into my nextcloud setup (21.0.0) as well. I was/am following the same guide. I have found that the proxy config file seems to be wrong. This is what is provided: # only office doc server server { listen 443 ssl; server_name external server name.*; include /config/nginx/ssl.conf; client_max_body_size 0; location / { include /config/nginx/proxy.conf; resolver 127.0.0.11 valid=30s; set $upstream_docs OnlyOfficeDocumentServer; proxy_pass https://$upstream_docs:443; proxy_redirect off; proxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Host $server_name; proxy_set_header X-Forwarded-Proto $scheme; } } I would then have the same error 400 page, when trying to connect to the external URL. I found if i changed this file to: # only office doc server server { listen 443 ssl; listen [::]:443 ssl; server_name external server name.*; include /config/nginx/ssl.conf; client_max_body_size 0; location / { include /config/nginx/proxy.conf; resolver 127.0.0.11 valid=30s; set $upstream_app OnlyOfficeDocumentServer; set $upstream_port 443; set $upstream_proto https; proxy_pass $upstream_proto://$upstream_app:$upstream_port; proxy_max_temp_file_size 2048m; } } I can then navigate (only using the external URL) to this page: (I tried just changing $upstream_docs to $upstream_app but it still failed). If i try and navigate to the local address i cannot connect. When i try to connect to onlyoffice in nextcloud i get the following: I'm gonna keep trying but looks like a few people have the same issue.
  6. I guess you guys didn't get this working? I have just started to look into integrating openoffice into my nextcloud (21.0.0) and I am getting the same error. Any advice?
  7. I setup my letsencrypt ages ago and it is in 'bridge' mode so i cannot change bitwarden to proxy mode. I think i will need to recreate my lets encrypt as external browsing to my bitwarden duckdns domain navigates to the default 'Welcome to our server' nginx splashpage. EDIT - right i think i have broken it now! I now get this screen for nextcloud and bitwarden: I have reconfigured my swag (letsencrypt) so that it now uses a proxy network. I have no errors in the logs for swag, nextcloud and bitwarden and the external urls all get the above screen but with their correct URL. So i think i must have my default apache or nginx configured incorrectly. Does anyone know how to factory reset this? EDIT2 - OK ignore me it seems it is caching the URL (even though i am doing a CTRL+F5), and if i try in another browser it now works as intended. EDIT3 - Does anyone know how to disable the email alerts for when someone logs into the vault?
  8. Has something changed in the last update? My local backups run to a Network NAS (it is very old granted) which can no longer be accessed in duplicati. unRAID can see the NAS and it is mounted and can be accessed: It is configured and the docker has not been edited since i created it (a few years ago): However the destination is not accessible any more in duplicati: Any ideas guys? EDIT - Figured it out. It seems the mounted share is now in /remotes and not /disks. I changed the docker setting and it's now working again.
  9. I think radarr would work for me but it doesnt look like i can set it up to views files and not files in individual folders
  10. Hi guys, I am just wondering what you guys use for metadata file renaming for movies. For TV i use Sonar and that seems to remove the metadata 'Title' I would like a similar renamer for movies. I was using an old version of filebot that renames the file, but does not do the metadata 'Title' tag. I know that this is a paid product now. I had a quick look at radarr but that seems to need a named folder and also i have my movies slightly differently for example /Movies/Star Wars - Collection/moviename.mkv. So radarr doesnt seem to work for me. Just wondered what people use? I don't need a download/sorter just a renamer.
  11. Page 1 says no licence is required for this app, but after installing, it looks like a licence is required. Is that right?
  12. Hi all, I updated to 19.0.0 today and i have a warning saying: This instance is missing some recommended PHP modules. For improved performance and better compatibility it is highly recommended to install them. bcmath Does anyone have any ideas how i can do this please? I always get the 'MySQL is used as database but does not support 4-byte characters.' warning when i upgrade, but i have resolved this.
  13. Morning all - firstly i hope you are all well in these crazy times! I have a strange issue with my unraid server today. My docker & apps tab's in the webgui do not seem to show anything other than the 'orange loading wave'. All my docker apps are not accessible but my VM's are. All my disks seem healthy and i don't think my docker.img is full. I read about deleting this and recreating it but i don't think that i can do this in the gui - and i am not 100% sure this is my issue anyway. I have tried firefox and chrome just to try and rule out a browser issue. I have attached the diagnostics below. If anyone can help it would be greatly appreciated! Thanks all. diagnostics-20200330-1003.zip EDIT 01 - Hmmmm i am having quite a few issues. I think the docker.img may have outgrown the given size but i cannot stop the docker service at all. I have tried the command prompt: /etc/rc.d/rc.docker stop but it doesn't seem to do anything. If i run the status command it says that it is running and that letsencrypt is running. EDIT 02 - OK so i took a gamble and managed to rename my docker.img to docker.old and then bounced the server. It is now loading apps and docker. So i am recreating my dockers now. Strange that it pretty much crashed the system.
  14. Hi guys, I changed my version quite a while ago as Jackett was not connecting to IPTorrents for me. It is now asking me to update but i cant remember what i need to change in the Repository field - is it just latest? EDIT - Fixed it. Just change it to 'binhex/arch-jackett'
  15. @karlpox did you ever resolve this issue. I have the same issue where the docker doesn't seem to automatically start-up but will manually start-up. I have the same 'Misconfigured DNS' error. I have looked back through the thread and people are saying to delete and reinstall the docker, i have also changed the docker hub URL but on restart i still get the error. Looking at the github 127.0.0.11 is required for containers to talk to each other. So i am not sure how to resolve this.
  16. This is a hotfix released that 'should' fix the issue for the buffering on Samsung TV's. Any chance this docker could be updated please?
  17. Hi guys, I am following CHBMB's guide on performing the update. When i am performing the upgrade i am getting this error: root@28bf2224e09f:/# sudo -u abc php7 /config/www/nextcloud/occ upgrade Nextcloud or one of the apps require upgrade - only a limited number of commands are available You may use your browser or the occ upgrade command to do the upgrade Set log level to debug Turned on maintenance mode Updating database schema Updated database Updating <dav> ... InvalidArgumentException: Migration step 'OCA\DAV\Migration\Version1006Date20180628111625' is unknown Update failed Maintenance mode is kept active Reset log level root@28bf2224e09f:/# Does anyone have any idea how i correct this please? ****************EDIT*********************** OK - i have managed to get around this error now and it has upgraded but i am not sure if i have broken it as when i try and log in i get: Internal Server Error The server was unable to complete your request. If this happens again, please send the technical details below to the server administrator. More details can be found in the server log. Technical details Remote Address: 172.17.0.1 Request ID: kr8onV5827RpHybQYzV3 Now the remote address in the error is 172.17.0.1 but my mapping is 172.17.0.7 - could this be the issue, and how would i fix this? ************EDIT 2***************** Now resolved and working. Ignore the error and continue the incremental upgrades to latest version.
  18. Hi all, Sorry for the long title! For the last week or so i have been having a strange issue with my unraid server (6.6.7 Stable). I notice that all of my dockers stop on a daily basis. I can manually start them, but then they say update available. However the updates download 0kb. Also i have noticed that if i reboot then i cannot always connect to the web interface, the shared drives are unavailable and i cannot SSH to the server. It is on and running as i can use IPMI to get onto the logon prompt screen. I normally have to reboot 2 or 3 times and then it starts working again. I read that it could be a DNS issue (for the dockers) so i changed unraid network settings to use google DNS, but i still have the issue. I have a diagnostic zip file which has a lot of files and folders in. I can upload this, or if someone has any ideas on what i can try then i would be grateful! Thanks.
  19. Uninstall and re-install hasnt fixed for me either. Happy to submit logs if i can get some instructions. EDIT- Can confirm that it works in Chrome but not in FireFox. 
  20. I should read first!! Thanks for your help.
  21. Thanks for this. To re-install do i need to add the package to the server?
  22. I am having the same 'Updating Content' page - how do you uninstall as i cannot select anything on the /apps page.
  23. Thanks for this. Is there a way that i can install an older docker version to get it working again do you know?
  24. Is this now working? I use PIA SOCKS5 and Jackett connects once and then fails immediately after - 'Request to Jacket server failed' Log - 03-26 08:26:02 Error System.Net.Http.HttpRequestException: Connection refused ---> System.Net.Sockets.SocketException: Connection refused System.Net.Http.HttpRequestException: Connection refused ---> System.Net.Sockets.SocketException: Connection refused at System.Net.Http.ConnectHelper.ConnectAsync(String host, Int32 port, CancellationToken cancellationToken) --- End of inner exception stack trace --- at System.Net.Http.ConnectHelper.ConnectAsync(String host, Int32 port, CancellationToken cancellationToken) at System.Threading.Tasks.ValueTask`1.get_Result() at System.Net.Http.HttpConnectionPool.CreateConnectionAsync(HttpRequestMessage request, CancellationToken cancellationToken) at System.Threading.Tasks.ValueTask`1.get_Result() at System.Net.Http.HttpConnectionPool.WaitForCreatedConnectionAsync(ValueTask`1 creationTask) at System.Threading.Tasks.ValueTask`1.get_Result() at System.Net.Http.HttpConnectionPool.SendWithRetryAsync(HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken) at System.Net.Http.HttpConnectionPool.EstablishProxyTunnel(CancellationToken cancellationToken) at System.Threading.Tasks.ValueTask`1.get_Result() at System.Net.Http.HttpConnectionPool.CreateConnectionAsync(HttpRequestMessage request, CancellationToken cancellationToken) at System.Threading.Tasks.ValueTask`1.get_Result() at System.Net.Http.HttpConnectionPool.WaitForCreatedConnectionAsync(ValueTask`1 creationTask) at System.Threading.Tasks.ValueTask`1.get_Result() at System.Net.Http.HttpConnectionPool.SendWithRetryAsync(HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken) at System.Net.Http.DecompressionHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken) at CloudFlareUtilities.ClearanceHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken) at System.Net.Http.HttpClient.FinishSendAsyncBuffered(Task`1 sendTask, HttpRequestMessage request, CancellationTokenSource cts, Boolean disposeCts) at Jackett.Common.Utils.Clients.HttpWebClientNetCore.Run(WebRequest webRequest) in /home/appveyor/projects/jackett/src/Jackett.Common/Utils/Clients/HttpWebClientNetCore.cs:line 214 at Jackett.Common.Utils.Clients.WebClient.GetString(WebRequest request) in /home/appveyor/projects/jackett/src/Jackett.Common/Utils/Clients/WebClient.cs:line 114 at Jackett.Common.Indexers.BaseWebIndexer.RequestStringWithCookies(String url, String cookieOverride, String referer, Dictionary`2 headers) in /home/appveyor/projects/jackett/src/Jackett.Common/Indexers/BaseIndexer.cs:line 445 at Jackett.Common.Indexers.IPTorrents.GetConfigurationForSetup() in /home/appveyor/projects/jackett/src/Jackett.Common/Indexers/IPTorrents.cs:line 147 at Jackett.Server.Controllers.IndexerApiController.Config() in /home/appveyor/projects/jackett/src/Jackett.Server/Controllers/IndexerApiController.cs:line 79 at Microsoft.AspNetCore.Mvc.Internal.ActionMethodExecutor.TaskOfIActionResultExecutor.Execute(IActionResultTypeMapper mapper, ObjectMethodExecutor executor, Object controller, Object[] arguments) at Microsoft.AspNetCore.Mvc.Internal.ControllerActionInvoker.InvokeActionMethodAsync() at Microsoft.AspNetCore.Mvc.Internal.ControllerActionInvoker.InvokeNextActionFilterAsync() at Microsoft.AspNetCore.Mvc.Internal.ControllerActionInvoker.Rethrow(ActionExecutedContext context) at Microsoft.AspNetCore.Mvc.Internal.ControllerActionInvoker.Next(State& next, Scope& scope, Object& state, Boolean& isCompleted) at Microsoft.AspNetCore.Mvc.Internal.ControllerActionInvoker.InvokeInnerFilterAsync() at Microsoft.AspNetCore.Mvc.Internal.ResourceInvoker.InvokeNextResourceFilter() at Microsoft.AspNetCore.Mvc.Internal.ResourceInvoker.Rethrow(ResourceExecutedContext context) at Microsoft.AspNetCore.Mvc.Internal.ResourceInvoker.Next(State& next, Scope& scope, Object& state, Boolean& isCompleted) at Microsoft.AspNetCore.Mvc.Internal.ResourceInvoker.InvokeFilterPipelineAsync() at Microsoft.AspNetCore.Mvc.Internal.ResourceInvoker.InvokeAsync() at Microsoft.AspNetCore.Builder.RouterMiddleware.Invoke(HttpContext httpContext) at Microsoft.AspNetCore.Authentication.AuthenticationMiddleware.Invoke(HttpContext context) at Microsoft.AspNetCore.StaticFiles.StaticFileMiddleware.Invoke(HttpContext context) at Jackett.Server.Middleware.CustomExceptionHandler.Invoke(HttpContext httpContext) in /home/appveyor/projects/jackett/src/Jackett.Server/Middleware/CustomExceptionHandler.cs:line 29