Roxedus

Community Developer
  • Content Count

    213
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by Roxedus

  1. This was the missing part. We do indeed recommend that.
  2. Looks like its time to close my feature request now.
  3. the admin panel needs another regex to catch failed attempts
  4. And singup is disallowed in the admin panel?
  5. I just use CA backup, then rclone that archive to the cloud.
  6. If you are using swag, use the sample in swag.
  7. I didnt touch anything, if anything changed it had to be technium pushing a update thats not in the changelog, or that one of the few dependencies broke something.
  8. It all boils down to security. For the webpage, it is a limitation set by the browser. And for the apps, Its a decision by bitwarden.
  9. It really should work if you map the port.
  10. They both do the work, and cater to different scenarios. My reasoning for my suggestion is that I dont want to be able to reach /admin at all with my reverse proxy. Another thing to think about is the resulting error code, where my suggestion gives a 404, while the deny gives a 403. A 403 might say to a potential attacker that there is something there (you could have it respond with a 404 instead)
  11. If it is anything like the iOS app, if keeps its own chain of certs
  12. I did consider that way when I did my post, and my conclusion is still that it should not be able be reached outside of the lan. I have the port mapped, so I can reach it outside of the reverse proxy, if that's not the case for you, doing a allow/deny is the next best option, outside of just disabling the admin panel in the container.
  13. This is not a bug. The container has no idea what port you set on the host-side.
  14. sounds like the database is missing, corrupted or set to read-only
  15. Bitwarden_rs runs on port 80 by default, have you changed the app itself to listen to 8086? There is two ways you can tackle this. But which to choose depends on two things, do you use dns validation with swag, and do you have a internal dns server? If the answer to both is yes, you can just set up the local dns to point to swag on your subdomain. If it is no on either of those, you can use allow/deny in nginx to only let the lan subnet connect.
  16. Follow the bitwarden_rs project. As stated in the post, i do not create these applications.
  17. It is not implemented in this version.
  18. You cannot change ports when using the --network argument, it behaves similarly to host. you would have to use port 80.
  19. And just to be sure, other sites on the same domain work?
  20. This just enforces my suspicion of the app using a ip or something
  21. And you are sure your app i set to connect to the subdomain?
  22. Im not sure how advanced that feature is, like if it follows the html tag for favicon, or just assumes it lives on /favicon.ico, i have those errors too sometimes, and i havent seen anything bad from it.