[Support] Organzir Organizr


39 posts in this topic Last Reply

Recommended Posts

Despite the name change, it is for Organizr V2.

Migration should be very easy, just replace the repository field to organizr/organizr. If you used another tag, see the migration note on how the get the same result.

Support thread for the Official container for Organizr V2
 

DockerHub: https://hub.docker.com/r/organizr/organizr/
GitHub: https://github.com/Organizr/docker-organizr
Discord: https://organizr.app/discord

Edited by Roxedus
Link to post
  • 3 weeks later...
1 hour ago, Gruenbaum said:

Error when updaing Organizr on unraid
 


master|develop is not a valid branch, exiting

It does not launch. 
Toggling from "master" to "developer" then back fixes the issue. 

I had the same issue this morning, I actually just removed the container and re-added it and it's working again now.

 

For what it's wroth, very much *not* a fan of the animated gif logo in my docker page either. ;) 

If anyone else is not either, I changed

 

FROM: 

https://raw.githubusercontent.com/Organizr/docker-organizr/master/logo.gif

TO: 

https://raw.githubusercontent.com/causefx/Organizr/v2-master/plugins/images/organizr/logo-no-border.png

 

Edited by CorneliousJD
Link to post
2 hours ago, CorneliousJD said:

I had the same issue this morning, I actually just removed the container and re-added it and it's working again now.

 

For what it's wroth, very much *not* a fan of the animated gif logo in my docker page either. ;) 

If anyone else is not either, I changed

 

FROM: 


https://raw.githubusercontent.com/Organizr/docker-organizr/master/logo.gif

TO: 


https://raw.githubusercontent.com/causefx/Organizr/v2-master/plugins/images/organizr/logo-no-border.png

 

Just came here to see why the update broke the container and what the deal was with the spinning logo. Also not a fan of the animated logo.

 

Thanks for the quick fix.

Link to post
  • 3 weeks later...

Just installed this and the web link takes me to my unraid homepage. Anyone else getting this on a fresh install?

 

[Updated] I changed the port from blank to 8081 and it's working now. Thanks for the docker!

image.thumb.png.89313f8b773a1299c28ac3883b02c2df.png

Edited by MrLinux
Link to post
2 minutes ago, Squid said:

Did you remove from the template the port mapping for 80?

Yes. I changed it from blank (default) to 8081 (unused port) to get it working. By default it's blank which then points back to unraid.

Edited by MrLinux
clarification and indicating it's working now after my change.
Link to post
  • 1 month later...
34 minutes ago, Roxedus said:

Thanks, but I'm not sure what to do to get access to my sites.  This is what I currently have for radarr and the others are similar.  Can you tell me what to change please:

 

location ^~ /radarr {
	auth_request /auth-0;
    # enable the next two lines for http auth
    #auth_basic "Restricted";
    #auth_basic_user_file /config/nginx/.htpasswd;

    # enable the next two lines for ldap auth, also customize and enable ldap.conf in the default conf
    #auth_request /auth;
    #error_page 401 =200 /login;

    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
#    set $upstream_radarr radarr;
    proxy_pass http://192.168.50.93:7878;
}

location ^~ /radarr/api {
	auth_request /auth-0;
    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
#    set $upstream_radarr radarr;
    proxy_pass http://192.168.50.93:7878;
}

 

Link to post
6 minutes ago, Roxedus said:

You need to update the organizr-auth file in swag

 

Thanks for replying so quickly.  I tried editing line 35 based on the link, but it's still not working for me:

 

# make sure that your dns has a cname set for organizr

server {
    listen 443 ssl;
    listen [::]:443 ssl;

    server_name www.*;

    include /config/nginx/ssl.conf;

    client_max_body_size 0;

    # enable for ldap auth, fill in ldap details in ldap.conf
    #include /config/nginx/ldap.conf;

    location / {
        # enable the next two lines for http auth
        #auth_basic "Restricted";
        #auth_basic_user_file /config/nginx/.htpasswd;

        # enable the next two lines for ldap auth
        #auth_request /auth;
        #error_page 401 =200 /login;

        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
        proxy_pass http://192.168.50.17:80;
    }

    location ~ /auth-([0-9]+) {
        # This is used for Organizr V2
        internal;
        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
#        proxy_pass http://192.168.50.17:80/api/?v1/auth&group=$1;
        proxy_pass http://192.168.50.17:80/api/v2/auth?group=$1;
        proxy_set_header Content-Length "";
    }
}

 

Link to post
1 hour ago, Roxedus said:

And you restarted SWAG, and still got that 500 error? Paste nginx logs

 

Swag logs:

 

Brought to you by linuxserver.io
-------------------------------------

To support the app dev(s) visit:
Certbot: https://supporters.eff.org/donate/support-work-on-certbot

To support LSIO projects visit:
https://www.linuxserver.io/donate/
-------------------------------------
GID/UID
-------------------------------------

User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 20-config: executing...
[cont-init.d] 20-config: exited 0.
[cont-init.d] 30-keygen: executing...
using keys found in /config/keys
[cont-init.d] 30-keygen: exited 0.
[cont-init.d] 50-config: executing...
Variables set:
PUID=99
PGID=100
TZ=Europe/London
URL=mydomain.com
SUBDOMAINS=onlyoffice,ha,nextcloud,www,qbittorrent,unraid,help,synclounge
EXTRA_DOMAINS=
ONLY_SUBDOMAINS=false
VALIDATION=http
DNSPLUGIN=
EMAIL=me@email.com
STAGING=false

SUBDOMAINS entered, processing
SUBDOMAINS entered, processing
Sub-domains processed are: -d onlyoffice.mydomain.com -d ha.mydomain.com -d nextcloud.mydomain.com -d www.mydomain.com -d qbittorrent.mydomain.com -d unraid.mydomain.com -d help.mydomain.com -d synclounge.mydomain.com
E-mail address entered: me@email.com
http validation is selected
Certificate exists; parameters unchanged; starting nginx
[cont-init.d] 50-config: exited 0.
[cont-init.d] 60-renew: executing...
The cert does not expire within the next day. Letting the cron script handle the renewal attempts overnight (2:08am).
[cont-init.d] 60-renew: exited 0.
[cont-init.d] 99-custom-files: executing...
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-files: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
Server ready
nginx: [alert] detected a LuaJIT version which is not OpenResty's; many optimizations will be disabled and performance will be compromised (see https://github.com/openresty/luajit2 for OpenResty's LuaJIT or, even better, consider using the OpenResty releases from https://openresty.org/en/download.html)

The nginx logs were very long, so I hope this snippet is useful:

 

 

Edited by DZMM
removed logs
Link to post
10 minutes ago, Roxedus said:

NOTE: You exposed your plex token, you should revoke all logged in sessions in plex to generate new ones

The snippet doesnt seem to have any attempts to use the auth

 

Thanks deleted.

 

I'm going to go and read up first on how the auth thing works again and implement from scratch.  I did this ages ago following an online guide and I can't remember how I did it, so I guess it's time for a refresher.

Link to post
On 10/30/2020 at 8:30 AM, DZMM said:

Thanks deleted.

 

I'm going to go and read up first on how the auth thing works again and implement from scratch.  I did this ages ago following an online guide and I can't remember how I did it, so I guess it's time for a refresher.

Did you figure this out? I am having the same problem

Link to post
3 hours ago, Jomo said:

Did you figure this out? I am having the same problem

Nope.  I tried to do from scratch using the instructions, but I couldn't get it to work and ran out of time so I had to disable auth.  I'll have another go when I have time.  I found the instructions confusing as I'm not that technical, but that could be me - I need to dig up the blog that I followed before as that was easy to follow and covered just the unraid docker scenario.

Link to post

I was struggling with this too - the thing that fixed it for me was to:

- Edit the default file in the letsencrypt/nginx site-confs folder

- Comment out the #location ~ \.php$ section

 

This was a comment that I noticed in one of the newer swag template files.

 

Hope this helps some of you guys!

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.