Jump to content

Random.Name

Members
  • Content Count

    61
  • Joined

  • Last visited

Community Reputation

5 Neutral

About Random.Name

  • Rank
    Advanced Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Random.Name

    [support] digiblur's Docker Template Repository

    Well i have found a sollution that works... but it is not that great first i setup my nginx config file like this: location /speedtest { include /config/nginx/proxy.conf; proxy_pass http://192.168.178.22:6580/; } that way, i can access the speedtest remotely. My Problem was, that the js worker was not called correctly The "sollution" was to log into the speedtest docker console install nano or any other file editor edit the index.html file search for else{ //test is not running, begin w=new Worker('BASEURL/speedtest_worker.min.js'); w.postMessage('start'); //Add optional parameters as a JSON object to this command and change it so that you set your BASEURL/ correctly. This seems to work, but its not an ideal solution since it will be overwritten as soon as the docker container gets updated. Also it won't work anymore if you try to access it via your local ip... more of a bandaid solution
  2. Random.Name

    [Support] Linuxserver.io - Nginx

    well, since i am quite new to nginx i would love to get some help here, too Also everything is running on a dyndns and i am not sure if sub domains work with ddns.net
  3. Random.Name

    [Support] Linuxserver.io - Nginx

    so, i am running this speedtest docker on my unRAID server: https://github.com/adolfintel/speedtest/tree/docker Everything is running fine locally but when i try to setup a reverse Proxy with nginx, i run into a very annoying problem: This is my nginx config for speedtest location /speed { include /config/nginx/proxy.conf; proxy_pass http://192.168.178.22:6580/; } I can reach the page just fin, but if i try to use it i get a 404 error for one of the .js files that is needed. The TEST Button tries to call https://REVER.SE/speedtest\_worker.min.js but since everything is behind the reverse proxy the correct path would be https://REVER.SE/PROXY/speedtest\_worker.min.js i tried for hours to figure out how to setup a rewrite rule in nginx to automatically change all the urls, but without luck. can somebody help me out here?
  4. Random.Name

    [support] digiblur's Docker Template Repository

    i have searched the web for information for the past hours, but i can't get the speedtest docker working behind the already mentioned revere Proxy. The problem seems to be, that the speedtest_worker.min.js file wants to run from https://PROXNAME/speedtest_worker.min.js instead of https//PROXNAME/REVERSE/speedtest_worker.min.js i have no idea how to use nginx rewrite rules to fix this, everything i tried resulted in more errors :(
  5. Random.Name

    [Support] Djoss - Nginx Proxy Manager

    Well, i just set this up for testing and i really like the WebUi. I just setup a new SSl Certificate via the UI and accourding to the UI and the Logs everything should be running. After that i tried to setup my first reverse proxy to my speedtest docker sadly no matter what i choose i get a ERR_SSL_VERSION_OR_CIPHER_MISMATCH Error message in Chrome...any ideas? if i try to connect from my phone (mobile connection) i geht ERR_SSL_PROTOCOL_ERROR any ideas?
  6. Random.Name

    More cache on the parity drive a good thing?

    Thanks for the clarification
  7. Random.Name

    More cache on the parity drive a good thing?

    I am not completely sure, but unraid might see the bigger cache drives as „smaller“ then the others. And so they would not work as parity drives. i think I got that problem I a system I built for a friend, but don’t take my word for fact. I mostly post this answer to get someone with more knowledge to correct me if I am wrong :)
  8. same here... i just installed Lakka as a VM and everything seems to be working. Although i dont like the Lakka GUI as much... well we will see
  9. Seems like i got the same error. At least the problem is the same and my log looks quite similar. Any help? lvl2: EmulationStation - v2.8.0rp-dev, built Aug 16 2018 - 00:23:07 lvl2: Parsing XML file "/storage/.emulationstation/resources/mamenames.xml"... lvl2: Creating surface... lvl2: Created window successfully. lvl2: Added known joystick Microsoft X-Box One pad (Firmware 2015) (instance ID: 0, device index: 0) lvl2: Checking available OpenGL extensions... lvl2: ARB_texture_non_power_of_two: ok lvl2: Loading system config file /storage/.emulationstation/es_systems.cfg... lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/carbon.xml") could not find file "" lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/theme.xml" could not find file "./art/controller/${system.theme}.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/art/controller/n3ds.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/theme.xml" could not find file "./art/logo/${system.theme}.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/art/logo/n3ds.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/theme.xml" could not find file "./art/logo/${system.theme}.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/art/logo/n3ds.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/theme.xml" could not find file "./art/controller/${system.theme}.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/art/controller/n3ds.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/theme.xml" could not find file "./art/logo/${system.theme}.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/art/logo/n3ds.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/theme.xml" could not find file "./art/controller/${system.theme}.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/art/controller/n3ds.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/theme.xml" could not find file "./art/logo/${system.theme}.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/art/logo/n3ds.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/theme.xml" could not find file "./art/controller/${system.theme}.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/art/controller/n3ds.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/theme.xml" could not find file "./art/logo/${system.theme}.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/art/logo/n3ds.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/theme.xml" could not find file "./art/controller/${system.theme}.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/art/controller/n3ds.svg") lvl1: System "n3ds" has no games! Ignoring it. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/amiga/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/amiga/../carbon.xml") could not find file "" lvl1: System "amiga" has no games! Ignoring it. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/c64/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/c64/../carbon.xml") could not find file "" lvl1: System "c64" has no games! Ignoring it. lvl1: Unknown platform for system "fba" (platform "fba" from list "fba") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/fba/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/fba/../carbon.xml") could not find file "" lvl1: System "fba" has no games! Ignoring it. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/mame/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/mame/../carbon.xml") could not find file "" lvl1: System "mame" has no games! Ignoring it. lvl2: Parsing XML file "/storage/.emulationstation/gamelists/nes/gamelist.xml"... lvl1: File "/storage/roms/nes/Super Mario Bros 3 (E).nes" does not exist! Ignoring. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/nes/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/nes/../carbon.xml") could not find file "" lvl1: System "nes" has no games! Ignoring it. lvl2: Parsing XML file "/storage/.emulationstation/gamelists/n64/gamelist.xml"... lvl1: File "/storage/roms/n64/Star Wars - Shadows of the Empire (U) (V1.2) [!].z64" does not exist! Ignoring. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/n64/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/n64/../carbon.xml") could not find file "" lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/psx/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/psx/../carbon.xml") could not find file "" lvl1: System "psx" has no games! Ignoring it. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/ps2/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/ps2/../carbon.xml") could not find file "" lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/ps2/theme.xml" could not find file "./art/controller.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/ps2/art/controller.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/ps2/theme.xml" could not find file "./art/controller.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/ps2/art/controller.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/ps2/theme.xml" could not find file "./art/controller.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/ps2/art/controller.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/ps2/theme.xml" could not find file "./art/controller.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/ps2/art/controller.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/ps2/theme.xml" could not find file "./art/controller.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/ps2/art/controller.svg") lvl1: System "ps2" has no games! Ignoring it. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/psp/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/psp/../carbon.xml") could not find file "" lvl1: System "psp" has no games! Ignoring it. lvl2: Parsing XML file "/storage/.emulationstation/gamelists/snes/gamelist.xml"... lvl1: File "/storage/roms/snes/Super Mario World (U) [!].smc" does not exist! Ignoring. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/snes/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/snes/../carbon.xml") could not find file "" lvl1: System "snes" has no games! Ignoring it. lvl1: Error - folder with path "/storage/roms/zxspectrum" is not a directory! lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/zxspectrum/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/zxspectrum/../carbon.xml") could not find file "" lvl1: System "zxspectrum" has no games! Ignoring it. lvl2: Parsing XML file "/storage/.emulationstation/gamelists/gba/gamelist.xml"... lvl1: File "/storage/roms/gba/Legend of Zelda, The - A Link To The Past Four Swords (U) [!].gba" does not exist! Ignoring. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/gba/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/gba/../carbon.xml") could not find file "" lvl1: System "gba" has no games! Ignoring it. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/saturn/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/saturn/../carbon.xml") could not find file "" lvl1: System "saturn" has no games! Ignoring it. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/dreamcast/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/dreamcast/../carbon.xml") could not find file "" lvl1: System "dreamcast" has no games! Ignoring it. lvl2: Parsing XML file "/storage/.emulationstation/gamelists/nds/gamelist.xml"... lvl1: File "/storage/roms/nds/0023 - Star Wars Episode III - Revenge of the Sith (E)(Trashman).nds" does not exist! Ignoring. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/nds/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/nds/../carbon.xml") could not find file "" lvl1: System "nds" has no games! Ignoring it. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/genesis/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/genesis/../carbon.xml") could not find file "" lvl1: System "genesis" has no games! Ignoring it. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/gc/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/gc/../carbon.xml") could not find file "" lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/gc/theme.xml" could not find file "./art/controller.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/gc/art/controller.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/gc/theme.xml" could not find file "./art/controller.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/gc/art/controller.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/gc/theme.xml" could not find file "./art/controller.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/gc/art/controller.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/gc/theme.xml" could not find file "./art/controller.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/gc/art/controller.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/gc/theme.xml" could not find file "./art/controller.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/gc/art/controller.svg") lvl1: System "gc" has no games! Ignoring it. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/pc/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/pc/../carbon.xml") could not find file "" lvl1: System "pc" has no games! Ignoring it. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/wii/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/wii/../carbon.xml") could not find file "" lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/wii/theme.xml" could not find file "./art/controller.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/wii/art/controller.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/wii/theme.xml" could not find file "./art/controller.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/wii/art/controller.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/wii/theme.xml" could not find file "./art/controller.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/wii/art/controller.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/wii/theme.xml" could not find file "./art/controller.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/wii/art/controller.svg") lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/wii/theme.xml" could not find file "./art/controller.svg" (which resolved to "/etc/emulationstation/themes/es-theme-carbon/wii/art/controller.svg") lvl1: System "wii" has no games! Ignoring it. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/wonderswan/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/wonderswan/../carbon.xml") could not find file "" lvl1: System "wonderswan" has no games! Ignoring it. lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/auto-allgames/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/auto-allgames/../carbon.xml") could not find file "" lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/auto-favorites/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/auto-favorites/../carbon.xml") could not find file "" lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/auto-lastplayed/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/auto-lastplayed/../carbon.xml") could not find file "" lvl1: Warning from theme "/etc/emulationstation/themes/es-theme-carbon/custom-collections/theme.xml" (from included file "/etc/emulationstation/themes/es-theme-carbon/custom-collections/../carbon.xml") could not find file "" lvl2: req sound [basic.launch] lvl2: (missing) lvl0: AudioManager Error - Unable to open SDL audio: ALSA: Couldn't open audio device: No such file or directory lvl2: Attempting to launch game... lvl0: VolumeControl::init() - Failed to find mixer elements! lvl2: /usr/bin/retroarch.start -L /tmp/cores/mupen64plus_libretro.so /storage/roms/n64/Mario\ Kart\ 64\ \(E\)\ \(V1.1\)\ \[\!\].z64 lvl2: Creating surface... lvl2: Created window successfully. lvl2: Added known joystick Microsoft X-Box One pad (Firmware 2015) (instance ID: 0, device index: 0) lvl0: VolumeControl::init() - Failed to find mixer elements! lvl2: Added known joystick Microsoft X-Box One pad (Firmware 2015) (instance ID: 0, device index: 0) lvl2: req sound [basic.launch] lvl2: (missing) lvl2: Attempting to launch game... lvl0: AudioManager Error - Unable to open SDL audio: ALSA: Couldn't open audio device: No such file or directory lvl2: /usr/bin/retroarch.start -L /tmp/cores/mupen64plus_libretro.so /storage/roms/n64/Mario\ Kart\ 64\ \(E\)\ \(V1.1\)\ \[\!\].z64 lvl2: Creating surface... lvl2: Created window successfully. lvl2: Added known joystick Microsoft X-Box One pad (Firmware 2015) (instance ID: 0, device index: 0) lvl0: VolumeControl::init() - Failed to find mixer elements! lvl2: Added known joystick Microsoft X-Box One pad (Firmware 2015) (instance ID: 0, device index: 0)
  10. sorry for the late reply. It got quite late over here. i tried connecting to it via my smartphone (wifi off) and it did not work... today after a few hours of sleep everything seems to be just fine and running. V>ery strange, but i will not complain
  11. i checked for open ports with http://canyouseeme.org/ and for 443 i get an open port message. i checked for pings with https://ping.eu/ping/ the packages get lost, but the ip seems to be right. Also my VPN connction works just fine...
  12. does not seem like it, port 443 is open as far as i can see.
  13. well i recently moved and now i have a new ISP, router and so on. I managed to get almost everything working, exept letsencryt/ nginx. all my reverse proxys seem to be down, and i can't reach anything via my public domain. I went through the site-configs and changed the ip adresses to the new one, but i have no idea what else i need to do I get only "Site can't be reached" messages, so it seems like nothing is working. Ports are open. Any ideas?
  14. Random.Name

    Worth trying to build around? xeon 5660 x2

    Well the cpu is dirt cheap but there are a lot of dual socket motherboards out there that fit it. So you could just grab a second one and a motherboard an build a decent system. i have dual 5640s and 96GB of Ram and my server seems to be running fine. it really depends on how much you would pay for a second 5660 and a dual socket motherboard
  15. Random.Name

    Server stops working, no error messages.

    Well the server just crashed again without prior warnings I will let it be shut off for now, hope someone can help me