[Support] lnxd - PhoenixMiner


208 posts in this topic Last Reply

Recommended Posts

  • Replies 207
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

PM is a Miner for GPUs -see https://phoenixminer.org/   I would recomend to read about cryptos first. But basically it is possible to mine ETH with a CPU but very much not recomended. H

it works now, thanks @lnxd, @ich777 for all the effort you put into making this community work   put the other port         Project: PhoenixMiner 5.

Overview: Support thread for lnxd/PhoenixMiner in CA. Application: PhoenixMiner - https://github.com/PhoenixMinerDevTeam/PhoenixMiner/ Docker Hub: https://hub.docker.com/r/lnxd/phoenixminer

Posted Images

1 hour ago, frodr said:

Is this the support thread for the docker xmrig? The docker support links here. 

It can be for now, or you can PM me. How can I help?

Link to post
3 minutes ago, tsakodim said:

Nice docker that xmrig, many thanks 

Now is there a way to connect to that docker and see the console and the miner?

Thanks! If you mean to control it you’d need to start an interactive session using docker exec for now, I’m still investigating whether that’s possible.
 

Otherwise the logs should be visible via the WebUI in the Docker page, click on the xmrig logo and press logs.

 

Or of course run this in terminal:

docker logs xmrig -f

 

Link to post
9 minutes ago, lnxd said:

Thanks! If you mean to control it you’d need to start an interactive session using docker exec for now, I’m still investigating whether that’s possible.
 

Otherwise the logs should be visible via the WebUI in the Docker page, click on the xmrig logo and press logs.

 

Or of course run this in terminal:


docker logs xmrig -f

 

Yes the logs are what I wanted to see perfect
Thanks again

ps I left the donation to lnxd-fee, thats you right? Chears!

Link to post
Posted (edited)
9 minutes ago, tsakodim said:

Yes the logs are what I wanted to see perfect
Thanks again

ps I left the donation to lnxd-fee, thats you right? Chears!

Yes that's me, thank you! ☺️ On that setting (for the xmrig container) it mines for me for 1 minute every 100 minutes. I need to make the new support thread!

Edited by lnxd
Link to post
3 minutes ago, tsakodim said:

Yes you should, XMR mining is gaining, with the prices and scarcity of the GPUs many will try CPU mining and Monero.

😂 it's available here. I like everything to be perfect before I post it but I'm starting work in 9 minutes so that'll have to do for now.

Link to post
  • lnxd changed the title to [Support] lnxd - PhoenixMiner
Posted (edited)
5 hours ago, frodr said:

I have a Nvidia GPU with Unraid drivers. How should it be set up?

 

377407789_Screenshot2021-04-03at01_35_33.thumb.png.853e83ba67e3ccf1a114981f6e971280.png

Like that but take out the -amd 😅 I'll add that into the instructions in OP.

 

EDIT: It looks like you were following the right instructions by the way, if you get stuck at all just let me know.

Edited by lnxd
Link to post
5 hours ago, lnxd said:

Like that but take out the -amd 😅 I'll add that into the instructions in OP.

 

EDIT: It looks like you were following the right instructions by the way, if you get stuck at all just let me know.

 

Removing -amd, it only popped in again. I removed the whole line.

 

The log says it can't find the Nvidia drivers. But the GPU runs fine with Plex, etc.

 

[0mNo CUDA driver found
OpenCL driver version: 20.20-1089974-ubuntu-20.04
[91mNo avaiable GPUs for mining. Please check your drivers and/or hardware.
[0m

 

90811574_Screenshot2021-04-03at12_43_33.thumb.png.235913c3da18a49900a759ac8b0dce12.png

Link to post
1 hour ago, frodr said:

Removing -amd, it only popped in again. I removed the whole line.

 

The log says it can't find the Nvidia drivers. But the GPU runs fine with Plex, etc.

Very interesting, I'm going to see if I can find out more information on your card's compatibility with the built-in drivers and go from there. I'll get back to you in the next day or so. You have a very high end server 😅

Link to post
1 hour ago, lnxd said:

Very interesting, I'm going to see if I can find out more information on your card's compatibility with the built-in drivers and go from there. I'll get back to you in the next day or so. You have a very high end server 😅

Thanks, looking forward to it. 

 

Did you forget to include your prosentage fee in the docker setup? I think it is fair that the one supporting the docker image have a possibility for compensation.

 

The server is fine, and quite strong. Watercooled. If I only can get hold of a 3080/90 GPU, I will not pay overprice.

 

Link to post
46 minutes ago, frodr said:

Thanks, looking forward to it. 

Have you set the Variables 'NVIDIA_VISIBLE_DEVICES' set to your UUID of your GPU, 'NVIDIA_CAPABILITIES' to 'all' and in the Extra Parameters also '--runtime=nvidia' in the Docker template?

Link to post
9 minutes ago, ich777 said:

Have you set the Variables 'NVIDIA_VISIBLE_DEVICES' set to your UUID of your GPU, 'NVIDIA_CAPABILITIES' to 'all' and in the Extra Parameters also '--runtime=nvidia' in the Docker template?

I tried without and with it. Error message with the setup below (and not in the log file):

Also, Server error when removing the line "GPU Device"

 

 

1644269379_Screenshot2021-04-03at17_03_53.png.b71aa972b022c23443f7ae667d0c2953.png

 

 

 

764637618_Screenshot2021-04-03at17_01_43.thumb.png.2b45b973017e1bf02b097647f51ff89d.png

 

Link to post
17 minutes ago, frodr said:

I tried without and with it. Error message with the setup below (and not in the log file)

Then there is something wrong with the plugin or the nvidia driver itself.

 

Can you change a setting in the container template itself and post the Error that you get when the docker run command is executed.

Also what is this server error?

Also please remove the /dev/dri entry.

 

EDIT: I tried the container a few days ago with my GTX1060 6GB and it ran flawlessly.

Link to post
40 minutes ago, ich777 said:

Then there is something wrong with the plugin or the nvidia driver itself.

 

Can you change a setting in the container template itself and post the Error that you get when the docker run command is executed.

Also what is this server error?

Also please remove the /dev/dri entry.

 

EDIT: I tried the container a few days ago with my GTX1060 6GB and it ran flawlessly.

 

Saving a setting is fine, starting the docker:

474380027_Screenshot2021-04-03at17_03_53.png.18026ca00cac6df17dd112ea8fe8ce43.png

 

Nothing in the log file. 

 

Edit: I have removed the /dev/dri entry.

 

Can it be something related to the GPU/GPU driver. I having a strange transcoding error. From Plex log file:

 

Jobs: Exec of /config/Library/Application Support/Plex Media Server/Codecs/EasyAudioEncoder-1165-linux-x86_64/EasyAudioEncoder/EasyAudioEncoder failed. (13)

 

 

 

 

Edited by frodr
Link to post
11 minutes ago, frodr said:

Saving a setting is fine, starting the docker

Ah, yes, they have changed that, try to remove the parameter '--runtime=nvidia' and then start up the container.

When it is started click on the container and then add the '--runtime=nvidia' again and it should output what's wrong with it.

 

Have you restarted your server after installing the Nvidia Driver Plugin?

Link to post
32 minutes ago, ich777 said:

Ah, yes, they have changed that, try to remove the parameter '--runtime=nvidia' and then start up the container.

When it is started click on the container and then add the '--runtime=nvidia' again and it should output what's wrong with it.

 

Have you restarted your server after installing the Nvidia Driver Plugin?

I removed the "--runtime=nvidia", and the "Server error" disappeared, but is do not start. The log file says:

 

Project: PhoenixMiner 5.5c

Author: lnxd

Base: Ubuntu 20.04

Driver: amdgpu-pro-20.20-1098277 / AMDGPU-Pro Driver v20.20

 

Target: Unraid 6.9.0 - 6.9.1

 

Wallet: 0x23B9ab2B75943Be63857AA8768Aedce1BB75eD91

Pool: eu1.ethermine.org:4444

 

Starting PhoenixMiner 5.5c with the following arguments:

-pool eu1.ethermine.org:4444 -wal 0x23B9ab2B75943Be63857AA8768Aedce1BB75eD91.x -tt 70 -tstop 85 -tstart 80 -cdm 1 -cdmport 5450

Phoenix Miner 5.5c Linux/gcc - Release build

--------------------------------------------

 

[0mNo CUDA driver found

 

OpenCL driver version: 20.20-1089974-ubuntu-20.04

 

[91mNo avaiable GPUs for mining. Please check your drivers and/or hardware.

[0m

 

 

Yes, server is restarted many time. But to be sure I tested with a new restart. 

 

Link to post
16 minutes ago, frodr said:

Yes, server is restarted many time. But to be sure I tested with a new restart. 

Something seems wrong with your Docker service since it can't actually connect to the nvidia runtime.

Also it can't find Cuda because you are not passing it through.

Link to post
5 minutes ago, ich777 said:

Something seems wrong with your Docker service since it can't actually connect to the nvidia runtime.

Also it can't find Cuda because you are not passing it through.

 

The docker image ran full a few days ago due to incorrect nzbget paths. I fixed the paths, and changed the docker file to 120GB. Maybe I should delete and rebuild the docker image file?

Link to post
14 minutes ago, frodr said:

 

The docker image ran full a few days ago due to incorrect nzbget paths. I fixed the paths, and changed the docker file to 120GB. Maybe I should delete and rebuild the docker image file?

That has nothing to do with the docker.img file.

If the container won't start if you are passing the argument '--runtime=nvidia' to it then there is something else wrong.

 

Is Plex working with the same settings?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.