Jump to content

[SOLVED] Unable to remove old cache drive

Recommended Posts

I used to run with two cache drives, a Samsung 830 and a PNY, both SSDs.  I decided I didn't need both as cache devices anymore and removed the PNY drive as cache.  It now shows up in unassigned devices (along with a busted jpg icon).  If I physically remove the PNY drive from my system, my remaining Samsung cache drive says unreadable.  If I physically put the PNY drive back in, the Samsung cache drive is readable again and the PNY drive still shows up in unassigned devices with the busted icon.  See screenshot.  How can I release this drive so I can remove it and not lose my cache contents?  All of my docker and VM configs are on this and they're totally missing if I boot without the PNY drive (and Samsung cache drive says unreadable).


Link to comment

Pool is using single profile for metadata so it failed to remove the device, likely it was created with v6.7.x, there was a bug, do this to fix:


Stop the array, if Docker/VM services are using the cache pool disable them, unassign the single cache device, start array to make Unraid "forget" current cache config, stop array, reassign both cache devices (there can't be an "All existing data on this device will be OVERWRITTEN when array is Started" warning for any cache device), re-enable Docker/VMs if needed, start array, convert pool to raid1 and once that's done remove cache2 again.



  • Thanks 1
Link to comment
9 minutes ago, Chuck Claunch said:

if I disable Docker/VM services I won't lose all that data?

You won't lose the data, but they won't go to the main pool, it's just for when you start the array without cache Unraid doesn't create new docker/libvirt images, also make sure cache backups are up to date before doing this, not a risky operation but just in case.

  • Thanks 1
Link to comment
  • JorgeB changed the title to [SOLVED] Unable to remove old cache drive
  • 1 year later...

I'm in the same boat as OP wherein my server doesn't boot if I remove the NVME drive (which is currently unassigned) from the slot. It's not in a cache pool with the primary m.2 device. Before following the same steps by JorgeB to troubleshoot, I wanted to check with the forum if I can proceed. FWIW, I'm going through a full migration of the server to a new MoBo, Intel CPU, and a new cache drive.


Link to comment
10 hours ago, vvolfpack said:

I'm in the same boat as OP wherein my server doesn't boot if I remove the NVME drive (which is currently unassigned) from the slot.

Do you mean the pool does not mount as was the problem for the OP or the server does not boot? I guess the latter since the unassigned NVMe device is not using the same filesystem.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...