"SimpleFeatures" Plugin - Version 1.0.11



2848 posts in this topic Last Reply

Recommended Posts

First, I'll admit I haven't read all 62 pages in this thread...phew! So, this may have already been touched on, not sure. I really like the plugin, great stuff! I like the Stats page and the graphs, but I wanted to ask about how the memory usage is represented. Currently it appears that it shows memory usage "used" and "free" as it is shown in the Top command for "used"and "free". If my assertion is true, then that isn't really an accurate representation and would lead people to believe that they may be having a memory leak because over time the graph may show that all the memory is used. That's what I started seeing and I only have 1 GB RAM, so I was concerned. But after running the command "free -m", which subtracts the buffers and adds in the cache I then could see that only about 6% of my memory was being used because the majority of it is being reserved for disk caching, but of course is still free for applications to use. So, my question is, would it make sense to have the graph represent what "free -m" shows as this would be more in line with what is really "used" and "free".

 

Thanx,

 

+1 !

Link to post
  • Replies 2.8k
  • Created
  • Last Reply

Top Posters In This Topic

Is this working with rc2?

There are no changes in the stock GUI of unRAID between rc1 and rc2.

 

In other words the latest simpleFeatures version works on both rc1 and rc2.

Link to post

Feature Request:  I create log files from some scripts that I run periodically.  I store the logs in /var/log and would like to be able to view them much like the syslog.  In unmenu the log viewer set the default log to syslog, but could be overwritten so another log could be viewed.  Could this feature be added to Simple Features?

Link to post

I have made an update to the memory graph to display three values: free, cached and used.

 

Coming soon to you!

 

Thank you very much. This will definitely be more useful information.

 

+1

Link to post

Feature Request:  Could you include non-array disks in the "Disk Stats"?

I don't have a spare disk at the moment to test this, but the request has been noted. Can't give any date though!

Link to post

Feature Request:  Could you include non-array disks in the "Disk Stats"?

I don't have a spare disk at the moment to test this, but the request has been noted. Can't give any date though!

 

All you would need is a portable USB disk drive I think.  There is no rush.  Thanks for the consideration.

 

Simple Features makes unraid a joy to use!

Link to post

i just upgraded to v5rc2 and installed the simple features and it works fine with the exception of the email notifications. i can get the test to work but everytime and have changed the frequency to 1 min but no emails. i also tried to stop the email notifications by using the stop button it shows stopped but when i leave and go back it show running still. also everytime i hit the stop button on the console i see "sed: -e expression #1, char 1: unterminated address regex".

 

EDIT: after a reboot the 1 min email notify works so i still have the problem of the stopping and starting of the process via the webpage.

 

thanks

 

Link to post

i just upgraded to v5rc2 and installed the simple features and it works fine with the exception of the email notifications. i can get the test to work but everytime and have changed the frequency to 1 min but no emails. i also tried to stop the email notifications by using the stop button it shows stopped but when i leave and go back it show running still. also everytime i hit the stop button on the console i see "sed: -e expression #1, char 1: unterminated address regex".

 

EDIT: after a reboot the 1 min email notify works so i still have the problem of the stopping and starting of the process via the webpage.

 

thanks

 

No worries - have another version in the works.

Link to post

i just upgraded to v5rc2 and installed the simple features and it works fine with the exception of the email notifications. i can get the test to work but everytime and have changed the frequency to 1 min but no emails. i also tried to stop the email notifications by using the stop button it shows stopped but when i leave and go back it show running still. also everytime i hit the stop button on the console i see "sed: -e expression #1, char 1: unterminated address regex".

 

EDIT: after a reboot the 1 min email notify works so i still have the problem of the stopping and starting of the process via the webpage.

 

thanks

 

No worries - have another version in the works.

 

thanks.

 

one other thing i found is the "RCPT TO:" seems to be populated by the "Sending Address" field and not the email recipients field. the actual To: looks ok.

 

thanks

 

Link to post

Hi,

 

I have just installed SimpleFeatures with v5-RC2 and it is working really well. The only issue I have is cosmetic, when I click on the tabs - Main\Shares\Stats etc. the pages seem to jump around as though the page positions are different i.e If I click on 'Main' and the click 'Shares' the page jumps to the left and up a bit. I have tried Chrome and IE v9.0. Can this be easily fixed?

 

Thanks

 

Zaxxan

Link to post

On the Syslog page, might it be possible to add a script button to automatically download to the browser client a copy of the syslog?  It would be advantageous if it was piped through 'todos' as a part of the process.

Link to post

Second Item:  On 'Main', the box for "Write Corrections to parity disk" is checked.  I would prefer that (1) it either be unchecked  or (2) have an option on the settings page to determine the status of the check in the box.  Perhaps, a good place for this second option would be on the 'Settings' page under the 'Simple Features' in the "Confirmation' area. 

 

On the 'Settings' page again on the 'Simple Features' tab, there is the 'Scheduler' for the automatic parity check.  The default choice for 'Write corrections to parity disk' is 'Yes'.  I would prefer that it be 'No'.

 

The reason for wanting these box(s) unchecked is that should NOT be any parity errors found during a parity check.  If there is an error, the user should be given an opportunity to check for the cause and correct it.  Correcting parity before the cause has been determined will cause data loss if the error is in the data array (most likely one of the data disks) and not in the parity array (most likely the parity disk).  Until the user has made that determination, an automatic parity check will simply hide a data array error from the user and give a false sense of security that all is well.

Link to post

Apologize coming back to the sleep function.

 

I'm afraid, that the mySQL database is preventing an automatic sleep after the time period I entered under "Settings":

Extra delay after array inactivity (minutes): 15
Interval of network / device inactivity (minutes): 2
Wait for device inactivity (address): empty

 

Wouldn't it be possible to check if a user is active; in that case: don't fall into sleep and activate the timer as soon as the last user disconnected? Another option might be to exclude (in my case mysql) specific streams from letting the server fall into sleep?

 

Sorry for another request ...  ::)

 

I love the plugin anyhow....

Link to post

I had a similar issue and cleared my cache (b14). Worked after that until I unnistalled it so I could install RC2 with no add ons.

 

I've tried clearing my cache but I still have the same problem.

Link to post

Second Item:  On 'Main', the box for "Write Corrections to parity disk" is checked.  I would prefer that (1) it either be unchecked  or (2) have an option on the settings page to determine the status of the check in the box.  Perhaps, a good place for this second option would be on the 'Settings' page under the 'Simple Features' in the "Confirmation' area. 

 

On the 'Settings' page again on the 'Simple Features' tab, there is the 'Scheduler' for the automatic parity check.  The default choice for 'Write corrections to parity disk' is 'Yes'.  I would prefer that it be 'No'.

 

The reason for wanting these box(s) unchecked is that should NOT be any parity errors found during a parity check.  If there is an error, the user should be given an opportunity to check for the cause and correct it.  Correcting parity before the cause has been determined will cause data loss if the error is in the data array (most likely one of the data disks) and not in the parity array (most likely the parity disk).  Until the user has made that determination, an automatic parity check will simply hide a data array error from the user and give a false sense of security that all is well.

The write to parity disk setting is the default setting of unRAID itself - that is the same setting as used under the stock GUI (though the wording has been changed). It is the intended choice of Limetech to have the behaviour like this.

 

If you don't want to write to the parity disk then uncheck the box before initiating a manual parity check.

 

For the scheduled parity check you can change the setting and it will be stored for future use.

 

Link to post

Apologize coming back to the sleep function.

 

I'm afraid, that the mySQL database is preventing an automatic sleep after the time period I entered under "Settings":

Extra delay after array inactivity (minutes): 15
Interval of network / device inactivity (minutes): 2
Wait for device inactivity (address): empty

 

Wouldn't it be possible to check if a user is active; in that case: don't fall into sleep and activate the timer as soon as the last user disconnected? Another option might be to exclude (in my case mysql) specific streams from letting the server fall into sleep?

 

Sorry for another request ...  ::)

 

I love the plugin anyhow....

Did you try to unset all conditions except wait for network inactivity?

 

The above would trigger a sleep action after no users are actively using the DB anymore (you may need to experiment with the network interval to find an optimum).

 

Link to post

On the Syslog page, might it be possible to add a script button to automatically download to the browser client a copy of the syslog?  It would be advantageous if it was piped through 'todos' as a part of the process.

This is on the todo list, but be patient for it :)

Link to post

Hi,

 

I have just installed SimpleFeatures with v5-RC2 and it is working really well. The only issue I have is cosmetic, when I click on the tabs - Main\Shares\Stats etc. the pages seem to jump around as though the page positions are different i.e If I click on 'Main' and the click 'Shares' the page jumps to the left and up a bit. I have tried Chrome and IE v9.0. Can this be easily fixed?

 

Thanks

 

Zaxxan

The reason why the page moves left/right is because the browser displays or hides the scrolling bar at the right side of the screen, depending on whether scrolling is required or not.

 

This is an expected behaviour.

 

Link to post
  • Squid locked this topic
Guest
This topic is now closed to further replies.