Jump to content
Zeron

Open VM Tools for unRAID 6

248 posts in this topic Last Reply

Recommended Posts

6.2.1 version finally posted.

 

Thanks, Zeron.  Unfortunately, we are now up to 6.2.4, with kernel 4.4.30.

Share this post


Link to post

6.2.1 version finally posted.

 

Thanks, Zeron.  Unfortunately, we are now up to 6.2.4, with kernel 4.4.30.

 

Just finished 4.4.26, 4.4.30 is next.  Should be uploaded in a few hours.

Share this post


Link to post

Zeron, you need a donation button, or a 'Buy me a beer' button!  ;)

Share this post


Link to post

Thanks for the great work!

 

I get this error when trying to install the plugin:

 

plugin: installing: http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg
plugin: downloading http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg
plugin: downloading: http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg ... done

Warning: simplexml_load_file(): I/O warning : failed to load external entity "/boot/config/plugins/openVMTools.plg" in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 214
plugin: xml parse error

 

What causes this?

Share this post


Link to post

Thanks for the great work!

 

I get this error when trying to install the plugin:

 

plugin: installing: http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg
plugin: downloading http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg
plugin: downloading: http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg ... done

Warning: simplexml_load_file(): I/O warning : failed to load external entity "/boot/config/plugins/openVMTools.plg" in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 214
plugin: xml parse error

 

What causes this?

 

Anyone?

Share this post


Link to post

Thanks for the great work!

 

I get this error when trying to install the plugin:

 

plugin: installing: http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg
plugin: downloading http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg
plugin: downloading: http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg ... done

Warning: simplexml_load_file(): I/O warning : failed to load external entity "/boot/config/plugins/openVMTools.plg" in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 214
plugin: xml parse error

 

What causes this?

 

Anyone?

Can you write anything to the flash drive?

Share this post


Link to post

Thanks for the great work!

 

I get this error when trying to install the plugin:

 

plugin: installing: http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg
plugin: downloading http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg
plugin: downloading: http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg ... done

Warning: simplexml_load_file(): I/O warning : failed to load external entity "/boot/config/plugins/openVMTools.plg" in /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin on line 214
plugin: xml parse error

 

What causes this?

 

Anyone?

Can you write anything to the flash drive?

 

Yes, everything else works but this.

Share this post


Link to post

Looks like it's that time again, would it be possible to have a version compiled for 6.3.0?

 

Built for 6.3.1

Share this post


Link to post

Looks like it's that time again, would it be possible to have a version compiled for 6.3.0?

 

Built for 6.3.1

 

Thanks, Zeron!

Share this post


Link to post

They put out new versions fast.  Would you mind building it for 6.3.2

Per the plugin -- Open-VM-Tools is not available for Kernel 4.9.10 Please update the plugin.

Share this post


Link to post

They put out new versions fast.  Would you mind building it for 6.3.2

Per the plugin -- Open-VM-Tools is not available for Kernel 4.9.10 Please update the plugin.

 

Done.

Share this post


Link to post

Bad place to ask, but now that I have the tools installed, I had chosen FreeBSD 64-bit as the OS in ESXI, and now it is telling me to select the correct one, any suggestions as to what to select?  It had said Linux 4.9.10-unRAID Slackware 14.2.

 

After a restart, it doesn't seem to give me the same warning.  So maybe it's good now.

 

 

Share this post


Link to post

Bad place to ask, but now that I have the tools installed, I had chosen FreeBSD 64-bit as the OS in ESXI, and now it is telling me to select the correct one, any suggestions as to what to select?  It had said Linux 4.9.10-unRAID Slackware 14.2.

 

After a restart, it doesn't seem to give me the same warning.  So maybe it's good now.

 

i think, your choice "FreeBSD 64-bit" is OK. if everything works then no probs.

unRAID is custom kernel build based on Slackware, so there will be no such option in ESXi to choose.

Share this post


Link to post

Would it be possible to have a version for 6.3.4?

 

Thank you very much Zeron for the support!

Share this post


Link to post
On 5/20/2017 at 7:11 AM, rooftop said:

Would it be possible to have a version for 6.3.4?

 

Thank you very much Zeron for the support!

 

Uploaded a version for 6.3.4

Share this post


Link to post
On 5/27/2017 at 10:21 AM, zin105 said:

And 6.3.5? You're doing the lord's work!

 

6.3.5 version is uploaded.

Share this post


Link to post
On 5/29/2017 at 4:16 AM, Zeron said:

 

6.3.5 version is uploaded.

 

I can't get this to work, but I'm unsure if its me as a new user doing something wrong?

This is the log when I try to install using the URL in the first post:

 

plugin: installing: http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg
plugin: downloading http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg
plugin: downloading: http://unraid.zeron.ca/plugins/open-vm-tools/openVMTools.plg ... done
plugin: downloading: http://unraid.zeron.ca/plugins/open-vm-tools/open_vm_tools-10.1.0.4449150-K4.9.30_unRaid-x86_64-26Zeron.tgz ... failed (Invalid URL / Server error response)
plugin: wget: http://unraid.zeron.ca/plugins/open-vm-tools/open_vm_tools-10.1.0.4449150-K4.9.30_unRaid-x86_64-26Zeron.tgz download failure (Invalid URL / Server error response)

 

Share this post


Link to post

Is it possible to have VM's set up & have the VPN working for Network access as well? Currently if I run my VM's with a network bridge, I get no eccess to the rest of my network, only the unraid box I VPN to?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.