Jump to content
Mettbrot

TVheadend plugin for unRaid 6

150 posts in this topic Last Reply

Recommended Posts

yeah! i think that solved it.

Was there anything wrong with what i have done?

From what i remeber it wouldn't even have been possible for me to change that in the webinterface? "Yes" was there by default.

THX!

Share this post


Link to post

yeah! i think that solved it.

Was there anything wrong with what i have done?

From what i remeber it wouldn't even have been possible for me to change that in the webinterface? "Yes" was there by default.

THX!

 

I've got Yes in the script field as well. Even if I stop the service, remove 'Yes' and restart, it pops back in there all by itself!

 

Anyway, installed this at the weekend as I was fed up with MediaPortal TV Server crashing my Win7 VM. It works great with by Digital Devices Octopus tuners (enabled by CHBMB's DVD build).

 

One gotcha if you use Kodi....

 

DONT set any recordings with a frequency of 'forever'. They will record and save to your storage but will not show up in the TVHeadEnd completed recordings or Kodi UI. It's a bug with v 4.0.x (fixed in 4.1, apparently). You can set any frequency up to and including 3 years. Drove me nuts trying to figure out whey some recordings were showing up and some now, even though all were saved.

 

Share this post


Link to post

Anyway, installed this at the weekend as I was fed up with MediaPortal TV Server crashing my Win7 VM. It works great with by Digital Devices Octopus tuners (enabled by CHBMB's DVD build).

 

Cool, you know you got me back into this DVB stuff don't you, I was looking at your blog and even bought you a coffee!  ;D

Share this post


Link to post

Anyway, installed this at the weekend as I was fed up with MediaPortal TV Server crashing my Win7 VM. It works great with by Digital Devices Octopus tuners (enabled by CHBMB's DVD build).

 

Cool, you know you got me back into this DVB stuff don't you, I was looking at your blog and even bought you a coffee!  ;D

 

The one and only coffee received on that blog! Very much appreciated  8)

 

Must start writing there again. I'd slipped into a 'it's all working' mode but must update with these tvheadend changes.

 

Keep up the good work!!

Share this post


Link to post

Will the plugin work on the 6.2 beta?

 

Don't see any reason why not..

Share this post


Link to post

i've just received a DVBSky S952 DVB-S2 pci card that i want to use to run tvheadend on my unraid server, i'm currently using tvheadend via a wetek openelec edition, using 3 rpi2 as clients however the wetek seems pretty sluggish so i'm hoping this may speed things up.

 

anyway, i'm currently on 6.1.9 and have installled the plugin linked to on this thread via the install plugin option on the server gui.

 

i've also installed the unraid dvb plugin, this is where i'm geting confused, which option from the dropdown do i select? i'm thinking the latest openelec one?

 

also at what point is best to physically install the pci card?

 

apologies if this isn't the right place to ask

Share this post


Link to post

Hey! You could install the card at any time, before you reboot the server with the DVB enabled images the card is simply not recognized. The image to get would be the openelec one. This one is the one with all stock kernel drivers enabled plus openelec specific patches. You can see if your card is supported by the Linux kernel by searching for it here: https://www.linuxtv.org/wiki/index.php/Main_Page

 

Once you restart with the correct image you should see the card recognized in the tvheadend addon on the left.

Share this post


Link to post

many thanks :)

 

i have the card installed and the openelec dvb build installed.

 

i have created a tvheadend folder in my appdata folder, ane changed the data directory to /mnt/cache/tvheadend/.htsconfig is this right?

 

it isshowing media tree & dvb tuner as detected, but login/password is not accepted? login & password are blank in advanced config?

 

thanks again for the help!

 

 

 

 

Share this post


Link to post

You don't need the htsconfig, just a dedicated tvheadend folder is sufficient. Just set an admin username and a password and enable it and it should start :)

Share this post


Link to post

thanks again!

 

i'm now having issues with setting up tvheadend, i've set it up the same as i did on the wetek play but its is still

 

i've set up a dvb-s network and used astra 28.2 pre-defined as i'm in the uk.

 

then selected config - dvb inputs - tv adapters then selected the astra network i created in parameters, and enabled both.

 

when i then look at muxes, the scans all show up and are all at idle/fail??

 

are there any other settings i should be adjusting?

 

or if anyone can poitn me in the right direction of a walk through for dvb-s as everything i can find seems to lean towards dvb-t

 

many thanks for all the help

Share this post


Link to post

You installed the DVB-S drivers?  See my signature if not.

Share this post


Link to post

yes, i used the links from the first post.

 

i installed the unraid dvb plugin, and installed the openelec 6.1.9 image. is there a way of telling if its installed correctly?

 

or should i try a different build??

 

thanks for the help:)

Share this post


Link to post

yes, i used the links from the first post.

 

i installed the unraid dvb plugin, and installed the openelec 6.1.9 image. is there a way of telling if its installed correctly?

 

or should i try a different build??

 

thanks for the help:)

 

Look in the bottom left on my plugin screen and see what it says....  Should tell you whether drivers are installed etc.  Don't know what build you should use as I don't know what card you're using.

Share this post


Link to post

apologies i'm using a DVBSky S952 PCIe card DVB-S2

 

yes its showing that the openelec 6.1.9 , driver 1.11 installed.

 

i've tried rebooting and reinstalling it again.

Share this post


Link to post

apologies i'm using a DVBSky S952 PCIe card DVB-S2

 

yes its showing that the openelec 6.1.9 , driver 1.11 installed.

 

i've tried rebooting and reinstalling it again.

 

What does it say for DVB Adapter Drivers?

Share this post


Link to post

DVB Adapter Drivers: Detected

 

So that's all good, you using this plugin right and not a docker?

Share this post


Link to post

yes using the plugin from this thread.

 

i'm deleting the plugin now to see if a fresh install does anything.

Share this post


Link to post

Post a screenshot of the plugin setup and we'll see what we can do..

Share this post


Link to post

so wen't through the setup again and its still faiing, this is what i'm getting in the system log.  i'll grab the screenshots now, thanks again for the help

 

2016-06-17 19:25:11.605 http: 192.168.1.18: HTTP/1.1 POST /api/idnode/load -- 400
2016-06-17 19:27:57.000 mpegts: 11265V in astra - tuning on Montage M88RS6000 : DVB-S #0
2016-06-17 19:27:57.032 opentv-ausat: registering mux 11265V in astra
2016-06-17 19:27:57.032 subscription: 0002: "scan" subscribing to mux "11265V", weight: 5, adapter: "Montage M88RS6000 : DVB-S #0", network: "astra", service: "Raw PID Subscription"
2016-06-17 19:27:57.032 mpegts: 11265H in astra - tuning on Montage M88RS6000 : DVB-S #0
2016-06-17 19:27:57.070 opentv-ausat: registering mux 11265H in astra
2016-06-17 19:27:57.070 subscription: 0003: "scan" subscribing to mux "11265H", weight: 5, adapter: "Montage M88RS6000 : DVB-S #0", network: "astra", service: "Raw PID Subscription"
2016-06-17 19:28:01.530 linuxdvb: Unable to provide UNC value.
2016-06-17 19:28:01.585 linuxdvb: Unable to provide UNC value.
2016-06-17 19:28:07.000 mpegts: 11265H in astra - scan no data, failed
2016-06-17 19:28:07.000 subscription: 0003: "scan" unsubscribing
2016-06-17 19:28:07.000 mpegts: 11225V in astra - tuning on Montage M88RS6000 : DVB-S #0
2016-06-17 19:28:07.032 opentv-ausat: registering mux 11225V in astra
2016-06-17 19:28:07.032 subscription: 0005: "scan" subscribing to mux "11225V", weight: 5, adapter: "Montage M88RS6000 : DVB-S #0", network: "astra", service: "Raw PID Subscription"
2016-06-17 19:28:07.032 mpegts: 11265V in astra - scan no data, failed
2016-06-17 19:28:07.032 subscription: 0002: "scan" unsubscribing
2016-06-17 19:28:07.032 mpegts: 11225H in astra - tuning on Montage M88RS6000 : DVB-S #0
2016-06-17 19:28:07.070 opentv-ausat: registering mux 11225H in astra
2016-06-17 19:28:07.070 subscription: 0007: "scan" subscribing to mux "11225H", weight: 5, adapter: "Montage M88RS6000 : DVB-S #0", network: "astra", service: "Raw PID Subscription"
2016-06-17 19:28:17.002 mpegts: 11225H in astra - scan no data, failed
2016-06-17 19:28:17.002 subscription: 0007: "scan" unsubscribing
2016-06-17 19:28:17.002 mpegts: 11426V in astra - tuning on Montage M88RS6000 : DVB-S #0
2016-06-17 19:28:17.035 opentv-ausat: registering mux 11426V in astra
2016-06-17 19:28:17.035 subscription: 0009: "scan" subscribing to mux "11426V", weight: 5, adapter: "Montage M88RS6000 : DVB-S #0", network: "astra", service: "Raw PID Subscription"
2016-06-17 19:28:17.035 mpegts: 11225V in astra - scan no data, failed
2016-06-17 19:28:17.035 subscription: 0005: "scan" unsubscribing
2016-06-17 19:28:17.035 mpegts: 11425H in astra - tuning on Montage M88RS6000 : DVB-S #0
2016-06-17 19:28:17.792 opentv-ausat: registering mux 11425H in astra
2016-06-17 19:28:17.792 subscription: 000B: "scan" subscribing to mux "11425H", weight: 5, adapter: "Montage M88RS6000 : DVB-S #0", network: "astra", service: "Raw PID Subscription"
2016-06-17 19:28:27.000 mpegts: 11425H in astra - scan no data, failed
2016-06-17 19:28:27.000 subscription: 000B: "scan" unsubscribing
2016-06-17 19:28:27.000 mpegts: 11385V in astra - tuning on Montage M88RS6000 : DVB-S #0
2016-06-17 19:28:27.022 opentv-ausat: registering mux 11385V in astra
2016-06-17 19:28:27.022 subscription: 000D: "scan" subscribing to mux "11385V", weight: 5, adapter: "Montage M88RS6000 : DVB-S #0", network: "astra", service: "Raw PID Subscription"
2016-06-17 19:28:27.022 mpegts: 11426V in astra - scan no data, failed
2016-06-17 19:28:27.022 subscription: 0009: "scan" unsubscribing
2016-06-17 19:28:27.022 mpegts: 11385H in astra - tuning on Montage M88RS6000 : DVB-S #0
2016-06-17 19:28:27.045 opentv-ausat: registering mux 11385H in astra
2016-06-17 19:28:27.045 subscription: 000F: "scan" subscribing to mux "11385H", weight: 5, adapter: "Montage M88RS6000 : DVB-S #0", network: "astra", service: "Raw PID Subscription"
2016-06-17 19:28:37.298 mpegts: 11385H in astra - scan no data, failed
2016-06-17 19:28:37.298 subscription: 000F: "scan" unsubscribing
2016-06-17 19:28:37.298 mpegts: 11344.5V in astra - tuning on Montage M88RS6000 : DVB-S #0
2016-06-17 19:28:37.320 opentv-ausat: registering mux 11344.5V in astra
2016-06-17 19:28:37.321 subscription: 0011: "scan" subscribing to mux "11344.5V", weight: 5, adapter: "Montage M88RS6000 : DVB-S #0", network: "astra", service: "Raw PID Subscription"
2016-06-17 19:28:37.321 mpegts: 11385V in astra - scan no data, failed
2016-06-17 19:28:37.321 subscription: 000D: "scan" unsubscribing
2016-06-17 19:28:37.321 mpegts: 11344H in astra - tuning on Montage M88RS6000 : DVB-S #0
2016-06-17 19:28:37.420 opentv-ausat: registering mux 11344H in astra
2016-06-17 19:28:37.420 subscription: 0013: "scan" subscribing to mux "11344H", weight: 5, adapter: "Montage M88RS6000 : DVB-S #0", network: "astra", service: "Raw PID Subscription"
2016-06-17 19:28:47.000 mpegts: 11344H in astra - scan no data, failed
2016-06-17 19:28:47.000 subscription: 0013: "scan" unsubscribing
2016-06-17 19:28:47.000 mpegts: 11307V in astra - tuning on Montage M88RS6000 : DVB-S #0
2016-06-17 19:28:47.022 opentv-ausat: registering mux 11307V in astra
2016-06-17 19:28:47.022 subscription: 0015: "scan" subscribing to mux "11307V", weight: 5, adapter: "Montage M88RS6000 : DVB-S #0", network: "astra", service: "Raw PID Subscription"
2016-06-17 19:28:47.022 mpegts: 11344.5V in astra - scan no data, failed
2016-06-17 19:28:47.022 subscription: 0011: "scan" unsubscribing
2016-06-17 19:28:47.022 mpegts: 11307H in astra - tuning on Montage M88RS6000 : DVB-S #0
2016-06-17 19:28:47.045 opentv-ausat: registering mux 11307H in astra
2016-06-17 19:28:47.045 subscription: 0017: "scan" subscribing to mux "11307H", weight: 5, adapter: "Montage M88RS6000 : DVB-S #0", network: "astra", service: "Raw PID Subscription"

Share this post


Link to post

I'm afraid I'm a dreaded DVB-T user  ;)

 

Let me see if one of my mates is around who knows about DVB-S, and I'll point him this way.

Share this post


Link to post

Try changing user to nobody and group to users

 

Might be a permissions thing..

 

I don't actually use this plugin myself, so I may be way off...

Share this post


Link to post

Also you may want to change your data directory

 

/usr/local/ is in memory so will get wiped on reboot.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.