Jump to content
Mettbrot

TVheadend plugin for unRaid 6

144 posts in this topic Last Reply

Recommended Posts

Just a quick notice. I updated the tvh pack to the latest 4.0.7 version!

 

Thanks for the update :)

Share this post


Link to post

Hey guys!

 

I updated tvh to 4.0.8 today. Also fixed the loading of the two settings "Show storage memory usage" and "Show data persistency information".

 

I also added a setting where you can put the location for a 'shutdown scipt' which is called right after tvh is stopped. I use this to call an ACPI Wakeup script: http://www.tvheadend.org/projects/tvheadend/wiki/Wakeup

 

Enjoy!

Share this post


Link to post

Hi,

 

Does this version support transcoding?

 

I have installed it - but no options for this under Configuration / General

Share this post


Link to post

There is no option for turning on/off transcoding in general anymore.

You should have stream profiles somewhere in settings.

Share this post


Link to post

Any chance for the 4.1 update? :)

There isn't a 4.1 stable yet, so that is the reason I guess.

Share this post


Link to post

Hey! Since tvheadend 4.2 is supposed to be released soon I held off on the update. It's been some time since the announcement that development has been finished (http://tvheadend.org/news/65) though.. :-\

I am definitely planning on releasing a 4.2 version once it's done :)

Share this post


Link to post

Hey! Since tvheadend 4.2 is supposed to be released soon I held off on the update. It's been some time since the announcement that development has been finished (http://tvheadend.org/news/65) though.. :-\

I am definitely planning on releasing a 4.2 version once it's done :)

 

Hello,

how's this plan going?

I'm currently switching to unraid and this plugin would be nice, because i would be able to drop my rpi2 which is running TVHeadend 4.2

Since 4.2 could possibly be breaking sonfiguration i assume, your next update will do so, too and i like to spare me the double configuration within a few days/weeks

Share this post


Link to post

What is this Plugin doing?  ???

Must i install a TV-Tuner in the unraid-machine or how is this working?

Share this post


Link to post

You either need a dvb card to use this as well as my plugin in my signature or some sort of iptv device like a hdhomerun.

 

 

Share this post


Link to post

What am i missing?

This plugins causes trouble being stopped on my unraid

if stopped manually it takes a few minutes and the website is going wild by showing me yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy etc. before my browser cuts it. a few minutes later it's stopped an d everythins is back to normal.

if i forget to stop it and simply stop the array it has a similar effect and i need to shutdown the system with "powerdown" because rsyslogd and emhttp are going to eat the cpu to infinity while my syslog blows up simply writing "Jun  4 14:51:57 UNRAID emhttp: y" over and over and over again.

i read the first post over and over, but i simply don't get it, where i am doing it wrong.

Data directory is set to

/mnt/cache/tvheadend

 

Share this post


Link to post

Same thing for me thought I was the only one looking forward to an answer also.

 

Sent from my Xperia Z2 using Tapatalk

 

 

Share this post


Link to post

Hm. Which unRaid version are you on? This plugin is only testes for the 6.1.x releases. Also, could you post the config file in your tvheadend directory? Maybe something got messed up.

Do you have the media build installed? What does it say on the left side of the tvheadend configuration page? All green?

Share this post


Link to post

Hm. Which unRaid version are you on? This plugin is only testes for the 6.1.x releases. Also, could you post the config file in your tvheadend directory? Maybe something got messed up.

Do you have the media build installed? What does it say on the left side of the tvheadend configuration page? All green?

I'm on V6.1.9

Configfile attached (had to change name to config.txt because the board didn't let me upload without extension)

i installed unRAID DVB(plugin) to get a nicer way to tvheadend :)

and there i used 6.19 Openelec Driver Version 1.11

left side of tvheadend config:

MEDIA tree:	DETECTED
DVB tuner:	DETECTED
Tvheadend login/password:	ACCEPTED

all green

config.txt

Share this post


Link to post

Looking good so far. This is not the config file I meant. There is one in your /flash/config/plugins/tvheadend directory if I remember correctly.

 

Although I don't know how the DVB plugin works and what it does. I would recommend just replacing bzroot and bzimage and installing the original plg from this thread.

Share this post


Link to post

correct file attached.

i'll test your advice later on.(Array is in Rebuild atm) Can you explain, how your files are different, from the one, the plugin provides?

will your files support my Technotrend-Stick?

tvheadend.cfg

Share this post


Link to post

Dave my plugin replaces the stock Unraid files (bzroot & bzimage) with versions that have DVB drivers so you can use your DVB PCI, PCI-E or USB tuners.  If you are using a homerun device then you don't need my plugin.

Share this post


Link to post

Dave my plugin replaces the stock Unraid files (bzroot & bzimage) with versions that have DVB drivers so you can use your DVB PCI, PCI-E or USB tuners.  If you are using a homerun device then you don't need my plugin.

yeah, I'm aware of that :-)

But as your Post says deprecated switch to > method i used( http://lime-technology.com/forum/index.php?topic=47899.0 ) and of course there is Driver version 1.10 in your files, i assumed m,y method is the right one. I simpy don't get it atm, what's going on with your files and the plugin i used.

anyway, my unraid is still in rebuild, so it will take anoter two or three hours, before i'm able to test the files in your post with Driver Version 1.10

Share this post


Link to post

Initially I just made the files and put links to them. 

 

Then Squid and I produced a plugin that does it all automatically.  Basically it downloads the files for you and will tell you when there's a new version.  It's just an automated process rather than the old manual method.

Share this post


Link to post

Hey! Could you try setting that last line in the config file to

SCRIPT=""

that should be it. For the next version, I will try to check if the script really exists before executing it :)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.