[Support] Linuxserver.io - Transmission


335 posts in this topic Last Reply

Recommended Posts

linuxserver_medium.png

 

Application Name: Transmission

Application Site: http://www.transmissionbt.com/

Docker Hub: https://hub.docker.com/r/linuxserver/transmission/

Github: https://github.com/linuxserver/docker-transmission

 

Please post any questions/issues relating to this docker you have in this thread.

 

If you are not using Unraid (and you should be!) then please do not post here, instead head to linuxserver.io to see how to get support.

Edited by linuxserver.io
Link to post
  • Replies 334
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Application Name: Transmission Application Site: http://www.transmissionbt.com/ Docker Hub: https://hub.docker.com/r/linuxserver/transmission/ Github: https://github.com/linuxserver/doc

Possibly the path is incorrect. To what path is the docker trying to save the torrent when you get the message? Does that path correspond to something in the docker volume mappings?

Sounds like you aren't getting what jonathanm said. You said you had mapped /download, but then you said you expected to find them in /downloads. /download is not the same as /downloads.  

Posted Images

There was, at least on mine (default admin/pass), but that may have been a remnant from a previous docker as I migrated to the Linuxserver docker from another one.

 

Anyway, I figured out how to disable it.  Stop the docker, change the rpc-authentication-required setting to false in the settings.json file in the docker appdata directory.  It will no longer prompt for a password.

Link to post

There was, at least on mine (default admin/pass), but that may have been a remnant from a previous docker as I migrated to the Linuxserver docker from another one.

 

Anyway, I figured out how to disable it.  Stop the docker, change the rpc-authentication-required setting to false in the settings.json file in the docker appdata directory.  It will no longer prompt for a password.

 

False is the default setting on settings.json :)  I agree was from your previous docker.

 

https://github.com/linuxserver/docker-transmission/blob/master/defaults/settings.json

Link to post
  • 2 weeks later...

I'm having trouble setting the watch directory.  It keeps resetting itself back to /config/watch which isn't where my watch dirtectory is.  I've tried many sequences of editing the settings.json with no luck.  My Download and incomplete settings hold fine.

 

Any ideas ?  It worked fine in your previous (pre-ls.io) container.

Link to post

Has anyone else tried to change the watch folder with any success ?

 

 

added separate mapping for watch folder.

 

if you pull the latest version from the hub by updating, you will need to add

 

/watch as an extra volume mapping in the unraid template, new users won't have to do this.

Link to post

Hey guys. Been using this and several of your dockers and they are working great.  ;D

 

I would like to make a suggestion to this specific docker. Is it possible to add python2.7 package to the Docker image? I use a postprocessing script (nzbToMedia) when the torrent download finishes but its not being triggered because of the missing package.

 

TIA and keep up the awesome work.

Link to post

added separate mapping for watch folder.

 

if you pull the latest version from the hub by updating, you will need to add

 

/watch as an extra volume mapping in the unraid template, new users won't have to do this.

 

Thanks.  Pulled the latest and it's all working with a new watch folder mapping.  Cheers.

Link to post
  • 1 month later...

i migrated from needos docker.

 

1.

my current folders are capitalized for Complete & Incomplete.

now each time the docker starts a complete & incomplete folder is created lowercase.

downloads still go towards the capitalized directories but the lowercase are just there being duplicates and causing headaches on my mac

i tried editing the settings.json but changes doesnt seem to stick and issue still persists when restarted.

 

2.

is there a way to add a username and password?? similar to needos container??

Link to post

The team should have told you this, but the init scripts inside the docker are hardwired to create the directories thats giving you hell. Best recourse is to move everything into the lower case directories and use those.

 

thats news to me. bummer :'(

 

can anyone from the team let me know if creating the directories can be avoided??

 

Link to post

The obvious solution would be to just use lowercase.  Personally I try to avoid using uppercase on Linux for this very reason.  I'll take a look over the next couple of days.  But if we changed it to use uppercase then I'm sure we'll see complaints from others about wanting to use lowercase...

 

Having said that, until I've looked at it further I'm not entirely sure of the issue and the exact cause.  So I'll reserve judgement for now.

Link to post

The team should have told you this, but the init scripts inside the docker are hardwired to create the directories thats giving you hell. Best recourse is to move everything into the lower case directories and use those.

 

thats news to me. bummer :'(

 

can anyone from the team let me know if creating the directories can be avoided??

 

ken-ji is right, lowercase is hardcoded in and I'm struggling to think of a reason why it's a significant problem, but I'm happy to listen to arguments for and against...  ;)

Link to post

ken-ji is right, lowercase is hardcoded in and I'm struggling to think of a reason why it's a significant problem, but I'm happy to listen to arguments for and against...  ;)

 

its just the way ive always had things since unraid 4.7. and from plugins to needos dockers.

thw beginning of thie year i made the switch from needos dockers to linuxserver.io dockers

all went well except for transmission creating those lowercase folders and having to delete them

annoying at the most as long as i dont reboot the server or restart the docker lol

 

attached is how nice it looks on my explorer/finder :P

Screen_Shot.png.759359ea3461ed08947e3ee6097e19c8.png

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.