[Support] for atribe's repo Docker images


509 posts in this topic Last Reply

Recommended Posts

  • 2 weeks later...
  • Replies 508
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

As mentioned above, the latest tag now installs influx 2.0 and a docker update automatically installed this for me.   It was causing Grafana to return Authorization errors for me so clearly

Same error on my 6.9.2 box after the latest container update. Looks like there is already a GitHub issue targeting a fix in Glances 3.2.3 release: https://github.com/nicolargo/glances/issues/1905.

The update changed it to influx 2.0 you need to go back to the 1.X version. I changed mine from latest to influxdb:1.7.10-alpine Everything started back up and and all is good with the world

Posted Images

What version is untelegraf currently running? v0.13? If so, what would it take to upgrade untelegraf to v0.13.1?

 

It seems that if my CPU usage gets too high, the connection to Docker is dropped and does not recover. This ends up showing in the untelegraf logs as "An error occurred trying to connect: context deadline exceeded". 

 

From checking telegraf's Github repo, it appears that this was a known issue that was resolved in v0.13.1: https://github.com/influxdata/telegraf/issues/1195

 

So far, the only way to recover from this is to restart the Docker image or the box itself. I've also noticed though that the untelegraf container does not like to stop/restart from the UI or command line. It usually gives an execution error and then I will find it stopped an hour or so later. Is this a known issue? This makes for a very long recovery process. :(

 

Thanks in advance!

Edited by fairplay89
Link to post
On 2/18/2017 at 9:36 AM, clowrym said:

Thats the issue, I don't have :latest......

 

So you are saying you don't have :latest in the minecraft docker setting's page repository field, but it is getting appended when hit apply and you see the command?

Link to post
19 hours ago, fairplay89 said:

What version is untelegraf currently running? v0.13? If so, what would it take to upgrade untelegraf to v0.13.1?

 

It seems that if my CPU usage gets too high, the connection to Docker is dropped and does not recover. This ends up showing in the untelegraf logs as "An error occurred trying to connect: context deadline exceeded". 

 

From checking telegraf's Github repo, it appears that this was a known issue that was resolved in v0.13.1: https://github.com/influxdata/telegraf/issues/1195

 

So far, the only way to recover from this is to restart the Docker image or the box itself. I've also noticed though that the untelegraf container does not like to stop/restart from the UI or command line. It usually gives an execution error and then I will find it stopped an hour or so later. Is this a known issue? This makes for a very long recovery process. :(

 

Thanks in advance!

The telegraf docker is running version 1.0, but I'm going to update it to 1.2.1. Did you change you settings so it is sampling at a really high rate or something?

Link to post
37 minutes ago, atribe said:

The telegraf docker is running version 1.0, but I'm going to update it to 1.2.1. Did you change you settings so it is sampling at a really high rate or something?

 

My untelegraf + influxdb + grafana setup is nearly stock and followed a couple of your other posts. 

 

I'll pull a fresh copy of the latest version and give it a shot. 

 

Thanks for the quick turnaround time! 

Edited by fairplay89
Link to post
17 hours ago, atribe said:

So you are saying you don't have :latest in the minecraft docker setting's page repository field, but it is getting appended when hit apply and you see the command?

 

 

Exactly!! & it errors out as there is not latest tag used in the repo

Link to post

Follow-up to the "Update Ready" & my comment regarding the ":Latest" tag, Hexparrot has added a :latest tag for node-jesse on Docker hub, Just change the Repository to just "hexparrot/mineos" everything should work fine!Capture.thumb.JPG.7846c614a998179bfd892644cb5f3a22.JPG

Link to post
3 hours ago, clowrym said:

Follow-up to the "Update Ready" & my comment regarding the ":Latest" tag, Hexparrot has added a :latest tag for node-jesse on Docker hub, Just change the Repository to just "hexparrot/mineos" everything should work fine!

 

Great thanks. I just looked at the xml that defines the app and it is tagged as  <Repository>hexparrot/mineos:node-jessie</Repository> . That's what I should have told you the first time. But yeah, your solution works too.

Link to post
59 minutes ago, atribe said:

 

Great thanks. I just looked at the xml that defines the app and it is tagged as  <Repository>hexparrot/mineos:node-jessie</Repository> . That's what I should have told you the first time. But yeah, your solution works too.

 

 

I had looked through the xml as well, but for whatever reason Unraid always apends :latest after "hexparrot/mineos:node-jessie" causing the repository to not be found during an update. Now that he's added the latest tag, no more "update ready"!!

Link to post
On 3/3/2017 at 11:11 PM, dalben said:

If there is anyone out there that who has the skills to turn a docker into an easy installer unraid container, and wants Minecraft PE servers, this looks quite sexy

 

https://hub.docker.com/r/ixilon/nukkit/

 

Its actually not overly difficult to add, The only issue is on start-up his java script asks for a language, I had to enter the docker container and manually start the nukkit server, selecting the Language.... Now if I could just figure out how to run Screen inside the docker container!!

Link to post

Anyone else having issues with Glances?  It's been running great the last few months, but a recent container update killed it on both of my unRAID servers.  Forcing an update or rebuilding it doesn't have any effect.The container says it's up and running but the web view doesn't respond.

Edited by jedimstr
Link to post
2 hours ago, zin105 said:

 

Kind of the same problem. My docker stops pretty much as soon as I start it. Seems to happen in some updates, then a new one comes and fixes it. Currently I can't start glances.

I don't even use glances, so I haven't noticed it breaking. Is there an error message in the log? The xml for the community apps hasn't changed, so it's probably an issue with the glances docker itself.

Link to post
3 minutes ago, atribe said:

I don't even use glances, so I haven't noticed it breaking. Is there an error message in the log? The xml for the community apps hasn't changed, so it's probably an issue with the glances docker itself.

Here is the error I get

 

Traceback (most recent call last):
File "/usr/lib/python2.7/runpy.py", line 174, in _run_module_as_main
"__main__", fname, loader, pkg_name)
File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
exec code in run_globals
File "/glances/glances/__main__.py", line 29, in <module>
glances.main()
File "glances/__init__.py", line 238, in main
start_webserver(config=config, args=args)
File "glances/__init__.py", line 193, in start_webserver
webserver = GlancesWebServer(config=config, args=args)
File "glances/webserver.py", line 41, in __init__
self.stats.update()
File "glances/stats.py", line 164, in update
self._plugins[p].update()
File "glances/plugins/glances_plugin.py", line 805, in wrapper
ret = fct(self, *args, **kw)
File "glances/plugins/glances_plugin.py", line 814, in wrapper
ret = fct(*args, **kw)
File "/glances/glances/plugins/glances_batpercent.py", line 78, in update
self.glancesgrabbat.update()
File "/glances/glances/plugins/glances_batpercent.py", line 119, in update
'value': int(self.bat.sensors_battery().percent),
AttributeError: 'NoneType' object has no attribute 'percent'

 

Link to post
1 minute ago, wreave said:

Here is the error I get

 


Traceback (most recent call last):
File "/usr/lib/python2.7/runpy.py", line 174, in _run_module_as_main
"__main__", fname, loader, pkg_name)
File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
exec code in run_globals
File "/glances/glances/__main__.py", line 29, in <module>
glances.main()
File "glances/__init__.py", line 238, in main
start_webserver(config=config, args=args)
File "glances/__init__.py", line 193, in start_webserver
webserver = GlancesWebServer(config=config, args=args)
File "glances/webserver.py", line 41, in __init__
self.stats.update()
File "glances/stats.py", line 164, in update
self._plugins[p].update()
File "glances/plugins/glances_plugin.py", line 805, in wrapper
ret = fct(self, *args, **kw)
File "glances/plugins/glances_plugin.py", line 814, in wrapper
ret = fct(*args, **kw)
File "/glances/glances/plugins/glances_batpercent.py", line 78, in update
self.glancesgrabbat.update()
File "/glances/glances/plugins/glances_batpercent.py", line 119, in update
'value': int(self.bat.sensors_battery().percent),
AttributeError: 'NoneType' object has no attribute 'percent'

 

Yeah, that looks like something deep inside of glances... Not sure if I can do anything about that one.

Link to post
  • 1 month later...
  • 2 weeks later...
  • 1 month later...
20 hours ago, GilbN said:

Where is the grafana.ini file located?

The docker version of grafana doesn't use a grafana.ini file. It uses container variables instead. The Key 1 and Key 2 of the unraid docker container are mapped to container variables GF_SERVER_ROOT_URL and GF_SECURITY_ADMIN_PASSWORD respectively. You would add any configuration you would have put in the .ini file into a variable of the with a name patterned after the two I just mentioned.

Link to post
  • 2 weeks later...

Hi,

 

I am currently trying to setup a new Influxdb docker on my new unraid 6.3.5 server. However when I attempt run the docker and access the admin web interface I am getting a connection refused. Can any one help with this issues? Let me know what information you would need from me to assist with this. 

 

Influxdb
Container ID: 7970bf9a253a
By: library/influxdb:latest
 up-to-date
 force update
8083/tcp  192.168.1.13:8083
8086/tcp  192.168.1.13:8086	
/var/lib/influxdb  /mnt/user/logs/
8888888 .d888 888 8888888b. 888888b.
888 d88P" 888 888 "Y88b 888 "88b
888 888 888 888 888 888 .88P
888 88888b. 888888 888 888 888 888 888 888 888 8888888K.
888 888 "88b 888 888 888 888 Y8bd8P' 888 888 888 "Y88b
888 888 888 888 888 888 888 X88K 888 888 888 888
888 888 888 888 888 Y88b 888 .d8""8b. 888 .d88P 888 d88P
8888888 888 888 888 888 "Y88888 888 888 8888888P" 8888888P"
[I] 2017-06-29T16:01:02Z InfluxDB starting, version 1.3.0, branch master, commit 76124df5c121e411e99807b9473a03eb785cd43b

[I] 2017-06-29T16:01:02Z Go version go1.8.3, GOMAXPROCS set to 16

[I] 2017-06-29T16:01:02Z Using configuration at: /etc/influxdb/influxdb.conf

[I] 2017-06-29T16:01:02Z Using data dir: /var/lib/influxdb/data service=store
[I] 2017-06-29T16:01:02Z opened service service=subscriber
[I] 2017-06-29T16:01:02Z Starting monitor system service=monitor
[I] 2017-06-29T16:01:02Z 'build' registered for diagnostics monitoring service=monitor
[I] 2017-06-29T16:01:02Z 'runtime' registered for diagnostics monitoring service=monitor
[I] 2017-06-29T16:01:02Z 'network' registered for diagnostics monitoring service=monitor
[I] 2017-06-29T16:01:02Z 'system' registered for diagnostics monitoring service=monitor
[I] 2017-06-29T16:01:02Z Starting precreation service with check interval of 10m0s, advance period of 30m0s service=shard-precreation
[I] 2017-06-29T16:01:02Z Starting snapshot service service=snapshot
[I] 2017-06-29T16:01:02Z Starting continuous query service service=continuous_querier
[I] 2017-06-29T16:01:02Z Starting HTTP service service=httpd
[I] 2017-06-29T16:01:02Z Authentication enabled:false service=httpd
[I] 2017-06-29T16:01:02Z Listening on HTTP:0.0.0.0:8086 service=httpd
[I] 2017-06-29T16:01:02Z Starting retention policy enforcement service with check interval of 30m0s service=retention
[I] 2017-06-29T16:01:02Z Listening for signals
[I] 2017-06-29T16:01:02Z Sending usage statistics to usage.influxdata.com
[I] 2017-06-29T16:01:02Z Storing statistics in database '_internal' retention policy 'monitor', at interval 10s service=monitor

 

Link to post
25 minutes ago, owzo said:

 

I am currently trying to setup a new Influxdb docker on my new unraid 6.3.5 server. However when I attempt run the docker and access the admin web interface I am getting a connection refused. Can any one help with this issues? Let me know what information you would need from me to assist with this. 

 

Hi Owzo, check out this previous post for the answer. 

 

Link to post
  • 5 weeks later...
On 29/06/2017 at 5:44 PM, atribe said:

 

Hi Owzo, check out this previous post for the answer. 

 

Good evening, I just installed influxdb from your repo and ran the config to enable the web interface. I can see the docker is listening on that port but when I try and browse via GUI I get nothing and telnet drops straight away. I also cannot see a config file anywhere in /mnt/user/appdata/influxdb or sub directories to confirm that its taken the config for enabling the GUI. Appreciate any assistance you can give, many thanks.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.