Jump to content
Djoss

[Support] Djoss - CrashPlan PRO (aka CrashPlan for Small Business)

795 posts in this topic Last Reply

Recommended Posts

I'm getting a "server disconnected (code: 1006) when trying to hit the web gui on port 5800. Seeing this log entry:

17/10/2017 09:08:04 Error: could not obtain listening port.

Share this post


Link to post

Are you using default port mappings?  If not, make sure the port you assign is not already used by another container.

Share this post


Link to post

I am using the default mapping. Nothing has changed with my setup. My backups are still happening according to my crashplan account online, but I just can't get the app to connect. I also installed a VNC viewer app and tried to connect to IP:7910, but it just says connection refused. Something broke, but not sure what or how to fix it. One odd thing in the settings is that I have "Web port for GUI" and "VNC port for gui" listed 3 times? All three are set the same, Web = 7810 and VNC = 7910. I don't even see a setting for port 5800 which is the port it uses when I right click on the docker and choose "Web GUI". I'm always nervous to mess with the settings since I don't really understand them and I don't want to accidentally cause all my files to be backed up again. 

Share this post


Link to post

Try to remove duplicated settings.  Then look at the Docker tab, you have a column with all the port mappings.  Make sure there is no duplicates.

 

Also, port 5800 is the container's internal port.  By default, it is mapped to port 7810 and it's the port you use to access the web interface: http://IP:7810.

Share this post


Link to post

I was able to remove the duplicate entries, but it's still not working. Under "deployed hosts ports" I see this:

crashplanpro    7810 7910
plex    32400
plexpy    8181

 

Crashplanpro and ports are in red. I'm noot sure if that's because I'm on that docker or if it's because there is a problem.?

 

 

Share this post


Link to post

Ports in red don't indicate a problem, I have the same thing.

Can you provide the container's log?  Are you using the latest version of the container?

Share this post


Link to post

First logs are missing.  Can you try to stop the container, start it and take the logs again?

Share this post


Link to post

I stopped it, restarted it and clicked on the lo g icon to the right. I just did a select all and copied to a text file. If there is a better way to grab the log let me know. 

 

 

CrashPlanProDockerLog.txt

Share this post


Link to post

In your container settings, is the network type set to "bridge"?

Share this post


Link to post

Ah, any reason why not using the bridge mode?

 

The problem is that you have something else running on port 5900 on your server.  You can see it with:

 

netstat -tulpn|grep 5900

 

Share this post


Link to post

No reason. I just set it to bridge mode and it created the duplicate ports again. I removed them and restarted the container. Now the page doesn't load at all over port 7810 or 5800? Everything was working fine on 10/9 when you pushed out the update to fix our problems so I can't figure out what changed since then. How can I see what is running on port 5900? I've not added anything in the last few weeks so not sure what would be using that port

Share this post


Link to post

tcp        0      0 0.0.0.0:5900            0.0.0.0:*               LISTEN      15843/qemu-system-x

 

Any idea what that would be?

Share this post


Link to post
Just now, meoge said:

tcp        0      0 0.0.0.0:5900            0.0.0.0:*               LISTEN      15843/qemu-system-x

 

Any idea what that would be?

 

It's to access your VM.

 

Bridge mode should work fine.  It's the default and recommended mode.  Try to edit the config again and after you hit the Apply button, post the docker command that is showed.  Also, look again at the container logs.

Share this post


Link to post

Command after switching to bridge mode:

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="CrashPlanPRO" --net="bridge" -e TZ="America/New_York" -e HOST_OS="unRAID" -e "USER_ID"="99" -e "GROUP_ID"="100" -e "UMASK"="000" -e "APP_NICENESS"="" -e "DISPLAY_WIDTH"="1280" -e "DISPLAY_HEIGHT"="768" -e "X11VNC_EXTRA_OPTS"="" -e "CRASHPLAN_SRV_MAX_MEM"="4096M" -e "SECURE_CONNECTION"="0" -p 7810:7810/tcp -p 7910:7910/tcp -v "/mnt/user":"/storage":ro -v "/boot":"/flash":ro -v "/mnt/user/appdata/CrashPlanPRO":"/config":rw jlesage/crashplan-pro
400b1f3d13144d3662c40b79179ad93e7f49fc4fade1c92b81e9e33dde768f15

The command finished successfully!

 

Nothing is loading when I go to IP:5800 or IP:7810

 

 

CrashPlanProDockerLog.txt

Share this post


Link to post

Ok now the issue is that port mappings have incorrect container ports.  I think this is an issue that occurs when switching the network mode.

To bring back default mappings:

  • Remove ports from settings.
  • Apply settings.
  • Click the "Check for Updates" button (Docker tab).
  • Edit again the config.  Ports will be back.
  • Just re-apply the config (change any field and put it back to the same value).

Share this post


Link to post

That did it. Thank you for walking me through all of that. I have no idea why it stopped working, but hopefully things will be good going forward.

Share this post


Link to post

I am seeing this repeatedly. If I click Yes, it will attempt to start scanning files again, then after maybe 30 seconds it returns to this screen then has to restart scanning files again. Any ideas on what may be causing this loop?

crashpro.PNG

Share this post


Link to post

Looks like the backup engine is crashing...  How big is your backup?  Maybe you need to increase memory.

Share this post


Link to post

I completely didn't check the additional variables under the "Show advanced settings ..." button in the container settings. I increased it and the crashing has stopped, thank you!

Share this post


Link to post

I'm having the same issue with it disconnecting when I try to view the webGUI.  I have not been able to access it since installation.  Any ideas?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.