[Support] Djoss - CrashPlan PRO (aka CrashPlan for Small Business)

Recommended Posts

Thanks a bunch for the assistance @Djoss!


Originally everything appeared ok, having run the following due to migrating from 'that other docker' prior to starting up for the first time:  cp -a /mnt/user/appdata/CrashPlan /mnt/user/appdata/CrashPlanPRO


"Just re-select your files, they are under /storage."
Under the WebGui's files I see all the same folders selected:  

CJK1, CompInstalls, etc

..BUT the size shows a dash, as does the date modifed, and a note out to the right indicates 'file is missing'
When I click into the folders subfolders/files are all missing.

Even if i must reupload all, that is ok as it works out to only be 1 TB
Note that on the webportal if i select any date prior to 2 days ago all the files still exist for recovery. 

The log is attached

Log for_ CrashPlanPRO.html


edit:  under the original crashplan container i see the storage (mnt/user) has read/write while under crashplan pro container it is marked as read only.  

This article highlights the symptoms i am experiencinghttps://support.code42.com/CrashPlan/4/Troubleshooting/File_selection_shows_0MB_selected


Edited by landS
Link to comment
18 minutes ago, landS said:

Under the WebGui's files I see all the same folders selected:  

CJK1, CompInstalls, etc

Yes, these are a mirror of what you have in the cloud, but the files don't exist inside the container because their paths changed.


It's for this reason that you need to re-select your files that should also appear under /storage.  These are the ones that exist locally.

Link to comment

This makes sense to me...

But what does not make sense is that under the Docker settings for storage i have



And under the WebGui's Details/Manage file i can back up to 











but everything downstream of /mnt is 'broken/blank'




edit:  nm.  Now i see a grey scroll bar in the gui to get down to /storage.  barely visible in my browser 


Thank you greatly!


(this gui is a massive step backwards)







Edited by landS
Link to comment

Getting an error from CP that my system has not backed up in 5 days. Went to the console and I have an errors on the Web GUI stating, "CrashPlan PRO failed to apply an upgrade and will try again automatically in one hour". Appears the client keeps trying to do an internal upgrade and failing and has been doing this for days. It appears it will never attempt another backup until it can get past this upgrade problem.

Link to comment

If you are running CP 4.9.0, then you are not running the latest docker image.


In the Docker page, you clicked the "Check for Updates" button at the bottom?  If you don't see any update, go in container's settings and report what you have for the "Repository" setting. 

Link to comment

Just spun up this container after uninstalling gfjardim's home container and migrating over to CP for SB.


I had a couple hiccups with ports at first (the same issues as @meoge), but uninstalling/reinstalling seemed to have fixed that.


Unfortunately, I am now getting the error message "Code42 cannot connect to it's background service".


I tried a couple of restarts, but no luck. Any ideas?



Edited by dmrichards26
uploading relevant image
Link to comment

Also, since you are coming from another container, did you started with an empty appdata?  If not, I would do that.


After you sign in, choose the "replace a device" option, select your device then skip the file transfert.  Don't forget to re-select your files if their paths inside the container is not the same.

Link to comment

@Djoss I did make sure to start with a fresh appdata directory, knowing that would likely cause issues.


After taking a quick peak at engine_output, and seeing hundreds of the following error:

Error occurred during initialization of VM
Initial heap size set to a larger value than the maximum heap size

I realized that the error was with my configuration of the "Maximum Memory" setting. I entered 4096, forgetting to add "M". It appears leaving out the unit caused this error.


Changing to 4096M (or 4G) solved the problem.


Thanks for helping me realize the issue.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.