Jump to content

Drivers for Broadcom Dell Network cards

Recommended Posts

Hello people!


My question is why unraid doesn't include the drivers for the newest Dell integrated network cards. I just bought a brand new Dell T640 and tried to install unraid. Unfortunately i'm not in for any luck on the network side. Probably it's an driver issue because "lspci" does show the two cards inside my system. But they don't show as network interfaces on the unraid webinterface. I tried windows with the driver and it just works perfectly. I tried adding the linux drivers from dell but that didn't work for me. Maybe there is somebody that can help met with this problem.


Maybe it's the wrong topic for this sub but i'm pointing it out anyways.


Anyhow, Please please add driver support for the new Broadcom BCM57416 NetXtreme-E 10Gb RDMA Ethernet Controller network card from Dell.










Link to comment
10 hours ago, johnnie.black said:

Please post your diagnostics: Tools -> Diagnostics

I want to do that but I can't connect to the pc in the local network because the networking isn't working....

I can only "download" the zip on the local machine, not on a remote machine.

Link to comment
5 minutes ago, Bryans50 said:

I want to do that but I can't connect to the pc in the local network because the networking isn't working....

I can only "download" the zip on the local machine, not on a remote machine. 

On the console type diagnostics and the zip will be saved to your flash drive, then just plug it in a desktop.

Link to comment
1 minute ago, johnnie.black said:

Next time please use the forum instead of pm, but yeah the NICs are detected and no driver is loaded, if there's an available driver in the kernel LT are usually quick to add it and it should be on the next release.

Ah alright! thanks I'll wait for the next release. Is there any way I can add the drivers myself?

Link to comment
  • 2 months later...

I'm planning on using a Dell T640 server. Has there been any progress on a driver for the internal network adapter? Currently as of, 09/17/2018 the OS version of unRaid is 6.5.3. Would a workaround be to install a separate network adapter card that has a kernel driver? I chose this server because it can house (18) 3.5 HDD's.

  • Upvote 1
Link to comment

Those drivers have been included for a while now.  You can try latest 6.6.0-rc.  If no luck, we cannot do anything without diagnostics.zip because we need to see PCI ID's to see if they are actually in the source.  This site referenced by @Dazog says they should be, and looking at kernel 'menuconfig' we have all Broadcom device support turned on (and have for quite a while now), and specifically NetXtreme II 10Gb is included.

  • Like 1
Link to comment
  • 9 months later...

Hi all,


Resurrecting this post from almost a year ago 😊.

I just purchased a Dell Broadcom 57810 10GB duel nic and in the same situation as above.


Below you can see my NetXtreme II BCM57810 in IOMMU Group 10 and my onboard duel 1GB nic's in group 13 & 14.

So UNraid can see the new card.




Problem is they just keep showing up as interface down

Eth0 & 1 is set to the new 10GB card

Eth 2 & 3 is set to the onboard 1GB card




My log is currently being flooded with this. BNX2x is my 1 10GB port



Attached is my diagnostics please help 😜


Link to comment
  • 6 months later...
  • 3 months later...
  • 3 years later...

Broadcom 57416 Dual-Port 10GB (Dell 540-BBVJ)


Not tested with a router, just ran a cable to a server that has 10GB.

Guess this one is supported?

$ethtool eth2
Settings for eth2:
        Supported ports: [ TP ]
        Supported link modes:   1000baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: RS  BASER
        Advertised link modes:  1000baseT/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Speed: Unknown!
        Duplex: Unknown! (255)
        Auto-negotiation: on
        Port: Twisted Pair
        PHYAD: 12
        Transceiver: internal
        MDI-X: Unknown
        Supports Wake-on: d
        Wake-on: d
        Current message level: 0x00002081 (8321)
                               drv tx_err hw
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...