Help with InvoiceNinja docker?


cyberspectre

62 posts in this topic Last Reply

Recommended Posts

Just now, IronBeardKnight said:

man I'm having so much trouble with this container 

 

.env trick then get chown  error for it in the setup page, so chow whole app directory as the ,env does not exist anymore. Wooo hoo one sep further.

then straight up after submit on setup page straight up 500 error. and so many errors in the logs 

 

 child 37 said into stderr: "src/Illuminate/Pipeline/Pipeline.php(149): Illuminate\Cookie\Middleware\EncryptCookies->handle(Object(Illuminate\Http\Request), Object(Closure)) #36

 

etc etc. 

would be so good if this worked properly. Not sure why this container self generates ssl cert through lets encrypt but most people running the container will be using reverse proxies anyway.

tried editing in  GEN_SSL but it just completely breaks the container.

Link to post
  • 1 month later...
  • Replies 61
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I have resolved my password issues!  DO NOT put a URL in the Client Portal box.  It will SCREW you.  Also there is a separate hidden page for client logins at host.com/client/login so when testing the

@Benjamin Picard yes, it's beta-ish. I will create another post for it, but did not have time. @newillusions helped me test it so far, and only the export doesn't work from v5, but there is a fix for

Okay, as you might imagine, I am very excited to tell you.... I GOT IT WORKING in that unraid container... Below are the (rough?) steps I followed.   Please keep in mind that I am JUST

Posted Images

1 hour ago, newillusions said:

Sorry for resurrecting a zombie, but did anyone manage to get a v5 install running?
Would love to keep using this on my home server rather than migrating to the remote web one.

@newillusions I'm running v4.5.37.
Unfortunately anojht/invoiceninja repository only has 4.x version so for v5 I think we'd have to create a whole different Docker image since anojht doesn't have issues enabled for the repository unfortunately :( 
After a quick Google search I realized that upgrading involves creating a whole new install, and using the migration tool. I'd be willing to create a different repo for this, would you have time to help me test?

 

@IronBeardKnight sorry for being late to the party, but in case it's still relevant: what error did you get when trying to disable GEN_SSL?

Link to post
  • 5 weeks later...

@Benjamin Picard yes, it's beta-ish. I will create another post for it, but did not have time. @newillusions helped me test it so far, and only the export doesn't work from v5, but there is a fix for that which I didn't have time yet to include into the Docker image yet. I will later tonight.

For now it's not official in UnRAID, so to install it you have to add this url in Docker -> (Scroll down) -> Template Repositories and click Save:

https://github.com/mihai-cindea/invoiceninja_v5

 

After that you should be able to click "ADD CONTAINER" and then select "invoiceninjav5" from the templates, and the rest should be pretty similar how to setup v4.

You can find more info, including on how to migrate here:

https://github.com/mihai-cindea/invoiceninja_v5#upgrade-from-v4-to-v5

 

One thing worth mentioning for which I didn't find a solution yet, is that you HAVE to import the self signed certificate in your browser if you don't somehow use LetsEncrypt to have proper certificates. For some reason even if I acknowledged the SSL error in the browser, some requests simply failed due to the bad cert. I think it was Chrome, so it might work in other browsers. Also disabling SSL with `REQUIRE_HTTPS=false` didn't seem to work for me, but if you find a way, please let me know so we can update the documentation :)

 

Feel free to PM if you have any questions or issues

Edited by Mihai
Link to post

@Mihai Hey thank you for that work on getting invoiceninja to work on unraid without any issues. Would it be possible to keep it updated to latest v5-stable, since invoiceninja is @ 5.2.x and this is on an older 5.1.x version? 

 

Thanks again for the work 

Link to post

@Mihai Thanks for that, could you also make sure you run php artisan migrate:status or php artisan migrate, it might be another command but whichever it is to properly do any DB updates prior to starting up because I am currently stuck on a loop and can't run it on the container since it fails to boot up services and crashes.

Edited by razor950
Link to post
  • 2 weeks later...

Having a very strange issue. Currently I have it running fine for the most part. I can access the app via the local IP and port (192.168.1.21:8443) and it loads fine. I CANNOT access it via the domain set up in NPM (invoice.example.com) on a machine that is on the same network as the server hosting it. I CAN access it via the domain on a machine that is not on the same network, so if I VPN or remote into my home machine, the domain works fine. Any idea as to why that might be?

Link to post
  • 3 weeks later...

@MihaiI got it to start, wich is more then the v4 version, but when I log in and want to change the company name I get this

422: The given data was invalid.

 • The portal domain format is invalid.

 

any idea how to resolve this?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.