Jump to content
FoxxMD

[Support] FoxxMD - shoginn-vrs

9 posts in this topic Last Reply

Recommended Posts

Application Name: shoginn-vrs

Application Site: http://virtualradarserver.co.uk

Github Repo: https://github.com/ShoGinn/virtualradarserver-docker

Docker Hub: https://hub.docker.com/r/shoginn/vrs @ShoGinn <3

Template Repo: https://github.com/FoxxMD/unraid-docker-templates

 

Overview

 

Virtual Radar Server is an open-source .NET application used to overlay and track the real time position of aircraft on a map within a modern browser. VRS can receive aircraft data from a multitude of sources including ADS-B streams.

 

vrs.thumb.jpg.f38e9527a5618c7c8aaabccf792f5bee.jpg

 

 

Requirements

 

  • A configuration directory (default mapped to /mnt/user/appdata/vrs)
  • A port exposed for the web ui (default mapped to 8117) 

 

Optionally, if you want to see anything, you will need to configure at least one Receiver (data source). I highly recommend a cheap RTL-SDR usb device and shoginn-dump1090, available in Community Apps ;)

 

 

Usage (Setup)

 

The Admin Interface can be accessed at http://IP:PORT/VirtualRadar/WebAdmin/Index.html

 

Adding a Data Source (Receiver)

 

  • Access the Admin Interface
  • Navigate to Options => Receiver Locations
    • Add a new Location with the Lat/Long of your data source
  • Navigate to Options => Receivers
    • Add a new Receiver and specify Location from the dropdown as the one added from above
    • Use these settings if you are using shoginn-dump1090:
      • Format: AVR or Beast Raw Feed | Address: [IP of dump1090] | Port: [Port of dump1090]
      • Check "Send keep-alive packets"

 

Make sure to hit Save at the bottom of the page!

 

Your data source is now setup and should be feeding VRS. You can verify this by going to Connector Activity Log (located on the Admin Interface).

 

Saving Default Client Settings (Map Location, etc.)

 

  • Navigate to the Web UI for shoginn-vrs
  • In the top-left corner navigate Menu => Options
    • To set default Map Location
      • On the General tab click "Set current location", then drag the marker to the desired center position on the map
    • Set any other default settings in the Options window at this time, then close it
  • In a new window navigate to http://IP:PORT/VirtualRadar/settings.html
    • Click Export Settings
    • Copy all of the text in the input box that appears
  • In the Admin Interface navigate to Options => Initial Settings
    • Paste the contents of the input box into the input box for Exported settings
    • Save your changes at the bottom of the page

 

Using VRS with a reverse proxy (nginx)

 

Refer to this comment for how to setup VRS behind a reverse proxy. 

Edited by FoxxMD

Share this post


Link to post

Thanks for all the dockers. I have all the Shoginns installed & they are all working perfectly.

 

although shoginn-flightradar24 wouldn't start with the MLAT enabled.

Share this post


Link to post
40 minutes ago, FoxxMD said:

@PSYCHOPATHiO ive mentioned that issue in the support thread! In the docker settings set mlat and mlat w/o gps to no.

sorry i was excited trying to install everything at once, but it didn't take me long to find it out as it was basic troubleshooting.

Share this post


Link to post

Hi,

 

i got an issue with silhouettes dissapearing since the latest update, i just got flight traces and callsign/Reg/alt box, everything was working perfectly before. Any idea where it might comes from ?

 

Share this post


Link to post

Check your admin ui and make sure that "/opt/vrs/Flags/" and "/opt/vrs/Silhouettes" are in there

 

But my guess is you are mentioning the markers and plane icons on the map.

 

I don't run VRS anymore (moved to modes mixer) but I spun up my old container and noticed the problem.

 

Not sure if its a Mono thing (I use latest..) so I'll revert back to an older Mono and see if that changes anything!

Share this post


Link to post

Looks like i spoke too fast, curiously some a/c are still missing markers. That did not happen before. 

Edit: if i click at where the a/c is supposed to be, the selected yellow marker appears along with alt line and dissapear again if i click elsewhere.

 

It might be related to some picture handling issue as the a/c pictures (those top right) which had also dissapeared are back.

I did a quick check the same PNG could be perfectly fine for an a/c but not for another one, only change is the rotation.

 

No a/c marker, just a blank png: images/web-markers/top/Wdth-40/Hght-112/Rotate-330/Alt-70/CenX-20/WTC-Medium-2-Jet.png
a/c marker as usual: images/web-markers/top/Wdth-40/Hght-112/Rotate-200/Alt-70/CenX-20/WTC-Medium-2-Jet.png

 

in the log:

libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: cHRM chunk does not match sRGB

 

might be an issue with incorrect pngs having troubles being handled by an updated libpng.

 

missing-markers.thumb.PNG.edf6d9f2f8f721d557e2ee2286438889.PNG

 

The select/unselect behavior 

Capture.PNG.d5ed586decc1ac49a5ce018be84bb868.PNGCapture2.PNG.8051083f9a2443dfe1ccde283992db02.PNG

Edited by butch2k

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.