External USB drive not showing up

Recommended Posts

Hi guys I've attached a brand new external WD Easystore 8T drive to my server via USB3.0 but for some reason it's not showing up under "Unassigned Devices" or as available for preclear via the plugin. I'm running the latest Unraid  pro version and puzzled by this. I can feel the drive spinning and I can also explore it when connected to my windows PC meaning it's not a bad drive.

What could be wrong here?

Link to comment

Thank you. Rebooting the array did the trick. USB drive is now showing up under "Unassigned Devices" and also available for pre-clear.

Problem solved. I have done this severl times before but don't recall having to reboot for drive recognition. Thanks again for the suggestion.

Link to comment
  • 2 years later...
  • 1 year later...
On 6/16/2020 at 4:31 AM, JorgeB said:

Rebooting shouldn't be needed for this, but glad it's working now.

Same issue as well, tried two different USB 3.0 external drive enclosures. Rebooting gets it working again but then eventually detection fails.

Link to comment
  • 2 weeks later...
9 hours ago, JonathanM said:

Different USB controller on the motherboard? Different USB modes in BIOS?

I can try different USB ports but there's been a recent regression as far as I can tell. Several versions ago this wasn't an issue (or several versions of the plugin ago).

7 hours ago, trurl said:

Are you trying to pass a USB controller to a VM?

Not the controller(s) but a few individual devices, yes. Those are successfully being passed and many preclears have been successful without this issue.

I've been able to successfully preclear drives this with non-UASP enclosures a dozen times or so but the past several versions of UNRAID seem to have made this more problematic. Perhaps related but at least one time the unassigned devices plugin dropped nfs/smb shares and needed a reboot. The plugin itself may be part of the issue here.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.