[SOLVED] Is the Realtek RTL8125B-NIC supported?


14 posts in this topic Last Reply

Recommended Posts

I have a small problem with my UNRAID-Server. I replaced the hardware of the hostsystem. Everything expect the NIC works fine. 
Mainboard is an Asus TUF GAMING B550-PLUS with a Realtek RTL8125B 2.5Gb Ethernet-NIC. If I boot just with this NIC I get a random private IP. I have deleted from the boot-Partition the network.cfg and edited this file. With an USB-NIC the network works almost fine but seems to stops working after a random time.

 

Any Ideas what to do? I did not find any information on installing drivers. I don't have any further information on Slackware. I think the RTL8125B-Chip is not fully supported at this point and I need another NIC. Can anyone confirm this issue? Or are there any solutions to this problem. 

Link to post
  • JorgeB changed the title to [SOLVED] Is the Realtek RTL8125B-NIC supported?

Does the v6.9-beta25 include drivers for Realtek RTL8125 (no "B") correct? 

 

I know this is a stupid question, but I have some serious issues with NIC installation with Unraid and want to be 100% sure this time... 

 

Am about to pull the trigger for this NIC (built with the RTL8125 chipset): 

https://www.amazon.ca/gp/product/B07Y2GWVB8/ref=ox_sc_act_title_2?smid=A1CG9BNSUV962M&psc=1

 

 

 

Edited by coyoung@gmail.com
fml - second amazon link is sold out. reverted to original amazon link to 2.5 gb nic.
Link to post
2 hours ago, JorgeB said:

It should.

I'm not entirely sure about this:

<node id="network" claimed="true" class="network" handle="PCI:0000:08:00.0">
             <description>Ethernet interface</description>
             <product>RTL8125 2.5GbE Controller</product>
             <vendor>Realtek Semiconductor Co., Ltd.</vendor>
             <physid>0</physid>
             <businfo>pci@0000:08:00.0</businfo>
             <logicalname>eth0</logicalname>
             <version>04</version>
             <serial>[REMOVED]</serial>
             <size units="bit/s">1000000000</size>
             <capacity>1000000000</capacity>
             <width units="bits">64</width>
             <clock units="Hz">33000000</clock>
             <configuration>
              <setting id="autonegotiation" value="on" />
              <setting id="broadcast" value="yes" />
              <setting id="driver" value="r8125" />
              <setting id="driverversion" value="9.003.05-NAPI" />
              <setting id="duplex" value="full" />
              <setting id="latency" value="0" />
              <setting id="link" value="yes" />
              <setting id="multicast" value="yes" />
              <setting id="port" value="twisted pair" />
              <setting id="slave" value="yes" />
              <setting id="speed" value="1Gbit/s" />
             </configuration>
             <capabilities>
              <capability id="pm" >Power Management</capability>
              <capability id="msi" >Message Signalled Interrupts</capability>
              <capability id="pciexpress" >PCI Express</capability>
              <capability id="msix" >MSI-X</capability>
              <capability id="vpd" >Vital Product Data</capability>
              <capability id="bus_master" >bus mastering</capability>
              <capability id="cap_list" >PCI capabilities listing</capability>
              <capability id="ethernet" />
              <capability id="physical" >Physical interface</capability>
              <capability id="tp" >twisted pair</capability>
              <capability id="10bt" >10Mbit/s</capability>
              <capability id="10bt-fd" >10Mbit/s (full duplex)</capability>
              <capability id="100bt" >100Mbit/s</capability>
              <capability id="100bt-fd" >100Mbit/s (full duplex)</capability>
              <capability id="1000bt-fd" >1Gbit/s (full duplex)</capability>
              <capability id="autonegotiation" >Auto-negotiation</capability>
             </capabilities>
             <resources>
              <resource type="irq" value="66" />
              <resource type="ioport" value="c000(size=256)" />
              <resource type="memory" value="fcc00000-fcc0ffff" />
              <resource type="memory" value="fcc10000-fcc13fff" />
             </resources>
            </node>

Shuldn't there be a capability like "<capability id="2500bt-fd" >2,5Gbit/s (full duplex)</capability>"? So the support is there but "only" with 1 GBit/s FD?

Link to post
43 minutes ago, Sebastian Apprecht said:

Did not matter for me in this case. But in general that might be an issue.

Oh, I see, you were talking about 2.5GbE support, that I don't know, very few people with 2.5GbE, don't remember anyone with 2.5GbE capability posting about that NIC in the forum.

Link to post
1 minute ago, JorgeB said:

Oh, I see, you were talking about 2.5GbE support, that I don't know, very few people with 2.5GbE, don't remember anyone with 2.5GbE capability posting about that NIC in the forum.

Yes, on all upcoming consumer/prosumer boards there will be more likely 2.5GbE onboard, so the hassle might be at a later point and you don't need to get 10 GbE SPF+ or (more or less reliable) RJ45 with copper and you just dump it into your 10 GbE Router/Switch. Otherwise I don't know the reason because I would get an RTL8125 (2.5GbE Nic) like @coyoung@gmail.com - just wanna help :)

 

For me it was the buying decision for a "cheap" NAS that is somewhat future-proofed.

Link to post

To anybody trying to purchase the RTL8125 NIC - DON'T.  

 

Unraid recognizes the 8125 NIC as a 1.0 gbe.  

 

I have just purchased a brand new OEM Intel X540-T2 from Ebay for ~$90 USD.   Seems like that NIC works with Unraid.  

 

https://www.ebay.ca/itm/Intel-OEM-X540-T2-10G-Dual-RJ45-Ports-PCI-Express-Ethernet-Network-Adapter/142022690949?hash=item2111364885:g:arMAAOSwn8FXSp04

Edited by coyoung@gmail.com
Link to post
  • 2 months later...

I'm planning on doing a new amd build and wanted to get some benefit out of my 2.5G switch and was hoping that unraid would support it by now.

 

Can someone confirm if unraid 6.9.x in fact does do 2.5G with one of these nic's:

  • Realtek RTL8125-CG  (from ASUS CROSSHAIR VIII HERO)
  • Dragon RTL8125AG (from ASRock X570 Phantom Gaming X)

 

Link to post
  • 1 month later...

Apologies for posting on this thread that didn't see any updates in a while, just wondering if anyone managed to get 2.5G speeds on 8125 cards?

 

I have RTL8125 both on my unraid tower and my desktop machine (Windows 10), connected together directly using a fairly chunky 1 meter long cat6 cable and no matter what I tweak (mtu settings, parallel threads etc)  I can't get past 1.32Gbits/sec on iperf3:

 

image.thumb.png.9c432a977d40d07216e2b725eb9af719.png

 

MTU is set to 9000 on both the server (unraid tower) and client (my desktop).

 

Any idea what might be wrong?

 

This is using Unraid Version: 6.9.0-rc2.

 

Thanks.

 

UPDATE: After updating the Windows driver for RTL8125 (using "Win10 Auto Installation Program (SId:1152921505692730722) / 10.045 / 2020/12/31" downloaded from here) AND explicitly setting the "Speed & Duplex" setting to "2.5Gbps Full Duplex" in device properties -> Advanced (updating the driver alone didn't do anything), I now get 2.5Gbps speeds on iperf:

 

image.thumb.png.04bf9c83423405d853a1bebce087b0a6.png

 

Don't forget to reboot Windows after changing that setting, I was getting a few hundred kbits until I rebooted which was puzzling...

 

Hope this helps folks with the same setup as mine.

 

Edited by hamzas
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.