rojarrolla

Members
  • Posts

    106
  • Joined

  • Last visited

Everything posted by rojarrolla

  1. I've Never used Letsencript. If I want to use SWAG is the same install and config? Thanks.
  2. Rsync works very well, however it is not real time. I've Seen GDrive2, but it syncs to Google. Is there an app that works like that? Thanks
  3. I will tell you what I know. Maybe it will give you some information. Something similar happened to me, I lost my cache drive too and restored the .img file from the CA Backup/Restore. But, mine was 6 days old. My Nextcloud worked after restoring, however, files stored in the cache drive, were not passed on to the array. I could recover them, but, when the user was running the nextcloud client from her computer, she got a lot of synching errors. So I had to erase and upload again everything. My best advice is to backup realtime or at least daily the Database (I use MariaDB), The containers and synch the files to another NAS. I hope this helps you at least something.
  4. Hello, I have a similar issue. I've experiencing some problems to reach the WebUi. I have "solved" by restarting the services like this: /etc/rc.d/rc.php-fpm restart /etc/rc.d/rc.nginx restart I have 2 Networks, the 192.168.100.X and the 192.168.2.X. I can not access the WebUi through the 192.168.2.X network, however, windows can access the shares and Nextcloud service is working fine and even remotely. Through the 192.168.100.X network, I can reach the WebUI. I have rebooted the server and it is the same. Here is my config file. I hope you can give me a hint. Thanks. tower-diagnostics-20211004-1113.zip
  5. Thanks for the tip. Is there a way to have it backed up real time?
  6. Hello guys! thanks for all your work to make possible Nextcloud in Unraid. I want to ask you some questions. But let me first explain you what happened to me. I have a server running nextcloud in a docker container. It has an ssd as cache drive that holds the Nextcloud folder where all the files are stored before being moved to the array (my first mistake). Just to justify this, I was trying to speed up data transmissions but, since all the clients accessing this server are over the internet, it makes not much of a difference. And, in this case, was a disadvantage. The thing is that I changed the server, and moved the drives to another one, started the array, but, to my bad luck the parity disk failed and I had to replace it. So I was distracted and never realized that the cache one was not recognized by Unraid (second mistake), and, despite of that, the array started normally and Nextcloud and MariaDB (which run from the cache drive) started as well. (it should be at least a flag there if the cache drives are missing when starting the array). So when I loggid into nextcloud's webUI, It was asking me to configure the database. So I panicked and the best solution I could come up was to restore my appdata backup but it was 6 days old (third mistake). Then started Nextcloud again and it went "well". I could log on and all the users were being recognized but I wasn't aware that there were misstakes going on. Next day in the morning users were complaining that all their Nextcloud folders were missing files from last week. So, the worst of all (like it hadn't been enough already) was that, due to the outdated database, Nextcloud deleted the newer files and those who had changes where an endless list of problems in the user application: checksum errors, sync errors, to mention some. Why did Nextcloud did this instead of asking the user to keep or delete those files? I was really stressed. And I hope it does not happen to any of you guys. So, I would like to understand deeper how Nextcloud + MariaDB work, because I thought that the database was only storing user names and passwords, but, as you have seen it is not. What else is stored in that database that needs to be handled carefully? Dos any of you have a good knowledge about how Nextcloud works internally In order to troubleshoot it better and faster? And it is quite a topic, what to do and how to properly have Nextcloud backed up and maintained so data loss won't happen. If there is here an advice on the best practices of how to proceed in case of critical hardware failure, I am open to suggestions and I hope that you can learn from my mistakes. Here is what I've learned so far: 1.- Dont Use a Cache Drive for Nextcloud, at least from users that rely on it remotely. 2.- Backup MariaDB daily If more than once every day, much better. 3.- Every time the array starts, to check if all the cache pools and drives are working correctly. 4.- Don't jump fast into restoring backups, the right files could still be there... hidden. Thanks in advance. Cheers.
  7. I also run an Rsync for my Nextcloud share, but I do not delete any directory. It has been running for 1 week and I hadn't had this issue before. Well in my case, /etc/rc.d/rc.php-fpm restart brought the NGINX Server online. However, Nextcloud and MariaDB, which are the only services I'm using my unraid server were woriking fine, I did not want to reboot since there are clients relying on nextcloud for their daily work. I hope this adds some information up! Cheers.
  8. OK, No, I haven't, I will try to look into it, and if I find how, I will post the 2 options and mark this thread as solved. Should you know before me, please let us know in this thread. Thanks!
  9. I didn't know that was even possible, but if you write a tutorial of how to do it I will make another showing how to do it the way I did it. Do we have a deal?
  10. Hi guys! I've been crawling the internet and not been able to find anything clear. Currently I want to have a backup unraid server in case of hardware failure. So I want to go from server A to server B. I have nextcloud running and I would like to backup the whole nextcloud (docker container, MariaDB and Nextcloud Share). I was thinking to run a backup on server A and recover it on server B. then to copy the whole Nextcloud share. I don't know if it is that simple, but at leasts shows you what I am trying to achieve. Have any of you guys done this? I mean If you have a couple of users relying on nextcloud and if it breaks, what would happen? Thanks a lot.
  11. Hi, I did some digging, and used the console with the "tail" command to the syslog file when starting the array and I found that the array was starting correctly (good thing!) that is why there were no errors on the drives. However, unraid is mounting a "shim-eth0" ethernet card, with the same ip adress as my eth0 card, so, that was why the GUI "stopped working" (it never did) it was only unreacheable. Then I took it down and I can acces the GUI again, the array is ok and all the shares are there. So, Unraid never stopped working, the array was working fine, the problem is that there were then 2 ethernet cards (eth0 and shimeth0) with the same IP address. I hope this helps. I will keep looking to see if I can figure out, why the shimeth0 is created. If you know why, it happens, I'll be very thankful. Thanks.
  12. Here is the one created when trying to start the array. tower-diagnostics-20210726-1112.zip
  13. If I try to start in normal mode, it hangs and I can not access the Graphic interphase. I can access via console and then "powerdown -r" from there. I will try to generate the diagnostics file when "starting" the array in normal mode. Auto start is disabled, just a precaution since I've been running some tests. But I can enable it.
  14. Thanks, I mean I can only start it on Maintenance Mode. Here is a copy of the diagnostics: Thanks tower-diagnostics-20210726-1231.zip
  15. Hi, where do you find which drive is the faulty one? My array is not starting, there are no errors in the parity but I need to run the diagnostics again, but I don't know wich drive should repair.
  16. Ok, I'll do that this weekend and I'll keep you posted. Thanks a lot!
  17. If it is not cleanly powered down, I can think that it is normal as you said, but, I always try to do clean shut downs in order to take a good care of the drives. I have other drives, do you think it would be a good idea to try another one? In order to replace the drives I need to stop the array ? Or I just can hot swap it? Thx a lot!
  18. Hello JorgeB. Yes, it is always the same device. What do you mean it is normal? I shut down safely the server instead of letting the power cut shut it down.
  19. Hello to all, thanks in advance for all the answers you've written here. I know this thread is been closed, but I don't think we quite have a solution for this yet. I mean If you format the drive and assing it to the array it is "fixed" but in my case I am still getting this issue. It's been a while since I posted regarding this issue, but, since it is a server I don`t shut it down frequently. As long as it is online there are no issues. However, I had a long power cut yesterday, and I had to shut down the server for around 24 hours and now that I started it again and started the array, I get the same message: (unsupported partition layout) I am getting used to it because if I restart the server normally there is no problem, the issue appears. I can format the drive again and set it online. I don´t have many data on this drive, however, I've been reluctant to add information there since I don't quite like this situation and I would like to fix it before I place more data on it. Do you think it would be the drive? Thanks! PS here are my diagnostics. tower-diagnostics-20210519-1100.zip
  20. A friend of mine helped me to install it via command line, (he is a genius in linux by the way) however the sad part is that This OpenVPN only works for free for 2 simultaneous connections. If you need more, you need to pay for the service. Just a heads up, should you need more connections for free, I would suggest to find another app that can do the job and stop loosing time trying to make this one work. Cheers!
  21. I've sat here for a while and took me some days to finish reading ALL the posts so far. First of all I want to thank and congratulate @JTok for making this plug in. And I wish you the best from now on. I've read that you don't have a test server. Feel free to tell me and I can grant you access in mine should you want to run some tests. However I'm backing up Win 2012 Server, Win 7 and win 10 VMs. And sometimes the backup is done and some it is not. I've installed the plugin a couple of weeks ago and I'm in a run test phase. I found in the logs that the problem is that the VMs are not being shut properly and when that happens the vm is not backed up. I don't know if you could point me in some direction in order to start looking I would really appreciate it. TIA!
  22. I have the same problem here: "Sorry, a session error has occurred It is possible that your session has expired or your login credentials do not allow access to this resource. See error text below for further details: SESSION ERROR: SESSION: Your session has expired, please reauthenticate (9007)" Thanks!
  23. I get something similar regarding Krusader: "Docker application binhex-krusader has volumes being passed that are mounted by Unassigned Devices, but they are not mounted with the slave option". However, my unassigned devices are accessible through Krusader. I'm ignoring it then.