monarc

Members
  • Posts

    55
  • Joined

  • Last visited

Everything posted by monarc

  1. Hej, I have the same problem, Gluetun was updated shortly and now I am getting the following error messages. 2021/09/30 12:41:29 ERROR cannot read servers from file: json: cannot unmarshal string into Go struct field ProtonvpnServer.protonvpn.servers.exit_ip of type []net.IP 2021/09/30 12:41:29 INFO Shutdown successful 2021/09/30 12:43:03 ERROR cannot read servers from file: json: cannot unmarshal string into Go struct field ProtonvpnServer.protonvpn.servers.exit_ip of type []net.IP 2021/09/30 12:43:03 INFO Shutdown successful
  2. Magst du mal dein Skript teilen welches du auf dem Synology nutzt, da hast du doch sicherlich die ein oder andere Anpassung gemacht. Kann es dann bei Gelegenheit mal mit meinem vergleichen.
  3. Das stimmt natürlich 👍
  4. Muss meine Aussage von eben revidieren bei mir sieht es so aus... externe HDD /Skript läuft unter UNraid: mnt/disks/Daily_Backup/Shares/Share Name/Datum/Share Name Synology / Skript läuft unter Synology: [...]/Shares/Share Name/Datum/Share Name Also quasi auf beiden Systemen identisch. Nur wieso der Share Name doppelt verwendet wird ist mir nicht ganz klar und eigentlich nicht notwendig, oder?!
  5. Also bei meinem Backup von Unraid auf externe HDD ist es auch genau so.... mnt/disks/Daily_Backup/Shares/Share Name/Datum Ich meine aber, dass es auf meinem Synology auch anders war... ich schau gleich mal nach
  6. Die HDDs spielen da auf jeden Fall eine Rolle. Die normalen HDDs haben ja soweit ich weiß nur so um die 120 MB/s schreiben und lesen!?
  7. Hi Pixelpaule, bei mir läuft das Script auf meinem Synology NAS. Hab ehrlich gesagt jetzt aber auch schon länger nicht geschaut wie der Status ist. Mache ich die Tage mal und geben Rückmeldung. Auch bei dem Fehler mit der gelöschten Datei bin ich mir gerade nicht sicher. Das initiale Backup hat schon relativ lange gedauert, aber da es bei mir nicht so viele bzw. große Änderungen gibt gehen die inkrementellen Backups jetzt immer sehr zügig. Genaue Angaben zur Geschwindigkeit kann ich allerdings nicht machen. Habe aktuell viel um die Ohren, daher kann es ein paar Tage dauern bis ich mich mit weiteren bzw. detaillierteren Infos wieder melde.
  8. Did it and first I wasn't able to mount but then I re-entered the encryption password in the UD settings and now I was able to mount the drive. Do you know if there are any restrictions regarding the encryption password? I will try everything from scratch with the 1TB HDD again in the next days, to see if what happens. I will keep you posted. Thanks a lot for your help so far. Very much appreciated. What should I do with the lib.php I have copied over? Leave it or delete it?
  9. root@Unraid:/usr/local/emhttp/plugins/unassigned.devices/include# cp /mnt/user/Marc/lib.php /usr/local/emhttp/plugins/unassigned.devices/include/lib.php root@Unraid:/usr/local/emhttp/plugins/unassigned.devices/include# ls -l total 80 -rwxr-xr-x 1 root root 1078 Jun 20 2020 Legacy.php* -rwxr-xr-x 1 root root 3145 Feb 13 20:25 fsck.php* -rwxr-xr-x 1 root root 68440 May 12 23:32 lib.php* -rwxr-xr-x 1 root root 1762 Feb 13 20:25 script.php* root@Unraid:/usr/local/emhttp/plugins/unassigned.devices/include# rm /var/state/unassigned.devices/unassigned.devices.ini May 12 23:33:01 Unraid unassigned.devices: Adding disk '/dev/mapper/Intenso_External_USB_3.0'... May 12 23:33:03 Unraid unassigned.devices: Mount drive command: /sbin/mount -o rw,noatime,nodiratime '/dev/mapper/Intenso_External_USB_3.0' '/mnt/disks/Intenso_External_USB_3.0' May 12 23:33:03 Unraid kernel: /dev/mapper/Intenso_External_USB_3.0: Can't open blockdev May 12 23:33:03 Unraid unassigned.devices: Mount of '/dev/mapper/Intenso_External_USB_3.0' failed: 'mount: /mnt/disks/Intenso_External_USB_3.0: special device /dev/mapper/Intenso_External_USB_3.0 does not exist. ' May 12 23:33:03 Unraid unassigned.devices: Partition 'Intenso External_USB_3.0' cannot be mounted.
  10. I hope I did everything right? Why did I have to copy it to the flash drive (/boot/) first? root@Unraid:/boot# cp /mnt/user/Marc/lib.php /boot/lib.php root@Unraid:/boot# cp /boot/lib.php /usr/local/emhttp/plugins/unassigned.devices/include/lib.php root@Unraid:/usr/local/emhttp/plugins/unassigned.devices/include# ls -l total 80 -rwxr-xr-x 1 root root 1078 Jun 20 2020 Legacy.php* -rwxr-xr-x 1 root root 3145 Feb 13 20:25 fsck.php* -rwxr-xr-x 1 root root 68423 May 12 23:19 lib.php* -rwxr-xr-x 1 root root 1762 Feb 13 20:25 script.php* Unfortunately, it did not help. May 12 23:20:38 Unraid unassigned.devices: Adding disk '/dev/mapper/Intenso_External_USB_3.0'... May 12 23:20:40 Unraid unassigned.devices: Mount drive command: /sbin/mount -o rw,noatime,nodiratime '/dev/mapper/Intenso_External_USB_3.0' '/mnt/disks/Intenso_External_USB_3.0' May 12 23:20:40 Unraid kernel: /dev/mapper/Intenso_External_USB_3.0: Can't open blockdev May 12 23:20:40 Unraid unassigned.devices: Mount of '/dev/mapper/Intenso_External_USB_3.0' failed: 'mount: /mnt/disks/Intenso_External_USB_3.0: special device /dev/mapper/Intenso_External_USB_3.0 does not exist. ' May 12 23:20:40 Unraid unassigned.devices: Partition 'Intenso External_USB_3.0' cannot be mounted.
  11. is it this what you are looking for? May 12 22:25:27 Unraid kernel: usb 2-3: USB disconnect, device number 5 May 12 22:25:27 Unraid kernel: sd 11:0:0:0: [sdg] Synchronizing SCSI cache May 12 22:25:27 Unraid kernel: sd 11:0:0:0: [sdg] Synchronize Cache(10) failed: Result: hostbyte=0x01 driverbyte=0x00 May 12 22:26:05 Unraid kernel: usb 2-2: new SuperSpeed Gen 1 USB device number 6 using xhci_hcd May 12 22:26:05 Unraid kernel: usb-storage 2-2:1.0: USB Mass Storage device detected May 12 22:26:05 Unraid kernel: scsi host11: usb-storage 2-2:1.0 May 12 22:26:07 Unraid kernel: scsi 11:0:0:0: Direct-Access Intenso External USB 3.0 5438 PQ: 0 ANSI: 6 May 12 22:26:07 Unraid kernel: sd 11:0:0:0: Attached scsi generic sg6 type 0 May 12 22:26:07 Unraid kernel: sd 11:0:0:0: [sdg] 1953525164 512-byte logical blocks: (1.00 TB/932 GiB) May 12 22:26:07 Unraid kernel: sd 11:0:0:0: [sdg] Write Protect is off May 12 22:26:07 Unraid kernel: sd 11:0:0:0: [sdg] Mode Sense: 23 00 00 00 May 12 22:26:33 Unraid flash_backup: adding task: php /usr/local/emhttp/plugins/dynamix.unraid.net/include/UpdateFlashBackup.php update May 12 22:26:37 Unraid kernel: usb 2-2: reset SuperSpeed Gen 1 USB device number 6 using xhci_hcd May 12 22:26:38 Unraid kernel: sd 11:0:0:0: [sdg] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA May 12 22:26:38 Unraid kernel: sdg: sdg1 May 12 22:27:08 Unraid kernel: usb 2-2: reset SuperSpeed Gen 1 USB device number 6 using xhci_hcd May 12 22:27:08 Unraid kernel: sd 11:0:0:0: [sdg] Attached SCSI disk May 12 22:27:09 Unraid unassigned.devices: Disk with serial 'External_USB_3.0_20130522013291', mountpoint 'Intenso_External_USB_3.0' is not set to auto mount. May 12 22:27:09 Unraid unassigned.devices: Issue spin down timer for device '/dev/sdg'.
  12. Sorry, but where do you see a period in the mountpoint of the new disk? I also tested other mountpoint names like "Test" with the previous two disks and also with the new disk. May 12 15:03:26 Unraid unassigned.devices: Adding disk '/dev/mapper/Test'... May 12 15:03:28 Unraid unassigned.devices: Mount drive command: /sbin/mount -o rw,noatime,nodiratime '/dev/mapper/Test' '/mnt/disks/Test' May 12 15:03:28 Unraid kernel: /dev/mapper/Test: Can't open blockdev May 12 15:03:28 Unraid unassigned.devices: Mount of '/dev/mapper/Test' failed: 'mount: /mnt/disks/Test: special device /dev/mapper/Test does not exist. ' May 12 15:03:28 Unraid unassigned.devices: Partition 'Test' cannot be mounted.
  13. New disk, same problem. 😒 May 12 13:04:44 Unraid unassigned.devices: Device '/dev/sdg' block size: 625142448. May 12 13:04:44 Unraid unassigned.devices: Clearing partition table of disk '/dev/sdg'. May 12 13:04:44 Unraid unassigned.devices: Clear partition result: 1+0 records in 1+0 records out 2097152 bytes (2.1 MB, 2.0 MiB) copied, 0.0650799 s, 32.2 MB/s May 12 13:04:44 Unraid unassigned.devices: Reloading disk '/dev/sdg' partition table. May 12 13:04:44 Unraid unassigned.devices: Reload partition table result: /dev/sdg: re-reading partition table May 12 13:04:44 Unraid unassigned.devices: Creating Unraid compatible mbr partition on disk '/dev/sdg'. May 12 13:04:44 Unraid unassigned.devices: Create mbr partition table result: write mbr signature done May 12 13:04:44 Unraid unassigned.devices: Reloading disk '/dev/sdg' partition table. May 12 13:04:44 Unraid kernel: sdg: sdg1 May 12 13:04:44 Unraid unassigned.devices: Reload partition table result: /dev/sdg: re-reading partition table May 12 13:04:44 Unraid unassigned.devices: Formatting disk '/dev/sdg' with 'xfs-encrypted' filesystem. May 12 13:04:44 Unraid unassigned.devices: Disk with serial 'FUJITSU_MHZ2320B_0123456789ABCDE', mountpoint 'ATA_FUJITSU_MHZ2320B' is not set to auto mount. May 12 13:05:02 Unraid unassigned.devices: Format disk '/dev/sdg' with 'xfs-encrypted' filesystem: meta-data=/dev/mapper/format_sdg isize=512 agcount=4, agsize=19534676 blks = sectsz=512 attr=2, projid32bit=1 = crc=1 finobt=1, sparse=1, rmapbt=0 = reflink=1 data = bsize=4096 blocks=78138702, imaxpct=25 = sunit=0 swidth=0 blks naming =version 2 bsize=4096 ascii-ci=0, ftype=1 log =internal log bsize=4096 blocks=38153, version=2 = sectsz=512 sunit=0 blks, lazy-count=1 realtime =none extsz=4096 blocks=0, rtextents=0 May 12 13:05:05 Unraid unassigned.devices: Reloading disk '/dev/sdg' partition table. May 12 13:05:05 Unraid kernel: sdg: sdg1 May 12 13:05:05 Unraid unassigned.devices: Reload partition table result: /dev/sdg: re-reading partition table May 12 13:05:06 Unraid unassigned.devices: Disk with serial 'FUJITSU_MHZ2320B_0123456789ABCDE', mountpoint 'ATA_FUJITSU_MHZ2320B' is not set to auto mount. May 12 13:05:21 Unraid unassigned.devices: Adding disk '/dev/mapper/ATA_FUJITSU_MHZ2320B'... May 12 13:05:23 Unraid unassigned.devices: Mount drive command: /sbin/mount -o rw,noatime,nodiratime '/dev/mapper/ATA_FUJITSU_MHZ2320B' '/mnt/disks/ATA_FUJITSU_MHZ2320B' May 12 13:05:23 Unraid kernel: /dev/mapper/ATA_FUJITSU_MHZ2320B: Can't open blockdev May 12 13:05:23 Unraid unassigned.devices: Mount of '/dev/mapper/ATA_FUJITSU_MHZ2320B' failed: 'mount: /mnt/disks/ATA_FUJITSU_MHZ2320B: special device /dev/mapper/ATA_FUJITSU_MHZ2320B does not exist. ' May 12 13:05:23 Unraid unassigned.devices: Partition 'ATA FUJITSU_MHZ2320B' cannot be mounted.
  14. The last one I have tried was a new one already. Same brand (Intenso) by different model. 4TB (first) and 1TB (second). I can additionally try a USB stick later today.
  15. Same issue even after the reboot 😒 May 11 21:34:35 Unraid unassigned.devices: Adding disk '/dev/mapper/Test'... May 11 21:34:37 Unraid unassigned.devices: Mount drive command: /sbin/mount -o rw,noatime,nodiratime '/dev/mapper/Test' '/mnt/disks/Test' May 11 21:34:37 Unraid kernel: /dev/mapper/Test: Can't open blockdev May 11 21:34:37 Unraid unassigned.devices: Mount of '/dev/mapper/Test' failed: 'mount: /mnt/disks/Test: special device /dev/mapper/Test does not exist. ' May 11 21:34:37 Unraid unassigned.devices: Partition 'Test' cannot be mounted.
  16. Had the same idea and already rebooted. Later I will try to format the external with encrypted XFS again. I'll keep you all posted.
  17. Mounting it without encryption works flawless. This is my workaround for now, but I really would like to have the disk encrypted.
  18. @dlandon Many thanks for your reply. Any specific file in mind from the diag pack or do you want the whole thing?
  19. Is anyone experiencing the same issue with encrypted UAD drives or maybe does someone has an idea what is causing this issue?
  20. Die Datei bzw. die Dateien habe ich nach dem ersten Full Backup gelöscht. Die Meldung kommt quasi jetzt bei jedem neuen Start des Backupskriptes. Während des Backupvorgangs habe ich keine Dateien gelöscht.
  21. Backup ist mit einem Testordner sauber durchgelaufen. 👍 Auch inkrementell klappt super. 🥳 Allerdings wenn ich auf meinem Unraid Share jetzt eine Datei lösche, und das Backup erneut starte, bekomme ich bei jedem weiteren Backup die folgende Meldungen angezeigt. file has vanished: "/volume1/unraid_mnt/Marc/.fuse_hidden002be5e5000017d2" rsync warning: some files vanished before they could be transferred (code 24) at main.c(1355) [sender=3.0.9] Create backup of /volume1/unraid_mnt/Marc Backup path has been set to /volume1/Backups/Test Create incremental backup 20210510_112704 by using last backup 20210510_112245 sending incremental file list file has vanished: "/volume1/unraid_mnt/Marc/.fuse_hidden002be5e5000017d2" Number of files: 5532 Number of files transferred: 1 Total file size: 23760558910 bytes Total transferred file size: 227526 bytes Literal data: 0 bytes Matched data: 0 bytes File list size: 135559 File list generation time: 0.005 seconds File list transfer time: 0.000 seconds Total bytes sent: 136120 Total bytes received: 563 sent 136120 bytes received 563 bytes 24851.45 bytes/sec total size is 23760558910 speedup is 173836.97 rsync warning: some files vanished before they could be transferred (code 24) at main.c(1355) [sender=3.0.9] Make backup visible Das aber auch mal Daten im Bestand gelöscht werden ist ja nicht ganz untypisch, deswegen verwundert mich die Meldung ein wenig?!
  22. Wusste nicht, dass man manuell zwischen den Formaten auswählen kann. Habe es jetzt auf Unix (LF) umgestellt. Skript lässt sich starten. Mal schauen wie es weiterläuft.