spants

Community Developer
  • Posts

    586
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by spants

  1. Ok, just started having the same permissions problem- at least I have something to work on now!
  2. looks like a permissions problem on the appdata directory for the docker.... (maybe try doing a newperms on that directory (only)). Have you changed the appdata directory to where you need it to be? Just tried it on mine and it is still working well
  3. Unfortunately I dont use home-assistant... I built all my Home Automation on NodeRed (and mqtt)
  4. Passwords for Mosquitto ======================= Mosquitto likes encrypted passwords, but these are difficult create for a docker instance. In the mosquitto.conf file, you will see the password file is called passwords.mqtt. Do not change this. To add passwords to the MQTT instance, just store a file called passwords.txt in this directory and restart the docker. The passwords will be encrypted and stored in passwords.mqtt and the old passwords.txt file will be deleted. The contents of passwords.txt should look like this: bob:bobpassword fred:fredpassword The new passwords are added to the top of password.mqtt when they are encrypted. MQTT uses the first username/password combo that it finds. You can delete the old passwords manually if you wish. 1) stop the mqtt docker 2) ssh to the unraid server and navigate to the appdata directory 3) type nano passwords.txt and add your user:password 4) save file and exit nano 5) restart docker = it should import and create the users and put them in passwords.mqtt (use MC, highlight passwords.mqtt and press F3 Hope that helps
  5. Glad you are getting it working. Perhaps I should rename ServerIP in the template to PiHoleServerIP?
  6. What are you trying to do? My template just is a loader for the diginc docker.... no changes are made The URL is: https://hub.docker.com/r/diginc/pi-hole But just use my template! EDIT: you do have the Community Applications plugin installed, do you?
  7. I believe that you can do this with 6.4 but I havent tried it as yet. My system is very stable and I dont want to tweak it whilst I sort out an intermittent network switch problem on my network!
  8. Not tried it, but: https://discourse.pi-hole.net/t/how-do-i-block-ads-on-youtube/253
  9. did an update happen at the same time? I know that there is now a drop down menu that you select what network the docker is attaching to on the latest 6.4 rc. I have a dual nic server but only one is connected and I dont have an issue....
  10. k, I have to go offline now. Maybe a value was added to the allowed networks settings on the plex server via web interface (or automatically). Plex doesnt like the "not fully formed" ip address and is refusing to let you in.... Good luck!
  11. Yes - I need to add proper labels on those! Thanks Tony
  12. is there a 192.168.1 item in allowedNetworks key in your Preferences.xml file
  13. actually its name is Plex Media Server.log . (may be!)
  14. The plex logs are at: (on my machine) /mnt/user/appdata/plexmediaserver/Library/Application Support/Plex Media Server/Logs/ and the file: Plex (anonymous).log Does anything look strange with this file on your machine?
  15. that is weird. I wonder if plex stores an ip address in its settings. I will remote in to mine and take a look
  16. you just installed and uninstalled on the server? did you do anything to the clients? do you have any other clients you can try? I cant see how it could affect it ....
  17. any other plex clients you can try? Other than a server reboot, Im not sure what to suggest ...
  18. does everything else on the fire tv work? any logs from the plex docker?
  19. try clearing your browser cache or try private mode....
  20. Pihole should be fairly easy to use. Either run it on the server and use the servers ip address for the dns server for the clients.If this doenst work (you have another dns service on the unraid server) use the set separate IP address for a docker instance detailed a couple of posts back. If you want to disable pihole on one of all clients, just change their settings to use dhcp to get their settings from the router or change their dns settings to google 8.8.8.8 and 8.8.4.4 and reboot clients. Pihole doesnt affect plex directly - it may just be your dns settings on the clients
  21. have you set the clients to use pihole? 2 ways to do this - 1) on your router, set the dns servers to point to the unraid box (or pihole IP address if you have changed it) 2) turn off dhcp on the clients if you have not chosen (1) and manually add the pihole server ip as the dns server address
  22. would this help you? I think that KVM/VM subsystem can use port 53....
  23. Hi When the docker is updated by the docker owner, the template automatically shows that an update is ready (I am not building the docker....just supplying the template). Some of the changes to pihole need dockerfile changes so it best to wait until he updates the docker for all.
  24. would be worth a try!. Let me know how you get on