[Support] Machinaris - Chia cryptocurrency farming + Plotman plotting + Unraid WebUI


Recommended Posts

11 hours ago, Helmonder said:

Just saw below in the logs..
It says “added coins” but nothing visible in the dashboard..
The log text does not mean chia was won hopefully ? Cause if so something is wrong..

 

No, that log line is part of the Chiadog start-up process indicating the log monitor is activating its various checks, one of which is to watch for added coins.  As it occurs at the beginning of every Chiadog launch, this activation of the checking module does not indicate the check was actually triggered by a real event.  Sorry!

20210630_095653.png

  • Like 1
Link to comment
2 hours ago, jaj08 said:

Loving the remote workers to consolidate everything to a single interface. Wish Machinaris could be a stand alone install for all my windows remote harvesters I have running.

Hi, glad to hear it!  Please share why you aren't able to run Machinaris as a remote harvester on Windows?

 

2 hours ago, jaj08 said:

With that, I want to report my estimated time to win has the wrong info.  If I compare to Chia calculator it seems like the expected time to win is using a remote worker instance to calculate my time to win, and not combining the estimate with the primary instance. This setup has the primary +1 remote full node.

639 total plots, chia calc 4 months

166 on the remote worker, chia calc about 1 year

473 on the primary instance, chia calc 5 months

Machinaris expected time to win: 1 Year

 

 

Hi, if the primary instance is a Machinaris fullnode/controller and the remote worker is a Machinaris harvester, then yes in Machinaris v0.4.0 only the plots attached to the Machinaris fullnode are included in ETW calculation.  Unfortunately, I didn't catch this defect until just after the release. 

 

However, I have now fixed the ETW calculation to include all plots across the Machinaris-managed farm.  Currently available in the test version and fix will be available in next release.  Thanks for the report!

  • Like 1
Link to comment
Just now, guy.davis said:

Hi, glad to hear it!  Please share why you aren't able to run Machinaris as a remote harvester on Windows?

 

 

Hi, if the primary instance is a Machinaris fullnode/controller and the remote worker is a Machinaris harvester, then yes in Machinaris v0.4.0 only the plots attached to the Machinaris fullnode are included in ETW calculation.  Unfortunately, I didn't catch this defect until just after the release. 

 

However, I have now fixed the ETW calculation to include all plots across the Machinaris-managed farm.  Currently available in the test version and fix will be available in next release.  Thanks for the report!

Actually both are full nodes, but I assume the bug is the same as far as how the workers are communicating.

Link to comment
5 hours ago, sworcery said:

Flax netspace is showing up as ? and I'm currently having issues connecting to the chia network. This was working prior to updating to the :test branch. Also, Flax appears to be not seeing half my plots that are on a shared network drive, but chia does?

 

Hi!  Thanks for providing feedback on the test release with Flax support.  The test release is being updated regularly, fixing issues and adding enhancements as quick as possible.  So, please be sure to pull the latest when restarting the container: 

ghcr.io/guydavis/machinaris:test

 

Link to comment
7 minutes ago, jaj08 said:

Actually both are full nodes, but I assume the bug is the same as far as how the workers are communicating.

 

Thanks for the quick response.  I would recommend only one running Machinaris fullnode/controller on your LAN, which hosts the control WebUI for the network.  The others can be workers such as plotter, harvester, or harvester+plotter.  Details on the Workers wiki page.  Hope this helps!

Link to comment
On 6/29/2021 at 4:18 PM, guy.davis said:

 

Good day, thanks for testing the test version.   Please stop the Machinaris container, delete the following files, then restart:

  • /mnt/user/appdata/machinaris/machinaris/dbs/machinaris.db
  • /mnt/user/appdata/machinaris/machinaris/dbs/stats.db
  • /mnt/user/appdata/machinaris/chiadog/dbs/chiadog.db

On startup wait a few minutes for things to populate. Afterwards, take a look at /mnt/user/appdata/machinaris/machinaris/logs/migration.log.  Thanks!

 

Thanks! This helped, working again!

Quick note: The "Farming" section does only show the first plot directory, dirs manually added via command line don't show up anymore. this worked in previous releases.

 

Edited by localh0rst
Link to comment
44 minutes ago, localh0rst said:

 

Thanks! This helped, working again!

Quick note: The "Farming" section does only show the first plot directory, dirs manually added via command line don't show up anymore. this worked in previous releases.

 

 

Great!  Btw, are you the same fellow behind the Flaxdog port?  If so, thanks!  I am wiring this up into Machinaris right now.

Regarding the multiple plots dirs, please set them via the 'plots_dir' environment variable. It's probably in Unraid Docker Edit for Machinaris if you toggle Advanced View and Show More Settings.  Should be a colon-separated list of in-container paths.  Will be used to both add dir to chia and for Machinaris to list plots in WebUI.  Hope this helps!

Actually, maybe you're seeing the 150 plot limit (sorted by newest descending), I just added to the Farming page?  Previously it listed everything on a single page, but I thought this was a bad idea for many plots. I could change it back.  I really need to make all the tables sortable/paged/searchable/etc...

Link to comment
8 minutes ago, guy.davis said:

 

Great!  Btw, are you the same fellow behind the Flaxdog port?  If so, thanks!  I am wiring this up into Machinaris right now.
 

 

I'm not, but I wish I could contribute something to this really great project! But good to know that you're on it!

 

Quote

Regarding the multiple plots dirs, please set them via the 'plots_dir' environment variable. It's probably in Unraid Docker Edit for Machinaris if you toggle Advanced View and Show More Settings.  Should be a colon-separated list of in-container paths.  Will be used to both add dir to chia and for Machinaris to list plots in WebUI.  Hope this helps!

 

I just checked, and there are two entries with plots_dir. I added this in a previous release and probably didn't notice that there was already a variable in the config.

 

Quote

Actually, maybe you're seeing the 150 plot limit (sorted by newest descending), I just added to the Farming page?  Previously it listed everything on a single page, but I thought this was a bad idea for many plots. I could change it back.  I really need to make all the tables sortable/paged/searchable/etc...

 

It states that I have 650 plots (which is correct), so it is limited by 150 in this page. Maybe you could create a link to a new page or just display all plots when clicking a button to avoid listing all from the beginning.

 

I really appreciate all your help! Keep up the good work! If there's a way to virtually buy you a beer, let me know :)

  • Like 2
Link to comment
7 hours ago, guy.davis said:

Hi, glad to hear it!  Please share why you aren't able to run Machinaris as a remote harvester on Windows?

 

Skipped over this portion of the reply this morning.  I would say I'm doing Chia the way the developers said to, I am utilizing spare resources I have laying around the office. With that, installing a small/not obtrusive harvester exe seems harmless and low key. But installing docker service on each server starts to get a little more intrusive on office utilized equipment.  Several of my harvesters are also 2012r2 servers which I believe by default do not support Dockers.  I do have a couple backup only 2016 servers maybe I will see if I can expand an instance or two to those.

  • Like 1
Link to comment
Posted (edited)
8 hours ago, guy.davis said:

 

Hi!  Thanks for providing feedback on the test release with Flax support.  The test release is being updated regularly, fixing issues and adding enhancements as quick as possible.  So, please be sure to pull the latest when restarting the container: 



ghcr.io/guydavis/machinaris:test

 

I'm using the latest test build, still experiencing the same as last night. Anything I can provide to help you pinpoint the causes?

Edited by sworcery
Link to comment
20 hours ago, sworcery said:

I'm using the latest test build, still experiencing the same as last night. Anything I can provide to help you pinpoint the causes?

Hi, well, a restart of the container should do it, unless there is some sort of file corruption or upgrade error.  Anything in the logs at /mnt/user/appdata/machinaris/machinaris/logs/ ?  Also, to restart Chia services from inside the container use:

 

chia start farmer -r

 

Hope this helps!

Link to comment
3 minutes ago, Spazhead said:

hi does my plots_dir setup look correct?

I have not tried colon seprating them as the description says. 

But i can tell that it works when comma separating them.

/plots, /plots2 etc

Link to comment
6 hours ago, Struck said:

I have not tried colon seprating them as the description says. 

But i can tell that it works when comma separating them.

/plots, /plots2 etc

 

hi there , i just tried with comma's, still no luck for me

 

Link to comment

It looks like the "Alerts" page is stuck on a few days before.. The log is still beiing monitored though, I think I saw this a couple of days before also, when I restart the docker I think it will start with today again (and then get stuck on that).

 

Do not want to try though, as it will stop my plotting ;-)

 

Stopping and starting the monitoring job itself does not help.

Link to comment
18 hours ago, Helmonder said:

It looks like the "Alerts" page is stuck on a few days before.. The log is still beiing monitored though, I think I saw this a couple of days before also, when I restart the docker I think it will start with today again (and then get stuck on that).

 

Do not want to try though, as it will stop my plotting ;-)

 

Stopping and starting the monitoring job itself does not help.

 

Mine is stuck on June 27th right now. 

I just restarted the container and you're right. All daily alerts are shown now.

Link to comment
 
Mine is stuck on June 27th right now. 
I just restarted the container and you're right. All daily alerts are shown now.

Yeah… but tomorrow i expecting you will not be seeing the nee alerts… its now stuck on today..


Verzonden vanaf mijn iPhone met Tapatalk
Link to comment

Thought I'd comment in case anyone else is struggling to setup workers... You need to add a variable (on the worker node) "controller_host" with the value "your controller node ip/hostname".

 

Any chance @guy.davis could update the container template to include this under advanced so it's easier to find?

 

Loving the project it's neat to watch the progress and see how quickly things are moving, chia... well I might love it if i had a chance to win before next year ;)

Link to comment
38 minutes ago, Spazhead said:

could someone post their unraid docker setting screen that has multiple plots_dir working.

It's driving me crazy that I can't get mine to work.

 

Thanks

 

did you list it in the config within the container too? there is a section in the farming and plotting config that you can add extras. I have for example: 

 

- /plots

- /plots2

Link to comment
45 minutes ago, Spazhead said:

could someone post their unraid docker setting screen that has multiple plots_dir working.

It's driving me crazy that I can't get mine to work.

 

Thanks

 

There you go.

image.png.37392ec568f0f4a185d8491862e44b81.png

 

6 minutes ago, sworcery said:

did you list it in the config within the container too? there is a section in the farming and plotting config that you can add extras. I have for example: 

 

- /plots

- /plots2

This should not be nessesary, that is why it is a requirement to set these in the container information like above.

It should automatically get updated.

 

@SpazheadMaybe you can double check the information in here with your configuration

Link to comment
2 minutes ago, Struck said:

There you go.

image.png.37392ec568f0f4a185d8491862e44b81.png

 

This should not be nessesary, that is why it is a requirement to set these in the container information like above.

It should automatically get updated.

 

@SpazheadMaybe you can double check the information in here with your configuration

 

hey there thanks, could you please show me your complete settings, exactly as you have setup, please and thank you!

Link to comment
7 minutes ago, Spazhead said:

 

hey there thanks, could you please show me your complete settings, exactly as you have setup, please and thank you!

image.thumb.png.6bd8090cd35c8634216e617c7d371546.png

 

I have not yet updated to the newest test version. Don't know what changed there.
I am running the 4 days old test version.

  • Like 1
Link to comment
12 minutes ago, Struck said:

image.thumb.png.6bd8090cd35c8634216e617c7d371546.png

 

I have not yet updated to the newest test version. Don't know what changed there.
I am running the 4 days old test version.

 

this is what i have, but plots_dir is not working for me

 

1585646344_ScreenShot2021-07-05at12_25_07PM.thumb.png.aefc1273fe63a2a2a8b139bc1c4cff1c.png

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.