Jump to content
We're Hiring! Full Stack Developer ×

Internal Server Error Nextcloud


Pava

Recommended Posts

After last update Mariadb Nextcloud stop to work. have message: / I try to restart, stop, start /

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

 

From MAriadb have logs:

 

210825 23:53:24 mysqld_safe Starting mariadbd daemon with databases from /config/databases
210825 23:53:25 mysqld_safe Logging to '/config/databases/34e8bef8ba82.err'.
 

From log:

 

210826 08:56:14 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended
210826 08:56:15 mysqld_safe Starting mariadbd daemon with databases from /config/databases
2021-08-26  8:56:15 0 [Note] /usr/bin/mariadbd (mysqld 10.5.12-MariaDB-log) starting as process 15613 ...
2021-08-26  8:56:15 0 [Note] InnoDB: Uses event mutexes
2021-08-26  8:56:15 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2021-08-26  8:56:15 0 [Note] InnoDB: Number of pools: 1
2021-08-26  8:56:15 0 [Note] InnoDB: Using SSE4.2 crc32 instructions
2021-08-26  8:56:15 0 [Note] mariadbd: O_TMPFILE is not supported on /var/tmp (disabling future attempts)
2021-08-26  8:56:15 0 [Note] InnoDB: Using Linux native AIO
2021-08-26  8:56:15 0 [Note] InnoDB: Initializing buffer pool, total size = 268435456, chunk size = 134217728
2021-08-26  8:56:15 0 [Note] InnoDB: Completed initialization of buffer pool
2021-08-26  8:56:15 0 [ERROR] InnoDB: Upgrade after a crash is not supported. The redo log was created with MariaDB 10.4.21.
2021-08-26  8:56:15 0 [ERROR] InnoDB: Plugin initialization aborted with error Generic error
2021-08-26  8:56:15 0 [Note] InnoDB: Starting shutdown...
2021-08-26  8:56:15 0 [ERROR] Plugin 'InnoDB' init function returned error.
2021-08-26  8:56:15 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2021-08-26  8:56:15 0 [Note] Plugin 'FEEDBACK' is disabled.
2021-08-26  8:56:15 0 [ERROR] Unknown/unsupported storage engine: InnoDB
2021-08-26  8:56:15 0 [ERROR] Aborting

 

 

Please how I can resolve this problem?

Edited by Pava
Link to comment

I have found this fix in another thread:

 

Change the mariadb docker repository to "linuxserver/mariadb:110.4.21mariabionic-ls31" (without the " of course) and let it run.

Then edit the docker repository again to "linuxserver/mariadb:latest" and it should run fine again.

 

 

Edited by whitedwarf
  • Like 1
  • Thanks 3
Link to comment

Hello, thank you for help. I change repository to linuxserver/mariadb:110.4.21mariabionic-ls31, click apply, but now can not find Mariadb in Docker Containers. Its missing.

 

Please where I can find now Mariadb config file to change and start again? Now I find container in orphan image. How I can rebuild again?

 

Screenshot_20210826_171503new.png

Edited by Pava
Link to comment

Hello. Folowing mariaDB update hi experienced the same problem.

 

MariaDB was updated while nextcloud was running. i don't know if this is wyse to do it like this, but i wanted to test and see what happenend. 

 

and of course it crashed with the same problem.

 

following instructions posted by @whitedwarfi have done the following steps

 

  1. shut down docker nextcloud
  2. shut down docker mariaDB
  3. edited mariaDB docker and Changed the mariadb docker repository to "linuxserver/mariadb:110.4.21mariabionic-ls31"
  4. started the mariaDB docker waited 5mins for cpu utilization to idle on the docker
  5. shut down the mariadb docker
  6. edited mariaDB docker and Changed the mariadb docker repository to "linuxserver/mariadb:latest"
  7. started the mariaDB docker waited 5mins for cpu utilization to idle on the docker
  8. started nextcloud docker. 

 

Webui for nextcloud up and running again. 

 

many thanks to @whitedwarffor the solution. 🙏

 

Edited by tomtom77550
  • Like 1
Link to comment
9 hours ago, tomtom77550 said:

Hello. Folowing mariaDB update hi experienced the same problem.

 

MariaDB was updated while nextcloud was running. i don't know if this is wyse to do it like this, but i wanted to test and see what happenend. 

 

and of course it crashed with the same problem.

 

following instructions posted by @whitedwarfi have done the following steps

 

  1. shut down docker nextcloud
  2. shut down docker mariaDB
  3. edited mariaDB docker and Changed the mariadb docker repository to "linuxserver/mariadb:110.4.21mariabionic-ls31"
  4. started the mariaDB docker waited 5mins for cpu utilization to idle on the docker
  5. shut down the mariadb docker
  6. edited mariaDB docker and Changed the mariadb docker repository to "linuxserver/mariadb:latest"
  7. started the mariaDB docker waited 5mins for cpu utilization to idle on the docker
  8. started nextcloud docker. 

 

Webui for nextcloud up and running again. 

 

many thanks to @whitedwarffor the solution. 🙏

 

 

An alternate way is here 

https://forums.unraid.net/topic/48383-support-linuxserverio-nextcloud/?do=findComment&comment=1028554

 

  • Like 1
Link to comment

Well it did work,

Since today I'm now getting "unexpectedly closed the connection" errors

 

EDIt,

trying the fix again to see if it helps.

I did notice that my Maria DB is constantly logging like this

 

Spoiler

ErrorWarningSystemArrayLogin


[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 01-envfile: executing...
[cont-init.d] 01-envfile: exited 0.
[cont-init.d] 10-adduser: executing...

-------------------------------------
_ ()
| | ___ _ __
| | / __| | | / \
| | \__ \ | | | () |
|_| |___/ |_| \__/


Brought to you by linuxserver.io
-------------------------------------

To support LSIO projects visit:
https://www.linuxserver.io/donate/
-------------------------------------
GID/UID
-------------------------------------

User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 30-config: executing...
[cont-init.d] 30-config: exited 0.
[cont-init.d] 40-initialise-db: executing...
[cont-init.d] 40-initialise-db: exited 0.
[cont-init.d] 90-custom-folders: executing...
[cont-init.d] 90-custom-folders: exited 0.
[cont-init.d] 90-warning: executing...

******************************************************
******************************************************
* *
* *
* This image will soon be rebased *
* from ubuntu to alpine. *
* Please be aware, this may cause issues *
* It is strongly recommended to make backups *
* of your config and databases before *
* updating your image to the alpine base. *
* *
* *
******************************************************
******************************************************
[cont-init.d] 90-warning: exited 0.
[cont-init.d] 99-custom-scripts: executing...
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-scripts: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
210828 11:10:07 mysqld_safe Logging to syslog.
210828 11:10:07 mysqld_safe Starting mysqld daemon with databases from /config/databases
210828 11:10:08 mysqld_safe Logging to syslog.
210828 11:10:08 mysqld_safe Starting mysqld daemon with databases from /config/databases
210828 11:10:09 mysqld_safe Logging to syslog.
210828 11:10:09 mysqld_safe Starting mysqld daemon with databases from /config/databases
210828 11:10:10 mysqld_safe Logging to syslog.
210828 11:10:10 mysqld_safe Starting mysqld daemon with databases from /config/databases


 

Those last lines just go on and on for the rest of the log

Edited by daveo132
Link to comment
On 8/26/2021 at 1:50 PM, tomtom77550 said:

Hello. Folowing mariaDB update hi experienced the same problem.

 

MariaDB was updated while nextcloud was running. i don't know if this is wyse to do it like this, but i wanted to test and see what happenend. 

 

and of course it crashed with the same problem.

 

following instructions posted by @whitedwarfi have done the following steps

 

  1. shut down docker nextcloud
  2. shut down docker mariaDB
  3. edited mariaDB docker and Changed the mariadb docker repository to "linuxserver/mariadb:110.4.21mariabionic-ls31"
  4. started the mariaDB docker waited 5mins for cpu utilization to idle on the docker
  5. shut down the mariadb docker
  6. edited mariaDB docker and Changed the mariadb docker repository to "linuxserver/mariadb:latest"
  7. started the mariaDB docker waited 5mins for cpu utilization to idle on the docker
  8. started nextcloud docker. 

 

Webui for nextcloud up and running again. 

 

many thanks to @whitedwarffor the solution. 🙏

 

This too worked for me.  Thank  you

Link to comment
On 8/26/2021 at 4:18 AM, whitedwarf said:

I have found this fix in another thread:

 

Change the mariadb docker repository to "linuxserver/mariadb:110.4.21mariabionic-ls31" (without the " of course) and let it run.

Then edit the docker repository again to "linuxserver/mariadb:latest" and it should run fine again.

 

 

Awesome, thanks for the share; seems to have fixed it!

Link to comment
On 8/26/2021 at 8:50 PM, tomtom77550 said:

Hello. Folowing mariaDB update hi experienced the same problem.

 

MariaDB was updated while nextcloud was running. i don't know if this is wyse to do it like this, but i wanted to test and see what happenend. 

 

and of course it crashed with the same problem.

 

following instructions posted by @whitedwarfi have done the following steps

 

  1. shut down docker nextcloud
  2. shut down docker mariaDB
  3. edited mariaDB docker and Changed the mariadb docker repository to "linuxserver/mariadb:110.4.21mariabionic-ls31"
  4. started the mariaDB docker waited 5mins for cpu utilization to idle on the docker
  5. shut down the mariadb docker
  6. edited mariaDB docker and Changed the mariadb docker repository to "linuxserver/mariadb:latest"
  7. started the mariaDB docker waited 5mins for cpu utilization to idle on the docker
  8. started nextcloud docker. 

 

Webui for nextcloud up and running again. 

 

many thanks to @whitedwarffor the solution. 🙏

 

 

Thanks @Tomtom77550 & @whitedwarf for your info this was foxing me good style

 

Link to comment
On 8/26/2021 at 1:18 PM, whitedwarf said:

I have found this fix in another thread:

 

Change the mariadb docker repository to "linuxserver/mariadb:110.4.21mariabionic-ls31" (without the " of course) and let it run.

Then edit the docker repository again to "linuxserver/mariadb:latest" and it should run fine again.

 

 

Thank you very much! This saved my evening quick! Thank you!!!

Link to comment
On 8/26/2021 at 1:18 PM, whitedwarf said:

I have found this fix in another thread:

 

Change the mariadb docker repository to "linuxserver/mariadb:110.4.21mariabionic-ls31" (without the " of course) and let it run.

Then edit the docker repository again to "linuxserver/mariadb:latest" and it should run fine again.

 

 

 

You're my Hero :)

Thanks a lot!

Edited by Mogool
Link to comment

Got this error last week - the posted solution worked.

 

Got this error this evening, the posted solution does not work now. Any ideas? :(

 

Log for: mariadb

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 30-config: executing...
[cont-init.d] 30-config: exited 0.
[cont-init.d] 40-initialise-db: executing...
[cont-init.d] 40-initialise-db: exited 0.
[cont-init.d] 90-custom-folders: executing...
[cont-init.d] 90-custom-folders: exited 0.
[cont-init.d] 99-custom-files: executing...
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-files: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
Warning: World-writable config file '/etc/my.cnf.d/custom.cnf' is ignored

Warning: World-writable config file '/etc/my.cnf.d/custom.cnf' is ignored

210909 22:01:41 mysqld_safe Logging to '/config/databases/aae9e9e9ff69.err'.
210909 22:01:41 mysqld_safe Starting mariadbd daemon with databases from /config/databases

 

Log for: nextcloud

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 20-config: executing...
[cont-init.d] 20-config: exited 0.
[cont-init.d] 30-keygen: executing...
using keys found in /config/keys
[cont-init.d] 30-keygen: exited 0.
[cont-init.d] 40-config: executing...
[cont-init.d] 40-config: exited 0.
[cont-init.d] 50-install: executing...
[cont-init.d] 50-install: exited 0.
[cont-init.d] 60-memcache: executing...
[cont-init.d] 60-memcache: exited 0.
[cont-init.d] 70-aliases: executing...
[cont-init.d] 70-aliases: exited 0.
[cont-init.d] 90-custom-folders: executing...
[cont-init.d] 90-custom-folders: exited 0.
[cont-init.d] 99-custom-files: executing...
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-files: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.

 

Link to comment
On 8/26/2021 at 2:18 PM, whitedwarf said:

I have found this fix in another thread:

 

Change the mariadb docker repository to "linuxserver/mariadb:110.4.21mariabionic-ls31" (without the " of course) and let it run.

Then edit the docker repository again to "linuxserver/mariadb:latest" and it should run fine again.

 

 

Working fine, thanks a lot. 

Link to comment
  • 2 weeks later...
  • 1 month later...
  • 1 month later...
On 8/26/2021 at 9:50 PM, tomtom77550 said:

Hello. Folowing mariaDB update hi experienced the same problem.

 

MariaDB was updated while nextcloud was running. i don't know if this is wyse to do it like this, but i wanted to test and see what happenend. 

 

and of course it crashed with the same problem.

 

following instructions posted by @whitedwarfi have done the following steps

 

  1. shut down docker nextcloud
  2. shut down docker mariaDB
  3. edited mariaDB docker and Changed the mariadb docker repository to "linuxserver/mariadb:110.4.21mariabionic-ls31"
  4. started the mariaDB docker waited 5mins for cpu utilization to idle on the docker
  5. shut down the mariadb docker
  6. edited mariaDB docker and Changed the mariadb docker repository to "linuxserver/mariadb:latest"
  7. started the mariaDB docker waited 5mins for cpu utilization to idle on the docker
  8. started nextcloud docker. 

 

Webui for nextcloud up and running again. 

 

many thanks to @whitedwarffor the solution. 🙏

 

Hello everyone.

I have followed the following instructions provided by @tomtom77550 and have not been able to get it to work again....

Accessing the log, I get the following error:

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 20-config: executing...
[cont-init.d] 20-config: exited 0.
[cont-init.d] 30-keygen: executing...
using keys found in /config/keys
[cont-init.d] 30-keygen: exited 0.
[cont-init.d] 40-config: executing...
[cont-init.d] 40-config: exited 0.
[cont-init.d] 50-install: executing...
[cont-init.d] 50-install: exited 0.
[cont-init.d] 60-memcache: executing...
[cont-init.d] 60-memcache: exited 0.
[cont-init.d] 70-aliases: executing...
[cont-init.d] 70-aliases: exited 0.
[cont-init.d] 90-custom-folders: executing...
[cont-init.d] 90-custom-folders: exited 0.
[cont-init.d] 99-custom-files: executing...
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-files: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
Doctrine\DBAL\Exception: Failed to connect to the database: An exception occurred in the driver: SQLSTATE[HY000] [2002] Host is unreachable in /config/www/nextcloud/lib/private/DB/Connection.php:87

Searching for information about the error I found this post, but I don't quite understand what I should do.

What should I do? Any suggestions?
Thank you very much for your help.

Link to comment
On 8/26/2021 at 1:50 PM, tomtom77550 said:

Hello. Folowing mariaDB update hi experienced the same problem.

 

MariaDB was updated while nextcloud was running. i don't know if this is wyse to do it like this, but i wanted to test and see what happenend. 

 

and of course it crashed with the same problem.

 

following instructions posted by @whitedwarfi have done the following steps

 

  1. shut down docker nextcloud
  2. shut down docker mariaDB
  3. edited mariaDB docker and Changed the mariadb docker repository to "linuxserver/mariadb:110.4.21mariabionic-ls31"
  4. started the mariaDB docker waited 5mins for cpu utilization to idle on the docker
  5. shut down the mariadb docker
  6. edited mariaDB docker and Changed the mariadb docker repository to "linuxserver/mariadb:latest"
  7. started the mariaDB docker waited 5mins for cpu utilization to idle on the docker
  8. started nextcloud docker. 

 

Webui for nextcloud up and running again. 

 

many thanks to @whitedwarffor the solution. 🙏

 

I tried this as well as deleting the the log files mentioned in the alternate way and neither work. It just sits there saying this over and over when switching it to the linuxserver/mariadb:110.4.21mariabionic-ls31. I let it even run over night and still same result. Is there something I'm missing as stuck with this and nextcloud won't work, still have internal server error?

 

211202 08:40:46 mysqld_safe Logging to syslog.
211202 08:40:46 mysqld_safe Starting mysqld daemon with databases from /config/databases

Link to comment
  • 4 weeks later...
On 12/2/2021 at 11:42 PM, Snowman said:

I tried this as well as deleting the the log files mentioned in the alternate way and neither work. It just sits there saying this over and over when switching it to the linuxserver/mariadb:110.4.21mariabionic-ls31. I let it even run over night and still same result. Is there something I'm missing as stuck with this and nextcloud won't work, still have internal server error?

 

211202 08:40:46 mysqld_safe Logging to syslog.
211202 08:40:46 mysqld_safe Starting mysqld daemon with databases from /config/databases

Same issue for me, have you found a work around yet?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...