[Support] xthursdayx - RoonServer


Recommended Posts

  Roon Icon

 

Application Name: RoonServer

Application Site: https://roonlabs.com/

Github: https://github.com/steefdebruijn/docker-roonserver

 

Roon Server is a software package that provides a “headless” Roon install; that is, it is a version of Roon that has no user interface. Roon Server also uses less computing resources than the full version of Roon, and is the best choice for installation on headless servers.

 

Roon Server is used in conjunction with Roon or Roon Remote, both of which provide control functionality.

 

================ Install RoonServer docker  container ================

All defaults from the template should be fine. The pre-filled in fields are pretty self explanatory.

 

As of Roon 2.0, the Roon devs have added remote listening, yay! It's called Roon ARC, and the RoonServer Docker template has been updated to add a remote listening port.

 

If you are already running a RoonServer container and need to update it for remote listening, edit the Docker Template to add  a port:

 

Config Type: Port (drop down)
Name: Roon ARC
Host Port: 55000
Default Value 55000
Connection Type: TCP (drop down)
Description: Roon ARC

roon-remote-port-details.png

 

The finished docker template should look something like this:

roon-remote-port-forward.png

 

You will also have to forward ports on your router or firewall to get it to fully work with ARC. Check out this post over there:

https://help.roonlabs.com/portal/en/kb/articles/arc-port-forwarding#Still_having_problems

You can also check portforward.com for steps specific to your router/firewall.

 

Once you get that done, go to Roon > Settings > Roon ARC in your Roon app. You should that the settings look like this:

roon-arc-inside-settings.png

 

 

You can download the desktop version of Roon here: https://roonlabs.com/downloads.html, just the Roon (for Mac or Windows, not the Roon Server). When you run the Roon Desktop software, it will detect the Roon Core running on your Unraid server, as long as you are on the same network (If you are using separate VLANs or anything, you'll need to make sure that your Roon software and RoonServer can listen to each other).

8sMWG0i.png

 

 

 

================ Old Help Thread ================

 

 

 

  • Like 1
Link to comment
  • 1 month later...

Hello, do we have to create an account on the roon website for this? I installed the core and I can't find it with the app. I tried roon remote on my android and roon arc. Roon arc ask for account, roon remote just never found the server.

 

Edit: Found out it's working if I put host, meaning there's other port needed to be forwarded. Is it possible to have it with a custom bridge and have the proper port forwarded?

Link to comment

@Nodiaque yes you have to make an account at the Roon website, put in your credit card, and sign up for the trial. Roon is expen$ive software! and hosting a Docker doesn’t get us out of it, sadly.

 

ARC certainly won’t work if you can’t find the core with a regular Windows Roon client or Roon client on your phone (also while on home wifi). I suggest sorting that out first. 
 

I’m not sure how it works exactly, but there are no ports to forward. Until you use ARC, then you will have to choose a port and forward it. There are details on those instructions above. 

Edited by dkerlee
Link to comment

ah ok, I'm looking to replace my lms (logitech media server) and there isn't a lot of option for that. I need something that hose the music and can blast the music in whatever device I have from the server, able to sync multiple together, etc. It seems everything I find are "player" that you can access from anywhere. I though Roon would be it, it seems to do it, but I'm not willing to pay the price only for my music.

 

Thanks for the help!

  • Like 1
Link to comment

Yeah it’s a steep ask. Having been using the software for a year now, I’d say it’s actually worth it. For whatever that’s worth. 
$10/mo billed annually 

$700 lifetime

 

After 1/1/2023 increasing to 

$12/mo and $830 lifetime

 

I hear what you’re saying there too with all those little players all over the place. Have you looked into Plex? I got a lifetime of that years ago, and have been using it nonstop for the whole time - but only for tv and movies. They do have a music section, and it might have some neat sync listen stuff and “end points” and casting you could look at. Otherwise, Roon does seem to be the only game in town. 

Link to comment
  • 1 month later...

When logging in into Roon, it detects the Unraid Roon Core, however it gives me an "unauthorized: please enter your account's password properly"! Obviously I triple checked my password and even reset just to make sure but still gives the same error.  

 

I'm getting the following error in logs:

 

Warn:  get lock file path: /tmp/.rnsgem0-

 

Is it something that needs to be fixed!?

Link to comment

I had this docker running great for a few days until I tried to add my new Denon AVR as a audio source. This crashed the server and its no longer accessible so I've tried remover the container and readding it which didn't help.

 

I've tried to delete the files in the roonserver folder in appdata but it throws up a permissions problem.

 

Can anyone give me any pointers?

Link to comment

@Mercian it sounds like there are some issues going on outside of the roon Docker specifically. I’d try searching for those permission errors on the rest of the forum. 
 

I’m trying to recall when I last had permission errors. You can restart the server itself. There’s also a “fix permissions” setting process somewhere. I’ve had luck with that before too. 
 

I believe in the Docker setting there is a field for user and group. You’ll want to make sure that populates the same as you other dockers, though I’m sure the defaults should be fine. And if you removed the Docker image and the appdata files, you should be back to all default. 

Link to comment
  • 2 weeks later...

Since the Roon 2.0 update, it seems like Roon works the hard drives much more than any other program or container.  My hard drives thrash constantly for weeks, unless I turn off Roon docker.  Also, with Roon running, my parity check runs at 10 MB/s, and if I turn off Roon it runs at 130 MB/s.  Can it be the container settings do not use the cache correctly? My share "appdata" is the one I try to have on cache.  I have:

 

image.png.a5083768a83d44b3c05c548e1d4af2ce.png

 

For the container settings I have:

image.png

 

I have not yet added the port 55000 for ARC, but I used ARC on my iphone.  Could that be the problem?

Link to comment

Would be nice, but still does not work. I'm not able to stop the Roonserver Docker. It simply does not stop (which is bad for app-backups and system security). It just times out. After that I get the error

Quote

00:00:00.002 Warn:  get lock file path: /tmp/.rnsgem0-

Nothing helped. Not nuking/reinstall. Not installing into /.../mount/user/apps/...  instead of /mount/cache/apps/... - i'm a bit sick of it, because the same thing runs easily on my other (Synology) NAS as a docker. Any more ideas? Shouldn't there be mapping for temp files also (i had this with Unmanic, where it is helpful to map tmp to RAM in any way.

 

Any ideas?

Link to comment

Roon Docker does not have good logging. As I’m thinking about this, I think it may have more to do with Docker and your system more than the Roon Docker specifically. It’s real odd that you can’t stop the Docker container. I’ve never had a Docker container like that. 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.