Jump to content

why does unraid hang at udev boot and so slow and then cpu infinity

Recommended Posts

ya i just changed cpu  from a 3700x to a 5800x to try things  and i didnt plug in the network cables.. but i find it always slow and it hangs at a udev:/   for like 5 min  it seems and i dont know why the cpu utliziation  does that infinity stuff.. but i can do a reboot with the network cables in  and take another diagnostic


Link to comment

here is diagnostic.. and  the other spot it hangs is the  "mover" command saying directory not there or so... it sits there and hangs 

here is a new diagnostic

and does the inifninty  mean it cant read the cpu?

as i know it can read my 3700x  as it doesnt have this issue

logs have a bunch of red erros. i seen then before i dunno what those are



Edited by comet424
Link to comment

@ljm42  so the tardis server is my main server.. its the one really slow... its got other warnings now... its also took a long time to make the diagnostic file.

the other 2 servers are my other unraids on the network.. they all got similar or different errors now  .. but tardis seems to be really slow still  here diagnostics of 3 servers



backupserver-diagnostics-20230630-2309.zip tardis-diagnostics-20230630-2307.zip k-9-diagnostics-20230630-2308.zip

Link to comment

@comet424 It looks like all three of these systems have Realtek network cards. Unraid ships with the official drivers that Linux provides, but the community has created a plugin with out-of-tree drivers from Realtek:
This is a brand new plugin that isn't yet available in Community Apps, but you can install it manually if you'd like. You want the R8125 version.


Can you clarify, are you still seeing the infinity cpu usage in 6.12.2?


Link to comment

@ljm42  so are these drivers when everyone says dont use realtek  you want intel drivers as linux doesnt support realtek..  

all 3 servers have onboard  realtek then  and tardis  has the 4 port card added on too..

and why is it like pfsens too its not supported  realtek drivers.. yet these onboard nics have them


so  i installed drivers on tardis but i cant reboot yet.. its doing a btfs scrub...  and backup server is doing a preclear.. and i finding that 6.12.1 .2  versions dont wanna resume the preclear..  so  i dont wanna touch it


so i tried on the k-9 server...  i installed the r8125  you said... i rebooted  the server... and no access   you cant ping it i guess driver didnt work i dont have a video card in it at the moment so i cant test at the moment.. i did a 2nd reboot and didnt help...  so i guess driver didnt work  leastthe 8125



Link to comment

i tried deleting the driver in the plugins folder on the flash drive in my desktop pc and then plug back in  to boot it up  but still cant get an ip.. i have to wait a day or 2  for the one preclear to finish first round and take the vid card out of it... as i dont wanna start over 

Link to comment


For the r8125 driver plugin, could you please boot into server with GUI (second one in boot options list) and check whether the card is present in the network settings? The ip may be different. Also you need to connect a working network cable to the port otherwise unraid might not allocate ip to it.

Also you can run command "modinfo r8125" to see whether the driver is installed.

Edited by jinlife
  • Like 1
Link to comment
1 minute ago, comet424 said:

@jinlife  once i get a video card out of my other server  i can try those  they busy at the moment  so i cant and ill give them a try

i did check pfsense for arp table  and my k-9 host name not there so its not picking up  but ya once i get a card in there i can run those tests


Awesome. Thanks for the test.

Link to comment

@jinlife  i dosed off waiting for my main server to finish lol

but i uninstalled driver of my main server just incase this bricking temporary my main server


so i removed vid card from main server shoved a card in my k-9 server

booted up...  i forgot to plug in keyboard so i didnt do the gui


but i did log in did a diganostics and i did a couple screen shots... and the network card did work before as i never upluged it and the lights are flickering once power comes on


but here i did cell phone capture of the screen hope its good enough

and on this sever it hangs on the "RM" command whatever it does    but it booted up ok..


if you need me to go back into the gui mode one i will.. i just didnt when i did all these tests

just the orginal boot




and i dont have the vid card back in main server to test.. but i do know it hangs at the "MV" command and "udev"  command    sits like 5 min it seems and i not sure if those releated to the network card?    i dunno if that shows those errors in the diganostics  i only seen it on the screen


but hope these screen shots help  if you need me to go into the gui i can








Link to comment

ill reboot and check  if the network card is there i re read what you wrote.. damn disylexia...   ill check if the network card is there 



sorry about that  i miss read so i went and did what you said and went to settings.. i guess the network card is gone

dont know why these photos side ways





Edited by comet424
Link to comment

@comet424 It looks like the driver is running since there is information in "modinfo r8125".

Do you have only 1 ethernet port? The eth0 seems don't have the MAC address. It is strange. Is it the r8125 chip ethenet port? Could you please try command "ethtool -i eth0" to see whether the driver is working?

Link to comment


and i dunno if its a r8125  i only going off what you said for me to use.. from the diagnostics...  or you can go by the motherboards i use 

i have 2 other unraids off site.. but the 3 at home are 

2 x ASus Tuf X570 Gaming

1 x Asus Strik X570 Gaming board


that computer has just 1 ethernet port

so  the 3 diganostics

k-9   1 ethernet port    ASus Tuf X570 motherboard

Backupserver 1 ethernet port  ASUS Tuf X570 motherboard

tardis (main server) 1 onboard ethernet  4 (1 pci card)   ASUS Strik Gaming X570 Motherboard


and looks like the ethernet port is gone...  but it still lit up on the back of the comp






i re did it i thought it was L  not an I  for the attributes


here is another screen shot 


Edited by comet424
Link to comment

@jinlife so i should uninstall the r8125  and install the 8169 then?  as i only installed the 8125 from what you said...


does the diagnostics  say why tardis  takes forever to boot  at those 

or what a "RM"  is  that hangs least on the k-9 server..


ill try to uninstall driver to get k-9 back up  and ill put vid card back in tardis and take cell phone pics of the screen...  if the diagnostics dont show anything


Link to comment

@jinlife  so i cant fix my k-9 server i  unable to uninstall the 8125 driver on the server... its not in the plugins   and its under install plugin errors tab.. i tried the delete button and then reboot  but didnt help.. still no network card...


how can i uninstall it... so ill try the  r8169 driver then

Link to comment

@jinlife ok got it back up again...   i wasnt able to uninstall the r8125 as it was not there in plugins page  it was under the install error plugin page

but i did delete the conf file in the modprobe.d  and rebooted..  

is there any other tests or the other driver you want me to test?  and if not ill plug video card back in the main server to take pics of the screen of the 2 spots it hangs alot 

Link to comment
11 minutes ago, comet424 said:

@jinlife ok got it back up again...   i wasnt able to uninstall the r8125 as it was not there in plugins page  it was under the install error plugin page

but i did delete the conf file in the modprobe.d  and rebooted..  

is there any other tests or the other driver you want me to test?  and if not ill plug video card back in the main server to take pics of the screen of the 2 spots it hangs alot 

I'm working on the plugin, it seems not working properly.

Please go ahead with your change. I'm afraid I can't help you with the plugin now. Please ask other expert's help.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...